]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- updated to 2.1.25
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite 2 plugin
11 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
12 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
13 %bcond_with     opie            # enable opie plugin
14 %bcond_with     srp             # build srp pluggin
15 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
16 %bcond_with     x509            # build x509 plugin (no sources in package???)
17 #
18 %if %{without mysql} && %{without pgsql}
19 %undefine with_cryptedpw
20 %endif
21
22 Summary:        The SASL library API for the Cyrus mail system
23 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
24 Summary(pt_BR.UTF-8):   Implementação da API SASL
25 Summary(ru.UTF-8):      Библиотека Cyrus SASL
26 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
27 Name:           cyrus-sasl
28 Version:        2.1.25
29 Release:        1
30 License:        distributable
31 Group:          Libraries
32 Source0:        ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
33 # Source0-md5:  341cffe829a4d71f2a6503d669d5a946
34 Source1:        saslauthd.init
35 Source2:        saslauthd.sysconfig
36 Source3:        %{name}.pam
37 Source4:        check_saslauthd.cfg
38 Patch0:         %{name}-nolibs.patch
39 Patch1:         %{name}-lt.patch
40 Patch2:         %{name}-split-sql.patch
41 Patch3:         %{name}-opie.patch
42 Patch4:         %{name}-gcc4.patch
43 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
44 Patch5:         %{name}-cryptedpw.patch
45 Patch6:         %{name}-md5sum-passwords.patch
46 Patch7:         %{name}-db.patch
47 Patch8:         %{name}-keytab.patch
48 Patch9:         %{name}-sizes.patch
49 Patch10:        %{name}-nagios-plugin.patch
50 Patch11:        %{name}-parallel-make.patch
51 Patch12:        %{name}-gssapi-detect.patch
52 Patch13:        %{name}-saslauthd-httpform-urlescape.patch
53 Patch14:        %{name}-ac-libs.patch
54 Patch15:        %{name}-pam.patch
55 Patch16:        %{name}-gssapi_ext.patch
56 URL:            http://asg.web.cmu.edu/sasl/
57 BuildRequires:  autoconf >= 2.54
58 BuildRequires:  automake >= 1:1.7
59 %{?with_authlib:BuildRequires:  courier-authlib-devel}
60 BuildRequires:  db-devel
61 BuildRequires:  ed
62 BuildRequires:  groff
63 %{?with_gssapi:BuildRequires:   heimdal-devel}
64 BuildRequires:  libtool >= 1.4
65 %{?with_mysql:BuildRequires:    mysql-devel}
66 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
67 BuildRequires:  openssl-devel >= 0.9.7d
68 %{?with_opie:BuildRequires:     opie-devel}
69 BuildRequires:  pam-devel
70 %{?with_pgsql:BuildRequires:    postgresql-devel}
71 BuildRequires:  rpmbuild(macros) >= 1.268
72 %{?with_sqlite:BuildRequires:   sqlite-devel}
73 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
74 Requires:       pam >= 0.79.0
75 Requires:       %{name}-libs = %{version}-%{release}
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %define         _sysconfdir     /etc/sasl
79
80 %define         specflags       -fno-strict-aliasing
81
82 %description
83 This is an implementation of the SASL API, useful for adding
84 authentication, authorization, and security to network protocols. The
85 SASL protocol itself is documented in rfc2222; the API standard is a
86 work in progress.
87
88 Note: remember to install appropriate plugins, or you won't have any
89 authentication mechanisms available.
90
91 %description -l pl.UTF-8
92 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
93 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
94 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
95 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
96 RFC 2222; standaryzacja API jest w toku.
97
98 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
99 doinstalować odpowiednie wtyczki.
100
101 %description -l pt_BR.UTF-8
102 Esta é uma implementação da API SASL, útil para acrescentar
103 autenticação, autorização e seguança (criptografia) para protocolos de
104 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
105 ainda está em desenvolvimento.
106
107 %description -l ru.UTF-8
108 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
109 Authentication and Security Layer, метод для добавления поддержки
110 аутентикации к протоколам, основанным на соединениях.
111
112 %description -l uk.UTF-8
113 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
114 Authentication and Security Layer, метод для додання підтримки
115 аутентикації до протоколів, базованих на з'єднаннях.
116
117 %package libs
118 Summary:        cyrus-sasl library itself
119 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
120 Group:          Libraries
121 Requires(post,postun):  /sbin/ldconfig
122 Conflicts:      cyrus-sasl < 2.1.23-8
123
124 %description libs
125 cyrus-sasl library itself.
126
127 %description libs -l pl.UTF-8
128 Sama biblioteka cyrus-sasl.
129
130 %package devel
131 Summary:        Header files and documentation for cyrus-sasl
132 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
133 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
134 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
135 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
136 Group:          Development/Libraries
137 Requires:       %{name} = %{version}-%{release}
138
139 %description devel
140 This includes the header files and documentation needed to develop
141 applications which use SASL.
142
143 %description devel -l pl.UTF-8
144 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
145
146 %description devel -l pt_BR.UTF-8
147 Este pacote inclui os arquivos de cabeçalho e documentação necessários
148 para desenvolver aplicativos que usem SASL.
149
150 %description devel -l ru.UTF-8
151 Хедеры и библиотеки, необходимые для разработки приложений,
152 использующих Cyrus SASL.
153
154 %description devel -l uk.UTF-8
155 Хедери та бібліотеки, необхідні для розробки програм, що
156 використовують Cyrus SASL.
157
158 %package static
159 Summary:        Static cyrus-sasl libraries
160 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
161 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
162 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
163 Group:          Development/Libraries
164 Requires:       %{name}-devel = %{version}-%{release}
165
166 %description static
167 Static cyrus-sasl libraries.
168
169 %description static -l pl.UTF-8
170 Statyczne biblioteki cyrus-sasl.
171
172 %description static -l ru.UTF-8
173 Статические библиотеки, необходимые для разработки приложений,
174 использующих Cyrus SASL.
175
176 %description static -l uk.UTF-8
177 Статичні бібліотеки, необхідні для розробки програм, що використовують
178 Cyrus SASL.
179
180 %package anonymous
181 Summary:        Anonymous Cyrus SASL plugin
182 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
183 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
184 Group:          Libraries
185 Requires:       %{name} = %{version}-%{release}
186
187 %description anonymous
188 This plugin implements the SASL ANONYMOUS mechanism, used for
189 anonymous authentication.
190
191 %description anonymous -l pl.UTF-8
192 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
193 anonimowego uwierzytelniania.
194
195 %description anonymous -l pt_BR.UTF-8
196 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
197 autenticação anônima.
198
199 %package cram-md5
200 Summary:        Cram-MD5 Cyrus SASL plugin
201 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
202 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
203 Group:          Libraries
204 Requires:       %{name} = %{version}-%{release}
205
206 %description cram-md5
207 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
208 mandatory-to-implement authentication mechanism for a number of
209 protocols; it uses MD5 with a challenge/response system to
210 authenticate the user.
211
212 %description cram-md5 -l pl.UTF-8
213 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
214 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
215 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
216 systemem challenge/response.
217
218 %description cram-md5 -l pt_BR.UTF-8
219 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
220 mecanismo de autenticação obrigatório de ser implementado para vários
221 protocolos: ele usa MD5 com um sistema de desafio/resposta para
222 autenticar o usuário.
223
224 %package digest-md5
225 Summary:        Digest-MD5 Cyrus SASL plugin
226 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
227 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
228 Group:          Libraries
229 Requires:       %{name} = %{version}-%{release}
230
231 %description digest-md5
232 This plugin implements the latest draft of the SASL DIGEST-MD5
233 mechanism. Although not yet finalized, this is likely to become the
234 new mandatory-to-implement authentication system in all new protocols.
235 It's based on the digest md5 authentication system designed for HTTP.
236
237 %description digest-md5 -l pl.UTF-8
238 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
239 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
240 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
241 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
242 Digest-MD5 zaprojektowanym dla HTTP.
243
244 %description digest-md5 -l pt_BR.UTF-8
245 Este plugin implementa a última versão da especificação do mecanismo
246 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
247 provavelmente será o novo sistema de autenticação obrigatório para
248 protocolos novos. Ele é baseado na autenticação md5 digest
249 desenvolvida para HTTP.
250
251 %package gssapi
252 Summary:        GSSAPI Cyrus SASL plugin
253 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
254 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
255 Group:          Libraries
256 Requires:       %{name} = %{version}-%{release}
257
258 %description gssapi
259 This plugin implements the SASL GSSAPI mechanism, used for
260 GSSAPI/Kerberos5 authentication.
261
262 %description gssapi -l pl.UTF-8
263 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
264 uwierzytelniania z użyciem GSSAPI/Kerberos5.
265
266 %description gssapi -l pt_BR.UTF-8
267 Este plugin implementa o mecanismo SASL GSSAPI, usado para
268 autenticação Kerberos/GSSAPI.
269
270 %package login
271 Summary:        Unsupported Login Cyrus SASL plugin
272 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
273 Group:          Libraries
274 Requires:       %{name} = %{version}-%{release}
275
276 %description login
277 Unsupported LOGIN Cyrus SASL plugin.
278
279 %description login -l pl.UTF-8
280 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
281 SASL.
282
283 %package mysql
284 Summary:        Cyrus SASL MySQL plugin
285 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
286 Group:          Libraries
287 Requires:       %{name} = %{version}-%{release}
288
289 %description mysql
290 Cyrus SASL MySQL plugin.
291
292 %description mysql -l pl.UTF-8
293 Wtyczka MySQL do Cyrus SASL.
294
295 %package opie
296 Summary:        OPIE Cyrus SASL plugin
297 Summary(pl.UTF-8):      Wtyczka OPIE do Cyrus SASL
298 Summary(pt_BR.UTF-8):   Mecanismo SASL OPIE
299 Group:          Libraries
300 Requires:       %{name} = %{version}-%{release}
301
302 %description opie
303 This plugin implements the SASL OPIE (One Time Password) mechanism.
304
305 %description opie -l pl.UTF-8
306 Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
307 SASL.
308
309 %package otp
310 Summary:        OTP Cyrus SASL plugin
311 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
312 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
313 Group:          Libraries
314 Requires:       %{name} = %{version}-%{release}
315
316 %description otp
317 This plugin implements the SASL OTP (One Time Password) mechanism.
318
319 %description otp -l pl.UTF-8
320 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
321 SASL.
322
323 %package pgsql
324 Summary:        Cyrus SASL PostgreSQL plugin
325 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
326 Group:          Libraries
327 Requires:       %{name} = %{version}-%{release}
328
329 %description pgsql
330 Cyrus SASL PostgreSQL plugin.
331
332 %description pgsql -l pl.UTF-8
333 Wtyczka PostgreSQL do Cyrus SASL.
334
335 %package plain
336 Summary:        Plain Cyrus SASL plugin
337 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
338 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
339 Group:          Libraries
340 Requires:       %{name} = %{version}-%{release}
341
342 %description plain
343 This plugin implements the SASL PLAIN mechanism. Although insecure,
344 PLAIN is useful for transitioning to new security mechanisms, as this
345 is the only mechanism which gives the server a copy of the user's
346 password.
347
348 %description plain -l pl.UTF-8
349 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
350 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
351 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
352 który udostępnia serwerowi kopię hasła użytkownika.
353
354 %description plain -l pt_BR.UTF-8
355 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
356 mecanismo é útil durante transições para novos mecanismos de
357 segurança, pois é o único esquema que fornece uma cópia da senha do
358 usuário para o servidor.
359
360 %package sasldb
361 Summary:        Cyrus SASL sasldb plugin
362 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
363 Group:          Libraries
364 Requires:       %{name} = %{version}-%{release}
365
366 %description sasldb
367 Cyrus SASL sasldb plugin.
368
369 %description sasldb -l pl.UTF-8
370 Wtyczka sasldb do Cyrus SASL.
371
372 %package scram
373 Summary:        SCRAM Cyrus SASL plugin
374 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
375 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
376 Group:          Libraries
377 Requires:       %{name} = %{version}-%{release}
378
379 %description scram
380 This plugin implements the SASL SCRAM-MD5 mechanism.
381
382 %description scram -l pl.UTF-8
383 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
384
385 %description scram -l pt_BR.UTF-8
386 Este plugin implementa o mecanismo SASL SCRAM.
387
388 %package sqlite
389 Summary:        Cyrus SQLite 2 PostgreSQL plugin
390 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
391 Group:          Libraries
392 Requires:       %{name} = %{version}-%{release}
393
394 %description sqlite
395 Cyrus SASL SQLite 2 plugin.
396
397 %description sqlite -l pl.UTF-8
398 Wtyczka SQLite 2 do Cyrus SASL.
399
400 %package sqlite3
401 Summary:        Cyrus SQLite 3 PostgreSQL plugin
402 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
403 Group:          Libraries
404 Requires:       %{name} = %{version}-%{release}
405
406 %description sqlite3
407 Cyrus SASL SQLite 3 plugin.
408
409 %description sqlite3 -l pl.UTF-8
410 Wtyczka SQLite 3 do Cyrus SASL.
411
412 %package srp
413 Summary:        SRP Cyrus SASL plugin
414 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
415 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
416 Group:          Libraries
417 Requires:       %{name} = %{version}-%{release}
418
419 %description srp
420 This plugin implements the SASL SRP mechanism, based on the Secure
421 Remote Password protocol. This mechanism performs mutual
422 authentication and can provide a security layer with replay detection,
423 integrity protection and/or condifentiality protection.
424
425 %description srp -l pl.UTF-8
426 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
427 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
428 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
429 powtarzania, zabezpieczeniem integralności i/lub poufności.
430
431 %description srp -l pt_BR.UTF-8
432 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
433 (Secure Remote Password). Este mecanismo oferece autenticação mútua
434 (do cliente e do servidor) e pode prover uma camada de segurança com
435 detecção de ataques de replay, garantia de integridade e/ou
436 confidencialidade.
437
438 %package x509
439 Summary:        x509 Cyrus SASL plugin
440 Summary(pl.UTF-8):      Wtyczka x509 do Cyrus SASL
441 Group:          Libraries
442 Requires:       %{name} = %{version}-%{release}
443
444 %description x509
445 x509 Cyrus SASL plugin.
446
447 %description x509 -l pl.UTF-8
448 Wtyczka x509 do Cyrus SASL.
449
450 %package pwcheck
451 Summary:        Cyrus SASL pwcheck helper
452 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
453 Group:          Libraries
454 Requires:       %{name} = %{version}-%{release}
455
456 %description pwcheck
457 Cyrus SASL pwcheck helper.
458
459 %description pwcheck -l pl.UTF-8
460 Program pomocniczy pwcheck do Cyrus SASL.
461
462 %package saslauthd
463 Summary:        Cyrus SASL authd
464 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
465 Group:          Daemons
466 Requires(post,preun):   /sbin/chkconfig
467 Requires:       %{name} = %{version}-%{release}
468 Requires:       /sbin/chkconfig
469 Requires:       rc-scripts
470
471 %description saslauthd
472 Cyrus SASL authd.
473
474 %description saslauthd -l pl.UTF-8
475 Demon authd do Cyrus SASL.
476
477 %package -n nagios-plugin-check_saslauthd
478 Summary:        Nagios plugin to check health of saslauthd
479 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
480 Group:          Networking
481 Requires:       nagios-core
482
483 %description -n nagios-plugin-check_saslauthd
484 Nagios plugin to check health of saslauthd.
485
486 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
487 Wtyczka Nagiosa do sprawdzania działania saslauthd.
488
489 %prep
490 %setup -q
491 %patch0 -p1
492 %patch1 -p1
493 %patch2 -p1
494 %patch3 -p1
495 %patch4 -p1
496 %if %{with cryptedpw}
497 %patch5 -p1
498 %patch6 -p1
499 %endif
500 %patch7 -p1
501 %patch8 -p1
502 %patch9 -p1
503 %patch10 -p1
504 %patch11 -p1
505 %patch12 -p1
506 %patch13 -p0
507 %patch14 -p1
508 %patch15 -p1
509 %patch16 -p1
510
511 cd doc
512 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
513 ls rfc*.txt >> rfc-compliance
514 rm -f rfc*.txt
515 cd ..
516
517 # old version
518 %{__rm} config/libtool.m4
519
520 # update to our paths
521 sed -i -e '
522         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
523         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
524         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
525         s,/var/state/saslauthd,/var/lib/sasl2,g
526 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
527
528 %build
529 %{__libtoolize}
530 %{__aclocal} -I cmulocal -I config
531 %{__autoheader}
532 %{__autoconf}
533 %{__automake}
534 cd saslauthd
535 %{__aclocal} -I ../cmulocal -I ../config
536 %{__autoheader}
537 %{__autoconf}
538 %{__automake}
539 cd ..
540 %configure \
541         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
542         --disable-krb4 \
543         %{!?with_gssapi: --disable-gssapi} \
544         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
545         --enable-login \
546         --enable-sample \
547         --enable-httpform \
548         --enable-sql \
549         %{?with_srp: --enable-srp} \
550         --enable-static \
551         --with-plugindir=%{_libdir}/sasl2 \
552         --with-configdir=%{_sysconfdir} \
553         --with-dblib=berkeley \
554         --with-dbpath=/var/lib/sasl2/sasl.db \
555         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
556         %{?with_ldap: --with-ldap=%{_prefix}} \
557         %{?with_mysql: --with-mysql=%{_prefix}} \
558         %{?with_pgsql: --with-pgsql=%{_prefix}} \
559         %{?with_sqlite: --with-sqlite=%{_prefix}} \
560         %{?with_sqlite3: --with-sqlite3=%{_prefix}} \
561         %{?with_opie: --with-opie=%{_prefix}} \
562         --with-pam \
563         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
564         --with-saslauthd=/var/lib/sasl2
565
566 %{__make}
567
568 %{__make} -C saslauthd testsaslauthd
569 %{__make} -C saslauthd saslcache
570 %{__make} -C sample sample-client sample-server
571
572 cd doc
573 RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
574 for i in $RFCLIST; do
575         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
576         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
577 done
578
579 %install
580 rm -rf $RPM_BUILD_ROOT
581 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
582                 $RPM_BUILD_ROOT%{_mandir}/man8
583
584 %{__make} install \
585         sasldir=%{_libdir}/sasl2 \
586         DESTDIR=$RPM_BUILD_ROOT
587
588 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
589
590 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
591 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
592
593 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
594
595 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
596
597 # create empty config
598 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
599 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
600 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
601 cp -a %{SOURCE3} cyrus.pam
602
603 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
604
605 # sample programs for testing sasl
606 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
607 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
608
609 # package for ghost
610 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
611
612 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
613 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
614
615 %clean
616 rm -rf $RPM_BUILD_ROOT
617
618 %post   libs -p /sbin/ldconfig
619 %postun libs -p /sbin/ldconfig
620
621 %post saslauthd
622 /sbin/chkconfig --add saslauthd
623 %service saslauthd restart
624
625 %preun saslauthd
626 if [ "$1" = "0" ]; then
627         %service saslauthd stop
628         /sbin/chkconfig --del saslauthd
629 fi
630
631 %triggerin saslauthd -- pam
632 # restart saslauthd if pam is upgraded
633 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
634 if [ "$2" != 1 ]; then
635         %service -q saslauthd restart
636 fi
637
638 %files
639 %defattr(644,root,root,755)
640 %doc AUTHORS COPYING ChangeLog NEWS README
641 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
642 %dir %{_sysconfdir}
643 %dir %{_libdir}/sasl2
644 # sample programs to subpackage instead?
645 %attr(755,root,root) %{_bindir}/sasl-sample-client
646 %attr(755,root,root) %{_bindir}/sasl-sample-server
647 %attr(755,root,root) %{_sbindir}/pluginviewer
648 %attr(755,root,root) %{_sbindir}/sasldblistusers2
649 %attr(755,root,root) %{_sbindir}/saslpasswd2
650 %dir /var/lib/sasl2
651 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
652 %{_mandir}/man8/pluginviewer.8*
653 %{_mandir}/man8/sasldblistusers2.8*
654 %{_mandir}/man8/saslpasswd2.8*
655
656 %files libs
657 %defattr(644,root,root,755)
658 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
659 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
660
661 %files devel
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_libdir}/libsasl2.so
664 %attr(755,root,root) %{_libdir}/libsasl.so
665 %{_libdir}/libsasl2.la
666 %{_includedir}/sasl
667 %{_mandir}/man3/sasl*.3*
668
669 %files static
670 %defattr(644,root,root,755)
671 %{_libdir}/libsasl2.a
672
673 %files anonymous
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
676
677 %if %{with gssapi}
678 %files gssapi
679 %defattr(644,root,root,755)
680 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
681 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
682 %endif
683
684 %files cram-md5
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
687
688 %files digest-md5
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
691
692 %files login
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
695
696 %if %{with mysql}
697 %files mysql
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
700 %endif
701
702 %files otp
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
705
706 %if %{with opie}
707 %files opie
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
710 %endif
711
712 %if %{with pgsql}
713 %files pgsql
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
716 %endif
717
718 %files plain
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
721
722 %files sasldb
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
725
726 %files scram
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
729
730 %if %{with sqlite}
731 %files sqlite
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
734 %endif
735
736 %if %{with sqlite3}
737 %files sqlite3
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
740 %endif
741
742 %if %{with srp}
743 %files srp
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
746 %endif
747
748 %if %{with x509}
749 %files x509
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
752 %endif
753
754 %if %{with pwcheck}
755 %files pwcheck
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_sbindir}/pwcheck
758 %endif
759
760 %files saslauthd
761 %defattr(644,root,root,755)
762 %doc cyrus.pam
763 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
764 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
765 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
766 %attr(755,root,root) %{_sbindir}/saslauthd
767 %attr(755,root,root) %{_sbindir}/testsaslauthd
768 %attr(755,root,root) %{_sbindir}/saslcache
769 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
770 %ghost /var/lib/sasl2/cache.flock
771 %ghost /var/lib/sasl2/cache.mmap
772 %ghost /var/lib/sasl2/mux
773 %ghost /var/lib/sasl2/mux.accept
774 %ghost /var/lib/sasl2/saslauthd.pid
775 %{_mandir}/man8/saslauthd.8*
776
777 %files -n nagios-plugin-check_saslauthd
778 %defattr(644,root,root,755)
779 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
780 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.073851 seconds and 4 git commands to generate.