]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- rel 8 (libmysqlclient_15)
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 #
2 # TODO:
3 # - add ldap plugin from openldap sources
4 #
5 # Conditional build:
6 %bcond_without  ldap    # disable LDAP support for saslauthd
7 %bcond_without  gssapi  # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql   # don't build MySQL pluggin
9 %bcond_without  pgsql   # do not build PostgreSQL pluggin
10 %bcond_without  sqlite  # do not enable sqlite plugin
11 %bcond_with     authlib # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     cryptedpw # if you keep crypted passwords in your *sql
13 %bcond_with     opie    # enable opie plugin
14 %bcond_with     srp     # build srp pluggin
15 %bcond_with     pwcheck # build pwcheck helper (deprecated)
16 %bcond_with     x509    # build x509 plugin (no sources in package???)
17 #
18 %if %{without mysql} && %{without pgsql}
19 %undefine with_cryptedpw
20 %endif
21
22 Summary:        The SASL library API for the Cyrus mail system
23 Summary(pl):    Biblioteka Cyrus SASL
24 Summary(pt_BR): Implementação da API SASL
25 Summary(ru):    âÉÂÌÉÏÔÅËÁ Cyrus SASL
26 Summary(uk):    â¦Â̦ÏÔÅËÁ Cyrus SASL
27 Name:           cyrus-sasl
28 Version:        2.1.21
29 Release:        8
30 License:        distributable
31 Group:          Libraries
32 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
33 # Source0-md5:  dde02db234dea892bee298390890502e
34 Source1:        saslauthd.init
35 Source2:        saslauthd.sysconfig
36 Source3:        %{name}.pam
37 Patch0:         %{name}-configdir.patch
38 Patch1:         %{name}-nolibs.patch
39 Patch2:         %{name}-lt.patch
40 Patch3:         %{name}-split-sql.patch
41 Patch4:         %{name}-opie.patch
42 Patch5:         %{name}-gcc4.patch
43 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
44 Patch6:         %{name}-cryptedpw.patch
45 Patch7:         %{name}-md5sum-passwords.patch
46 URL:            http://asg.web.cmu.edu/sasl/
47 %{?with_authlib:BuildRequires:  courier-authlib-devel}
48 BuildRequires:  autoconf >= 2.54
49 BuildRequires:  automake
50 BuildRequires:  db-devel
51 BuildRequires:  ed
52 BuildRequires:  groff
53 %{?with_gssapi:BuildRequires:   heimdal-devel >= 0.7}
54 BuildRequires:  libtool >= 1.4
55 %{?with_mysql:BuildRequires:    mysql-devel}
56 %{?with_pgsql:BuildRequires:    postgresql-devel}
57 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
58 %{?with_sqlite:BuildRequires:   sqlite-devel}
59 %{?with_opie:BuildRequires:     opie-devel}
60 BuildRequires:  openssl-devel >= 0.9.7d
61 BuildRequires:  pam-devel
62 Requires:       pam >= 0.79.0
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         _sysconfdir     /etc/sasl
66
67 %define         specflags       -fno-strict-aliasing
68
69 %description
70 This is an implementation of the SASL API, useful for adding
71 authentication, authorization, and security to network protocols. The
72 SASL protocol itself is documented in rfc2222; the API standard is a
73 work in progress.
74
75 Note: remember to install appropriate plugins, or you won't have any
76 authentication mechanisms available.
77
78 %description -l pl
79 Pakiet cyrus-sasl zawiera implementacjê biblioteki API SASL dla
80 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
81 tak¿e do dodawania uwierzytelniania, autoryzacji oraz zwiêkszania
82 bezpieczeñstwa protoko³ów sieciowych. Sam protokó³ SASL jest opisany w
83 RFC 2222; standaryzacja API jest w toku.
84
85 Uwaga: aby by³y dostêpne jakiekolwiek mechanizmy autoryzacji, nale¿y
86 doinstalowaæ odpowiednie wtyczki.
87
88 %description -l pt_BR
89 Esta é uma implementação da API SASL, útil para acrescentar
90 autenticação, autorização e seguança (criptografia) para protocolos de
91 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
92 ainda está em desenvolvimento.
93
94 %description -l ru
95 ðÁËÅÔ cyrus-sasl ÓÏÄÅÒÖÉÔ ÒÅÁÌÉÚÁÃÉÀ Cyrus SASL. SASL - ÜÔÏ Simple
96 Authentication and Security Layer, ÍÅÔÏÄ ÄÌÑ ÄÏÂÁ×ÌÅÎÉÑ ÐÏÄÄÅÒÖËÉ
97 ÁÕÔÅÎÔÉËÁÃÉÉ Ë ÐÒÏÔÏËÏÌÁÍ, ÏÓÎÏ×ÁÎÎÙÍ ÎÁ ÓÏÅÄÉÎÅÎÉÑÈ.
98
99 %description -l uk
100 ðÁËÅÔ cyrus-sasl Í¦ÓÔÉÔØ ÒÅÁ̦ÚÁæÀ Cyrus SASL. SASL - ÃÅ Simple
101 Authentication and Security Layer, ÍÅÔÏÄ ÄÌÑ ÄÏÄÁÎÎѠЦÄÔÒÉÍËÉ
102 ÁÕÔÅÎÔÉËÁ槠ÄÏ ÐÒÏÔÏËÏ̦×, ÂÁÚÏ×ÁÎÉÈ ÎÁ Ú'¤ÄÎÁÎÎÑÈ.
103
104 %package devel
105 Summary:        Header files and documentation for cyrus-sasl
106 Summary(pl):    Pliki nag³ówkowe i dokumentacja dla cyrus-sasl
107 Summary(pt_BR): Exemplos e arquivos para desenvolvimento com SASL
108 Summary(ru):    æÁÊÌÙ ÄÌÑ ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ Ó ÂÉÂÌÉÏÔÅËÏÊ Cyrus SASL
109 Summary(ru):    æÁÊÌÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎѠڠ¦Â̦ÏÔÅËÏÀ Cyrus SASL
110 Group:          Development/Libraries
111 Requires:       %{name} = %{version}-%{release}
112
113 %description devel
114 This includes the header files and documentation needed to develop
115 applications which use SASL.
116
117 %description devel -l pl
118 Pliki nag³ówkowe i dokumentacja dla cyrus-sasl.
119
120 %description devel -l pt_BR
121 Este pacote inclui os arquivos de cabeçalho e documentação necessários
122 para desenvolver aplicativos que usem SASL.
123
124 %description devel -l ru
125 èÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÉÌÏÖÅÎÉÊ,
126 ÉÓÐÏÌØÚÕÀÝÉÈ Cyrus SASL.
127
128 %description devel -l uk
129 èÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
130 ×ÉËÏÒÉÓÔÏ×ÕÀÔØ Cyrus SASL.
131
132 %package static
133 Summary:        Static cyrus-sasl libraries
134 Summary(pl):    Statyczne biblioteki cyrus-sasl
135 Summary(ru):    óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ Cyrus SASL
136 Summary(uk):    óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ Cyrus SASL
137 Group:          Development/Libraries
138 Requires:       %{name}-devel = %{version}-%{release}
139
140 %description static
141 Static cyrus-sasl libraries.
142
143 %description static -l pl
144 Statyczne biblioteki cyrus-sasl.
145
146 %description static -l ru
147 óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÉÌÏÖÅÎÉÊ,
148 ÉÓÐÏÌØÚÕÀÝÉÈ Cyrus SASL.
149
150 %description static -l uk
151 óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ
152 Cyrus SASL.
153
154 %package cram-md5
155 Summary:        Cram-MD5 Cyrus SASL plugin
156 Summary(pl):    Wtyczka Cram-MD5 do Cyrus SASL
157 Summary(pt_BR): Mecanismo SASL CRAM-MD5
158 Group:          Libraries
159 Requires:       %{name} = %{version}-%{release}
160
161 %description cram-md5
162 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
163 mandatory-to-implement authentication mechanism for a number of
164 protocols; it uses MD5 with a challenge/response system to
165 authenticate the user.
166
167 %description cram-md5 -l pl
168 Wtyczka dodaj±ca obs³ugê mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
169 jest obowi±zkowym do zaimplementowania mechanizmem uwierzytelniania
170 dla wielu protoko³ów; do uwierzytelnienia u¿ytkownika u¿ywa MD5 wraz z
171 systemem challenge/response.
172
173 %description cram-md5 -l pt_BR
174 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
175 mecanismo de autenticação obrigatório de ser implementado para vários
176 protocolos: ele usa MD5 com um sistema de desafio/resposta para
177 autenticar o usuário.
178
179 %package digest-md5
180 Summary:        Digest-MD5 Cyrus SASL plugin
181 Summary(pl):    Wtyczka Digest-MD5 do Cyrus SASL
182 Summary(pt_BR): Mecanismo SASL DIGEST-MD5
183 Group:          Libraries
184 Requires:       %{name} = %{version}-%{release}
185
186 %description digest-md5
187 This plugin implements the latest draft of the SASL DIGEST-MD5
188 mechanism. Although not yet finalized, this is likely to become the
189 new mandatory-to-implement authentication system in all new protocols.
190 It's based on the digest md5 authentication system designed for HTTP.
191
192 %description digest-md5 -l pl
193 Wtyczka dodaj±ca najnowsz± wersjê mechanizmu DIGEST-MD5 do Cyrus SASL.
194 Pomimo tego, ¿e nie jest jeszcze ukoñczony, najprawdopodobniej stanie
195 siê obowi±zkowym do zaimplementowania systemem uwierzytelniania we
196 wszystkich nowych protoko³ach. Bazuje na systemie uwierzytelniania
197 Digest-MD5 zaprojektowanym dla HTTP.
198
199 %description digest-md5 -l pt_BR
200 Este plugin implementa a última versão da especificação do mecanismo
201 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
202 provavelmente será o novo sistema de autenticação obrigatório para
203 protocolos novos. Ele é baseado na autenticação md5 digest
204 desenvolvida para HTTP.
205
206 %package plain
207 Summary:        Plain Cyrus SASL plugin
208 Summary(pl):    Wtyczka plain do Cyrus SASL
209 Summary(pt_BR): Mecanismo SASL PLAIN
210 Group:          Libraries
211 Requires:       %{name} = %{version}-%{release}
212
213 %description plain
214 This plugin implements the SASL PLAIN mechanism. Although insecure,
215 PLAIN is useful for transitioning to new security mechanisms, as this
216 is the only mechanism which gives the server a copy of the user's
217 password.
218
219 %description plain -l pl
220 Wtyczka dodaj±ca obs³ugê mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
221 ¿e nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
222 nowe mechanizmu bezpieczeñstwa, jako ¿e jest to jedyny mechanizm,
223 który udostêpnia serwerowi kopiê has³a u¿ytkownika.
224
225 %description plain -l pt_BR
226 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
227 mecanismo é útil durante transições para novos mecanismos de
228 segurança, pois é o único esquema que fornece uma cópia da senha do
229 usuário para o servidor.
230
231 %package anonymous
232 Summary:        Anonymous Cyrus SASL plugin
233 Summary(pl):    Wtyczka anonymous do Cyrus SASL
234 Summary(pt_BR): Mecanismo SASL ANONYMOUS
235 Group:          Libraries
236 Requires:       %{name} = %{version}-%{release}
237
238 %description anonymous
239 This plugin implements the SASL ANONYMOUS mechanism, used for
240 anonymous authentication.
241
242 %description anonymous -l pl
243 Wtyczka dodaj±ca obs³ugê mechanizmu ANONYMOUS do Cyrus SASL. S³u¿y do
244 anonimowego uwierzytelniania.
245
246 %description anonymous -l pt_BR
247 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
248 autenticação anônima.
249
250 %package gssapi
251 Summary:        GSSAPI Cyrus SASL plugin
252 Summary(pl):    Wtyczka GSSAPI do Cyrus SASL
253 Summary(pt_BR): Mecanismo SASL GSSAPI
254 Group:          Libraries
255 Requires:       %{name} = %{version}-%{release}
256
257 %description gssapi
258 This plugin implements the SASL GSSAPI mechanism, used for
259 GSSAPI/Kerberos5 authentication.
260
261 %description gssapi -l pl
262 Wtyczka dodaj±ca obs³ugê mechanizmu SASL GSSAPI, u¿ywanego do
263 uwierzytelniania z u¿yciem GSSAPI/Kerberos5.
264
265 %description gssapi -l pt_BR
266 Este plugin implementa o mecanismo SASL GSSAPI, usado para
267 autenticação Kerberos/GSSAPI.
268
269 %package login
270 Summary:        Unsupported Login Cyrus SASL plugin
271 Summary(pl):    Nie wspierana wtyczka Login do Cyrus SASL
272 Group:          Libraries
273 Requires:       %{name} = %{version}-%{release}
274
275 %description login
276 Unsupported LOGIN Cyrus SASL plugin.
277
278 %description login -l pl
279 Wtyczka dodaj±ca obs³ugê nie wspieranego mechanizmu LOGIN do Cyrus
280 SASL.
281
282 %package srp
283 Summary:        SRP Cyrus SASL plugin
284 Summary(pl):    Wtyczka SRP do Cyrus SASL
285 Summary(pt_BR): Mecanismo SASL SRP
286 Group:          Libraries
287 Requires:       %{name} = %{version}-%{release}
288
289 %description srp
290 This plugin implements the SASL SRP mechanism, based on the Secure
291 Remote Password protocol. This mechanism performs mutual
292 authentication and can provide a security layer with replay detection,
293 integrity protection and/or condifentiality protection.
294
295 %description srp -l pl
296 Wtyczka dodaj±ca obs³ugê mechanizmu SRP do Cyrus SASL. Bazuje na
297 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
298 uwierzytelnienia i mo¿e dodawaæ warstwê bezpieczeñstwa z wykrywaniem
299 powtarzania, zabezpieczeniem integralno¶ci i/lub poufno¶ci.
300
301 %description srp -l pt_BR
302 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
303 (Secure Remote Password). Este mecanismo oferece autenticação mútua
304 (do cliente e do servidor) e pode prover uma camada de segurança com
305 detecção de ataques de replay, garantia de integridade e/ou
306 confidencialidade.
307
308 %package otp
309 Summary:        OTP Cyrus SASL plugin
310 Summary(pl):    Wtyczka OTP do Cyrus SASL
311 Summary(pt_BR): Mecanismo SASL OTP
312 Group:          Libraries
313 Requires:       %{name} = %{version}-%{release}
314
315 %description otp
316 This plugin implements the SASL OTP (One Time Password) mechanism.
317
318 %description otp -l pl
319 Wtyczka dodaj±ca obs³ugê mechanizmu OTP (has³a jednorazowe) do Cyrus
320 SASL.
321
322 %package opie
323 Summary:        OPIE Cyrus SASL plugin
324 Summary(pl):    Wtyczka OPIE do Cyrus SASL
325 Summary(pt_BR): Mecanismo SASL OPIE
326 Group:          Libraries
327 Requires:       %{name} = %{version}-%{release}
328
329 %description opie
330 This plugin implements the SASL OPIE (One Time Password) mechanism.
331
332 %description opie -l pl
333 Wtyczka dodaj±ca obs³ugê mechanizmu OPIE (has³a jednorazowe) do Cyrus
334 SASL.
335
336 %package x509
337 Summary:        x509 Cyrus SASL plugin
338 Summary(pl):    Wtyczka x509 do Cyrus SASL
339 Group:          Libraries
340 Requires:       %{name} = %{version}-%{release}
341
342 %description x509
343 x509 Cyrus SASL plugin.
344
345 %description x509 -l pl
346 Wtyczka x509 do Cyrus SASL.
347
348 %package saslauthd
349 Summary:        Cyrus SASL authd
350 Summary(pl):    Demon authd do Cyrus SASL
351 Group:          Daemons
352 Requires(post,postun):  /sbin/chkconfig
353 Requires:       %{name} = %{version}-%{release}
354
355 %description saslauthd
356 Cyrus SASL authd.
357
358 %description saslauthd -l pl
359 Demon authd do Cyrus SASL.
360
361 %package pwcheck
362 Summary:        Cyrus SASL pwcheck helper
363 Summary(pl):    Program pomocniczy pwcheck do Cyrus SASL
364 Group:          Libraries
365 Requires:       %{name} = %{version}-%{release}
366
367 %description pwcheck
368 Cyrus SASL pwcheck helper.
369
370 %description pwcheck -l pl
371 Program pomocniczy pwcheck do Cyrus SASL.
372
373 %package sasldb
374 Summary:        Cyrus SASL sasldb plugin
375 Summary(pl):    Wtyczka sasldb do Cyrus SASL
376 Group:          Libraries
377 Requires:       %{name} = %{version}-%{release}
378
379 %description sasldb
380 Cyrus SASL sasldb plugin.
381
382 %description sasldb -l pl
383 Wtyczka sasldb do Cyrus SASL.
384
385 %package mysql
386 Summary:        Cyrus SASL MySQL plugin
387 Summary(pl):    Wtyczka MySQL do Cyrus SASL
388 Group:          Libraries
389 Requires:       %{name} = %{version}-%{release}
390
391 %description mysql
392 Cyrus SASL MySQL plugin.
393
394 %description mysql -l pl
395 Wtyczka MySQL do Cyrus SASL.
396
397 %package pgsql
398 Summary:        Cyrus SASL PostgreSQL plugin
399 Summary(pl):    Wtyczka PostgreSQL do Cyrus SASL
400 Group:          Libraries
401 Requires:       %{name} = %{version}-%{release}
402
403 %description pgsql
404 Cyrus SASL PostgreSQL plugin.
405
406 %description pgsql -l pl
407 Wtyczka PostgreSQL do Cyrus SASL.
408
409 %package sqlite
410 Summary:        Cyrus SQLite PostgreSQL plugin
411 Summary(pl):    Wtyczka SQLite do Cyrus SASL
412 Group:          Libraries
413 Requires:       %{name} = %{version}-%{release}
414
415 %description sqlite
416 Cyrus SASL SQLite plugin.
417
418 %description sqlite -l pl
419 Wtyczka SQLite do Cyrus SASL.
420
421 %prep
422 %setup -q
423 %patch0 -p1
424 %patch1 -p1
425 %patch2 -p1
426 %patch3 -p1
427 %patch4 -p1
428 %patch5 -p1
429 %if %{with cryptedpw}
430 %patch6 -p1
431 %patch7 -p1
432 %endif
433
434 cd doc
435 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
436 ls rfc*.txt >> rfc-compliance
437 rm -f rfc*.txt
438 cd ..
439
440 rm -rf autom4te.cache saslauthd/autom4te.cache
441 # acinclude.m4 contains only old libtool.m4
442 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
443
444 %build
445 %{__libtoolize}
446 %{__aclocal} -I cmulocal -I config
447 %{__autoheader}
448 %{__automake}
449 %{__autoconf}
450
451 cd saslauthd
452 %{__libtoolize}
453 %{__aclocal} -I ../cmulocal -I ../config -I config
454 %{__autoheader}
455 %{__automake}
456 %{__autoconf}
457 cd ..
458
459 %configure \
460         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
461         --disable-krb4 \
462         %{!?with_gssapi: --disable-gssapi} \
463         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
464         --enable-login \
465         --enable-sql \
466         %{?with_srp: --enable-srp} \
467         --enable-static \
468         --with-plugindir=%{_libdir}/sasl2 \
469         --with-configdir=%{_sysconfdir} \
470         --with-dblib=berkeley \
471         --with-dbpath=/var/lib/sasl2/sasl.db \
472         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
473         %{?with_ldap: --with-ldap=%{_prefix}} \
474         %{?with_mysql: --with-mysql=%{_prefix}} \
475         %{?with_pgsql: --with-pgsql=%{_prefix}} \
476         %{?with_sqlite: --with-sqlite=%{_prefix}} \
477         %{?with_opie: --with-opie=%{_prefix}} \
478         --with-pam \
479         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
480         --with-saslauthd=/var/lib/sasl2
481 %{__make}
482
483 %{__make} -C saslauthd testsaslauthd
484 %{__make} -C saslauthd saslcache
485
486 cd doc
487 RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
488 for i in $RFCLIST; do
489         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
490         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
491 done
492
493 %install
494 rm -rf $RPM_BUILD_ROOT
495 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
496                 $RPM_BUILD_ROOT%{_mandir}/man8
497
498 %{__make} install \
499         sasldir=%{_libdir}/sasl2 \
500         DESTDIR=$RPM_BUILD_ROOT
501
502 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
503 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
504
505 install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
506 install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
507
508 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
509
510 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
511
512 # create empty config
513 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
514 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
515 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
516 install %{SOURCE3} ./cyrus.pam
517
518 install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
519
520 # sample programs for testing sasl
521 libtool --mode=install cp sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
522 libtool --mode=install cp sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
523
524 %clean
525 rm -rf $RPM_BUILD_ROOT
526
527 %post   -p /sbin/ldconfig
528 %postun -p /sbin/ldconfig
529
530 %post saslauthd
531 /sbin/chkconfig --add saslauthd
532 if [ -f /var/lock/subsys/saslauthd ]; then
533         /etc/rc.d/init.d/saslauthd restart 1>&2
534 else
535         echo "Run \"/etc/rc.d/init.d/saslauthd start\" to start saslauthd."
536 fi
537
538 %preun saslauthd
539 if [ "$1" = "0" ]; then
540         if [ -f /var/lock/subsys/saslauthd ]; then
541                 /etc/rc.d/init.d/saslauthd stop 1>&2
542         fi
543         /sbin/chkconfig --del saslauthd
544 fi
545
546 %files
547 %defattr(644,root,root,755)
548 %doc AUTHORS COPYING ChangeLog NEWS README
549 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
550 %dir %{_sysconfdir}
551 %dir %{_libdir}/sasl2
552 %dir /var/lib/sasl2
553 %attr(755,root,root) %{_libdir}/lib*.so.*.*
554 # sample programs to subpackage instead?
555 %attr(755,root,root) %{_bindir}/sasl-sample-client
556 %attr(755,root,root) %{_bindir}/sasl-sample-server
557 %attr(755,root,root) %{_sbindir}/sasldblistusers2
558 %attr(755,root,root) %{_sbindir}/saslpasswd2
559
560 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
561 %{_mandir}/man8/sasldblistusers2.*
562 %{_mandir}/man8/saslpasswd2.*
563
564 %files devel
565 %defattr(644,root,root,755)
566 %{_includedir}/sasl
567 %attr(755,root,root) %{_libdir}/lib*.so
568 %{_libdir}/lib*.la
569 %{_mandir}/man3/*
570
571 %files static
572 %defattr(644,root,root,755)
573 %{_libdir}/lib*.a
574
575 %files anonymous
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
578
579 %if %{with gssapi}
580 %files gssapi
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
583 %endif
584
585 %files cram-md5
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
588
589 %files digest-md5
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
592
593 %files login
594 %defattr(644,root,root,755)
595 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
596
597 %files otp
598 %defattr(644,root,root,755)
599 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
600
601 %if %{with opie}
602 %files opie
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
605 %endif
606
607 %files plain
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
610
611 %files sasldb
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
614
615 %if %{with mysql}
616 %files mysql
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
619 %endif
620
621 %if %{with pgsql}
622 %files pgsql
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
625 %endif
626
627 %if %{with sqlite}
628 %files sqlite
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
631 %endif
632
633 %if %{with srp}
634 %files srp
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
637 %endif
638
639 %if %{with x509}
640 %files x509
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
643 %endif
644
645 %if %{with pwcheck}
646 %files pwcheck
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_sbindir}/pwcheck
649 %endif
650
651 %files saslauthd
652 %defattr(644,root,root,755)
653 %doc cyrus.pam
654 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
655 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
656 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
657 %attr(755,root,root) %{_sbindir}/saslauthd
658 %attr(755,root,root) %{_sbindir}/testsaslauthd
659 %attr(755,root,root) %{_sbindir}/saslcache
660 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
661 %{_mandir}/man8/saslauthd.*
This page took 0.083298 seconds and 4 git commands to generate.