]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- am version
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # enable opie plugin
13 %bcond_with     srp             # build srp pluggin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 %bcond_with     x509            # build x509 plugin (no sources in package???)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.23
28 Release:        5
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
32 # Source0-md5:  2eb0e48106f0e9cd8001e654f267ecbc
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-db.patch
46 Patch8:         %{name}-automake_1_10.patch
47 Patch9:         %{name}-digest-commas.patch
48 Patch10:        %{name}-keytab.patch
49 Patch11:        %{name}-sizes.patch
50 Patch12:        %{name}-nagios-plugin.patch
51 Patch13:        %{name}-parallel-make.patch
52 URL:            http://asg.web.cmu.edu/sasl/
53 BuildRequires:  autoconf >= 2.54
54 BuildRequires:  automake >= 1:1.7
55 %{?with_authlib:BuildRequires:  courier-authlib-devel}
56 BuildRequires:  db-devel
57 BuildRequires:  ed
58 BuildRequires:  groff
59 %{?with_gssapi:BuildRequires:   heimdal-devel}
60 BuildRequires:  libtool >= 1.4
61 %{?with_mysql:BuildRequires:    mysql-devel}
62 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
63 BuildRequires:  openssl-devel >= 0.9.7d
64 %{?with_opie:BuildRequires:     opie-devel}
65 BuildRequires:  pam-devel
66 %{?with_pgsql:BuildRequires:    postgresql-devel}
67 BuildRequires:  rpmbuild(macros) >= 1.268
68 %{?with_sqlite:BuildRequires:   sqlite-devel}
69 Requires:       pam >= 0.79.0
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         _sysconfdir     /etc/sasl
73
74 %define         specflags       -fno-strict-aliasing
75
76 %description
77 This is an implementation of the SASL API, useful for adding
78 authentication, authorization, and security to network protocols. The
79 SASL protocol itself is documented in rfc2222; the API standard is a
80 work in progress.
81
82 Note: remember to install appropriate plugins, or you won't have any
83 authentication mechanisms available.
84
85 %description -l pl.UTF-8
86 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
87 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
88 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
89 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
90 RFC 2222; standaryzacja API jest w toku.
91
92 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
93 doinstalować odpowiednie wtyczki.
94
95 %description -l pt_BR.UTF-8
96 Esta é uma implementação da API SASL, útil para acrescentar
97 autenticação, autorização e seguança (criptografia) para protocolos de
98 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
99 ainda está em desenvolvimento.
100
101 %description -l ru.UTF-8
102 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
103 Authentication and Security Layer, метод для добавления поддержки
104 аутентикации к протоколам, основанным на соединениях.
105
106 %description -l uk.UTF-8
107 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
108 Authentication and Security Layer, метод для додання підтримки
109 аутентикації до протоколів, базованих на з'єднаннях.
110
111 %package devel
112 Summary:        Header files and documentation for cyrus-sasl
113 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
114 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
115 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
116 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
117 Group:          Development/Libraries
118 Requires:       %{name} = %{version}-%{release}
119
120 %description devel
121 This includes the header files and documentation needed to develop
122 applications which use SASL.
123
124 %description devel -l pl.UTF-8
125 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
126
127 %description devel -l pt_BR.UTF-8
128 Este pacote inclui os arquivos de cabeçalho e documentação necessários
129 para desenvolver aplicativos que usem SASL.
130
131 %description devel -l ru.UTF-8
132 Хедеры и библиотеки, необходимые для разработки приложений,
133 использующих Cyrus SASL.
134
135 %description devel -l uk.UTF-8
136 Хедери та бібліотеки, необхідні для розробки програм, що
137 використовують Cyrus SASL.
138
139 %package static
140 Summary:        Static cyrus-sasl libraries
141 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
142 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
143 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
144 Group:          Development/Libraries
145 Requires:       %{name}-devel = %{version}-%{release}
146
147 %description static
148 Static cyrus-sasl libraries.
149
150 %description static -l pl.UTF-8
151 Statyczne biblioteki cyrus-sasl.
152
153 %description static -l ru.UTF-8
154 Статические библиотеки, необходимые для разработки приложений,
155 использующих Cyrus SASL.
156
157 %description static -l uk.UTF-8
158 Статичні бібліотеки, необхідні для розробки програм, що використовують
159 Cyrus SASL.
160
161 %package cram-md5
162 Summary:        Cram-MD5 Cyrus SASL plugin
163 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
164 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
165 Group:          Libraries
166 Requires:       %{name} = %{version}-%{release}
167
168 %description cram-md5
169 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
170 mandatory-to-implement authentication mechanism for a number of
171 protocols; it uses MD5 with a challenge/response system to
172 authenticate the user.
173
174 %description cram-md5 -l pl.UTF-8
175 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
176 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
177 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
178 systemem challenge/response.
179
180 %description cram-md5 -l pt_BR.UTF-8
181 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
182 mecanismo de autenticação obrigatório de ser implementado para vários
183 protocolos: ele usa MD5 com um sistema de desafio/resposta para
184 autenticar o usuário.
185
186 %package digest-md5
187 Summary:        Digest-MD5 Cyrus SASL plugin
188 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
189 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
190 Group:          Libraries
191 Requires:       %{name} = %{version}-%{release}
192
193 %description digest-md5
194 This plugin implements the latest draft of the SASL DIGEST-MD5
195 mechanism. Although not yet finalized, this is likely to become the
196 new mandatory-to-implement authentication system in all new protocols.
197 It's based on the digest md5 authentication system designed for HTTP.
198
199 %description digest-md5 -l pl.UTF-8
200 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
201 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
202 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
203 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
204 Digest-MD5 zaprojektowanym dla HTTP.
205
206 %description digest-md5 -l pt_BR.UTF-8
207 Este plugin implementa a última versão da especificação do mecanismo
208 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
209 provavelmente será o novo sistema de autenticação obrigatório para
210 protocolos novos. Ele é baseado na autenticação md5 digest
211 desenvolvida para HTTP.
212
213 %package plain
214 Summary:        Plain Cyrus SASL plugin
215 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
216 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
217 Group:          Libraries
218 Requires:       %{name} = %{version}-%{release}
219
220 %description plain
221 This plugin implements the SASL PLAIN mechanism. Although insecure,
222 PLAIN is useful for transitioning to new security mechanisms, as this
223 is the only mechanism which gives the server a copy of the user's
224 password.
225
226 %description plain -l pl.UTF-8
227 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
228 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
229 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
230 który udostępnia serwerowi kopię hasła użytkownika.
231
232 %description plain -l pt_BR.UTF-8
233 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
234 mecanismo é útil durante transições para novos mecanismos de
235 segurança, pois é o único esquema que fornece uma cópia da senha do
236 usuário para o servidor.
237
238 %package anonymous
239 Summary:        Anonymous Cyrus SASL plugin
240 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
241 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
242 Group:          Libraries
243 Requires:       %{name} = %{version}-%{release}
244
245 %description anonymous
246 This plugin implements the SASL ANONYMOUS mechanism, used for
247 anonymous authentication.
248
249 %description anonymous -l pl.UTF-8
250 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
251 anonimowego uwierzytelniania.
252
253 %description anonymous -l pt_BR.UTF-8
254 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
255 autenticação anônima.
256
257 %package gssapi
258 Summary:        GSSAPI Cyrus SASL plugin
259 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
260 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
261 Group:          Libraries
262 Requires:       %{name} = %{version}-%{release}
263
264 %description gssapi
265 This plugin implements the SASL GSSAPI mechanism, used for
266 GSSAPI/Kerberos5 authentication.
267
268 %description gssapi -l pl.UTF-8
269 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
270 uwierzytelniania z użyciem GSSAPI/Kerberos5.
271
272 %description gssapi -l pt_BR.UTF-8
273 Este plugin implementa o mecanismo SASL GSSAPI, usado para
274 autenticação Kerberos/GSSAPI.
275
276 %package login
277 Summary:        Unsupported Login Cyrus SASL plugin
278 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
279 Group:          Libraries
280 Requires:       %{name} = %{version}-%{release}
281
282 %description login
283 Unsupported LOGIN Cyrus SASL plugin.
284
285 %description login -l pl.UTF-8
286 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
287 SASL.
288
289 %package srp
290 Summary:        SRP Cyrus SASL plugin
291 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
292 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
293 Group:          Libraries
294 Requires:       %{name} = %{version}-%{release}
295
296 %description srp
297 This plugin implements the SASL SRP mechanism, based on the Secure
298 Remote Password protocol. This mechanism performs mutual
299 authentication and can provide a security layer with replay detection,
300 integrity protection and/or condifentiality protection.
301
302 %description srp -l pl.UTF-8
303 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
304 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
305 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
306 powtarzania, zabezpieczeniem integralności i/lub poufności.
307
308 %description srp -l pt_BR.UTF-8
309 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
310 (Secure Remote Password). Este mecanismo oferece autenticação mútua
311 (do cliente e do servidor) e pode prover uma camada de segurança com
312 detecção de ataques de replay, garantia de integridade e/ou
313 confidencialidade.
314
315 %package otp
316 Summary:        OTP Cyrus SASL plugin
317 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
318 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
319 Group:          Libraries
320 Requires:       %{name} = %{version}-%{release}
321
322 %description otp
323 This plugin implements the SASL OTP (One Time Password) mechanism.
324
325 %description otp -l pl.UTF-8
326 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
327 SASL.
328
329 %package opie
330 Summary:        OPIE Cyrus SASL plugin
331 Summary(pl.UTF-8):      Wtyczka OPIE do Cyrus SASL
332 Summary(pt_BR.UTF-8):   Mecanismo SASL OPIE
333 Group:          Libraries
334 Requires:       %{name} = %{version}-%{release}
335
336 %description opie
337 This plugin implements the SASL OPIE (One Time Password) mechanism.
338
339 %description opie -l pl.UTF-8
340 Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
341 SASL.
342
343 %package x509
344 Summary:        x509 Cyrus SASL plugin
345 Summary(pl.UTF-8):      Wtyczka x509 do Cyrus SASL
346 Group:          Libraries
347 Requires:       %{name} = %{version}-%{release}
348
349 %description x509
350 x509 Cyrus SASL plugin.
351
352 %description x509 -l pl.UTF-8
353 Wtyczka x509 do Cyrus SASL.
354
355 %package saslauthd
356 Summary:        Cyrus SASL authd
357 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
358 Group:          Daemons
359 Requires(post,preun):   /sbin/chkconfig
360 Requires:       %{name} = %{version}-%{release}
361 Requires:       /sbin/chkconfig
362 Requires:       rc-scripts
363
364 %description saslauthd
365 Cyrus SASL authd.
366
367 %description saslauthd -l pl.UTF-8
368 Demon authd do Cyrus SASL.
369
370 %package pwcheck
371 Summary:        Cyrus SASL pwcheck helper
372 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
373 Group:          Libraries
374 Requires:       %{name} = %{version}-%{release}
375
376 %description pwcheck
377 Cyrus SASL pwcheck helper.
378
379 %description pwcheck -l pl.UTF-8
380 Program pomocniczy pwcheck do Cyrus SASL.
381
382 %package sasldb
383 Summary:        Cyrus SASL sasldb plugin
384 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
385 Group:          Libraries
386 Requires:       %{name} = %{version}-%{release}
387
388 %description sasldb
389 Cyrus SASL sasldb plugin.
390
391 %description sasldb -l pl.UTF-8
392 Wtyczka sasldb do Cyrus SASL.
393
394 %package mysql
395 Summary:        Cyrus SASL MySQL plugin
396 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
397 Group:          Libraries
398 Requires:       %{name} = %{version}-%{release}
399
400 %description mysql
401 Cyrus SASL MySQL plugin.
402
403 %description mysql -l pl.UTF-8
404 Wtyczka MySQL do Cyrus SASL.
405
406 %package pgsql
407 Summary:        Cyrus SASL PostgreSQL plugin
408 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
409 Group:          Libraries
410 Requires:       %{name} = %{version}-%{release}
411
412 %description pgsql
413 Cyrus SASL PostgreSQL plugin.
414
415 %description pgsql -l pl.UTF-8
416 Wtyczka PostgreSQL do Cyrus SASL.
417
418 %package sqlite
419 Summary:        Cyrus SQLite PostgreSQL plugin
420 Summary(pl.UTF-8):      Wtyczka SQLite do Cyrus SASL
421 Group:          Libraries
422 Requires:       %{name} = %{version}-%{release}
423
424 %description sqlite
425 Cyrus SASL SQLite plugin.
426
427 %description sqlite -l pl.UTF-8
428 Wtyczka SQLite do Cyrus SASL.
429
430 %package -n nagios-plugin-check_saslauthd
431 Summary:        Nagios plugin to check health of saslauthd
432 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
433 Group:          Networking
434 Requires:       nagios-core
435
436 %description -n nagios-plugin-check_saslauthd
437 Nagios plugin to check health of saslauthd.
438
439 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
440 Wtyczka Nagiosa do sprawdzania działania saslauthd.
441
442 %prep
443 %setup -q
444 %patch0 -p1
445 %patch1 -p1
446 %patch2 -p1
447 %patch3 -p1
448 %patch4 -p1
449 %if %{with cryptedpw}
450 %patch5 -p1
451 %patch6 -p1
452 %endif
453 %patch7 -p1
454 %patch8 -p1
455 %patch9 -p2
456 %patch10 -p1
457 %patch11 -p1
458 %patch12 -p1
459 %patch13 -p1
460
461 cd doc
462 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
463 ls rfc*.txt >> rfc-compliance
464 rm -f rfc*.txt
465 cd ..
466
467 rm -rf autom4te.cache saslauthd/autom4te.cache
468 # acinclude.m4 contains only old libtool.m4
469 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
470
471 %build
472 %{__libtoolize}
473 %{__aclocal} -I cmulocal -I config
474 %{__autoheader}
475 %{__automake}
476 %{__autoconf}
477
478 cd saslauthd
479 %{__libtoolize}
480 %{__aclocal} -I ../cmulocal -I ../config -I config
481 %{__autoheader}
482 %{__automake}
483 %{__autoconf}
484 cd ..
485
486 %configure \
487         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
488         --disable-krb4 \
489         %{!?with_gssapi: --disable-gssapi} \
490         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
491         --enable-login \
492         --enable-sample \
493         --enable-httpform \
494         --enable-sql \
495         %{?with_srp: --enable-srp} \
496         --enable-static \
497         --with-plugindir=%{_libdir}/sasl2 \
498         --with-configdir=%{_sysconfdir} \
499         --with-dblib=berkeley \
500         --with-dbpath=/var/lib/sasl2/sasl.db \
501         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
502         %{?with_ldap: --with-ldap=%{_prefix}} \
503         %{?with_mysql: --with-mysql=%{_prefix}} \
504         %{?with_pgsql: --with-pgsql=%{_prefix}} \
505         %{?with_sqlite: --with-sqlite=%{_prefix}} \
506         %{?with_opie: --with-opie=%{_prefix}} \
507         --with-pam \
508         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
509         --with-saslauthd=/var/lib/sasl2
510 %{__make}
511
512 %{__make} -C saslauthd testsaslauthd
513 %{__make} -C saslauthd saslcache
514 %{__make} -C sample sample-client sample-server
515
516 cd doc
517 RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
518 for i in $RFCLIST; do
519         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
520         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
521 done
522
523 %install
524 rm -rf $RPM_BUILD_ROOT
525 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
526                 $RPM_BUILD_ROOT%{_mandir}/man8
527
528 %{__make} install \
529         sasldir=%{_libdir}/sasl2 \
530         DESTDIR=$RPM_BUILD_ROOT
531
532 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
533 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
534
535 install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
536 install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
537
538 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
539
540 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
541
542 # create empty config
543 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
544 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
545 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
546 install %{SOURCE3} cyrus.pam
547
548 install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
549
550 # sample programs for testing sasl
551 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
552 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
553
554 # package for ghost
555 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
556
557 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
558 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
559
560 %clean
561 rm -rf $RPM_BUILD_ROOT
562
563 %post   -p /sbin/ldconfig
564 %postun -p /sbin/ldconfig
565
566 %post saslauthd
567 /sbin/chkconfig --add saslauthd
568 %service saslauthd restart
569
570 %preun saslauthd
571 if [ "$1" = "0" ]; then
572         %service saslauthd stop
573         /sbin/chkconfig --del saslauthd
574 fi
575
576 %files
577 %defattr(644,root,root,755)
578 %doc AUTHORS COPYING ChangeLog NEWS README
579 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
580 %dir %{_sysconfdir}
581 %dir %{_libdir}/sasl2
582 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
583 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
584 # sample programs to subpackage instead?
585 %attr(755,root,root) %{_bindir}/sasl-sample-client
586 %attr(755,root,root) %{_bindir}/sasl-sample-server
587 %attr(755,root,root) %{_sbindir}/pluginviewer
588 %attr(755,root,root) %{_sbindir}/sasldblistusers2
589 %attr(755,root,root) %{_sbindir}/saslpasswd2
590 %dir /var/lib/sasl2
591 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
592 %{_mandir}/man8/pluginviewer.8*
593 %{_mandir}/man8/sasldblistusers2.8*
594 %{_mandir}/man8/saslpasswd2.8*
595
596 %files devel
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_libdir}/libsasl2.so
599 %attr(755,root,root) %{_libdir}/libsasl.so
600 %{_libdir}/libsasl2.la
601 %{_includedir}/sasl
602 %{_mandir}/man3/sasl*.3*
603
604 %files static
605 %defattr(644,root,root,755)
606 %{_libdir}/libsasl2.a
607
608 %files anonymous
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
611
612 %if %{with gssapi}
613 %files gssapi
614 %defattr(644,root,root,755)
615 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
616 %endif
617
618 %files cram-md5
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
621
622 %files digest-md5
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
625
626 %files login
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
629
630 %files otp
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
633
634 %if %{with opie}
635 %files opie
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
638 %endif
639
640 %files plain
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
643
644 %files sasldb
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
647
648 %if %{with mysql}
649 %files mysql
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
652 %endif
653
654 %if %{with pgsql}
655 %files pgsql
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
658 %endif
659
660 %if %{with sqlite}
661 %files sqlite
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
664 %endif
665
666 %if %{with srp}
667 %files srp
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
670 %endif
671
672 %if %{with x509}
673 %files x509
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
676 %endif
677
678 %if %{with pwcheck}
679 %files pwcheck
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_sbindir}/pwcheck
682 %endif
683
684 %files saslauthd
685 %defattr(644,root,root,755)
686 %doc cyrus.pam
687 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
688 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
689 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
690 %attr(755,root,root) %{_sbindir}/saslauthd
691 %attr(755,root,root) %{_sbindir}/testsaslauthd
692 %attr(755,root,root) %{_sbindir}/saslcache
693 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
694 %ghost /var/lib/sasl2/cache.flock
695 %ghost /var/lib/sasl2/cache.mmap
696 %ghost /var/lib/sasl2/mux
697 %ghost /var/lib/sasl2/mux.accept
698 %ghost /var/lib/sasl2/saslauthd.pid
699 %{_mandir}/man8/saslauthd.8*
700
701 %files -n nagios-plugin-check_saslauthd
702 %defattr(644,root,root,755)
703 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
704 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.133858 seconds and 4 git commands to generate.