]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- merged nagios plugin from AC-branch
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # enable opie plugin
13 %bcond_with     srp             # build srp pluggin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 %bcond_with     x509            # build x509 plugin (no sources in package???)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.22
28 Release:        15
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
32 # Source0-md5:  45dde9d19193ae9dd388eb68b2027bc9
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-db.patch
46 Patch8:         %{name}-automake_1_10.patch
47 Patch9:         %{name}-digest-commas.patch
48 Patch10:        %{name}-keytab.patch
49 Patch11:        %{name}-sizes.patch
50 Patch12:        %{name}-nagios-plugin.patch
51 URL:            http://asg.web.cmu.edu/sasl/
52 BuildRequires:  autoconf >= 2.54
53 BuildRequires:  automake
54 %{?with_authlib:BuildRequires:  courier-authlib-devel}
55 BuildRequires:  db-devel
56 BuildRequires:  ed
57 BuildRequires:  groff
58 %{?with_gssapi:BuildRequires:   krb5-devel}
59 BuildRequires:  libtool >= 1.4
60 %{?with_mysql:BuildRequires:    mysql-devel}
61 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
62 BuildRequires:  openssl-devel >= 0.9.7d
63 %{?with_opie:BuildRequires:     opie-devel}
64 BuildRequires:  pam-devel
65 %{?with_pgsql:BuildRequires:    postgresql-devel}
66 BuildRequires:  rpmbuild(macros) >= 1.268
67 %{?with_sqlite:BuildRequires:   sqlite-devel}
68 Requires:       pam >= 0.79.0
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         _sysconfdir     /etc/sasl
72
73 %define         specflags       -fno-strict-aliasing
74
75 %description
76 This is an implementation of the SASL API, useful for adding
77 authentication, authorization, and security to network protocols. The
78 SASL protocol itself is documented in rfc2222; the API standard is a
79 work in progress.
80
81 Note: remember to install appropriate plugins, or you won't have any
82 authentication mechanisms available.
83
84 %description -l pl.UTF-8
85 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
86 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
87 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
88 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
89 RFC 2222; standaryzacja API jest w toku.
90
91 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
92 doinstalować odpowiednie wtyczki.
93
94 %description -l pt_BR.UTF-8
95 Esta é uma implementação da API SASL, útil para acrescentar
96 autenticação, autorização e seguança (criptografia) para protocolos de
97 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
98 ainda está em desenvolvimento.
99
100 %description -l ru.UTF-8
101 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
102 Authentication and Security Layer, метод для добавления поддержки
103 аутентикации к протоколам, основанным на соединениях.
104
105 %description -l uk.UTF-8
106 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
107 Authentication and Security Layer, метод для додання підтримки
108 аутентикації до протоколів, базованих на з'єднаннях.
109
110 %package devel
111 Summary:        Header files and documentation for cyrus-sasl
112 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
113 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
114 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
115 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
116 Group:          Development/Libraries
117 Requires:       %{name} = %{version}-%{release}
118
119 %description devel
120 This includes the header files and documentation needed to develop
121 applications which use SASL.
122
123 %description devel -l pl.UTF-8
124 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
125
126 %description devel -l pt_BR.UTF-8
127 Este pacote inclui os arquivos de cabeçalho e documentação necessários
128 para desenvolver aplicativos que usem SASL.
129
130 %description devel -l ru.UTF-8
131 Хедеры и библиотеки, необходимые для разработки приложений,
132 использующих Cyrus SASL.
133
134 %description devel -l uk.UTF-8
135 Хедери та бібліотеки, необхідні для розробки програм, що
136 використовують Cyrus SASL.
137
138 %package static
139 Summary:        Static cyrus-sasl libraries
140 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
141 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
142 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
143 Group:          Development/Libraries
144 Requires:       %{name}-devel = %{version}-%{release}
145
146 %description static
147 Static cyrus-sasl libraries.
148
149 %description static -l pl.UTF-8
150 Statyczne biblioteki cyrus-sasl.
151
152 %description static -l ru.UTF-8
153 Статические библиотеки, необходимые для разработки приложений,
154 использующих Cyrus SASL.
155
156 %description static -l uk.UTF-8
157 Статичні бібліотеки, необхідні для розробки програм, що використовують
158 Cyrus SASL.
159
160 %package cram-md5
161 Summary:        Cram-MD5 Cyrus SASL plugin
162 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
163 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
164 Group:          Libraries
165 Requires:       %{name} = %{version}-%{release}
166
167 %description cram-md5
168 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
169 mandatory-to-implement authentication mechanism for a number of
170 protocols; it uses MD5 with a challenge/response system to
171 authenticate the user.
172
173 %description cram-md5 -l pl.UTF-8
174 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
175 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
176 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
177 systemem challenge/response.
178
179 %description cram-md5 -l pt_BR.UTF-8
180 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
181 mecanismo de autenticação obrigatório de ser implementado para vários
182 protocolos: ele usa MD5 com um sistema de desafio/resposta para
183 autenticar o usuário.
184
185 %package digest-md5
186 Summary:        Digest-MD5 Cyrus SASL plugin
187 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
188 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
189 Group:          Libraries
190 Requires:       %{name} = %{version}-%{release}
191
192 %description digest-md5
193 This plugin implements the latest draft of the SASL DIGEST-MD5
194 mechanism. Although not yet finalized, this is likely to become the
195 new mandatory-to-implement authentication system in all new protocols.
196 It's based on the digest md5 authentication system designed for HTTP.
197
198 %description digest-md5 -l pl.UTF-8
199 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
200 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
201 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
202 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
203 Digest-MD5 zaprojektowanym dla HTTP.
204
205 %description digest-md5 -l pt_BR.UTF-8
206 Este plugin implementa a última versão da especificação do mecanismo
207 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
208 provavelmente será o novo sistema de autenticação obrigatório para
209 protocolos novos. Ele é baseado na autenticação md5 digest
210 desenvolvida para HTTP.
211
212 %package plain
213 Summary:        Plain Cyrus SASL plugin
214 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
215 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
216 Group:          Libraries
217 Requires:       %{name} = %{version}-%{release}
218
219 %description plain
220 This plugin implements the SASL PLAIN mechanism. Although insecure,
221 PLAIN is useful for transitioning to new security mechanisms, as this
222 is the only mechanism which gives the server a copy of the user's
223 password.
224
225 %description plain -l pl.UTF-8
226 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
227 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
228 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
229 który udostępnia serwerowi kopię hasła użytkownika.
230
231 %description plain -l pt_BR.UTF-8
232 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
233 mecanismo é útil durante transições para novos mecanismos de
234 segurança, pois é o único esquema que fornece uma cópia da senha do
235 usuário para o servidor.
236
237 %package anonymous
238 Summary:        Anonymous Cyrus SASL plugin
239 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
240 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
241 Group:          Libraries
242 Requires:       %{name} = %{version}-%{release}
243
244 %description anonymous
245 This plugin implements the SASL ANONYMOUS mechanism, used for
246 anonymous authentication.
247
248 %description anonymous -l pl.UTF-8
249 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
250 anonimowego uwierzytelniania.
251
252 %description anonymous -l pt_BR.UTF-8
253 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
254 autenticação anônima.
255
256 %package gssapi
257 Summary:        GSSAPI Cyrus SASL plugin
258 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
259 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
260 Group:          Libraries
261 Requires:       %{name} = %{version}-%{release}
262
263 %description gssapi
264 This plugin implements the SASL GSSAPI mechanism, used for
265 GSSAPI/Kerberos5 authentication.
266
267 %description gssapi -l pl.UTF-8
268 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
269 uwierzytelniania z użyciem GSSAPI/Kerberos5.
270
271 %description gssapi -l pt_BR.UTF-8
272 Este plugin implementa o mecanismo SASL GSSAPI, usado para
273 autenticação Kerberos/GSSAPI.
274
275 %package login
276 Summary:        Unsupported Login Cyrus SASL plugin
277 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
278 Group:          Libraries
279 Requires:       %{name} = %{version}-%{release}
280
281 %description login
282 Unsupported LOGIN Cyrus SASL plugin.
283
284 %description login -l pl.UTF-8
285 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
286 SASL.
287
288 %package srp
289 Summary:        SRP Cyrus SASL plugin
290 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
291 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
292 Group:          Libraries
293 Requires:       %{name} = %{version}-%{release}
294
295 %description srp
296 This plugin implements the SASL SRP mechanism, based on the Secure
297 Remote Password protocol. This mechanism performs mutual
298 authentication and can provide a security layer with replay detection,
299 integrity protection and/or condifentiality protection.
300
301 %description srp -l pl.UTF-8
302 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
303 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
304 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
305 powtarzania, zabezpieczeniem integralności i/lub poufności.
306
307 %description srp -l pt_BR.UTF-8
308 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
309 (Secure Remote Password). Este mecanismo oferece autenticação mútua
310 (do cliente e do servidor) e pode prover uma camada de segurança com
311 detecção de ataques de replay, garantia de integridade e/ou
312 confidencialidade.
313
314 %package otp
315 Summary:        OTP Cyrus SASL plugin
316 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
317 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
318 Group:          Libraries
319 Requires:       %{name} = %{version}-%{release}
320
321 %description otp
322 This plugin implements the SASL OTP (One Time Password) mechanism.
323
324 %description otp -l pl.UTF-8
325 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
326 SASL.
327
328 %package opie
329 Summary:        OPIE Cyrus SASL plugin
330 Summary(pl.UTF-8):      Wtyczka OPIE do Cyrus SASL
331 Summary(pt_BR.UTF-8):   Mecanismo SASL OPIE
332 Group:          Libraries
333 Requires:       %{name} = %{version}-%{release}
334
335 %description opie
336 This plugin implements the SASL OPIE (One Time Password) mechanism.
337
338 %description opie -l pl.UTF-8
339 Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
340 SASL.
341
342 %package x509
343 Summary:        x509 Cyrus SASL plugin
344 Summary(pl.UTF-8):      Wtyczka x509 do Cyrus SASL
345 Group:          Libraries
346 Requires:       %{name} = %{version}-%{release}
347
348 %description x509
349 x509 Cyrus SASL plugin.
350
351 %description x509 -l pl.UTF-8
352 Wtyczka x509 do Cyrus SASL.
353
354 %package saslauthd
355 Summary:        Cyrus SASL authd
356 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
357 Group:          Daemons
358 Requires(post,preun):   /sbin/chkconfig
359 Requires:       %{name} = %{version}-%{release}
360 Requires:       /sbin/chkconfig
361 Requires:       rc-scripts
362
363 %description saslauthd
364 Cyrus SASL authd.
365
366 %description saslauthd -l pl.UTF-8
367 Demon authd do Cyrus SASL.
368
369 %package pwcheck
370 Summary:        Cyrus SASL pwcheck helper
371 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
372 Group:          Libraries
373 Requires:       %{name} = %{version}-%{release}
374
375 %description pwcheck
376 Cyrus SASL pwcheck helper.
377
378 %description pwcheck -l pl.UTF-8
379 Program pomocniczy pwcheck do Cyrus SASL.
380
381 %package sasldb
382 Summary:        Cyrus SASL sasldb plugin
383 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
384 Group:          Libraries
385 Requires:       %{name} = %{version}-%{release}
386
387 %description sasldb
388 Cyrus SASL sasldb plugin.
389
390 %description sasldb -l pl.UTF-8
391 Wtyczka sasldb do Cyrus SASL.
392
393 %package mysql
394 Summary:        Cyrus SASL MySQL plugin
395 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
396 Group:          Libraries
397 Requires:       %{name} = %{version}-%{release}
398
399 %description mysql
400 Cyrus SASL MySQL plugin.
401
402 %description mysql -l pl.UTF-8
403 Wtyczka MySQL do Cyrus SASL.
404
405 %package pgsql
406 Summary:        Cyrus SASL PostgreSQL plugin
407 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
408 Group:          Libraries
409 Requires:       %{name} = %{version}-%{release}
410
411 %description pgsql
412 Cyrus SASL PostgreSQL plugin.
413
414 %description pgsql -l pl.UTF-8
415 Wtyczka PostgreSQL do Cyrus SASL.
416
417 %package sqlite
418 Summary:        Cyrus SQLite PostgreSQL plugin
419 Summary(pl.UTF-8):      Wtyczka SQLite do Cyrus SASL
420 Group:          Libraries
421 Requires:       %{name} = %{version}-%{release}
422
423 %description sqlite
424 Cyrus SASL SQLite plugin.
425
426 %description sqlite -l pl.UTF-8
427 Wtyczka SQLite do Cyrus SASL.
428
429 %package -n nagios-plugin-check_saslauthd
430 Summary:        Nagios plugin to check health of saslauthd
431 Group:          Networking
432 Requires:       nagios-core
433
434 %description -n nagios-plugin-check_saslauthd
435 Nagios plugin to check health of saslauthd
436
437 %prep
438 %setup -q
439 %patch0 -p1
440 %patch1 -p1
441 %patch2 -p1
442 %patch3 -p1
443 %patch4 -p1
444 %if %{with cryptedpw}
445 %patch5 -p1
446 %patch6 -p1
447 %endif
448 %patch7 -p1
449 %patch8 -p1
450 %patch9 -p2
451 %patch10 -p1
452 %patch11 -p1
453 %patch12 -p1
454
455 cd doc
456 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
457 ls rfc*.txt >> rfc-compliance
458 rm -f rfc*.txt
459 cd ..
460
461 rm -rf autom4te.cache saslauthd/autom4te.cache
462 # acinclude.m4 contains only old libtool.m4
463 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
464
465 %build
466 %{__libtoolize}
467 %{__aclocal} -I cmulocal -I config
468 %{__autoheader}
469 %{__automake}
470 %{__autoconf}
471
472 cd saslauthd
473 %{__libtoolize}
474 %{__aclocal} -I ../cmulocal -I ../config -I config
475 %{__autoheader}
476 %{__automake}
477 %{__autoconf}
478 cd ..
479
480 %configure \
481         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
482         --disable-krb4 \
483         %{!?with_gssapi: --disable-gssapi} \
484         %{?with_gssapi: --enable-gssapi --with-gss_impl=mit} \
485         --enable-login \
486         --enable-sample \
487         --enable-httpform \
488         --enable-sql \
489         %{?with_srp: --enable-srp} \
490         --enable-static \
491         --with-plugindir=%{_libdir}/sasl2 \
492         --with-configdir=%{_sysconfdir} \
493         --with-dblib=berkeley \
494         --with-dbpath=/var/lib/sasl2/sasl.db \
495         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
496         %{?with_ldap: --with-ldap=%{_prefix}} \
497         %{?with_mysql: --with-mysql=%{_prefix}} \
498         %{?with_pgsql: --with-pgsql=%{_prefix}} \
499         %{?with_sqlite: --with-sqlite=%{_prefix}} \
500         %{?with_opie: --with-opie=%{_prefix}} \
501         --with-pam \
502         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
503         --with-saslauthd=/var/lib/sasl2
504 %{__make}
505
506 %{__make} -C saslauthd testsaslauthd
507 %{__make} -C saslauthd saslcache
508
509 cd doc
510 RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
511 for i in $RFCLIST; do
512         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
513         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
514 done
515
516 %install
517 rm -rf $RPM_BUILD_ROOT
518 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
519                 $RPM_BUILD_ROOT%{_mandir}/man8
520
521 %{__make} install \
522         sasldir=%{_libdir}/sasl2 \
523         DESTDIR=$RPM_BUILD_ROOT
524
525 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
526 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
527
528 install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
529 install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
530
531 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
532
533 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
534
535 # create empty config
536 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
537 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
538 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
539 install %{SOURCE3} cyrus.pam
540
541 install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
542
543 # sample programs for testing sasl
544 libtool --mode=install cp sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
545 libtool --mode=install cp sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
546
547 # package for ghost
548 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
549
550 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
551 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
552
553 %clean
554 rm -rf $RPM_BUILD_ROOT
555
556 %post   -p /sbin/ldconfig
557 %postun -p /sbin/ldconfig
558
559 %post saslauthd
560 /sbin/chkconfig --add saslauthd
561 %service saslauthd restart
562
563 %preun saslauthd
564 if [ "$1" = "0" ]; then
565         %service saslauthd stop
566         /sbin/chkconfig --del saslauthd
567 fi
568
569 %files
570 %defattr(644,root,root,755)
571 %doc AUTHORS COPYING ChangeLog NEWS README
572 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
573 %dir %{_sysconfdir}
574 %dir %{_libdir}/sasl2
575 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
576 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
577 # sample programs to subpackage instead?
578 %attr(755,root,root) %{_bindir}/sasl-sample-client
579 %attr(755,root,root) %{_bindir}/sasl-sample-server
580 %attr(755,root,root) %{_sbindir}/pluginviewer
581 %attr(755,root,root) %{_sbindir}/sasldblistusers2
582 %attr(755,root,root) %{_sbindir}/saslpasswd2
583 %dir /var/lib/sasl2
584 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
585 %{_mandir}/man8/pluginviewer.8*
586 %{_mandir}/man8/sasldblistusers2.8*
587 %{_mandir}/man8/saslpasswd2.8*
588
589 %files devel
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_libdir}/libsasl2.so
592 %attr(755,root,root) %{_libdir}/libsasl.so
593 %{_libdir}/libsasl2.la
594 %{_includedir}/sasl
595 %{_mandir}/man3/sasl*.3*
596
597 %files static
598 %defattr(644,root,root,755)
599 %{_libdir}/libsasl2.a
600
601 %files anonymous
602 %defattr(644,root,root,755)
603 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
604
605 %if %{with gssapi}
606 %files gssapi
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
609 %endif
610
611 %files cram-md5
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
614
615 %files digest-md5
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
618
619 %files login
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
622
623 %files otp
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
626
627 %if %{with opie}
628 %files opie
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
631 %endif
632
633 %files plain
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
636
637 %files sasldb
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
640
641 %if %{with mysql}
642 %files mysql
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
645 %endif
646
647 %if %{with pgsql}
648 %files pgsql
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
651 %endif
652
653 %if %{with sqlite}
654 %files sqlite
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
657 %endif
658
659 %if %{with srp}
660 %files srp
661 %defattr(644,root,root,755)
662 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
663 %endif
664
665 %if %{with x509}
666 %files x509
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
669 %endif
670
671 %if %{with pwcheck}
672 %files pwcheck
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_sbindir}/pwcheck
675 %endif
676
677 %files saslauthd
678 %defattr(644,root,root,755)
679 %doc cyrus.pam
680 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
681 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
682 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
683 %attr(755,root,root) %{_sbindir}/saslauthd
684 %attr(755,root,root) %{_sbindir}/testsaslauthd
685 %attr(755,root,root) %{_sbindir}/saslcache
686 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
687 %ghost /var/lib/sasl2/cache.flock
688 %ghost /var/lib/sasl2/cache.mmap
689 %ghost /var/lib/sasl2/mux
690 %ghost /var/lib/sasl2/mux.accept
691 %ghost /var/lib/sasl2/saslauthd.pid
692 %{_mandir}/man8/saslauthd.8*
693
694 %files -n nagios-plugin-check_saslauthd
695 %defattr(644,root,root,755)
696 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
697 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.094944 seconds and 4 git commands to generate.