]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- updated to 2.1.27
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 #
2 # Conditional build:
3 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
4 %bcond_without  ldap            # disable LDAP support for saslauthd
5 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
6 %bcond_without  mysql           # don't build MySQL plugin
7 %bcond_without  ntlm            # do not build NTLM plugin
8 %bcond_without  pgsql           # do not build PostgreSQL plugin
9 %bcond_without  sqlite          # do not enable sqlite 2 plugin
10 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # OTP plugin using opie library instead of internal code
13 %bcond_with     srp             # build srp plugin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 #
16 %if %{without mysql} && %{without pgsql}
17 %undefine with_cryptedpw
18 %endif
19
20 Summary:        The SASL library API for the Cyrus mail system
21 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
22 Summary(pt_BR.UTF-8):   Implementação da API SASL
23 Summary(ru.UTF-8):      Библиотека Cyrus SASL
24 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
25 Name:           cyrus-sasl
26 Version:        2.1.27
27 Release:        1
28 License:        distributable
29 Group:          Libraries
30 Source0:        ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
31 # Source0-md5:  a33820c66e0622222c5aefafa1581083
32 Source1:        saslauthd.init
33 Source2:        saslauthd.sysconfig
34 Source3:        %{name}.pam
35 Source4:        check_saslauthd.cfg
36 Patch0:         %{name}-nolibs.patch
37 Patch1:         %{name}-lt.patch
38 Patch2:         %{name}-split-sql.patch
39 Patch3:         %{name}-opie.patch
40 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
41 Patch5:         %{name}-cryptedpw.patch
42 Patch6:         %{name}-md5sum-passwords.patch
43 Patch7:         %{name}-db.patch
44 Patch9:         %{name}-sizes.patch
45 Patch10:        %{name}-nagios-plugin.patch
46 Patch12:        %{name}-gssapi-detect.patch
47 Patch13:        %{name}-saslauthd-httpform-urlescape.patch
48 Patch14:        %{name}-ac-libs.patch
49 Patch20:        %{name}-auxprop.patch
50 Patch21:        0030-dont_use_la_files_for_opening_plugins.patch
51 URL:            http://asg.web.cmu.edu/sasl/
52 BuildRequires:  autoconf >= 2.63
53 BuildRequires:  automake >= 1:1.11
54 %{?with_authlib:BuildRequires:  courier-authlib-devel}
55 BuildRequires:  db-devel
56 BuildRequires:  ed
57 BuildRequires:  groff
58 %{?with_gssapi:BuildRequires:   heimdal-devel}
59 BuildRequires:  libtool >= 1.4
60 %{?with_mysql:BuildRequires:    mysql-devel}
61 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
62 BuildRequires:  openssl-devel >= 0.9.7d
63 %{?with_opie:BuildRequires:     opie-devel}
64 BuildRequires:  pam-devel
65 %{?with_pgsql:BuildRequires:    postgresql-devel}
66 BuildRequires:  rpmbuild(macros) >= 1.268
67 %{?with_sqlite:BuildRequires:   sqlite-devel}
68 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
69 Requires:       pam >= 0.79.0
70 Requires:       %{name}-libs = %{version}-%{release}
71 Obsoletes:      cyrus-sasl-x509 < %{version}
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _sysconfdir     /etc/sasl
75
76 %define         specflags       -fno-strict-aliasing
77
78 %description
79 This is an implementation of the SASL API, useful for adding
80 authentication, authorization, and security to network protocols. The
81 SASL protocol itself is documented in rfc2222; the API standard is a
82 work in progress.
83
84 Note: remember to install appropriate plugins, or you won't have any
85 authentication mechanisms available.
86
87 %description -l pl.UTF-8
88 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
89 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
90 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
91 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
92 RFC 2222; standaryzacja API jest w toku.
93
94 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
95 doinstalować odpowiednie wtyczki.
96
97 %description -l pt_BR.UTF-8
98 Esta é uma implementação da API SASL, útil para acrescentar
99 autenticação, autorização e seguança (criptografia) para protocolos de
100 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
101 ainda está em desenvolvimento.
102
103 %description -l ru.UTF-8
104 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
105 Authentication and Security Layer, метод для добавления поддержки
106 аутентикации к протоколам, основанным на соединениях.
107
108 %description -l uk.UTF-8
109 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
110 Authentication and Security Layer, метод для додання підтримки
111 аутентикації до протоколів, базованих на з'єднаннях.
112
113 %package libs
114 Summary:        cyrus-sasl library itself
115 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
116 Group:          Libraries
117 Requires(post,postun):  /sbin/ldconfig
118 Conflicts:      cyrus-sasl < 2.1.23-8
119
120 %description libs
121 cyrus-sasl library itself.
122
123 %description libs -l pl.UTF-8
124 Sama biblioteka cyrus-sasl.
125
126 %package devel
127 Summary:        Header files and documentation for cyrus-sasl
128 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
129 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
130 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
131 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
132 Group:          Development/Libraries
133 Requires:       %{name} = %{version}-%{release}
134
135 %description devel
136 This includes the header files and documentation needed to develop
137 applications which use SASL.
138
139 %description devel -l pl.UTF-8
140 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
141
142 %description devel -l pt_BR.UTF-8
143 Este pacote inclui os arquivos de cabeçalho e documentação necessários
144 para desenvolver aplicativos que usem SASL.
145
146 %description devel -l ru.UTF-8
147 Хедеры и библиотеки, необходимые для разработки приложений,
148 использующих Cyrus SASL.
149
150 %description devel -l uk.UTF-8
151 Хедери та бібліотеки, необхідні для розробки програм, що
152 використовують Cyrus SASL.
153
154 %package static
155 Summary:        Static cyrus-sasl libraries
156 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
157 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
158 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
159 Group:          Development/Libraries
160 Requires:       %{name}-devel = %{version}-%{release}
161
162 %description static
163 Static cyrus-sasl libraries.
164
165 %description static -l pl.UTF-8
166 Statyczne biblioteki cyrus-sasl.
167
168 %description static -l ru.UTF-8
169 Статические библиотеки, необходимые для разработки приложений,
170 использующих Cyrus SASL.
171
172 %description static -l uk.UTF-8
173 Статичні бібліотеки, необхідні для розробки програм, що використовують
174 Cyrus SASL.
175
176 %package anonymous
177 Summary:        Anonymous Cyrus SASL plugin
178 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
179 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
180 Group:          Libraries
181 Requires:       %{name} = %{version}-%{release}
182
183 %description anonymous
184 This plugin implements the SASL ANONYMOUS mechanism, used for
185 anonymous authentication.
186
187 %description anonymous -l pl.UTF-8
188 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
189 anonimowego uwierzytelniania.
190
191 %description anonymous -l pt_BR.UTF-8
192 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
193 autenticação anônima.
194
195 %package cram-md5
196 Summary:        Cram-MD5 Cyrus SASL plugin
197 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
198 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
199 Group:          Libraries
200 Requires:       %{name} = %{version}-%{release}
201
202 %description cram-md5
203 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
204 mandatory-to-implement authentication mechanism for a number of
205 protocols; it uses MD5 with a challenge/response system to
206 authenticate the user.
207
208 %description cram-md5 -l pl.UTF-8
209 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
210 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
211 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
212 systemem challenge/response.
213
214 %description cram-md5 -l pt_BR.UTF-8
215 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
216 mecanismo de autenticação obrigatório de ser implementado para vários
217 protocolos: ele usa MD5 com um sistema de desafio/resposta para
218 autenticar o usuário.
219
220 %package digest-md5
221 Summary:        Digest-MD5 Cyrus SASL plugin
222 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
223 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
224 Group:          Libraries
225 Requires:       %{name} = %{version}-%{release}
226
227 %description digest-md5
228 This plugin implements the latest draft of the SASL DIGEST-MD5
229 mechanism. Although not yet finalized, this is likely to become the
230 new mandatory-to-implement authentication system in all new protocols.
231 It's based on the digest md5 authentication system designed for HTTP.
232
233 %description digest-md5 -l pl.UTF-8
234 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
235 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
236 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
237 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
238 Digest-MD5 zaprojektowanym dla HTTP.
239
240 %description digest-md5 -l pt_BR.UTF-8
241 Este plugin implementa a última versão da especificação do mecanismo
242 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
243 provavelmente será o novo sistema de autenticação obrigatório para
244 protocolos novos. Ele é baseado na autenticação md5 digest
245 desenvolvida para HTTP.
246
247 %package gssapi
248 Summary:        GSSAPI Cyrus SASL plugin
249 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
250 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
251 Group:          Libraries
252 Requires:       %{name} = %{version}-%{release}
253
254 %description gssapi
255 This plugin implements the SASL GSSAPI mechanism, used for
256 GSSAPI/Kerberos5 authentication.
257
258 %description gssapi -l pl.UTF-8
259 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
260 uwierzytelniania z użyciem GSSAPI/Kerberos5.
261
262 %description gssapi -l pt_BR.UTF-8
263 Este plugin implementa o mecanismo SASL GSSAPI, usado para
264 autenticação Kerberos/GSSAPI.
265
266 %package login
267 Summary:        Unsupported Login Cyrus SASL plugin
268 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
269 Group:          Libraries
270 Requires:       %{name} = %{version}-%{release}
271
272 %description login
273 Unsupported LOGIN Cyrus SASL plugin.
274
275 %description login -l pl.UTF-8
276 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
277 SASL.
278
279 %package mysql
280 Summary:        Cyrus SASL MySQL plugin
281 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
282 Group:          Libraries
283 Requires:       %{name} = %{version}-%{release}
284
285 %description mysql
286 Cyrus SASL MySQL plugin.
287
288 %description mysql -l pl.UTF-8
289 Wtyczka MySQL do Cyrus SASL.
290
291 %package ntlm
292 Summary:        Cyrus SASL NTLM plugin
293 Summary(pl.UTF-8):      Wtyczka NTLM do Cyrus SASL
294 Group:          Libraries
295 Requires:       %{name} = %{version}-%{release}
296
297 %description ntlm
298 Cyrus SASL NTLM plugin.
299
300 %description ntlm -l pl.UTF-8
301 Wtyczka NTLM do Cyrus SASL.
302
303 %package otp
304 Summary:        OTP Cyrus SASL plugin
305 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
306 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
307 Group:          Libraries
308 Requires:       %{name} = %{version}-%{release}
309 Obsoletes:      cyrus-sasl-opie < %{version}
310
311 %description otp
312 This plugin implements the SASL OTP (One Time Password) mechanism.
313
314 %description otp -l pl.UTF-8
315 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
316 SASL.
317
318 %package pgsql
319 Summary:        Cyrus SASL PostgreSQL plugin
320 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
321 Group:          Libraries
322 Requires:       %{name} = %{version}-%{release}
323
324 %description pgsql
325 Cyrus SASL PostgreSQL plugin.
326
327 %description pgsql -l pl.UTF-8
328 Wtyczka PostgreSQL do Cyrus SASL.
329
330 %package plain
331 Summary:        Plain Cyrus SASL plugin
332 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
333 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
334 Group:          Libraries
335 Requires:       %{name} = %{version}-%{release}
336
337 %description plain
338 This plugin implements the SASL PLAIN mechanism. Although insecure,
339 PLAIN is useful for transitioning to new security mechanisms, as this
340 is the only mechanism which gives the server a copy of the user's
341 password.
342
343 %description plain -l pl.UTF-8
344 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
345 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
346 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
347 który udostępnia serwerowi kopię hasła użytkownika.
348
349 %description plain -l pt_BR.UTF-8
350 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
351 mecanismo é útil durante transições para novos mecanismos de
352 segurança, pois é o único esquema que fornece uma cópia da senha do
353 usuário para o servidor.
354
355 %package sasldb
356 Summary:        Cyrus SASL sasldb plugin
357 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
358 Group:          Libraries
359 Requires:       %{name} = %{version}-%{release}
360
361 %description sasldb
362 Cyrus SASL sasldb plugin.
363
364 %description sasldb -l pl.UTF-8
365 Wtyczka sasldb do Cyrus SASL.
366
367 %package ldapdb
368 Summary:        Cyrus SASL LDAPDB plugin
369 Summary(pl.UTF-8):      Wtyczka LDAPDB do Cyrus SASL
370 Group:          Libraries
371 Requires:       %{name} = %{version}-%{release}
372
373 %description ldapdb
374 Cyrus SASL ldapdb plugin.
375
376 %description ldapdb -l pl.UTF-8
377 Wtyczka ldapdb do Cyrus SASL.
378
379 %package passdss
380 Summary:        PASSDSS Cyrus SASL plugin
381 Summary(pl.UTF-8):      Wtyczka PASSDSS do Cyrus SASL
382 Summary(pt_BR.UTF-8):   Mecanismo SASL PASSDSS
383 Group:          Libraries
384 Requires:       %{name} = %{version}-%{release}
385
386 %description passdss
387 This plugin implements the PASSDSS 3DES mechanism.
388
389 %description passdss -l pl.UTF-8
390 Wtyczka dodająca obsługę mechanizmu PASSDSS 3DES do Cyrus SASL.
391
392 %description passdss -l pt_BR.UTF-8
393 Este plugin implementa o mecanismo SASL PASSDSS 3DES.
394
395 %package scram
396 Summary:        SCRAM Cyrus SASL plugin
397 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
398 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
399 Group:          Libraries
400 Requires:       %{name} = %{version}-%{release}
401
402 %description scram
403 This plugin implements the SASL SCRAM-MD5 mechanism.
404
405 %description scram -l pl.UTF-8
406 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
407
408 %description scram -l pt_BR.UTF-8
409 Este plugin implementa o mecanismo SASL SCRAM.
410
411 %package sqlite
412 Summary:        Cyrus SQLite 2 PostgreSQL plugin
413 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
414 Group:          Libraries
415 Requires:       %{name} = %{version}-%{release}
416
417 %description sqlite
418 Cyrus SASL SQLite 2 plugin.
419
420 %description sqlite -l pl.UTF-8
421 Wtyczka SQLite 2 do Cyrus SASL.
422
423 %package sqlite3
424 Summary:        Cyrus SQLite 3 PostgreSQL plugin
425 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
426 Group:          Libraries
427 Requires:       %{name} = %{version}-%{release}
428
429 %description sqlite3
430 Cyrus SASL SQLite 3 plugin.
431
432 %description sqlite3 -l pl.UTF-8
433 Wtyczka SQLite 3 do Cyrus SASL.
434
435 %package srp
436 Summary:        SRP Cyrus SASL plugin
437 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
438 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
439 Group:          Libraries
440 Requires:       %{name} = %{version}-%{release}
441
442 %description srp
443 This plugin implements the SASL SRP mechanism, based on the Secure
444 Remote Password protocol. This mechanism performs mutual
445 authentication and can provide a security layer with replay detection,
446 integrity protection and/or condifentiality protection.
447
448 %description srp -l pl.UTF-8
449 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
450 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
451 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
452 powtarzania, zabezpieczeniem integralności i/lub poufności.
453
454 %description srp -l pt_BR.UTF-8
455 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
456 (Secure Remote Password). Este mecanismo oferece autenticação mútua
457 (do cliente e do servidor) e pode prover uma camada de segurança com
458 detecção de ataques de replay, garantia de integridade e/ou
459 confidencialidade.
460
461 %package pwcheck
462 Summary:        Cyrus SASL pwcheck helper
463 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
464 Group:          Libraries
465 Requires:       %{name} = %{version}-%{release}
466
467 %description pwcheck
468 Cyrus SASL pwcheck helper.
469
470 %description pwcheck -l pl.UTF-8
471 Program pomocniczy pwcheck do Cyrus SASL.
472
473 %package saslauthd
474 Summary:        Cyrus SASL authd
475 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
476 Group:          Daemons
477 Requires(post,preun):   /sbin/chkconfig
478 Requires:       %{name} = %{version}-%{release}
479 Requires:       /sbin/chkconfig
480 Requires:       rc-scripts
481
482 %description saslauthd
483 Cyrus SASL authd.
484
485 %description saslauthd -l pl.UTF-8
486 Demon authd do Cyrus SASL.
487
488 %package -n nagios-plugin-check_saslauthd
489 Summary:        Nagios plugin to check health of saslauthd
490 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
491 Group:          Networking
492 Requires:       nagios-core
493
494 %description -n nagios-plugin-check_saslauthd
495 Nagios plugin to check health of saslauthd.
496
497 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
498 Wtyczka Nagiosa do sprawdzania działania saslauthd.
499
500 %prep
501 %setup -q
502 %patch0 -p1
503 %patch1 -p1
504 %patch2 -p1
505 %patch3 -p1
506 %if %{with cryptedpw}
507 %patch5 -p1
508 %patch6 -p1
509 %endif
510 %patch7 -p1
511 %patch9 -p1
512 %patch10 -p1
513 %patch12 -p1
514 %patch13 -p0
515 %patch14 -p1
516 %patch20 -p1
517 %patch21 -p1
518
519 # update to our paths
520 sed -i -e '
521         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
522         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
523         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
524         s,/var/state/saslauthd,/var/lib/sasl2,g
525 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/legacy/sysadmin.html
526
527 %build
528 %{__libtoolize}
529 %{__aclocal} -I m4
530 %{__autoconf}
531 %{__autoheader}
532 %{__automake}
533 %configure \
534         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
535         %{!?with_gssapi:--disable-gssapi} \
536         %{?with_gssapi:--enable-gssapi --with-gss_impl=heimdal} \
537         --enable-httpform \
538         --disable-krb4 \
539         %{?with_ldap:--enable-ldapdb} \
540         --enable-login \
541         --enable-passdss \
542         --enable-sample \
543         --enable-sql \
544         %{?with_srp:--enable-srp} \
545         --enable-static \
546         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
547         --with-configdir=%{_sysconfdir} \
548         --with-dblib=berkeley \
549         --with-dbpath=/var/lib/sasl2/sasl.db \
550         %{?with_ldap:--with-ldap} \
551         %{?with_mysql:--with-mysql=%{_prefix}} \
552         %{?with_ntlm:--enable-ntlm} \
553         %{?with_opie:--with-opie=%{_prefix}} \
554         --with-pam \
555         %{?with_pgsql:--with-pgsql=%{_prefix}} \
556         --with-plugindir=%{_libdir}/sasl2 \
557         %{?with_pwcheck:--with-pwcheck=/var/lib/sasl2} \
558         --with-saslauthd=/var/lib/sasl2 \
559         %{?with_sqlite:--with-sqlite=%{_prefix}} \
560         %{?with_sqlite3:--with-sqlite3=%{_prefix}}
561
562 %{__make}
563
564 %{__make} -C saslauthd testsaslauthd
565 %{__make} -C saslauthd saslcache
566 %{__make} -C sample sample-client sample-server
567
568 %{__rm} -rf doc/html/{_sources,objects.inv,.buildinfo}
569
570 %install
571 rm -rf $RPM_BUILD_ROOT
572 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
573                 $RPM_BUILD_ROOT%{_mandir}/man8
574
575 %{__make} install \
576         sasldir=%{_libdir}/sasl2 \
577         DESTDIR=$RPM_BUILD_ROOT
578
579 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
580
581 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
582 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
583
584 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
585
586 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
587
588 # create empty config
589 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
590 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
591 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
592 cp -a %{SOURCE3} cyrus.pam
593
594 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
595
596 # sample programs for testing sasl
597 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
598 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
599
600 # package for ghost
601 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
602
603 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
604 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
605
606 %clean
607 rm -rf $RPM_BUILD_ROOT
608
609 %post   libs -p /sbin/ldconfig
610 %postun libs -p /sbin/ldconfig
611
612 %post saslauthd
613 /sbin/chkconfig --add saslauthd
614 %service saslauthd restart
615
616 %preun saslauthd
617 if [ "$1" = "0" ]; then
618         %service saslauthd stop
619         /sbin/chkconfig --del saslauthd
620 fi
621
622 %triggerin saslauthd -- pam
623 # restart saslauthd if pam is upgraded
624 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
625 if [ "$2" != 1 ]; then
626         %service -q saslauthd restart
627 fi
628
629 %files
630 %defattr(644,root,root,755)
631 %doc AUTHORS COPYING ChangeLog README doc/legacy/{TODO,*.html,*.fig} doc/html
632 %dir %{_sysconfdir}
633 %dir %{_libdir}/sasl2
634 # sample programs to subpackage instead?
635 %attr(755,root,root) %{_bindir}/sasl-sample-client
636 %attr(755,root,root) %{_bindir}/sasl-sample-server
637 %attr(755,root,root) %{_sbindir}/pluginviewer
638 %attr(755,root,root) %{_sbindir}/sasldblistusers2
639 %attr(755,root,root) %{_sbindir}/saslpasswd2
640 %dir /var/lib/sasl2
641 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
642 %{_mandir}/man8/pluginviewer.8*
643 %{_mandir}/man8/sasldblistusers2.8*
644 %{_mandir}/man8/saslpasswd2.8*
645
646 %files libs
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.3
650
651 %files devel
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_libdir}/libsasl2.so
654 %attr(755,root,root) %{_libdir}/libsasl.so
655 %{_libdir}/libsasl2.la
656 %{_includedir}/sasl
657 %{_pkgconfigdir}/libsasl2.pc
658 %{_mandir}/man3/sasl*.3*
659
660 %files static
661 %defattr(644,root,root,755)
662 %{_libdir}/libsasl2.a
663
664 %files anonymous
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
667
668 %if %{with gssapi}
669 %files gssapi
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
672 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
673 %endif
674
675 %files cram-md5
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
678
679 %files digest-md5
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
682
683 %files login
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
686
687 %if %{with mysql}
688 %files mysql
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
691 %endif
692
693 %if %{with ntlm}
694 %files ntlm
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/sasl2/libntlm.so*
697 %endif
698
699 %files otp
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
702
703 %if %{with pgsql}
704 %files pgsql
705 %defattr(644,root,root,755)
706 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
707 %endif
708
709 %files plain
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
712
713 %files sasldb
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
716
717 %if %{with ldap}
718 %files ldapdb
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_libdir}/sasl2/libldapdb.so*
721 %endif
722
723 %files passdss
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_libdir}/sasl2/libpassdss.so*
726
727 %files scram
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
730
731 %if %{with sqlite}
732 %files sqlite
733 %defattr(644,root,root,755)
734 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
735 %endif
736
737 %if %{with sqlite3}
738 %files sqlite3
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
741 %endif
742
743 %if %{with srp}
744 %files srp
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
747 %endif
748
749 %if %{with pwcheck}
750 %files pwcheck
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_sbindir}/pwcheck
753 %endif
754
755 %files saslauthd
756 %defattr(644,root,root,755)
757 %doc cyrus.pam saslauthd/{COPYING,LDAP_SASLAUTHD}
758 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
759 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
760 %attr(755,root,root) %{_sbindir}/saslauthd
761 %attr(755,root,root) %{_sbindir}/testsaslauthd
762 %attr(755,root,root) %{_sbindir}/saslcache
763 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
764 %ghost /var/lib/sasl2/cache.flock
765 %ghost /var/lib/sasl2/cache.mmap
766 %ghost /var/lib/sasl2/mux
767 %ghost /var/lib/sasl2/mux.accept
768 %ghost /var/lib/sasl2/saslauthd.pid
769 %{_mandir}/man8/saslauthd.8*
770
771 %files -n nagios-plugin-check_saslauthd
772 %defattr(644,root,root,755)
773 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
774 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.44727 seconds and 4 git commands to generate.