]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- opie now could be used as underlying mechanism in OTP plugin (instead of internal...
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite 2 plugin
11 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
12 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
13 %bcond_with     opie            # OTP plugin using opie library instead of internal code
14 %bcond_with     srp             # build srp plugin
15 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.25
28 Release:        1
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
32 # Source0-md5:  341cffe829a4d71f2a6503d669d5a946
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-db.patch
46 Patch8:         %{name}-keytab.patch
47 Patch9:         %{name}-sizes.patch
48 Patch10:        %{name}-nagios-plugin.patch
49 Patch11:        %{name}-parallel-make.patch
50 Patch12:        %{name}-gssapi-detect.patch
51 Patch13:        %{name}-saslauthd-httpform-urlescape.patch
52 Patch14:        %{name}-ac-libs.patch
53 Patch15:        %{name}-pam.patch
54 Patch16:        %{name}-gssapi_ext.patch
55 URL:            http://asg.web.cmu.edu/sasl/
56 BuildRequires:  autoconf >= 2.54
57 BuildRequires:  automake >= 1:1.7
58 %{?with_authlib:BuildRequires:  courier-authlib-devel}
59 BuildRequires:  db-devel
60 BuildRequires:  ed
61 BuildRequires:  groff
62 %{?with_gssapi:BuildRequires:   heimdal-devel}
63 BuildRequires:  libtool >= 1.4
64 %{?with_mysql:BuildRequires:    mysql-devel}
65 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
66 BuildRequires:  openssl-devel >= 0.9.7d
67 %{?with_opie:BuildRequires:     opie-devel}
68 BuildRequires:  pam-devel
69 %{?with_pgsql:BuildRequires:    postgresql-devel}
70 BuildRequires:  rpmbuild(macros) >= 1.268
71 %{?with_sqlite:BuildRequires:   sqlite-devel}
72 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
73 Requires:       pam >= 0.79.0
74 Requires:       %{name}-libs = %{version}-%{release}
75 Obsoletes:      cyrus-sasl-x509 < %{version}
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %define         _sysconfdir     /etc/sasl
79
80 %define         specflags       -fno-strict-aliasing
81
82 %description
83 This is an implementation of the SASL API, useful for adding
84 authentication, authorization, and security to network protocols. The
85 SASL protocol itself is documented in rfc2222; the API standard is a
86 work in progress.
87
88 Note: remember to install appropriate plugins, or you won't have any
89 authentication mechanisms available.
90
91 %description -l pl.UTF-8
92 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
93 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
94 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
95 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
96 RFC 2222; standaryzacja API jest w toku.
97
98 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
99 doinstalować odpowiednie wtyczki.
100
101 %description -l pt_BR.UTF-8
102 Esta é uma implementação da API SASL, útil para acrescentar
103 autenticação, autorização e seguança (criptografia) para protocolos de
104 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
105 ainda está em desenvolvimento.
106
107 %description -l ru.UTF-8
108 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
109 Authentication and Security Layer, метод для добавления поддержки
110 аутентикации к протоколам, основанным на соединениях.
111
112 %description -l uk.UTF-8
113 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
114 Authentication and Security Layer, метод для додання підтримки
115 аутентикації до протоколів, базованих на з'єднаннях.
116
117 %package libs
118 Summary:        cyrus-sasl library itself
119 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
120 Group:          Libraries
121 Requires(post,postun):  /sbin/ldconfig
122 Conflicts:      cyrus-sasl < 2.1.23-8
123
124 %description libs
125 cyrus-sasl library itself.
126
127 %description libs -l pl.UTF-8
128 Sama biblioteka cyrus-sasl.
129
130 %package devel
131 Summary:        Header files and documentation for cyrus-sasl
132 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
133 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
134 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
135 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
136 Group:          Development/Libraries
137 Requires:       %{name} = %{version}-%{release}
138
139 %description devel
140 This includes the header files and documentation needed to develop
141 applications which use SASL.
142
143 %description devel -l pl.UTF-8
144 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
145
146 %description devel -l pt_BR.UTF-8
147 Este pacote inclui os arquivos de cabeçalho e documentação necessários
148 para desenvolver aplicativos que usem SASL.
149
150 %description devel -l ru.UTF-8
151 Хедеры и библиотеки, необходимые для разработки приложений,
152 использующих Cyrus SASL.
153
154 %description devel -l uk.UTF-8
155 Хедери та бібліотеки, необхідні для розробки програм, що
156 використовують Cyrus SASL.
157
158 %package static
159 Summary:        Static cyrus-sasl libraries
160 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
161 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
162 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
163 Group:          Development/Libraries
164 Requires:       %{name}-devel = %{version}-%{release}
165
166 %description static
167 Static cyrus-sasl libraries.
168
169 %description static -l pl.UTF-8
170 Statyczne biblioteki cyrus-sasl.
171
172 %description static -l ru.UTF-8
173 Статические библиотеки, необходимые для разработки приложений,
174 использующих Cyrus SASL.
175
176 %description static -l uk.UTF-8
177 Статичні бібліотеки, необхідні для розробки програм, що використовують
178 Cyrus SASL.
179
180 %package anonymous
181 Summary:        Anonymous Cyrus SASL plugin
182 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
183 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
184 Group:          Libraries
185 Requires:       %{name} = %{version}-%{release}
186
187 %description anonymous
188 This plugin implements the SASL ANONYMOUS mechanism, used for
189 anonymous authentication.
190
191 %description anonymous -l pl.UTF-8
192 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
193 anonimowego uwierzytelniania.
194
195 %description anonymous -l pt_BR.UTF-8
196 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
197 autenticação anônima.
198
199 %package cram-md5
200 Summary:        Cram-MD5 Cyrus SASL plugin
201 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
202 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
203 Group:          Libraries
204 Requires:       %{name} = %{version}-%{release}
205
206 %description cram-md5
207 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
208 mandatory-to-implement authentication mechanism for a number of
209 protocols; it uses MD5 with a challenge/response system to
210 authenticate the user.
211
212 %description cram-md5 -l pl.UTF-8
213 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
214 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
215 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
216 systemem challenge/response.
217
218 %description cram-md5 -l pt_BR.UTF-8
219 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
220 mecanismo de autenticação obrigatório de ser implementado para vários
221 protocolos: ele usa MD5 com um sistema de desafio/resposta para
222 autenticar o usuário.
223
224 %package digest-md5
225 Summary:        Digest-MD5 Cyrus SASL plugin
226 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
227 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
228 Group:          Libraries
229 Requires:       %{name} = %{version}-%{release}
230
231 %description digest-md5
232 This plugin implements the latest draft of the SASL DIGEST-MD5
233 mechanism. Although not yet finalized, this is likely to become the
234 new mandatory-to-implement authentication system in all new protocols.
235 It's based on the digest md5 authentication system designed for HTTP.
236
237 %description digest-md5 -l pl.UTF-8
238 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
239 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
240 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
241 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
242 Digest-MD5 zaprojektowanym dla HTTP.
243
244 %description digest-md5 -l pt_BR.UTF-8
245 Este plugin implementa a última versão da especificação do mecanismo
246 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
247 provavelmente será o novo sistema de autenticação obrigatório para
248 protocolos novos. Ele é baseado na autenticação md5 digest
249 desenvolvida para HTTP.
250
251 %package gssapi
252 Summary:        GSSAPI Cyrus SASL plugin
253 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
254 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
255 Group:          Libraries
256 Requires:       %{name} = %{version}-%{release}
257
258 %description gssapi
259 This plugin implements the SASL GSSAPI mechanism, used for
260 GSSAPI/Kerberos5 authentication.
261
262 %description gssapi -l pl.UTF-8
263 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
264 uwierzytelniania z użyciem GSSAPI/Kerberos5.
265
266 %description gssapi -l pt_BR.UTF-8
267 Este plugin implementa o mecanismo SASL GSSAPI, usado para
268 autenticação Kerberos/GSSAPI.
269
270 %package login
271 Summary:        Unsupported Login Cyrus SASL plugin
272 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
273 Group:          Libraries
274 Requires:       %{name} = %{version}-%{release}
275
276 %description login
277 Unsupported LOGIN Cyrus SASL plugin.
278
279 %description login -l pl.UTF-8
280 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
281 SASL.
282
283 %package mysql
284 Summary:        Cyrus SASL MySQL plugin
285 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
286 Group:          Libraries
287 Requires:       %{name} = %{version}-%{release}
288
289 %description mysql
290 Cyrus SASL MySQL plugin.
291
292 %description mysql -l pl.UTF-8
293 Wtyczka MySQL do Cyrus SASL.
294
295 %package otp
296 Summary:        OTP Cyrus SASL plugin
297 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
298 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
299 Group:          Libraries
300 Requires:       %{name} = %{version}-%{release}
301 Obsoletes:      cyrus-sasl-opie < %{version}
302
303 %description otp
304 This plugin implements the SASL OTP (One Time Password) mechanism.
305
306 %description otp -l pl.UTF-8
307 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
308 SASL.
309
310 %package pgsql
311 Summary:        Cyrus SASL PostgreSQL plugin
312 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
313 Group:          Libraries
314 Requires:       %{name} = %{version}-%{release}
315
316 %description pgsql
317 Cyrus SASL PostgreSQL plugin.
318
319 %description pgsql -l pl.UTF-8
320 Wtyczka PostgreSQL do Cyrus SASL.
321
322 %package plain
323 Summary:        Plain Cyrus SASL plugin
324 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
325 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
326 Group:          Libraries
327 Requires:       %{name} = %{version}-%{release}
328
329 %description plain
330 This plugin implements the SASL PLAIN mechanism. Although insecure,
331 PLAIN is useful for transitioning to new security mechanisms, as this
332 is the only mechanism which gives the server a copy of the user's
333 password.
334
335 %description plain -l pl.UTF-8
336 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
337 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
338 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
339 który udostępnia serwerowi kopię hasła użytkownika.
340
341 %description plain -l pt_BR.UTF-8
342 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
343 mecanismo é útil durante transições para novos mecanismos de
344 segurança, pois é o único esquema que fornece uma cópia da senha do
345 usuário para o servidor.
346
347 %package sasldb
348 Summary:        Cyrus SASL sasldb plugin
349 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
350 Group:          Libraries
351 Requires:       %{name} = %{version}-%{release}
352
353 %description sasldb
354 Cyrus SASL sasldb plugin.
355
356 %description sasldb -l pl.UTF-8
357 Wtyczka sasldb do Cyrus SASL.
358
359 %package scram
360 Summary:        SCRAM Cyrus SASL plugin
361 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
362 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
363 Group:          Libraries
364 Requires:       %{name} = %{version}-%{release}
365
366 %description scram
367 This plugin implements the SASL SCRAM-MD5 mechanism.
368
369 %description scram -l pl.UTF-8
370 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
371
372 %description scram -l pt_BR.UTF-8
373 Este plugin implementa o mecanismo SASL SCRAM.
374
375 %package sqlite
376 Summary:        Cyrus SQLite 2 PostgreSQL plugin
377 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
378 Group:          Libraries
379 Requires:       %{name} = %{version}-%{release}
380
381 %description sqlite
382 Cyrus SASL SQLite 2 plugin.
383
384 %description sqlite -l pl.UTF-8
385 Wtyczka SQLite 2 do Cyrus SASL.
386
387 %package sqlite3
388 Summary:        Cyrus SQLite 3 PostgreSQL plugin
389 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
390 Group:          Libraries
391 Requires:       %{name} = %{version}-%{release}
392
393 %description sqlite3
394 Cyrus SASL SQLite 3 plugin.
395
396 %description sqlite3 -l pl.UTF-8
397 Wtyczka SQLite 3 do Cyrus SASL.
398
399 %package srp
400 Summary:        SRP Cyrus SASL plugin
401 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
402 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
403 Group:          Libraries
404 Requires:       %{name} = %{version}-%{release}
405
406 %description srp
407 This plugin implements the SASL SRP mechanism, based on the Secure
408 Remote Password protocol. This mechanism performs mutual
409 authentication and can provide a security layer with replay detection,
410 integrity protection and/or condifentiality protection.
411
412 %description srp -l pl.UTF-8
413 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
414 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
415 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
416 powtarzania, zabezpieczeniem integralności i/lub poufności.
417
418 %description srp -l pt_BR.UTF-8
419 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
420 (Secure Remote Password). Este mecanismo oferece autenticação mútua
421 (do cliente e do servidor) e pode prover uma camada de segurança com
422 detecção de ataques de replay, garantia de integridade e/ou
423 confidencialidade.
424
425 %package pwcheck
426 Summary:        Cyrus SASL pwcheck helper
427 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
428 Group:          Libraries
429 Requires:       %{name} = %{version}-%{release}
430
431 %description pwcheck
432 Cyrus SASL pwcheck helper.
433
434 %description pwcheck -l pl.UTF-8
435 Program pomocniczy pwcheck do Cyrus SASL.
436
437 %package saslauthd
438 Summary:        Cyrus SASL authd
439 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
440 Group:          Daemons
441 Requires(post,preun):   /sbin/chkconfig
442 Requires:       %{name} = %{version}-%{release}
443 Requires:       /sbin/chkconfig
444 Requires:       rc-scripts
445
446 %description saslauthd
447 Cyrus SASL authd.
448
449 %description saslauthd -l pl.UTF-8
450 Demon authd do Cyrus SASL.
451
452 %package -n nagios-plugin-check_saslauthd
453 Summary:        Nagios plugin to check health of saslauthd
454 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
455 Group:          Networking
456 Requires:       nagios-core
457
458 %description -n nagios-plugin-check_saslauthd
459 Nagios plugin to check health of saslauthd.
460
461 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
462 Wtyczka Nagiosa do sprawdzania działania saslauthd.
463
464 %prep
465 %setup -q
466 %patch0 -p1
467 %patch1 -p1
468 %patch2 -p1
469 %patch3 -p1
470 %patch4 -p1
471 %if %{with cryptedpw}
472 %patch5 -p1
473 %patch6 -p1
474 %endif
475 %patch7 -p1
476 %patch8 -p1
477 %patch9 -p1
478 %patch10 -p1
479 %patch11 -p1
480 %patch12 -p1
481 %patch13 -p0
482 %patch14 -p1
483 %patch15 -p1
484 %patch16 -p1
485
486 cd doc
487 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
488 ls rfc*.txt >> rfc-compliance
489 rm -f rfc*.txt
490 cd ..
491
492 # old version
493 %{__rm} config/libtool.m4
494
495 # update to our paths
496 sed -i -e '
497         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
498         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
499         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
500         s,/var/state/saslauthd,/var/lib/sasl2,g
501 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
502
503 %build
504 %{__libtoolize}
505 %{__aclocal} -I cmulocal -I config
506 %{__autoheader}
507 %{__autoconf}
508 %{__automake}
509 cd saslauthd
510 %{__aclocal} -I ../cmulocal -I ../config
511 %{__autoheader}
512 %{__autoconf}
513 %{__automake}
514 cd ..
515 %configure \
516         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
517         --disable-krb4 \
518         %{!?with_gssapi: --disable-gssapi} \
519         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
520         --enable-login \
521         --enable-sample \
522         --enable-httpform \
523         --enable-sql \
524         %{?with_srp: --enable-srp} \
525         --enable-static \
526         --with-plugindir=%{_libdir}/sasl2 \
527         --with-configdir=%{_sysconfdir} \
528         --with-dblib=berkeley \
529         --with-dbpath=/var/lib/sasl2/sasl.db \
530         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
531         %{?with_ldap: --with-ldap=%{_prefix}} \
532         %{?with_mysql: --with-mysql=%{_prefix}} \
533         %{?with_pgsql: --with-pgsql=%{_prefix}} \
534         %{?with_sqlite: --with-sqlite=%{_prefix}} \
535         %{?with_sqlite3: --with-sqlite3=%{_prefix}} \
536         %{?with_opie: --with-opie=%{_prefix}} \
537         --with-pam \
538         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
539         --with-saslauthd=/var/lib/sasl2
540
541 %{__make}
542
543 %{__make} -C saslauthd testsaslauthd
544 %{__make} -C saslauthd saslcache
545 %{__make} -C sample sample-client sample-server
546
547 cd doc
548 RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
549 for i in $RFCLIST; do
550         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
551         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
552 done
553
554 %install
555 rm -rf $RPM_BUILD_ROOT
556 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
557                 $RPM_BUILD_ROOT%{_mandir}/man8
558
559 %{__make} install \
560         sasldir=%{_libdir}/sasl2 \
561         DESTDIR=$RPM_BUILD_ROOT
562
563 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
564
565 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
566 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
567
568 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
569
570 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
571
572 # create empty config
573 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
574 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
575 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
576 cp -a %{SOURCE3} cyrus.pam
577
578 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
579
580 # sample programs for testing sasl
581 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
582 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
583
584 # package for ghost
585 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
586
587 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
588 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
589
590 %clean
591 rm -rf $RPM_BUILD_ROOT
592
593 %post   libs -p /sbin/ldconfig
594 %postun libs -p /sbin/ldconfig
595
596 %post saslauthd
597 /sbin/chkconfig --add saslauthd
598 %service saslauthd restart
599
600 %preun saslauthd
601 if [ "$1" = "0" ]; then
602         %service saslauthd stop
603         /sbin/chkconfig --del saslauthd
604 fi
605
606 %triggerin saslauthd -- pam
607 # restart saslauthd if pam is upgraded
608 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
609 if [ "$2" != 1 ]; then
610         %service -q saslauthd restart
611 fi
612
613 %files
614 %defattr(644,root,root,755)
615 %doc AUTHORS COPYING ChangeLog NEWS README
616 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
617 %dir %{_sysconfdir}
618 %dir %{_libdir}/sasl2
619 # sample programs to subpackage instead?
620 %attr(755,root,root) %{_bindir}/sasl-sample-client
621 %attr(755,root,root) %{_bindir}/sasl-sample-server
622 %attr(755,root,root) %{_sbindir}/pluginviewer
623 %attr(755,root,root) %{_sbindir}/sasldblistusers2
624 %attr(755,root,root) %{_sbindir}/saslpasswd2
625 %dir /var/lib/sasl2
626 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
627 %{_mandir}/man8/pluginviewer.8*
628 %{_mandir}/man8/sasldblistusers2.8*
629 %{_mandir}/man8/saslpasswd2.8*
630
631 %files libs
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
634 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
635
636 %files devel
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_libdir}/libsasl2.so
639 %attr(755,root,root) %{_libdir}/libsasl.so
640 %{_libdir}/libsasl2.la
641 %{_includedir}/sasl
642 %{_mandir}/man3/sasl*.3*
643
644 %files static
645 %defattr(644,root,root,755)
646 %{_libdir}/libsasl2.a
647
648 %files anonymous
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
651
652 %if %{with gssapi}
653 %files gssapi
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
656 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
657 %endif
658
659 %files cram-md5
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
662
663 %files digest-md5
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
666
667 %files login
668 %defattr(644,root,root,755)
669 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
670
671 %if %{with mysql}
672 %files mysql
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
675 %endif
676
677 %files otp
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
680
681 %if %{with pgsql}
682 %files pgsql
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
685 %endif
686
687 %files plain
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
690
691 %files sasldb
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
694
695 %files scram
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
698
699 %if %{with sqlite}
700 %files sqlite
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
703 %endif
704
705 %if %{with sqlite3}
706 %files sqlite3
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
709 %endif
710
711 %if %{with srp}
712 %files srp
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
715 %endif
716
717 %if %{with pwcheck}
718 %files pwcheck
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_sbindir}/pwcheck
721 %endif
722
723 %files saslauthd
724 %defattr(644,root,root,755)
725 %doc cyrus.pam
726 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
727 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
728 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
729 %attr(755,root,root) %{_sbindir}/saslauthd
730 %attr(755,root,root) %{_sbindir}/testsaslauthd
731 %attr(755,root,root) %{_sbindir}/saslcache
732 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
733 %ghost /var/lib/sasl2/cache.flock
734 %ghost /var/lib/sasl2/cache.mmap
735 %ghost /var/lib/sasl2/mux
736 %ghost /var/lib/sasl2/mux.accept
737 %ghost /var/lib/sasl2/saslauthd.pid
738 %{_mandir}/man8/saslauthd.8*
739
740 %files -n nagios-plugin-check_saslauthd
741 %defattr(644,root,root,755)
742 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
743 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.163727 seconds and 4 git commands to generate.