]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- added db patch (allow to link with with db-4.5)
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # enable opie plugin
13 %bcond_with     srp             # build srp pluggin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 %bcond_with     x509            # build x509 plugin (no sources in package???)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl):    Biblioteka Cyrus SASL
23 Summary(pt_BR): Implementação da API SASL
24 Summary(ru):    âÉÂÌÉÏÔÅËÁ Cyrus SASL
25 Summary(uk):    â¦Â̦ÏÔÅËÁ Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.22
28 Release:        3
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
32 # Source0-md5:  45dde9d19193ae9dd388eb68b2027bc9
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Patch0:         %{name}-nolibs.patch
37 Patch1:         %{name}-lt.patch
38 Patch2:         %{name}-split-sql.patch
39 Patch3:         %{name}-opie.patch
40 Patch4:         %{name}-gcc4.patch
41 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
42 Patch5:         %{name}-cryptedpw.patch
43 Patch6:         %{name}-md5sum-passwords.patch
44 Patch7:         %{name}-db.patch
45 URL:            http://asg.web.cmu.edu/sasl/
46 BuildRequires:  autoconf >= 2.54
47 BuildRequires:  automake
48 %{?with_authlib:BuildRequires:  courier-authlib-devel}
49 BuildRequires:  db-devel
50 BuildRequires:  ed
51 BuildRequires:  groff
52 %{?with_gssapi:BuildRequires:   heimdal-devel >= 0.7}
53 BuildRequires:  libtool >= 1.4
54 %{?with_mysql:BuildRequires:    mysql-devel}
55 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
56 BuildRequires:  openssl-devel >= 0.9.7d
57 %{?with_opie:BuildRequires:     opie-devel}
58 BuildRequires:  pam-devel
59 %{?with_pgsql:BuildRequires:    postgresql-devel}
60 BuildRequires:  rpmbuild(macros) >= 1.268
61 %{?with_sqlite:BuildRequires:   sqlite-devel}
62 Requires:       pam >= 0.79.0
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         _sysconfdir     /etc/sasl
66
67 %define         specflags       -fno-strict-aliasing
68
69 %description
70 This is an implementation of the SASL API, useful for adding
71 authentication, authorization, and security to network protocols. The
72 SASL protocol itself is documented in rfc2222; the API standard is a
73 work in progress.
74
75 Note: remember to install appropriate plugins, or you won't have any
76 authentication mechanisms available.
77
78 %description -l pl
79 Pakiet cyrus-sasl zawiera implementacjê biblioteki API SASL dla
80 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
81 tak¿e do dodawania uwierzytelniania, autoryzacji oraz zwiêkszania
82 bezpieczeñstwa protoko³ów sieciowych. Sam protokó³ SASL jest opisany w
83 RFC 2222; standaryzacja API jest w toku.
84
85 Uwaga: aby by³y dostêpne jakiekolwiek mechanizmy autoryzacji, nale¿y
86 doinstalowaæ odpowiednie wtyczki.
87
88 %description -l pt_BR
89 Esta é uma implementação da API SASL, útil para acrescentar
90 autenticação, autorização e seguança (criptografia) para protocolos de
91 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
92 ainda está em desenvolvimento.
93
94 %description -l ru
95 ðÁËÅÔ cyrus-sasl ÓÏÄÅÒÖÉÔ ÒÅÁÌÉÚÁÃÉÀ Cyrus SASL. SASL - ÜÔÏ Simple
96 Authentication and Security Layer, ÍÅÔÏÄ ÄÌÑ ÄÏÂÁ×ÌÅÎÉÑ ÐÏÄÄÅÒÖËÉ
97 ÁÕÔÅÎÔÉËÁÃÉÉ Ë ÐÒÏÔÏËÏÌÁÍ, ÏÓÎÏ×ÁÎÎÙÍ ÎÁ ÓÏÅÄÉÎÅÎÉÑÈ.
98
99 %description -l uk
100 ðÁËÅÔ cyrus-sasl Í¦ÓÔÉÔØ ÒÅÁ̦ÚÁæÀ Cyrus SASL. SASL - ÃÅ Simple
101 Authentication and Security Layer, ÍÅÔÏÄ ÄÌÑ ÄÏÄÁÎÎѠЦÄÔÒÉÍËÉ
102 ÁÕÔÅÎÔÉËÁ槠ÄÏ ÐÒÏÔÏËÏ̦×, ÂÁÚÏ×ÁÎÉÈ ÎÁ Ú'¤ÄÎÁÎÎÑÈ.
103
104 %package devel
105 Summary:        Header files and documentation for cyrus-sasl
106 Summary(pl):    Pliki nag³ówkowe i dokumentacja dla cyrus-sasl
107 Summary(pt_BR): Exemplos e arquivos para desenvolvimento com SASL
108 Summary(ru):    æÁÊÌÙ ÄÌÑ ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ Ó ÂÉÂÌÉÏÔÅËÏÊ Cyrus SASL
109 Summary(uk):    æÁÊÌÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎѠڠ¦Â̦ÏÔÅËÏÀ Cyrus SASL
110 Group:          Development/Libraries
111 Requires:       %{name} = %{version}-%{release}
112
113 %description devel
114 This includes the header files and documentation needed to develop
115 applications which use SASL.
116
117 %description devel -l pl
118 Pliki nag³ówkowe i dokumentacja dla cyrus-sasl.
119
120 %description devel -l pt_BR
121 Este pacote inclui os arquivos de cabeçalho e documentação necessários
122 para desenvolver aplicativos que usem SASL.
123
124 %description devel -l ru
125 èÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÉÌÏÖÅÎÉÊ,
126 ÉÓÐÏÌØÚÕÀÝÉÈ Cyrus SASL.
127
128 %description devel -l uk
129 èÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
130 ×ÉËÏÒÉÓÔÏ×ÕÀÔØ Cyrus SASL.
131
132 %package static
133 Summary:        Static cyrus-sasl libraries
134 Summary(pl):    Statyczne biblioteki cyrus-sasl
135 Summary(ru):    óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ Cyrus SASL
136 Summary(uk):    óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ Cyrus SASL
137 Group:          Development/Libraries
138 Requires:       %{name}-devel = %{version}-%{release}
139
140 %description static
141 Static cyrus-sasl libraries.
142
143 %description static -l pl
144 Statyczne biblioteki cyrus-sasl.
145
146 %description static -l ru
147 óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÉÌÏÖÅÎÉÊ,
148 ÉÓÐÏÌØÚÕÀÝÉÈ Cyrus SASL.
149
150 %description static -l uk
151 óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ
152 Cyrus SASL.
153
154 %package cram-md5
155 Summary:        Cram-MD5 Cyrus SASL plugin
156 Summary(pl):    Wtyczka Cram-MD5 do Cyrus SASL
157 Summary(pt_BR): Mecanismo SASL CRAM-MD5
158 Group:          Libraries
159 Requires:       %{name} = %{version}-%{release}
160
161 %description cram-md5
162 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
163 mandatory-to-implement authentication mechanism for a number of
164 protocols; it uses MD5 with a challenge/response system to
165 authenticate the user.
166
167 %description cram-md5 -l pl
168 Wtyczka dodaj±ca obs³ugê mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
169 jest obowi±zkowym do zaimplementowania mechanizmem uwierzytelniania
170 dla wielu protoko³ów; do uwierzytelnienia u¿ytkownika u¿ywa MD5 wraz z
171 systemem challenge/response.
172
173 %description cram-md5 -l pt_BR
174 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
175 mecanismo de autenticação obrigatório de ser implementado para vários
176 protocolos: ele usa MD5 com um sistema de desafio/resposta para
177 autenticar o usuário.
178
179 %package digest-md5
180 Summary:        Digest-MD5 Cyrus SASL plugin
181 Summary(pl):    Wtyczka Digest-MD5 do Cyrus SASL
182 Summary(pt_BR): Mecanismo SASL DIGEST-MD5
183 Group:          Libraries
184 Requires:       %{name} = %{version}-%{release}
185
186 %description digest-md5
187 This plugin implements the latest draft of the SASL DIGEST-MD5
188 mechanism. Although not yet finalized, this is likely to become the
189 new mandatory-to-implement authentication system in all new protocols.
190 It's based on the digest md5 authentication system designed for HTTP.
191
192 %description digest-md5 -l pl
193 Wtyczka dodaj±ca najnowsz± wersjê mechanizmu DIGEST-MD5 do Cyrus SASL.
194 Pomimo tego, ¿e nie jest jeszcze ukoñczony, najprawdopodobniej stanie
195 siê obowi±zkowym do zaimplementowania systemem uwierzytelniania we
196 wszystkich nowych protoko³ach. Bazuje na systemie uwierzytelniania
197 Digest-MD5 zaprojektowanym dla HTTP.
198
199 %description digest-md5 -l pt_BR
200 Este plugin implementa a última versão da especificação do mecanismo
201 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
202 provavelmente será o novo sistema de autenticação obrigatório para
203 protocolos novos. Ele é baseado na autenticação md5 digest
204 desenvolvida para HTTP.
205
206 %package plain
207 Summary:        Plain Cyrus SASL plugin
208 Summary(pl):    Wtyczka plain do Cyrus SASL
209 Summary(pt_BR): Mecanismo SASL PLAIN
210 Group:          Libraries
211 Requires:       %{name} = %{version}-%{release}
212
213 %description plain
214 This plugin implements the SASL PLAIN mechanism. Although insecure,
215 PLAIN is useful for transitioning to new security mechanisms, as this
216 is the only mechanism which gives the server a copy of the user's
217 password.
218
219 %description plain -l pl
220 Wtyczka dodaj±ca obs³ugê mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
221 ¿e nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
222 nowe mechanizmu bezpieczeñstwa, jako ¿e jest to jedyny mechanizm,
223 który udostêpnia serwerowi kopiê has³a u¿ytkownika.
224
225 %description plain -l pt_BR
226 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
227 mecanismo é útil durante transições para novos mecanismos de
228 segurança, pois é o único esquema que fornece uma cópia da senha do
229 usuário para o servidor.
230
231 %package anonymous
232 Summary:        Anonymous Cyrus SASL plugin
233 Summary(pl):    Wtyczka anonymous do Cyrus SASL
234 Summary(pt_BR): Mecanismo SASL ANONYMOUS
235 Group:          Libraries
236 Requires:       %{name} = %{version}-%{release}
237
238 %description anonymous
239 This plugin implements the SASL ANONYMOUS mechanism, used for
240 anonymous authentication.
241
242 %description anonymous -l pl
243 Wtyczka dodaj±ca obs³ugê mechanizmu ANONYMOUS do Cyrus SASL. S³u¿y do
244 anonimowego uwierzytelniania.
245
246 %description anonymous -l pt_BR
247 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
248 autenticação anônima.
249
250 %package gssapi
251 Summary:        GSSAPI Cyrus SASL plugin
252 Summary(pl):    Wtyczka GSSAPI do Cyrus SASL
253 Summary(pt_BR): Mecanismo SASL GSSAPI
254 Group:          Libraries
255 Requires:       %{name} = %{version}-%{release}
256
257 %description gssapi
258 This plugin implements the SASL GSSAPI mechanism, used for
259 GSSAPI/Kerberos5 authentication.
260
261 %description gssapi -l pl
262 Wtyczka dodaj±ca obs³ugê mechanizmu SASL GSSAPI, u¿ywanego do
263 uwierzytelniania z u¿yciem GSSAPI/Kerberos5.
264
265 %description gssapi -l pt_BR
266 Este plugin implementa o mecanismo SASL GSSAPI, usado para
267 autenticação Kerberos/GSSAPI.
268
269 %package login
270 Summary:        Unsupported Login Cyrus SASL plugin
271 Summary(pl):    Nie wspierana wtyczka Login do Cyrus SASL
272 Group:          Libraries
273 Requires:       %{name} = %{version}-%{release}
274
275 %description login
276 Unsupported LOGIN Cyrus SASL plugin.
277
278 %description login -l pl
279 Wtyczka dodaj±ca obs³ugê nie wspieranego mechanizmu LOGIN do Cyrus
280 SASL.
281
282 %package srp
283 Summary:        SRP Cyrus SASL plugin
284 Summary(pl):    Wtyczka SRP do Cyrus SASL
285 Summary(pt_BR): Mecanismo SASL SRP
286 Group:          Libraries
287 Requires:       %{name} = %{version}-%{release}
288
289 %description srp
290 This plugin implements the SASL SRP mechanism, based on the Secure
291 Remote Password protocol. This mechanism performs mutual
292 authentication and can provide a security layer with replay detection,
293 integrity protection and/or condifentiality protection.
294
295 %description srp -l pl
296 Wtyczka dodaj±ca obs³ugê mechanizmu SRP do Cyrus SASL. Bazuje na
297 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
298 uwierzytelnienia i mo¿e dodawaæ warstwê bezpieczeñstwa z wykrywaniem
299 powtarzania, zabezpieczeniem integralno¶ci i/lub poufno¶ci.
300
301 %description srp -l pt_BR
302 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
303 (Secure Remote Password). Este mecanismo oferece autenticação mútua
304 (do cliente e do servidor) e pode prover uma camada de segurança com
305 detecção de ataques de replay, garantia de integridade e/ou
306 confidencialidade.
307
308 %package otp
309 Summary:        OTP Cyrus SASL plugin
310 Summary(pl):    Wtyczka OTP do Cyrus SASL
311 Summary(pt_BR): Mecanismo SASL OTP
312 Group:          Libraries
313 Requires:       %{name} = %{version}-%{release}
314
315 %description otp
316 This plugin implements the SASL OTP (One Time Password) mechanism.
317
318 %description otp -l pl
319 Wtyczka dodaj±ca obs³ugê mechanizmu OTP (has³a jednorazowe) do Cyrus
320 SASL.
321
322 %package opie
323 Summary:        OPIE Cyrus SASL plugin
324 Summary(pl):    Wtyczka OPIE do Cyrus SASL
325 Summary(pt_BR): Mecanismo SASL OPIE
326 Group:          Libraries
327 Requires:       %{name} = %{version}-%{release}
328
329 %description opie
330 This plugin implements the SASL OPIE (One Time Password) mechanism.
331
332 %description opie -l pl
333 Wtyczka dodaj±ca obs³ugê mechanizmu OPIE (has³a jednorazowe) do Cyrus
334 SASL.
335
336 %package x509
337 Summary:        x509 Cyrus SASL plugin
338 Summary(pl):    Wtyczka x509 do Cyrus SASL
339 Group:          Libraries
340 Requires:       %{name} = %{version}-%{release}
341
342 %description x509
343 x509 Cyrus SASL plugin.
344
345 %description x509 -l pl
346 Wtyczka x509 do Cyrus SASL.
347
348 %package saslauthd
349 Summary:        Cyrus SASL authd
350 Summary(pl):    Demon authd do Cyrus SASL
351 Group:          Daemons
352 Requires(post,preun):   /sbin/chkconfig
353 Requires:       %{name} = %{version}-%{release}
354 Requires:       /sbin/chkconfig
355 Requires:       rc-scripts
356
357 %description saslauthd
358 Cyrus SASL authd.
359
360 %description saslauthd -l pl
361 Demon authd do Cyrus SASL.
362
363 %package pwcheck
364 Summary:        Cyrus SASL pwcheck helper
365 Summary(pl):    Program pomocniczy pwcheck do Cyrus SASL
366 Group:          Libraries
367 Requires:       %{name} = %{version}-%{release}
368
369 %description pwcheck
370 Cyrus SASL pwcheck helper.
371
372 %description pwcheck -l pl
373 Program pomocniczy pwcheck do Cyrus SASL.
374
375 %package sasldb
376 Summary:        Cyrus SASL sasldb plugin
377 Summary(pl):    Wtyczka sasldb do Cyrus SASL
378 Group:          Libraries
379 Requires:       %{name} = %{version}-%{release}
380
381 %description sasldb
382 Cyrus SASL sasldb plugin.
383
384 %description sasldb -l pl
385 Wtyczka sasldb do Cyrus SASL.
386
387 %package mysql
388 Summary:        Cyrus SASL MySQL plugin
389 Summary(pl):    Wtyczka MySQL do Cyrus SASL
390 Group:          Libraries
391 Requires:       %{name} = %{version}-%{release}
392
393 %description mysql
394 Cyrus SASL MySQL plugin.
395
396 %description mysql -l pl
397 Wtyczka MySQL do Cyrus SASL.
398
399 %package pgsql
400 Summary:        Cyrus SASL PostgreSQL plugin
401 Summary(pl):    Wtyczka PostgreSQL do Cyrus SASL
402 Group:          Libraries
403 Requires:       %{name} = %{version}-%{release}
404
405 %description pgsql
406 Cyrus SASL PostgreSQL plugin.
407
408 %description pgsql -l pl
409 Wtyczka PostgreSQL do Cyrus SASL.
410
411 %package sqlite
412 Summary:        Cyrus SQLite PostgreSQL plugin
413 Summary(pl):    Wtyczka SQLite do Cyrus SASL
414 Group:          Libraries
415 Requires:       %{name} = %{version}-%{release}
416
417 %description sqlite
418 Cyrus SASL SQLite plugin.
419
420 %description sqlite -l pl
421 Wtyczka SQLite do Cyrus SASL.
422
423 %prep
424 %setup -q
425 %patch0 -p1
426 %patch1 -p1
427 %patch2 -p1
428 %patch3 -p1
429 %patch4 -p1
430 %if %{with cryptedpw}
431 %patch5 -p1
432 %patch6 -p1
433 %endif
434 %patch7 -p1
435
436 cd doc
437 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
438 ls rfc*.txt >> rfc-compliance
439 rm -f rfc*.txt
440 cd ..
441
442 rm -rf autom4te.cache saslauthd/autom4te.cache
443 # acinclude.m4 contains only old libtool.m4
444 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
445
446 %build
447 %{__libtoolize}
448 %{__aclocal} -I cmulocal -I config
449 %{__autoheader}
450 %{__automake}
451 %{__autoconf}
452
453 cd saslauthd
454 %{__libtoolize}
455 %{__aclocal} -I ../cmulocal -I ../config -I config
456 %{__autoheader}
457 %{__automake}
458 %{__autoconf}
459 cd ..
460
461 %configure \
462         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
463         --disable-krb4 \
464         %{!?with_gssapi: --disable-gssapi} \
465         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
466         --enable-login \
467         --enable-sample \
468         --enable-sql \
469         %{?with_srp: --enable-srp} \
470         --enable-static \
471         --with-plugindir=%{_libdir}/sasl2 \
472         --with-configdir=%{_sysconfdir} \
473         --with-dblib=berkeley \
474         --with-dbpath=/var/lib/sasl2/sasl.db \
475         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
476         %{?with_ldap: --with-ldap=%{_prefix}} \
477         %{?with_mysql: --with-mysql=%{_prefix}} \
478         %{?with_pgsql: --with-pgsql=%{_prefix}} \
479         %{?with_sqlite: --with-sqlite=%{_prefix}} \
480         %{?with_opie: --with-opie=%{_prefix}} \
481         --with-pam \
482         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
483         --with-saslauthd=/var/lib/sasl2
484 %{__make}
485
486 %{__make} -C saslauthd testsaslauthd
487 %{__make} -C saslauthd saslcache
488
489 cd doc
490 RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
491 for i in $RFCLIST; do
492         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
493         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
494 done
495
496 %install
497 rm -rf $RPM_BUILD_ROOT
498 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
499                 $RPM_BUILD_ROOT%{_mandir}/man8
500
501 %{__make} install \
502         sasldir=%{_libdir}/sasl2 \
503         DESTDIR=$RPM_BUILD_ROOT
504
505 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
506 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
507
508 install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
509 install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
510
511 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
512
513 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
514
515 # create empty config
516 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
517 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
518 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
519 install %{SOURCE3} ./cyrus.pam
520
521 install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
522
523 # sample programs for testing sasl
524 libtool --mode=install cp sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
525 libtool --mode=install cp sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
526
527 %clean
528 rm -rf $RPM_BUILD_ROOT
529
530 %post   -p /sbin/ldconfig
531 %postun -p /sbin/ldconfig
532
533 %post saslauthd
534 /sbin/chkconfig --add saslauthd
535 %service saslauthd restart
536
537 %preun saslauthd
538 if [ "$1" = "0" ]; then
539         %service saslauthd stop
540         /sbin/chkconfig --del saslauthd
541 fi
542
543 %files
544 %defattr(644,root,root,755)
545 %doc AUTHORS COPYING ChangeLog NEWS README
546 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
547 %dir %{_sysconfdir}
548 %dir %{_libdir}/sasl2
549 %dir /var/lib/sasl2
550 %attr(755,root,root) %{_libdir}/lib*.so.*.*
551 # sample programs to subpackage instead?
552 %attr(755,root,root) %{_bindir}/sasl-sample-client
553 %attr(755,root,root) %{_bindir}/sasl-sample-server
554 %attr(755,root,root) %{_sbindir}/pluginviewer
555 %attr(755,root,root) %{_sbindir}/sasldblistusers2
556 %attr(755,root,root) %{_sbindir}/saslpasswd2
557
558 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
559 %{_mandir}/man8/pluginviewer.8*
560 %{_mandir}/man8/sasldblistusers2.8*
561 %{_mandir}/man8/saslpasswd2.8*
562
563 %files devel
564 %defattr(644,root,root,755)
565 %{_includedir}/sasl
566 %attr(755,root,root) %{_libdir}/lib*.so
567 %{_libdir}/lib*.la
568 %{_mandir}/man3/*
569
570 %files static
571 %defattr(644,root,root,755)
572 %{_libdir}/lib*.a
573
574 %files anonymous
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
577
578 %if %{with gssapi}
579 %files gssapi
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
582 %endif
583
584 %files cram-md5
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
587
588 %files digest-md5
589 %defattr(644,root,root,755)
590 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
591
592 %files login
593 %defattr(644,root,root,755)
594 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
595
596 %files otp
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
599
600 %if %{with opie}
601 %files opie
602 %defattr(644,root,root,755)
603 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
604 %endif
605
606 %files plain
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
609
610 %files sasldb
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
613
614 %if %{with mysql}
615 %files mysql
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
618 %endif
619
620 %if %{with pgsql}
621 %files pgsql
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
624 %endif
625
626 %if %{with sqlite}
627 %files sqlite
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
630 %endif
631
632 %if %{with srp}
633 %files srp
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
636 %endif
637
638 %if %{with x509}
639 %files x509
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
642 %endif
643
644 %if %{with pwcheck}
645 %files pwcheck
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_sbindir}/pwcheck
648 %endif
649
650 %files saslauthd
651 %defattr(644,root,root,755)
652 %doc cyrus.pam
653 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
654 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
655 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
656 %attr(755,root,root) %{_sbindir}/saslauthd
657 %attr(755,root,root) %{_sbindir}/testsaslauthd
658 %attr(755,root,root) %{_sbindir}/saslcache
659 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
660 %{_mandir}/man8/saslauthd.8*
This page took 0.082935 seconds and 4 git commands to generate.