]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- changed ac patch to fix the real source of saslauthd breakage (underquoted AC_CHECK...
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # enable opie plugin
13 %bcond_with     srp             # build srp pluggin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 %bcond_with     x509            # build x509 plugin (no sources in package???)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.23
28 Release:        15
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
32 # Source0-md5:  2eb0e48106f0e9cd8001e654f267ecbc
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-db.patch
46 Patch8:         %{name}-automake_1_10.patch
47 Patch9:         %{name}-digest-commas.patch
48 Patch10:        %{name}-keytab.patch
49 Patch11:        %{name}-sizes.patch
50 Patch12:        %{name}-nagios-plugin.patch
51 Patch13:        %{name}-parallel-make.patch
52 Patch14:        %{name}-gssapi-detect.patch
53 Patch15:        %{name}-saslauthd-httpform-urlescape.patch
54 Patch16:        %{name}-ac-libs.patch
55 Patch17:        %{name}-pam.patch
56 Patch18:        %{name}-ac.patch
57 URL:            http://asg.web.cmu.edu/sasl/
58 BuildRequires:  autoconf >= 2.54
59 BuildRequires:  automake >= 1:1.7
60 %{?with_authlib:BuildRequires:  courier-authlib-devel}
61 BuildRequires:  db-devel
62 BuildRequires:  ed
63 BuildRequires:  groff
64 %{?with_gssapi:BuildRequires:   heimdal-devel}
65 BuildRequires:  libtool >= 1.4
66 %{?with_mysql:BuildRequires:    mysql-devel}
67 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
68 BuildRequires:  openssl-devel >= 0.9.7d
69 %{?with_opie:BuildRequires:     opie-devel}
70 BuildRequires:  pam-devel
71 %{?with_pgsql:BuildRequires:    postgresql-devel}
72 BuildRequires:  rpmbuild(macros) >= 1.268
73 %{?with_sqlite:BuildRequires:   sqlite-devel}
74 Requires:       pam >= 0.79.0
75 Requires:       %{name}-libs = %{version}-%{release}
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %define         _sysconfdir     /etc/sasl
79
80 %define         specflags       -fno-strict-aliasing
81
82 %description
83 This is an implementation of the SASL API, useful for adding
84 authentication, authorization, and security to network protocols. The
85 SASL protocol itself is documented in rfc2222; the API standard is a
86 work in progress.
87
88 Note: remember to install appropriate plugins, or you won't have any
89 authentication mechanisms available.
90
91 %description -l pl.UTF-8
92 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
93 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
94 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
95 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
96 RFC 2222; standaryzacja API jest w toku.
97
98 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
99 doinstalować odpowiednie wtyczki.
100
101 %description -l pt_BR.UTF-8
102 Esta é uma implementação da API SASL, útil para acrescentar
103 autenticação, autorização e seguança (criptografia) para protocolos de
104 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
105 ainda está em desenvolvimento.
106
107 %description -l ru.UTF-8
108 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
109 Authentication and Security Layer, метод для добавления поддержки
110 аутентикации к протоколам, основанным на соединениях.
111
112 %description -l uk.UTF-8
113 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
114 Authentication and Security Layer, метод для додання підтримки
115 аутентикації до протоколів, базованих на з'єднаннях.
116
117 %package libs
118 Summary:        cyrus-sasl library itself
119 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
120 Group:          Libraries
121 Requires(post,postun):  /sbin/ldconfig
122 Conflicts:      cyrus-sasl < 2.1.23-8
123
124 %description libs
125 cyrus-sasl library itself.
126
127 %description libs -l pl.UTF-8
128 Sama biblioteka cyrus-sasl.
129
130 %package devel
131 Summary:        Header files and documentation for cyrus-sasl
132 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
133 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
134 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
135 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
136 Group:          Development/Libraries
137 Requires:       %{name} = %{version}-%{release}
138
139 %description devel
140 This includes the header files and documentation needed to develop
141 applications which use SASL.
142
143 %description devel -l pl.UTF-8
144 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
145
146 %description devel -l pt_BR.UTF-8
147 Este pacote inclui os arquivos de cabeçalho e documentação necessários
148 para desenvolver aplicativos que usem SASL.
149
150 %description devel -l ru.UTF-8
151 Хедеры и библиотеки, необходимые для разработки приложений,
152 использующих Cyrus SASL.
153
154 %description devel -l uk.UTF-8
155 Хедери та бібліотеки, необхідні для розробки програм, що
156 використовують Cyrus SASL.
157
158 %package static
159 Summary:        Static cyrus-sasl libraries
160 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
161 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
162 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
163 Group:          Development/Libraries
164 Requires:       %{name}-devel = %{version}-%{release}
165
166 %description static
167 Static cyrus-sasl libraries.
168
169 %description static -l pl.UTF-8
170 Statyczne biblioteki cyrus-sasl.
171
172 %description static -l ru.UTF-8
173 Статические библиотеки, необходимые для разработки приложений,
174 использующих Cyrus SASL.
175
176 %description static -l uk.UTF-8
177 Статичні бібліотеки, необхідні для розробки програм, що використовують
178 Cyrus SASL.
179
180 %package cram-md5
181 Summary:        Cram-MD5 Cyrus SASL plugin
182 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
183 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
184 Group:          Libraries
185 Requires:       %{name} = %{version}-%{release}
186
187 %description cram-md5
188 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
189 mandatory-to-implement authentication mechanism for a number of
190 protocols; it uses MD5 with a challenge/response system to
191 authenticate the user.
192
193 %description cram-md5 -l pl.UTF-8
194 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
195 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
196 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
197 systemem challenge/response.
198
199 %description cram-md5 -l pt_BR.UTF-8
200 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
201 mecanismo de autenticação obrigatório de ser implementado para vários
202 protocolos: ele usa MD5 com um sistema de desafio/resposta para
203 autenticar o usuário.
204
205 %package digest-md5
206 Summary:        Digest-MD5 Cyrus SASL plugin
207 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
208 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
209 Group:          Libraries
210 Requires:       %{name} = %{version}-%{release}
211
212 %description digest-md5
213 This plugin implements the latest draft of the SASL DIGEST-MD5
214 mechanism. Although not yet finalized, this is likely to become the
215 new mandatory-to-implement authentication system in all new protocols.
216 It's based on the digest md5 authentication system designed for HTTP.
217
218 %description digest-md5 -l pl.UTF-8
219 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
220 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
221 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
222 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
223 Digest-MD5 zaprojektowanym dla HTTP.
224
225 %description digest-md5 -l pt_BR.UTF-8
226 Este plugin implementa a última versão da especificação do mecanismo
227 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
228 provavelmente será o novo sistema de autenticação obrigatório para
229 protocolos novos. Ele é baseado na autenticação md5 digest
230 desenvolvida para HTTP.
231
232 %package plain
233 Summary:        Plain Cyrus SASL plugin
234 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
235 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
236 Group:          Libraries
237 Requires:       %{name} = %{version}-%{release}
238
239 %description plain
240 This plugin implements the SASL PLAIN mechanism. Although insecure,
241 PLAIN is useful for transitioning to new security mechanisms, as this
242 is the only mechanism which gives the server a copy of the user's
243 password.
244
245 %description plain -l pl.UTF-8
246 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
247 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
248 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
249 który udostępnia serwerowi kopię hasła użytkownika.
250
251 %description plain -l pt_BR.UTF-8
252 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
253 mecanismo é útil durante transições para novos mecanismos de
254 segurança, pois é o único esquema que fornece uma cópia da senha do
255 usuário para o servidor.
256
257 %package anonymous
258 Summary:        Anonymous Cyrus SASL plugin
259 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
260 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
261 Group:          Libraries
262 Requires:       %{name} = %{version}-%{release}
263
264 %description anonymous
265 This plugin implements the SASL ANONYMOUS mechanism, used for
266 anonymous authentication.
267
268 %description anonymous -l pl.UTF-8
269 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
270 anonimowego uwierzytelniania.
271
272 %description anonymous -l pt_BR.UTF-8
273 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
274 autenticação anônima.
275
276 %package gssapi
277 Summary:        GSSAPI Cyrus SASL plugin
278 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
279 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
280 Group:          Libraries
281 Requires:       %{name} = %{version}-%{release}
282
283 %description gssapi
284 This plugin implements the SASL GSSAPI mechanism, used for
285 GSSAPI/Kerberos5 authentication.
286
287 %description gssapi -l pl.UTF-8
288 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
289 uwierzytelniania z użyciem GSSAPI/Kerberos5.
290
291 %description gssapi -l pt_BR.UTF-8
292 Este plugin implementa o mecanismo SASL GSSAPI, usado para
293 autenticação Kerberos/GSSAPI.
294
295 %package login
296 Summary:        Unsupported Login Cyrus SASL plugin
297 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
298 Group:          Libraries
299 Requires:       %{name} = %{version}-%{release}
300
301 %description login
302 Unsupported LOGIN Cyrus SASL plugin.
303
304 %description login -l pl.UTF-8
305 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
306 SASL.
307
308 %package srp
309 Summary:        SRP Cyrus SASL plugin
310 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
311 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
312 Group:          Libraries
313 Requires:       %{name} = %{version}-%{release}
314
315 %description srp
316 This plugin implements the SASL SRP mechanism, based on the Secure
317 Remote Password protocol. This mechanism performs mutual
318 authentication and can provide a security layer with replay detection,
319 integrity protection and/or condifentiality protection.
320
321 %description srp -l pl.UTF-8
322 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
323 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
324 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
325 powtarzania, zabezpieczeniem integralności i/lub poufności.
326
327 %description srp -l pt_BR.UTF-8
328 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
329 (Secure Remote Password). Este mecanismo oferece autenticação mútua
330 (do cliente e do servidor) e pode prover uma camada de segurança com
331 detecção de ataques de replay, garantia de integridade e/ou
332 confidencialidade.
333
334 %package otp
335 Summary:        OTP Cyrus SASL plugin
336 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
337 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
338 Group:          Libraries
339 Requires:       %{name} = %{version}-%{release}
340
341 %description otp
342 This plugin implements the SASL OTP (One Time Password) mechanism.
343
344 %description otp -l pl.UTF-8
345 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
346 SASL.
347
348 %package opie
349 Summary:        OPIE Cyrus SASL plugin
350 Summary(pl.UTF-8):      Wtyczka OPIE do Cyrus SASL
351 Summary(pt_BR.UTF-8):   Mecanismo SASL OPIE
352 Group:          Libraries
353 Requires:       %{name} = %{version}-%{release}
354
355 %description opie
356 This plugin implements the SASL OPIE (One Time Password) mechanism.
357
358 %description opie -l pl.UTF-8
359 Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
360 SASL.
361
362 %package x509
363 Summary:        x509 Cyrus SASL plugin
364 Summary(pl.UTF-8):      Wtyczka x509 do Cyrus SASL
365 Group:          Libraries
366 Requires:       %{name} = %{version}-%{release}
367
368 %description x509
369 x509 Cyrus SASL plugin.
370
371 %description x509 -l pl.UTF-8
372 Wtyczka x509 do Cyrus SASL.
373
374 %package saslauthd
375 Summary:        Cyrus SASL authd
376 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
377 Group:          Daemons
378 Requires(post,preun):   /sbin/chkconfig
379 Requires:       %{name} = %{version}-%{release}
380 Requires:       /sbin/chkconfig
381 Requires:       rc-scripts
382
383 %description saslauthd
384 Cyrus SASL authd.
385
386 %description saslauthd -l pl.UTF-8
387 Demon authd do Cyrus SASL.
388
389 %package pwcheck
390 Summary:        Cyrus SASL pwcheck helper
391 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
392 Group:          Libraries
393 Requires:       %{name} = %{version}-%{release}
394
395 %description pwcheck
396 Cyrus SASL pwcheck helper.
397
398 %description pwcheck -l pl.UTF-8
399 Program pomocniczy pwcheck do Cyrus SASL.
400
401 %package sasldb
402 Summary:        Cyrus SASL sasldb plugin
403 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
404 Group:          Libraries
405 Requires:       %{name} = %{version}-%{release}
406
407 %description sasldb
408 Cyrus SASL sasldb plugin.
409
410 %description sasldb -l pl.UTF-8
411 Wtyczka sasldb do Cyrus SASL.
412
413 %package mysql
414 Summary:        Cyrus SASL MySQL plugin
415 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
416 Group:          Libraries
417 Requires:       %{name} = %{version}-%{release}
418
419 %description mysql
420 Cyrus SASL MySQL plugin.
421
422 %description mysql -l pl.UTF-8
423 Wtyczka MySQL do Cyrus SASL.
424
425 %package pgsql
426 Summary:        Cyrus SASL PostgreSQL plugin
427 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
428 Group:          Libraries
429 Requires:       %{name} = %{version}-%{release}
430
431 %description pgsql
432 Cyrus SASL PostgreSQL plugin.
433
434 %description pgsql -l pl.UTF-8
435 Wtyczka PostgreSQL do Cyrus SASL.
436
437 %package sqlite
438 Summary:        Cyrus SQLite PostgreSQL plugin
439 Summary(pl.UTF-8):      Wtyczka SQLite do Cyrus SASL
440 Group:          Libraries
441 Requires:       %{name} = %{version}-%{release}
442
443 %description sqlite
444 Cyrus SASL SQLite plugin.
445
446 %description sqlite -l pl.UTF-8
447 Wtyczka SQLite do Cyrus SASL.
448
449 %package -n nagios-plugin-check_saslauthd
450 Summary:        Nagios plugin to check health of saslauthd
451 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
452 Group:          Networking
453 Requires:       nagios-core
454
455 %description -n nagios-plugin-check_saslauthd
456 Nagios plugin to check health of saslauthd.
457
458 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
459 Wtyczka Nagiosa do sprawdzania działania saslauthd.
460
461 %prep
462 %setup -q
463 %patch0 -p1
464 %patch1 -p1
465 %patch2 -p1
466 %patch3 -p1
467 %patch4 -p1
468 %if %{with cryptedpw}
469 %patch5 -p1
470 %patch6 -p1
471 %endif
472 %patch7 -p1
473 %patch8 -p1
474 %patch9 -p2
475 %patch10 -p1
476 %patch11 -p1
477 %patch12 -p1
478 %patch13 -p1
479 %patch14 -p1
480 %patch15 -p0
481 %patch16 -p1
482 %patch17 -p1
483 %patch18 -p1
484
485 cd doc
486 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
487 ls rfc*.txt >> rfc-compliance
488 rm -f rfc*.txt
489 cd ..
490
491 rm -rf autom4te.cache saslauthd/autom4te.cache
492 # acinclude.m4 contains only old libtool.m4
493 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
494
495 # update to our paths
496 sed -i -e '
497         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
498         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
499         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
500         s,/var/state/saslauthd,/var/lib/sasl2,g
501 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
502
503 %build
504 %{__libtoolize}
505 %{__aclocal} -I cmulocal -I config
506 %{__autoheader}
507 %{__autoconf}
508 %{__automake}
509 cd saslauthd
510 %{__aclocal} -I ../cmulocal -I ../config
511 %{__autoheader}
512 %{__autoconf}
513 %{__automake}
514 cd ..
515 %configure \
516         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
517         --disable-krb4 \
518         %{!?with_gssapi: --disable-gssapi} \
519         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
520         --enable-login \
521         --enable-sample \
522         --enable-httpform \
523         --enable-sql \
524         %{?with_srp: --enable-srp} \
525         --enable-static \
526         --with-plugindir=%{_libdir}/sasl2 \
527         --with-configdir=%{_sysconfdir} \
528         --with-dblib=berkeley \
529         --with-dbpath=/var/lib/sasl2/sasl.db \
530         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
531         %{?with_ldap: --with-ldap=%{_prefix}} \
532         %{?with_mysql: --with-mysql=%{_prefix}} \
533         %{?with_pgsql: --with-pgsql=%{_prefix}} \
534         %{?with_sqlite: --with-sqlite=%{_prefix}} \
535         %{?with_opie: --with-opie=%{_prefix}} \
536         --with-pam \
537         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
538         --with-saslauthd=/var/lib/sasl2
539
540 %{__make}
541
542 %{__make} -C saslauthd testsaslauthd
543 %{__make} -C saslauthd saslcache
544 %{__make} -C sample sample-client sample-server
545
546 cd doc
547 RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
548 for i in $RFCLIST; do
549         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
550         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
551 done
552
553 %install
554 rm -rf $RPM_BUILD_ROOT
555 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
556                 $RPM_BUILD_ROOT%{_mandir}/man8
557
558 %{__make} install \
559         sasldir=%{_libdir}/sasl2 \
560         DESTDIR=$RPM_BUILD_ROOT
561
562 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
563
564 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
565 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
566
567 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
568
569 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
570
571 # create empty config
572 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
573 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
574 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
575 cp -a %{SOURCE3} cyrus.pam
576
577 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
578
579 # sample programs for testing sasl
580 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
581 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
582
583 # package for ghost
584 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
585
586 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
587 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
588
589 %clean
590 rm -rf $RPM_BUILD_ROOT
591
592 %post   libs -p /sbin/ldconfig
593 %postun libs -p /sbin/ldconfig
594
595 %post saslauthd
596 /sbin/chkconfig --add saslauthd
597 %service saslauthd restart
598
599 %preun saslauthd
600 if [ "$1" = "0" ]; then
601         %service saslauthd stop
602         /sbin/chkconfig --del saslauthd
603 fi
604
605 %triggerin saslauthd -- pam
606 # restart saslauthd if pam is upgraded
607 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
608 if [ "$2" != 1 ]; then
609         %service -q saslauthd restart
610 fi
611
612 %files
613 %defattr(644,root,root,755)
614 %doc AUTHORS COPYING ChangeLog NEWS README
615 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
616 %dir %{_sysconfdir}
617 %dir %{_libdir}/sasl2
618 # sample programs to subpackage instead?
619 %attr(755,root,root) %{_bindir}/sasl-sample-client
620 %attr(755,root,root) %{_bindir}/sasl-sample-server
621 %attr(755,root,root) %{_sbindir}/pluginviewer
622 %attr(755,root,root) %{_sbindir}/sasldblistusers2
623 %attr(755,root,root) %{_sbindir}/saslpasswd2
624 %dir /var/lib/sasl2
625 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
626 %{_mandir}/man8/pluginviewer.8*
627 %{_mandir}/man8/sasldblistusers2.8*
628 %{_mandir}/man8/saslpasswd2.8*
629
630 %files libs
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
633 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
634
635 %files devel
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_libdir}/libsasl2.so
638 %attr(755,root,root) %{_libdir}/libsasl.so
639 %{_libdir}/libsasl2.la
640 %{_includedir}/sasl
641 %{_mandir}/man3/sasl*.3*
642
643 %files static
644 %defattr(644,root,root,755)
645 %{_libdir}/libsasl2.a
646
647 %files anonymous
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
650
651 %if %{with gssapi}
652 %files gssapi
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
655 %endif
656
657 %files cram-md5
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
660
661 %files digest-md5
662 %defattr(644,root,root,755)
663 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
664
665 %files login
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
668
669 %files otp
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
672
673 %if %{with opie}
674 %files opie
675 %defattr(644,root,root,755)
676 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
677 %endif
678
679 %files plain
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
682
683 %files sasldb
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
686
687 %if %{with mysql}
688 %files mysql
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
691 %endif
692
693 %if %{with pgsql}
694 %files pgsql
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
697 %endif
698
699 %if %{with sqlite}
700 %files sqlite
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
703 %endif
704
705 %if %{with srp}
706 %files srp
707 %defattr(644,root,root,755)
708 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
709 %endif
710
711 %if %{with x509}
712 %files x509
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
715 %endif
716
717 %if %{with pwcheck}
718 %files pwcheck
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_sbindir}/pwcheck
721 %endif
722
723 %files saslauthd
724 %defattr(644,root,root,755)
725 %doc cyrus.pam
726 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
727 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
728 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
729 %attr(755,root,root) %{_sbindir}/saslauthd
730 %attr(755,root,root) %{_sbindir}/testsaslauthd
731 %attr(755,root,root) %{_sbindir}/saslcache
732 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
733 %ghost /var/lib/sasl2/cache.flock
734 %ghost /var/lib/sasl2/cache.mmap
735 %ghost /var/lib/sasl2/mux
736 %ghost /var/lib/sasl2/mux.accept
737 %ghost /var/lib/sasl2/saslauthd.pid
738 %{_mandir}/man8/saslauthd.8*
739
740 %files -n nagios-plugin-check_saslauthd
741 %defattr(644,root,root,755)
742 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
743 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.202754 seconds and 4 git commands to generate.