]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- updated Source URL
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 #
2 # Conditional build:
3 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
4 %bcond_without  ldap            # disable LDAP support for saslauthd
5 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
6 %bcond_without  mysql           # don't build MySQL plugin
7 %bcond_without  ntlm            # do not build NTLM plugin
8 %bcond_without  pgsql           # do not build PostgreSQL plugin
9 %bcond_without  sqlite          # do not enable sqlite 2 plugin
10 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # OTP plugin using opie library instead of internal code
13 %bcond_with     srp             # build srp plugin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 #
16 %if %{without mysql} && %{without pgsql}
17 %undefine with_cryptedpw
18 %endif
19
20 Summary:        The SASL library API for the Cyrus mail system
21 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
22 Summary(pt_BR.UTF-8):   Implementação da API SASL
23 Summary(ru.UTF-8):      Библиотека Cyrus SASL
24 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
25 Name:           cyrus-sasl
26 Version:        2.1.27
27 Release:        1
28 License:        distributable
29 Group:          Libraries
30 #Source0Download: https://github.com/cyrusimap/cyrus-sasl/releases
31 Source0:        https://github.com/cyrusimap/cyrus-sasl/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
32 # Source0-md5:  a33820c66e0622222c5aefafa1581083
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
42 Patch5:         %{name}-cryptedpw.patch
43 Patch6:         %{name}-md5sum-passwords.patch
44 Patch7:         %{name}-db.patch
45 Patch9:         %{name}-sizes.patch
46 Patch10:        %{name}-nagios-plugin.patch
47 Patch12:        %{name}-gssapi-detect.patch
48 Patch13:        %{name}-saslauthd-httpform-urlescape.patch
49 Patch14:        %{name}-ac-libs.patch
50 Patch20:        %{name}-auxprop.patch
51 Patch21:        0030-dont_use_la_files_for_opening_plugins.patch
52 URL:            https://www.cyrusimap.org/sasl/
53 BuildRequires:  autoconf >= 2.63
54 BuildRequires:  automake >= 1:1.11
55 %{?with_authlib:BuildRequires:  courier-authlib-devel}
56 BuildRequires:  db-devel
57 BuildRequires:  ed
58 BuildRequires:  groff
59 %{?with_gssapi:BuildRequires:   heimdal-devel}
60 BuildRequires:  libtool >= 1.4
61 %{?with_mysql:BuildRequires:    mysql-devel}
62 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
63 BuildRequires:  openssl-devel >= 0.9.7d
64 %{?with_opie:BuildRequires:     opie-devel}
65 BuildRequires:  pam-devel
66 %{?with_pgsql:BuildRequires:    postgresql-devel}
67 BuildRequires:  rpmbuild(macros) >= 1.268
68 %{?with_sqlite:BuildRequires:   sqlite-devel}
69 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
70 Requires:       pam >= 0.79.0
71 Requires:       %{name}-libs = %{version}-%{release}
72 Obsoletes:      cyrus-sasl-x509 < %{version}
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _sysconfdir     /etc/sasl
76
77 %define         specflags       -fno-strict-aliasing
78
79 %description
80 This is an implementation of the SASL API, useful for adding
81 authentication, authorization, and security to network protocols. The
82 SASL protocol itself is documented in rfc2222; the API standard is a
83 work in progress.
84
85 Note: remember to install appropriate plugins, or you won't have any
86 authentication mechanisms available.
87
88 %description -l pl.UTF-8
89 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
90 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
91 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
92 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
93 RFC 2222; standaryzacja API jest w toku.
94
95 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
96 doinstalować odpowiednie wtyczki.
97
98 %description -l pt_BR.UTF-8
99 Esta é uma implementação da API SASL, útil para acrescentar
100 autenticação, autorização e seguança (criptografia) para protocolos de
101 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
102 ainda está em desenvolvimento.
103
104 %description -l ru.UTF-8
105 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
106 Authentication and Security Layer, метод для добавления поддержки
107 аутентикации к протоколам, основанным на соединениях.
108
109 %description -l uk.UTF-8
110 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
111 Authentication and Security Layer, метод для додання підтримки
112 аутентикації до протоколів, базованих на з'єднаннях.
113
114 %package libs
115 Summary:        cyrus-sasl library itself
116 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
117 Group:          Libraries
118 Requires(post,postun):  /sbin/ldconfig
119 Conflicts:      cyrus-sasl < 2.1.23-8
120
121 %description libs
122 cyrus-sasl library itself.
123
124 %description libs -l pl.UTF-8
125 Sama biblioteka cyrus-sasl.
126
127 %package devel
128 Summary:        Header files and documentation for cyrus-sasl
129 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
130 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
131 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
132 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
133 Group:          Development/Libraries
134 Requires:       %{name} = %{version}-%{release}
135
136 %description devel
137 This includes the header files and documentation needed to develop
138 applications which use SASL.
139
140 %description devel -l pl.UTF-8
141 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
142
143 %description devel -l pt_BR.UTF-8
144 Este pacote inclui os arquivos de cabeçalho e documentação necessários
145 para desenvolver aplicativos que usem SASL.
146
147 %description devel -l ru.UTF-8
148 Хедеры и библиотеки, необходимые для разработки приложений,
149 использующих Cyrus SASL.
150
151 %description devel -l uk.UTF-8
152 Хедери та бібліотеки, необхідні для розробки програм, що
153 використовують Cyrus SASL.
154
155 %package static
156 Summary:        Static cyrus-sasl libraries
157 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
158 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
159 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
160 Group:          Development/Libraries
161 Requires:       %{name}-devel = %{version}-%{release}
162
163 %description static
164 Static cyrus-sasl libraries.
165
166 %description static -l pl.UTF-8
167 Statyczne biblioteki cyrus-sasl.
168
169 %description static -l ru.UTF-8
170 Статические библиотеки, необходимые для разработки приложений,
171 использующих Cyrus SASL.
172
173 %description static -l uk.UTF-8
174 Статичні бібліотеки, необхідні для розробки програм, що використовують
175 Cyrus SASL.
176
177 %package anonymous
178 Summary:        Anonymous Cyrus SASL plugin
179 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
180 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
181 Group:          Libraries
182 Requires:       %{name} = %{version}-%{release}
183
184 %description anonymous
185 This plugin implements the SASL ANONYMOUS mechanism, used for
186 anonymous authentication.
187
188 %description anonymous -l pl.UTF-8
189 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
190 anonimowego uwierzytelniania.
191
192 %description anonymous -l pt_BR.UTF-8
193 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
194 autenticação anônima.
195
196 %package cram-md5
197 Summary:        Cram-MD5 Cyrus SASL plugin
198 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
199 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
200 Group:          Libraries
201 Requires:       %{name} = %{version}-%{release}
202
203 %description cram-md5
204 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
205 mandatory-to-implement authentication mechanism for a number of
206 protocols; it uses MD5 with a challenge/response system to
207 authenticate the user.
208
209 %description cram-md5 -l pl.UTF-8
210 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
211 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
212 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
213 systemem challenge/response.
214
215 %description cram-md5 -l pt_BR.UTF-8
216 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
217 mecanismo de autenticação obrigatório de ser implementado para vários
218 protocolos: ele usa MD5 com um sistema de desafio/resposta para
219 autenticar o usuário.
220
221 %package digest-md5
222 Summary:        Digest-MD5 Cyrus SASL plugin
223 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
224 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
225 Group:          Libraries
226 Requires:       %{name} = %{version}-%{release}
227
228 %description digest-md5
229 This plugin implements the latest draft of the SASL DIGEST-MD5
230 mechanism. Although not yet finalized, this is likely to become the
231 new mandatory-to-implement authentication system in all new protocols.
232 It's based on the digest md5 authentication system designed for HTTP.
233
234 %description digest-md5 -l pl.UTF-8
235 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
236 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
237 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
238 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
239 Digest-MD5 zaprojektowanym dla HTTP.
240
241 %description digest-md5 -l pt_BR.UTF-8
242 Este plugin implementa a última versão da especificação do mecanismo
243 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
244 provavelmente será o novo sistema de autenticação obrigatório para
245 protocolos novos. Ele é baseado na autenticação md5 digest
246 desenvolvida para HTTP.
247
248 %package gssapi
249 Summary:        GSSAPI Cyrus SASL plugin
250 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
251 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
252 Group:          Libraries
253 Requires:       %{name} = %{version}-%{release}
254
255 %description gssapi
256 This plugin implements the SASL GSSAPI mechanism, used for
257 GSSAPI/Kerberos5 authentication.
258
259 %description gssapi -l pl.UTF-8
260 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
261 uwierzytelniania z użyciem GSSAPI/Kerberos5.
262
263 %description gssapi -l pt_BR.UTF-8
264 Este plugin implementa o mecanismo SASL GSSAPI, usado para
265 autenticação Kerberos/GSSAPI.
266
267 %package login
268 Summary:        Unsupported Login Cyrus SASL plugin
269 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
270 Group:          Libraries
271 Requires:       %{name} = %{version}-%{release}
272
273 %description login
274 Unsupported LOGIN Cyrus SASL plugin.
275
276 %description login -l pl.UTF-8
277 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
278 SASL.
279
280 %package mysql
281 Summary:        Cyrus SASL MySQL plugin
282 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
283 Group:          Libraries
284 Requires:       %{name} = %{version}-%{release}
285
286 %description mysql
287 Cyrus SASL MySQL plugin.
288
289 %description mysql -l pl.UTF-8
290 Wtyczka MySQL do Cyrus SASL.
291
292 %package ntlm
293 Summary:        Cyrus SASL NTLM plugin
294 Summary(pl.UTF-8):      Wtyczka NTLM do Cyrus SASL
295 Group:          Libraries
296 Requires:       %{name} = %{version}-%{release}
297
298 %description ntlm
299 Cyrus SASL NTLM plugin.
300
301 %description ntlm -l pl.UTF-8
302 Wtyczka NTLM do Cyrus SASL.
303
304 %package otp
305 Summary:        OTP Cyrus SASL plugin
306 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
307 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
308 Group:          Libraries
309 Requires:       %{name} = %{version}-%{release}
310 Obsoletes:      cyrus-sasl-opie < %{version}
311
312 %description otp
313 This plugin implements the SASL OTP (One Time Password) mechanism.
314
315 %description otp -l pl.UTF-8
316 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
317 SASL.
318
319 %package pgsql
320 Summary:        Cyrus SASL PostgreSQL plugin
321 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
322 Group:          Libraries
323 Requires:       %{name} = %{version}-%{release}
324
325 %description pgsql
326 Cyrus SASL PostgreSQL plugin.
327
328 %description pgsql -l pl.UTF-8
329 Wtyczka PostgreSQL do Cyrus SASL.
330
331 %package plain
332 Summary:        Plain Cyrus SASL plugin
333 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
334 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
335 Group:          Libraries
336 Requires:       %{name} = %{version}-%{release}
337
338 %description plain
339 This plugin implements the SASL PLAIN mechanism. Although insecure,
340 PLAIN is useful for transitioning to new security mechanisms, as this
341 is the only mechanism which gives the server a copy of the user's
342 password.
343
344 %description plain -l pl.UTF-8
345 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
346 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
347 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
348 który udostępnia serwerowi kopię hasła użytkownika.
349
350 %description plain -l pt_BR.UTF-8
351 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
352 mecanismo é útil durante transições para novos mecanismos de
353 segurança, pois é o único esquema que fornece uma cópia da senha do
354 usuário para o servidor.
355
356 %package sasldb
357 Summary:        Cyrus SASL sasldb plugin
358 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
359 Group:          Libraries
360 Requires:       %{name} = %{version}-%{release}
361
362 %description sasldb
363 Cyrus SASL sasldb plugin.
364
365 %description sasldb -l pl.UTF-8
366 Wtyczka sasldb do Cyrus SASL.
367
368 %package ldapdb
369 Summary:        Cyrus SASL LDAPDB plugin
370 Summary(pl.UTF-8):      Wtyczka LDAPDB do Cyrus SASL
371 Group:          Libraries
372 Requires:       %{name} = %{version}-%{release}
373
374 %description ldapdb
375 Cyrus SASL ldapdb plugin.
376
377 %description ldapdb -l pl.UTF-8
378 Wtyczka ldapdb do Cyrus SASL.
379
380 %package passdss
381 Summary:        PASSDSS Cyrus SASL plugin
382 Summary(pl.UTF-8):      Wtyczka PASSDSS do Cyrus SASL
383 Summary(pt_BR.UTF-8):   Mecanismo SASL PASSDSS
384 Group:          Libraries
385 Requires:       %{name} = %{version}-%{release}
386
387 %description passdss
388 This plugin implements the PASSDSS 3DES mechanism.
389
390 %description passdss -l pl.UTF-8
391 Wtyczka dodająca obsługę mechanizmu PASSDSS 3DES do Cyrus SASL.
392
393 %description passdss -l pt_BR.UTF-8
394 Este plugin implementa o mecanismo SASL PASSDSS 3DES.
395
396 %package scram
397 Summary:        SCRAM Cyrus SASL plugin
398 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
399 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
400 Group:          Libraries
401 Requires:       %{name} = %{version}-%{release}
402
403 %description scram
404 This plugin implements the SASL SCRAM-MD5 mechanism.
405
406 %description scram -l pl.UTF-8
407 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
408
409 %description scram -l pt_BR.UTF-8
410 Este plugin implementa o mecanismo SASL SCRAM.
411
412 %package sqlite
413 Summary:        Cyrus SQLite 2 PostgreSQL plugin
414 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
415 Group:          Libraries
416 Requires:       %{name} = %{version}-%{release}
417
418 %description sqlite
419 Cyrus SASL SQLite 2 plugin.
420
421 %description sqlite -l pl.UTF-8
422 Wtyczka SQLite 2 do Cyrus SASL.
423
424 %package sqlite3
425 Summary:        Cyrus SQLite 3 PostgreSQL plugin
426 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
427 Group:          Libraries
428 Requires:       %{name} = %{version}-%{release}
429
430 %description sqlite3
431 Cyrus SASL SQLite 3 plugin.
432
433 %description sqlite3 -l pl.UTF-8
434 Wtyczka SQLite 3 do Cyrus SASL.
435
436 %package srp
437 Summary:        SRP Cyrus SASL plugin
438 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
439 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
440 Group:          Libraries
441 Requires:       %{name} = %{version}-%{release}
442
443 %description srp
444 This plugin implements the SASL SRP mechanism, based on the Secure
445 Remote Password protocol. This mechanism performs mutual
446 authentication and can provide a security layer with replay detection,
447 integrity protection and/or condifentiality protection.
448
449 %description srp -l pl.UTF-8
450 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
451 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
452 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
453 powtarzania, zabezpieczeniem integralności i/lub poufności.
454
455 %description srp -l pt_BR.UTF-8
456 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
457 (Secure Remote Password). Este mecanismo oferece autenticação mútua
458 (do cliente e do servidor) e pode prover uma camada de segurança com
459 detecção de ataques de replay, garantia de integridade e/ou
460 confidencialidade.
461
462 %package pwcheck
463 Summary:        Cyrus SASL pwcheck helper
464 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
465 Group:          Libraries
466 Requires:       %{name} = %{version}-%{release}
467
468 %description pwcheck
469 Cyrus SASL pwcheck helper.
470
471 %description pwcheck -l pl.UTF-8
472 Program pomocniczy pwcheck do Cyrus SASL.
473
474 %package saslauthd
475 Summary:        Cyrus SASL authd
476 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
477 Group:          Daemons
478 Requires(post,preun):   /sbin/chkconfig
479 Requires:       %{name} = %{version}-%{release}
480 Requires:       /sbin/chkconfig
481 Requires:       rc-scripts
482
483 %description saslauthd
484 Cyrus SASL authd.
485
486 %description saslauthd -l pl.UTF-8
487 Demon authd do Cyrus SASL.
488
489 %package -n nagios-plugin-check_saslauthd
490 Summary:        Nagios plugin to check health of saslauthd
491 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
492 Group:          Networking
493 Requires:       nagios-core
494
495 %description -n nagios-plugin-check_saslauthd
496 Nagios plugin to check health of saslauthd.
497
498 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
499 Wtyczka Nagiosa do sprawdzania działania saslauthd.
500
501 %prep
502 %setup -q
503 %patch0 -p1
504 %patch1 -p1
505 %patch2 -p1
506 %patch3 -p1
507 %if %{with cryptedpw}
508 %patch5 -p1
509 %patch6 -p1
510 %endif
511 %patch7 -p1
512 %patch9 -p1
513 %patch10 -p1
514 %patch12 -p1
515 %patch13 -p0
516 %patch14 -p1
517 %patch20 -p1
518 %patch21 -p1
519
520 # update to our paths
521 sed -i -e '
522         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
523         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
524         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
525         s,/var/state/saslauthd,/var/lib/sasl2,g
526 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/legacy/sysadmin.html
527
528 %build
529 %{__libtoolize}
530 %{__aclocal} -I m4
531 %{__autoconf}
532 %{__autoheader}
533 %{__automake}
534 %configure \
535         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
536         %{!?with_gssapi:--disable-gssapi} \
537         %{?with_gssapi:--enable-gssapi --with-gss_impl=heimdal} \
538         --enable-httpform \
539         --disable-krb4 \
540         %{?with_ldap:--enable-ldapdb} \
541         --enable-login \
542         --enable-passdss \
543         --enable-sample \
544         --enable-sql \
545         %{?with_srp:--enable-srp} \
546         --enable-static \
547         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
548         --with-configdir=%{_sysconfdir} \
549         --with-dblib=berkeley \
550         --with-dbpath=/var/lib/sasl2/sasl.db \
551         %{?with_ldap:--with-ldap} \
552         %{?with_mysql:--with-mysql=%{_prefix}} \
553         %{?with_ntlm:--enable-ntlm} \
554         %{?with_opie:--with-opie=%{_prefix}} \
555         --with-pam \
556         %{?with_pgsql:--with-pgsql=%{_prefix}} \
557         --with-plugindir=%{_libdir}/sasl2 \
558         %{?with_pwcheck:--with-pwcheck=/var/lib/sasl2} \
559         --with-saslauthd=/var/lib/sasl2 \
560         %{?with_sqlite:--with-sqlite=%{_prefix}} \
561         %{?with_sqlite3:--with-sqlite3=%{_prefix}}
562
563 %{__make}
564
565 %{__make} -C saslauthd testsaslauthd
566 %{__make} -C saslauthd saslcache
567 %{__make} -C sample sample-client sample-server
568
569 %{__rm} -rf doc/html/{_sources,objects.inv,.buildinfo}
570
571 %install
572 rm -rf $RPM_BUILD_ROOT
573 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
574                 $RPM_BUILD_ROOT%{_mandir}/man8
575
576 %{__make} install \
577         sasldir=%{_libdir}/sasl2 \
578         DESTDIR=$RPM_BUILD_ROOT
579
580 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
581
582 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
583 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
584
585 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
586
587 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
588
589 # create empty config
590 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
591 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
592 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
593 cp -a %{SOURCE3} cyrus.pam
594
595 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
596
597 # sample programs for testing sasl
598 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
599 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
600
601 # package for ghost
602 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
603
604 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
605 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
606
607 %clean
608 rm -rf $RPM_BUILD_ROOT
609
610 %post   libs -p /sbin/ldconfig
611 %postun libs -p /sbin/ldconfig
612
613 %post saslauthd
614 /sbin/chkconfig --add saslauthd
615 %service saslauthd restart
616
617 %preun saslauthd
618 if [ "$1" = "0" ]; then
619         %service saslauthd stop
620         /sbin/chkconfig --del saslauthd
621 fi
622
623 %triggerin saslauthd -- pam
624 # restart saslauthd if pam is upgraded
625 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
626 if [ "$2" != 1 ]; then
627         %service -q saslauthd restart
628 fi
629
630 %files
631 %defattr(644,root,root,755)
632 %doc AUTHORS COPYING ChangeLog README doc/legacy/{TODO,*.html,*.fig} doc/html
633 %dir %{_sysconfdir}
634 %dir %{_libdir}/sasl2
635 # sample programs to subpackage instead?
636 %attr(755,root,root) %{_bindir}/sasl-sample-client
637 %attr(755,root,root) %{_bindir}/sasl-sample-server
638 %attr(755,root,root) %{_sbindir}/pluginviewer
639 %attr(755,root,root) %{_sbindir}/sasldblistusers2
640 %attr(755,root,root) %{_sbindir}/saslpasswd2
641 %dir /var/lib/sasl2
642 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
643 %{_mandir}/man8/pluginviewer.8*
644 %{_mandir}/man8/sasldblistusers2.8*
645 %{_mandir}/man8/saslpasswd2.8*
646
647 %files libs
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
650 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.3
651
652 %files devel
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_libdir}/libsasl2.so
655 %attr(755,root,root) %{_libdir}/libsasl.so
656 %{_libdir}/libsasl2.la
657 %{_includedir}/sasl
658 %{_pkgconfigdir}/libsasl2.pc
659 %{_mandir}/man3/sasl*.3*
660
661 %files static
662 %defattr(644,root,root,755)
663 %{_libdir}/libsasl2.a
664
665 %files anonymous
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
668
669 %if %{with gssapi}
670 %files gssapi
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
673 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
674 %endif
675
676 %files cram-md5
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
679
680 %files digest-md5
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
683
684 %files login
685 %defattr(644,root,root,755)
686 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
687
688 %if %{with mysql}
689 %files mysql
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
692 %endif
693
694 %if %{with ntlm}
695 %files ntlm
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/sasl2/libntlm.so*
698 %endif
699
700 %files otp
701 %defattr(644,root,root,755)
702 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
703
704 %if %{with pgsql}
705 %files pgsql
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
708 %endif
709
710 %files plain
711 %defattr(644,root,root,755)
712 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
713
714 %files sasldb
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
717
718 %if %{with ldap}
719 %files ldapdb
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_libdir}/sasl2/libldapdb.so*
722 %endif
723
724 %files passdss
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_libdir}/sasl2/libpassdss.so*
727
728 %files scram
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
731
732 %if %{with sqlite}
733 %files sqlite
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
736 %endif
737
738 %if %{with sqlite3}
739 %files sqlite3
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
742 %endif
743
744 %if %{with srp}
745 %files srp
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
748 %endif
749
750 %if %{with pwcheck}
751 %files pwcheck
752 %defattr(644,root,root,755)
753 %attr(755,root,root) %{_sbindir}/pwcheck
754 %endif
755
756 %files saslauthd
757 %defattr(644,root,root,755)
758 %doc cyrus.pam saslauthd/{COPYING,LDAP_SASLAUTHD}
759 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
760 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
761 %attr(755,root,root) %{_sbindir}/saslauthd
762 %attr(755,root,root) %{_sbindir}/testsaslauthd
763 %attr(755,root,root) %{_sbindir}/saslcache
764 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
765 %ghost /var/lib/sasl2/cache.flock
766 %ghost /var/lib/sasl2/cache.mmap
767 %ghost /var/lib/sasl2/mux
768 %ghost /var/lib/sasl2/mux.accept
769 %ghost /var/lib/sasl2/saslauthd.pid
770 %{_mandir}/man8/saslauthd.8*
771
772 %files -n nagios-plugin-check_saslauthd
773 %defattr(644,root,root,755)
774 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
775 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.170898 seconds and 4 git commands to generate.