]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- added bcond cryptedpw allowing storing crypted passwd in database (mysql or pgsql)
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 #
2 # TODO:
3 # - add ldap plugin from openldap sources
4 #
5 # Conditional build:
6 %bcond_without  ldap    # disable LDAP support for saslauthd
7 %bcond_without  gssapi  # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql   # don't build MySQL pluggin
9 %bcond_without  pgsql   # do not build PostgreSQL pluggin
10 %bcond_without  sqlite  # do not enable sqlite plugin
11 %bcond_with     cryptedpw # if you keep crypted passwords in your *sql
12 %bcond_with     opie    # enable opie plugin
13 %bcond_with     srp     # build srp pluggin
14 %bcond_with     pwcheck # build pwcheck helper (deprecated)
15 %bcond_with     x509    # build x509 plugin (no sources in package???)
16 #
17 %if !%{with mysql} && !%{with pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl):    Biblioteka Cyrus SASL
23 Summary(pt_BR): Implementação da API SASL
24 Summary(ru):    âÉÂÌÉÏÔÅËÁ Cyrus SASL
25 Summary(uk):    â¦Â̦ÏÔÅËÁ Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.21
28 Release:        2
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
32 # Source0-md5:  dde02db234dea892bee298390890502e
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Patch0:         %{name}-configdir.patch
37 Patch1:         %{name}-nolibs.patch
38 Patch2:         %{name}-lt.patch
39 Patch3:         %{name}-split-sql.patch
40 Patch4:         %{name}-opie.patch
41 Patch5:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch6:         %{name}-cryptedpw.patch
44 URL:            http://asg.web.cmu.edu/sasl/
45 BuildRequires:  autoconf >= 2.54
46 BuildRequires:  automake
47 BuildRequires:  db-devel
48 BuildRequires:  ed
49 BuildRequires:  groff
50 %{?with_gssapi:BuildRequires:   heimdal-devel >= 0.7}
51 BuildRequires:  libtool >= 1.4
52 %{?with_mysql:BuildRequires:    mysql-devel}
53 %{?with_pgsql:BuildRequires:    postgresql-devel}
54 %{?with_ldap:BuildRequires:     openldap-devel}
55 %{?with_sqlite:BuildRequires:   sqlite-devel}
56 %{?with_opie:BuildRequires:     opie-devel}
57 BuildRequires:  openssl-devel >= 0.9.7d
58 BuildRequires:  pam-devel
59 Requires:       pam >= 0.79.0
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %define         _sysconfdir     /etc/sasl
63
64 %description
65 This is an implementation of the SASL API, useful for adding
66 authentication, authorization, and security to network protocols. The
67 SASL protocol itself is documented in rfc2222; the API standard is a
68 work in progress.
69
70 Note: remember to install appropriate plugins, or you won't have any
71 authentication mechanisms available.
72
73 %description -l pl
74 Pakiet cyrus-sasl zawiera implementacjê biblioteki API SASL dla
75 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
76 tak¿e do dodawania uwierzytelniania, autoryzacji oraz zwiêkszania
77 bezpieczeñstwa protoko³ów sieciowych. Sam protokó³ SASL jest opisany w
78 RFC 2222; standaryzacja API jest w toku.
79
80 Uwaga: aby by³y dostêpne jakiekolwiek mechanizmy autoryzacji, nale¿y
81 doinstalowaæ odpowiednie wtyczki.
82
83 %description -l pt_BR
84 Esta é uma implementação da API SASL, útil para acrescentar
85 autenticação, autorização e seguança (criptografia) para protocolos de
86 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
87 ainda está em desenvolvimento.
88
89 %description -l ru
90 ðÁËÅÔ cyrus-sasl ÓÏÄÅÒÖÉÔ ÒÅÁÌÉÚÁÃÉÀ Cyrus SASL. SASL - ÜÔÏ Simple
91 Authentication and Security Layer, ÍÅÔÏÄ ÄÌÑ ÄÏÂÁ×ÌÅÎÉÑ ÐÏÄÄÅÒÖËÉ
92 ÁÕÔÅÎÔÉËÁÃÉÉ Ë ÐÒÏÔÏËÏÌÁÍ, ÏÓÎÏ×ÁÎÎÙÍ ÎÁ ÓÏÅÄÉÎÅÎÉÑÈ.
93
94 %description -l uk
95 ðÁËÅÔ cyrus-sasl Í¦ÓÔÉÔØ ÒÅÁ̦ÚÁæÀ Cyrus SASL. SASL - ÃÅ Simple
96 Authentication and Security Layer, ÍÅÔÏÄ ÄÌÑ ÄÏÄÁÎÎѠЦÄÔÒÉÍËÉ
97 ÁÕÔÅÎÔÉËÁ槠ÄÏ ÐÒÏÔÏËÏ̦×, ÂÁÚÏ×ÁÎÉÈ ÎÁ Ú'¤ÄÎÁÎÎÑÈ.
98
99 %package devel
100 Summary:        Header files and documentation for cyrus-sasl
101 Summary(pl):    Pliki nag³ówkowe i dokumentacja dla cyrus-sasl
102 Summary(pt_BR): Exemplos e arquivos para desenvolvimento com SASL
103 Summary(ru):    æÁÊÌÙ ÄÌÑ ÐÒÏÇÒÁÍÍÉÒÏ×ÁÎÉÑ Ó ÂÉÂÌÉÏÔÅËÏÊ Cyrus SASL
104 Summary(ru):    æÁÊÌÉ ÄÌÑ ÐÒÏÇÒÁÍÕ×ÁÎÎѠڠ¦Â̦ÏÔÅËÏÀ Cyrus SASL
105 Group:          Development/Libraries
106 Requires:       %{name} = %{version}-%{release}
107
108 %description devel
109 This includes the header files and documentation needed to develop
110 applications which use SASL.
111
112 %description devel -l pl
113 Pliki nag³ówkowe i dokumentacja dla cyrus-sasl.
114
115 %description devel -l pt_BR
116 Este pacote inclui os arquivos de cabeçalho e documentação necessários
117 para desenvolver aplicativos que usem SASL.
118
119 %description devel -l ru
120 èÅÄÅÒÙ É ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÉÌÏÖÅÎÉÊ,
121 ÉÓÐÏÌØÚÕÀÝÉÈ Cyrus SASL.
122
123 %description devel -l uk
124 èÅÄÅÒÉ ÔÁ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ
125 ×ÉËÏÒÉÓÔÏ×ÕÀÔØ Cyrus SASL.
126
127 %package static
128 Summary:        Static cyrus-sasl libraries
129 Summary(pl):    Statyczne biblioteki cyrus-sasl
130 Summary(ru):    óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ Cyrus SASL
131 Summary(uk):    óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ Cyrus SASL
132 Group:          Development/Libraries
133 Requires:       %{name}-devel = %{version}-%{release}
134
135 %description static
136 Static cyrus-sasl libraries.
137
138 %description static -l pl
139 Statyczne biblioteki cyrus-sasl.
140
141 %description static -l ru
142 óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÉÌÏÖÅÎÉÊ,
143 ÉÓÐÏÌØÚÕÀÝÉÈ Cyrus SASL.
144
145 %description static -l uk
146 óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ, ÝÏ ×ÉËÏÒÉÓÔÏ×ÕÀÔØ
147 Cyrus SASL.
148
149 %package cram-md5
150 Summary:        Cram-MD5 Cyrus SASL plugin
151 Summary(pl):    Wtyczka Cram-MD5 do Cyrus SASL
152 Summary(pt_BR): Mecanismo SASL CRAM-MD5
153 Group:          Libraries
154 Requires:       %{name} = %{version}-%{release}
155
156 %description cram-md5
157 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
158 mandatory-to-implement authentication mechanism for a number of
159 protocols; it uses MD5 with a challenge/response system to
160 authenticate the user.
161
162 %description cram-md5 -l pl
163 Wtyczka dodaj±ca obs³ugê mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
164 jest obowi±zkowym do zaimplementowania mechanizmem uwierzytelniania
165 dla wielu protoko³ów; do uwierzytelnienia u¿ytkownika u¿ywa MD5 wraz z
166 systemem challenge/response.
167
168 %description cram-md5 -l pt_BR
169 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
170 mecanismo de autenticação obrigatório de ser implementado para vários
171 protocolos: ele usa MD5 com um sistema de desafio/resposta para
172 autenticar o usuário.
173
174 %package digest-md5
175 Summary:        Digest-MD5 Cyrus SASL plugin
176 Summary(pl):    Wtyczka Digest-MD5 do Cyrus SASL
177 Summary(pt_BR): Mecanismo SASL DIGEST-MD5
178 Group:          Libraries
179 Requires:       %{name} = %{version}-%{release}
180
181 %description digest-md5
182 This plugin implements the latest draft of the SASL DIGEST-MD5
183 mechanism. Although not yet finalized, this is likely to become the
184 new mandatory-to-implement authentication system in all new protocols.
185 It's based on the digest md5 authentication system designed for HTTP.
186
187 %description digest-md5 -l pl
188 Wtyczka dodaj±ca najnowsz± wersjê mechanizmu DIGEST-MD5 do Cyrus SASL.
189 Pomimo tego, ¿e nie jest jeszcze ukoñczony, najprawdopodobniej stanie
190 siê obowi±zkowym do zaimplementowania systemem uwierzytelniania we
191 wszystkich nowych protoko³ach. Bazuje na systemie uwierzytelniania
192 Digest-MD5 zaprojektowanym dla HTTP.
193
194 %description digest-md5 -l pt_BR
195 Este plugin implementa a última versão da especificação do mecanismo
196 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
197 provavelmente será o novo sistema de autenticação obrigatório para
198 protocolos novos. Ele é baseado na autenticação md5 digest
199 desenvolvida para HTTP.
200
201 %package plain
202 Summary:        Plain Cyrus SASL plugin
203 Summary(pl):    Wtyczka plain do Cyrus SASL
204 Summary(pt_BR): Mecanismo SASL PLAIN
205 Group:          Libraries
206 Requires:       %{name} = %{version}-%{release}
207
208 %description plain
209 This plugin implements the SASL PLAIN mechanism. Although insecure,
210 PLAIN is useful for transitioning to new security mechanisms, as this
211 is the only mechanism which gives the server a copy of the user's
212 password.
213
214 %description plain -l pl
215 Wtyczka dodaj±ca obs³ugê mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
216 ¿e nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
217 nowe mechanizmu bezpieczeñstwa, jako ¿e jest to jedyny mechanizm,
218 który udostêpnia serwerowi kopiê has³a u¿ytkownika.
219
220 %description plain -l pt_BR
221 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
222 mecanismo é útil durante transições para novos mecanismos de
223 segurança, pois é o único esquema que fornece uma cópia da senha do
224 usuário para o servidor.
225
226 %package anonymous
227 Summary:        Anonymous Cyrus SASL plugin
228 Summary(pl):    Wtyczka anonymous do Cyrus SASL
229 Summary(pt_BR): Mecanismo SASL ANONYMOUS
230 Group:          Libraries
231 Requires:       %{name} = %{version}-%{release}
232
233 %description anonymous
234 This plugin implements the SASL ANONYMOUS mechanism, used for
235 anonymous authentication.
236
237 %description anonymous -l pl
238 Wtyczka dodaj±ca obs³ugê mechanizmu ANONYMOUS do Cyrus SASL. S³u¿y do
239 anonimowego uwierzytelniania.
240
241 %description anonymous -l pt_BR
242 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
243 autenticação anônima.
244
245 %package gssapi
246 Summary:        GSSAPI Cyrus SASL plugin
247 Summary(pl):    Wtyczka GSSAPI do Cyrus SASL
248 Summary(pt_BR): Mecanismo SASL GSSAPI
249 Group:          Libraries
250 Requires:       %{name} = %{version}-%{release}
251
252 %description gssapi
253 This plugin implements the SASL GSSAPI mechanism, used for
254 GSSAPI/Kerberos5 authentication.
255
256 %description gssapi -l pl
257 Wtyczka dodaj±ca obs³ugê mechanizmu SASL GSSAPI, u¿ywanego do
258 uwierzytelniania z u¿yciem GSSAPI/Kerberos5.
259
260 %description gssapi -l pt_BR
261 Este plugin implementa o mecanismo SASL GSSAPI, usado para
262 autenticação Kerberos/GSSAPI.
263
264 %package login
265 Summary:        Unsupported Login Cyrus SASL plugin
266 Summary(pl):    Nie wspierana wtyczka Login do Cyrus SASL
267 Group:          Libraries
268 Requires:       %{name} = %{version}-%{release}
269
270 %description login
271 Unsupported LOGIN Cyrus SASL plugin.
272
273 %description login -l pl
274 Wtyczka dodaj±ca obs³ugê nie wspieranego mechanizmu LOGIN do Cyrus
275 SASL.
276
277 %package srp
278 Summary:        SRP Cyrus SASL plugin
279 Summary(pl):    Wtyczka SRP do Cyrus SASL
280 Summary(pt_BR): Mecanismo SASL SRP
281 Group:          Libraries
282 Requires:       %{name} = %{version}-%{release}
283
284 %description srp
285 This plugin implements the SASL SRP mechanism, based on the Secure
286 Remote Password protocol. This mechanism performs mutual
287 authentication and can provide a security layer with replay detection,
288 integrity protection and/or condifentiality protection.
289
290 %description srp -l pl
291 Wtyczka dodaj±ca obs³ugê mechanizmu SRP do Cyrus SASL. Bazuje na
292 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
293 uwierzytelnienia i mo¿e dodawaæ warstwê bezpieczeñstwa z wykrywaniem
294 powtarzania, zabezpieczeniem integralno¶ci i/lub poufno¶ci.
295
296 %description srp -l pt_BR
297 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
298 (Secure Remote Password). Este mecanismo oferece autenticação mútua
299 (do cliente e do servidor) e pode prover uma camada de segurança com
300 detecção de ataques de replay, garantia de integridade e/ou
301 confidencialidade.
302
303 %package otp
304 Summary:        OTP Cyrus SASL plugin
305 Summary(pl):    Wtyczka OTP do Cyrus SASL
306 Summary(pt_BR): Mecanismo SASL OTP
307 Group:          Libraries
308 Requires:       %{name} = %{version}-%{release}
309
310 %description otp
311 This plugin implements the SASL OTP (One Time Password) mechanism.
312
313 %description otp -l pl
314 Wtyczka dodaj±ca obs³ugê mechanizmu OTP (has³a jednorazowe) do Cyrus
315 SASL.
316
317 %package opie
318 Summary:        OPIE Cyrus SASL plugin
319 Summary(pl):    Wtyczka OPIE do Cyrus SASL
320 Summary(pt_BR): Mecanismo SASL OPIE
321 Group:          Libraries
322 Requires:       %{name} = %{version}-%{release}
323
324 %description opie
325 This plugin implements the SASL OPIE (One Time Password) mechanism.
326
327 %description opie -l pl
328 Wtyczka dodaj±ca obs³ugê mechanizmu OPIE (has³a jednorazowe) do Cyrus
329 SASL.
330
331 %package x509
332 Summary:        x509 Cyrus SASL plugin
333 Summary(pl):    Wtyczka x509 do Cyrus SASL
334 Group:          Libraries
335 Requires:       %{name} = %{version}-%{release}
336
337 %description x509
338 x509 Cyrus SASL plugin.
339
340 %description x509 -l pl
341 Wtyczka x509 do Cyrus SASL.
342
343 %package saslauthd
344 Summary:        Cyrus SASL authd
345 Summary(pl):    Demon authd do Cyrus SASL
346 Group:          Daemons
347 Requires(post,postun):  /sbin/chkconfig
348 Requires:       %{name} = %{version}-%{release}
349
350 %description saslauthd
351 Cyrus SASL authd.
352
353 %description saslauthd -l pl
354 Demon authd do Cyrus SASL.
355
356 %package pwcheck
357 Summary:        Cyrus SASL pwcheck helper
358 Summary(pl):    Program pomocniczy pwcheck do Cyrus SASL
359 Group:          Libraries
360 Requires:       %{name} = %{version}-%{release}
361
362 %description pwcheck
363 Cyrus SASL pwcheck helper.
364
365 %description pwcheck -l pl
366 Program pomocniczy pwcheck do Cyrus SASL.
367
368 %package sasldb
369 Summary:        Cyrus SASL sasldb plugin
370 Summary(pl):    Wtyczka sasldb do Cyrus SASL
371 Group:          Libraries
372 Requires:       %{name} = %{version}-%{release}
373
374 %description sasldb
375 Cyrus SASL sasldb plugin.
376
377 %description sasldb -l pl
378 Wtyczka sasldb do Cyrus SASL.
379
380 %package mysql
381 Summary:        Cyrus SASL MySQL plugin
382 Summary(pl):    Wtyczka MySQL do Cyrus SASL
383 Group:          Libraries
384 Requires:       %{name} = %{version}-%{release}
385
386 %description mysql
387 Cyrus SASL MySQL plugin.
388
389 %description mysql -l pl
390 Wtyczka MySQL do Cyrus SASL.
391
392 %package pgsql
393 Summary:        Cyrus SASL PostgreSQL plugin
394 Summary(pl):    Wtyczka PostgreSQL do Cyrus SASL
395 Group:          Libraries
396 Requires:       %{name} = %{version}-%{release}
397
398 %description pgsql
399 Cyrus SASL PostgreSQL plugin.
400
401 %description pgsql -l pl
402 Wtyczka PostgreSQL do Cyrus SASL.
403
404 %package sqlite
405 Summary:        Cyrus SQLite PostgreSQL plugin
406 Summary(pl):    Wtyczka SQLite do Cyrus SASL
407 Group:          Libraries
408 Requires:       %{name} = %{version}-%{release}
409
410 %description sqlite
411 Cyrus SASL SQLite plugin.
412
413 %description sqlite -l pl
414 Wtyczka SQLite do Cyrus SASL.
415
416 %prep
417 %setup -q
418 %patch0 -p1
419 %patch1 -p1
420 %patch2 -p1
421 %patch3 -p1
422 %patch4 -p1
423 %patch5 -p1
424 %if %{with cryptedpw}
425 %patch6 -p1
426 %endif
427
428 cd doc
429 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
430 ls rfc*.txt >> rfc-compliance
431 rm -f rfc*.txt
432 cd ..
433
434 rm -rf autom4te.cache saslauthd/autom4te.cache
435 # acinclude.m4 contains only old libtool.m4
436 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
437
438 %build
439 %{__libtoolize}
440 %{__aclocal} -I cmulocal -I config
441 %{__autoheader}
442 %{__automake}
443 %{__autoconf}
444
445 cd saslauthd
446 %{__libtoolize}
447 %{__aclocal} -I ../cmulocal -I ../config -I config
448 %{__autoheader}
449 %{__automake}
450 %{__autoconf}
451 cd ..
452
453 %configure \
454         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
455         --disable-krb4 \
456         %{!?with_gssapi: --disable-gssapi} \
457         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
458         --enable-login \
459         --enable-sql \
460         %{?with_srp: --enable-srp} \
461         --enable-static \
462         --with-plugindir=%{_libdir}/sasl2 \
463         --with-configdir=%{_sysconfdir} \
464         --with-dblib=berkeley \
465         --with-dbpath=/var/lib/sasl2/sasl.db \
466         %{?with_ldap: --with-ldap=%{_prefix}} \
467         %{?with_mysql: --with-mysql=%{_prefix}} \
468         %{?with_pgsql: --with-pgsql=%{_prefix}} \
469         %{?with_sqlite: --with-sqlite=%{_prefix}} \
470         %{?with_opie: --with-opie=%{_prefix}} \
471         --with-pam \
472         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
473         --with-saslauthd=/var/lib/sasl2
474 %{__make}
475
476 %{__make} -C saslauthd testsaslauthd
477 %{__make} -C saslauthd saslcache
478
479 cd doc
480 RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
481 for i in $RFCLIST; do
482         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
483         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
484 done
485
486 %install
487 rm -rf $RPM_BUILD_ROOT
488 install -d $RPM_BUILD_ROOT{/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
489                 $RPM_BUILD_ROOT%{_mandir}/man8
490
491 %{__make} install \
492         sasldir=%{_libdir}/sasl2 \
493         DESTDIR=$RPM_BUILD_ROOT
494
495 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
496 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
497
498 install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
499 install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
500
501 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
502
503 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
504
505 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
506 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
507 install %{SOURCE3} ./cyrus.pam
508
509 install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
510
511 %clean
512 rm -rf $RPM_BUILD_ROOT
513
514 %post   -p /sbin/ldconfig
515 %postun -p /sbin/ldconfig
516
517 %post saslauthd
518 /sbin/chkconfig --add saslauthd
519 if [ -f /var/lock/subsys/saslauthd ]; then
520         /etc/rc.d/init.d/saslauthd restart 1>&2
521 else
522         echo "Run \"/etc/rc.d/init.d/saslauthd start\" to start saslauthd."
523 fi
524
525 %preun saslauthd
526 if [ "$1" = "0" ]; then
527         if [ -f /var/lock/subsys/saslauthd ]; then
528                 /etc/rc.d/init.d/saslauthd stop 1>&2
529         fi
530         /sbin/chkconfig --del saslauthd
531 fi
532
533 %files
534 %defattr(644,root,root,755)
535 %doc AUTHORS COPYING ChangeLog NEWS README
536 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
537 %dir %{_sysconfdir}
538 %dir %{_libdir}/sasl2
539 %dir /var/lib/sasl2
540 %attr(755,root,root) %{_libdir}/lib*.so.*.*
541 %attr(755,root,root) %{_sbindir}/sasldblistusers2
542 %attr(755,root,root) %{_sbindir}/saslpasswd2
543
544 %attr(640,root,mail) %ghost %config(noreplace) %verify(not mtime md5 size) /var/lib/sasl2/sasl.db
545 %{_mandir}/man8/sasldblistusers2.*
546 %{_mandir}/man8/saslpasswd2.*
547
548 %files devel
549 %defattr(644,root,root,755)
550 %{_includedir}/sasl
551 %attr(755,root,root) %{_libdir}/lib*.so
552 %{_libdir}/lib*.la
553 %{_mandir}/man3/*
554
555 %files static
556 %defattr(644,root,root,755)
557 %{_libdir}/lib*.a
558
559 %files anonymous
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
562
563 %if %{with gssapi}
564 %files gssapi
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
567 %endif
568
569 %files cram-md5
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
572
573 %files digest-md5
574 %defattr(644,root,root,755)
575 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
576
577 %files login
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
580
581 %files otp
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
584
585 %if %{with opie}
586 %files opie
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
589 %endif
590
591 %files plain
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
594
595 %files sasldb
596 %defattr(644,root,root,755)
597 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
598
599 %if %{with mysql}
600 %files mysql
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
603 %endif
604
605 %if %{with pgsql}
606 %files pgsql
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
609 %endif
610
611 %if %{with sqlite}
612 %files sqlite
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
615 %endif
616
617 %if %{with srp}
618 %files srp
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
621 %endif
622
623 %if %{with x509}
624 %files x509
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
627 %endif
628
629 %if %{with pwcheck}
630 %files pwcheck
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_sbindir}/pwcheck
633 %endif
634
635 %files saslauthd
636 %defattr(644,root,root,755)
637 %doc cyrus.pam
638 %attr(755,root,root) %{_sbindir}/saslauthd
639 %attr(755,root,root) %{_sbindir}/testsaslauthd
640 %attr(755,root,root) %{_sbindir}/saslcache
641 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
642 %config(noreplace) %verify(not mtime md5 size) /etc/sysconfig/saslauthd
643 %{_mandir}/man8/saslauthd.*
This page took 0.082184 seconds and 4 git commands to generate.