]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
e6dd59e33eb46c7d6f61272907e32479e047ea5b
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # enable opie plugin
13 %bcond_with     srp             # build srp pluggin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 %bcond_with     x509            # build x509 plugin (no sources in package???)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.23
28 Release:        6
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
32 # Source0-md5:  2eb0e48106f0e9cd8001e654f267ecbc
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-db.patch
46 Patch8:         %{name}-automake_1_10.patch
47 Patch9:         %{name}-digest-commas.patch
48 Patch10:        %{name}-keytab.patch
49 Patch11:        %{name}-sizes.patch
50 Patch12:        %{name}-nagios-plugin.patch
51 Patch13:        %{name}-parallel-make.patch
52 Patch14:        %{name}-gssapi-detect.patch
53 URL:            http://asg.web.cmu.edu/sasl/
54 BuildRequires:  autoconf >= 2.54
55 BuildRequires:  automake >= 1:1.7
56 %{?with_authlib:BuildRequires:  courier-authlib-devel}
57 BuildRequires:  db-devel
58 BuildRequires:  ed
59 BuildRequires:  groff
60 %{?with_gssapi:BuildRequires:   heimdal-devel}
61 BuildRequires:  libtool >= 1.4
62 %{?with_mysql:BuildRequires:    mysql-devel}
63 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
64 BuildRequires:  openssl-devel >= 0.9.7d
65 %{?with_opie:BuildRequires:     opie-devel}
66 BuildRequires:  pam-devel
67 %{?with_pgsql:BuildRequires:    postgresql-devel}
68 BuildRequires:  rpmbuild(macros) >= 1.268
69 %{?with_sqlite:BuildRequires:   sqlite-devel}
70 Requires:       pam >= 0.79.0
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %define         _sysconfdir     /etc/sasl
74
75 %define         specflags       -fno-strict-aliasing
76
77 %description
78 This is an implementation of the SASL API, useful for adding
79 authentication, authorization, and security to network protocols. The
80 SASL protocol itself is documented in rfc2222; the API standard is a
81 work in progress.
82
83 Note: remember to install appropriate plugins, or you won't have any
84 authentication mechanisms available.
85
86 %description -l pl.UTF-8
87 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
88 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
89 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
90 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
91 RFC 2222; standaryzacja API jest w toku.
92
93 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
94 doinstalować odpowiednie wtyczki.
95
96 %description -l pt_BR.UTF-8
97 Esta é uma implementação da API SASL, útil para acrescentar
98 autenticação, autorização e seguança (criptografia) para protocolos de
99 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
100 ainda está em desenvolvimento.
101
102 %description -l ru.UTF-8
103 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
104 Authentication and Security Layer, метод для добавления поддержки
105 аутентикации к протоколам, основанным на соединениях.
106
107 %description -l uk.UTF-8
108 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
109 Authentication and Security Layer, метод для додання підтримки
110 аутентикації до протоколів, базованих на з'єднаннях.
111
112 %package devel
113 Summary:        Header files and documentation for cyrus-sasl
114 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
115 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
116 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
117 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
118 Group:          Development/Libraries
119 Requires:       %{name} = %{version}-%{release}
120
121 %description devel
122 This includes the header files and documentation needed to develop
123 applications which use SASL.
124
125 %description devel -l pl.UTF-8
126 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
127
128 %description devel -l pt_BR.UTF-8
129 Este pacote inclui os arquivos de cabeçalho e documentação necessários
130 para desenvolver aplicativos que usem SASL.
131
132 %description devel -l ru.UTF-8
133 Хедеры и библиотеки, необходимые для разработки приложений,
134 использующих Cyrus SASL.
135
136 %description devel -l uk.UTF-8
137 Хедери та бібліотеки, необхідні для розробки програм, що
138 використовують Cyrus SASL.
139
140 %package static
141 Summary:        Static cyrus-sasl libraries
142 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
143 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
144 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
145 Group:          Development/Libraries
146 Requires:       %{name}-devel = %{version}-%{release}
147
148 %description static
149 Static cyrus-sasl libraries.
150
151 %description static -l pl.UTF-8
152 Statyczne biblioteki cyrus-sasl.
153
154 %description static -l ru.UTF-8
155 Статические библиотеки, необходимые для разработки приложений,
156 использующих Cyrus SASL.
157
158 %description static -l uk.UTF-8
159 Статичні бібліотеки, необхідні для розробки програм, що використовують
160 Cyrus SASL.
161
162 %package cram-md5
163 Summary:        Cram-MD5 Cyrus SASL plugin
164 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
165 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
166 Group:          Libraries
167 Requires:       %{name} = %{version}-%{release}
168
169 %description cram-md5
170 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
171 mandatory-to-implement authentication mechanism for a number of
172 protocols; it uses MD5 with a challenge/response system to
173 authenticate the user.
174
175 %description cram-md5 -l pl.UTF-8
176 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
177 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
178 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
179 systemem challenge/response.
180
181 %description cram-md5 -l pt_BR.UTF-8
182 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
183 mecanismo de autenticação obrigatório de ser implementado para vários
184 protocolos: ele usa MD5 com um sistema de desafio/resposta para
185 autenticar o usuário.
186
187 %package digest-md5
188 Summary:        Digest-MD5 Cyrus SASL plugin
189 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
190 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
191 Group:          Libraries
192 Requires:       %{name} = %{version}-%{release}
193
194 %description digest-md5
195 This plugin implements the latest draft of the SASL DIGEST-MD5
196 mechanism. Although not yet finalized, this is likely to become the
197 new mandatory-to-implement authentication system in all new protocols.
198 It's based on the digest md5 authentication system designed for HTTP.
199
200 %description digest-md5 -l pl.UTF-8
201 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
202 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
203 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
204 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
205 Digest-MD5 zaprojektowanym dla HTTP.
206
207 %description digest-md5 -l pt_BR.UTF-8
208 Este plugin implementa a última versão da especificação do mecanismo
209 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
210 provavelmente será o novo sistema de autenticação obrigatório para
211 protocolos novos. Ele é baseado na autenticação md5 digest
212 desenvolvida para HTTP.
213
214 %package plain
215 Summary:        Plain Cyrus SASL plugin
216 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
217 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
218 Group:          Libraries
219 Requires:       %{name} = %{version}-%{release}
220
221 %description plain
222 This plugin implements the SASL PLAIN mechanism. Although insecure,
223 PLAIN is useful for transitioning to new security mechanisms, as this
224 is the only mechanism which gives the server a copy of the user's
225 password.
226
227 %description plain -l pl.UTF-8
228 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
229 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
230 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
231 który udostępnia serwerowi kopię hasła użytkownika.
232
233 %description plain -l pt_BR.UTF-8
234 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
235 mecanismo é útil durante transições para novos mecanismos de
236 segurança, pois é o único esquema que fornece uma cópia da senha do
237 usuário para o servidor.
238
239 %package anonymous
240 Summary:        Anonymous Cyrus SASL plugin
241 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
242 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
243 Group:          Libraries
244 Requires:       %{name} = %{version}-%{release}
245
246 %description anonymous
247 This plugin implements the SASL ANONYMOUS mechanism, used for
248 anonymous authentication.
249
250 %description anonymous -l pl.UTF-8
251 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
252 anonimowego uwierzytelniania.
253
254 %description anonymous -l pt_BR.UTF-8
255 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
256 autenticação anônima.
257
258 %package gssapi
259 Summary:        GSSAPI Cyrus SASL plugin
260 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
261 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
262 Group:          Libraries
263 Requires:       %{name} = %{version}-%{release}
264
265 %description gssapi
266 This plugin implements the SASL GSSAPI mechanism, used for
267 GSSAPI/Kerberos5 authentication.
268
269 %description gssapi -l pl.UTF-8
270 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
271 uwierzytelniania z użyciem GSSAPI/Kerberos5.
272
273 %description gssapi -l pt_BR.UTF-8
274 Este plugin implementa o mecanismo SASL GSSAPI, usado para
275 autenticação Kerberos/GSSAPI.
276
277 %package login
278 Summary:        Unsupported Login Cyrus SASL plugin
279 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
280 Group:          Libraries
281 Requires:       %{name} = %{version}-%{release}
282
283 %description login
284 Unsupported LOGIN Cyrus SASL plugin.
285
286 %description login -l pl.UTF-8
287 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
288 SASL.
289
290 %package srp
291 Summary:        SRP Cyrus SASL plugin
292 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
293 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
294 Group:          Libraries
295 Requires:       %{name} = %{version}-%{release}
296
297 %description srp
298 This plugin implements the SASL SRP mechanism, based on the Secure
299 Remote Password protocol. This mechanism performs mutual
300 authentication and can provide a security layer with replay detection,
301 integrity protection and/or condifentiality protection.
302
303 %description srp -l pl.UTF-8
304 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
305 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
306 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
307 powtarzania, zabezpieczeniem integralności i/lub poufności.
308
309 %description srp -l pt_BR.UTF-8
310 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
311 (Secure Remote Password). Este mecanismo oferece autenticação mútua
312 (do cliente e do servidor) e pode prover uma camada de segurança com
313 detecção de ataques de replay, garantia de integridade e/ou
314 confidencialidade.
315
316 %package otp
317 Summary:        OTP Cyrus SASL plugin
318 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
319 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
320 Group:          Libraries
321 Requires:       %{name} = %{version}-%{release}
322
323 %description otp
324 This plugin implements the SASL OTP (One Time Password) mechanism.
325
326 %description otp -l pl.UTF-8
327 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
328 SASL.
329
330 %package opie
331 Summary:        OPIE Cyrus SASL plugin
332 Summary(pl.UTF-8):      Wtyczka OPIE do Cyrus SASL
333 Summary(pt_BR.UTF-8):   Mecanismo SASL OPIE
334 Group:          Libraries
335 Requires:       %{name} = %{version}-%{release}
336
337 %description opie
338 This plugin implements the SASL OPIE (One Time Password) mechanism.
339
340 %description opie -l pl.UTF-8
341 Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
342 SASL.
343
344 %package x509
345 Summary:        x509 Cyrus SASL plugin
346 Summary(pl.UTF-8):      Wtyczka x509 do Cyrus SASL
347 Group:          Libraries
348 Requires:       %{name} = %{version}-%{release}
349
350 %description x509
351 x509 Cyrus SASL plugin.
352
353 %description x509 -l pl.UTF-8
354 Wtyczka x509 do Cyrus SASL.
355
356 %package saslauthd
357 Summary:        Cyrus SASL authd
358 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
359 Group:          Daemons
360 Requires(post,preun):   /sbin/chkconfig
361 Requires:       %{name} = %{version}-%{release}
362 Requires:       /sbin/chkconfig
363 Requires:       rc-scripts
364
365 %description saslauthd
366 Cyrus SASL authd.
367
368 %description saslauthd -l pl.UTF-8
369 Demon authd do Cyrus SASL.
370
371 %package pwcheck
372 Summary:        Cyrus SASL pwcheck helper
373 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
374 Group:          Libraries
375 Requires:       %{name} = %{version}-%{release}
376
377 %description pwcheck
378 Cyrus SASL pwcheck helper.
379
380 %description pwcheck -l pl.UTF-8
381 Program pomocniczy pwcheck do Cyrus SASL.
382
383 %package sasldb
384 Summary:        Cyrus SASL sasldb plugin
385 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
386 Group:          Libraries
387 Requires:       %{name} = %{version}-%{release}
388
389 %description sasldb
390 Cyrus SASL sasldb plugin.
391
392 %description sasldb -l pl.UTF-8
393 Wtyczka sasldb do Cyrus SASL.
394
395 %package mysql
396 Summary:        Cyrus SASL MySQL plugin
397 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
398 Group:          Libraries
399 Requires:       %{name} = %{version}-%{release}
400
401 %description mysql
402 Cyrus SASL MySQL plugin.
403
404 %description mysql -l pl.UTF-8
405 Wtyczka MySQL do Cyrus SASL.
406
407 %package pgsql
408 Summary:        Cyrus SASL PostgreSQL plugin
409 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
410 Group:          Libraries
411 Requires:       %{name} = %{version}-%{release}
412
413 %description pgsql
414 Cyrus SASL PostgreSQL plugin.
415
416 %description pgsql -l pl.UTF-8
417 Wtyczka PostgreSQL do Cyrus SASL.
418
419 %package sqlite
420 Summary:        Cyrus SQLite PostgreSQL plugin
421 Summary(pl.UTF-8):      Wtyczka SQLite do Cyrus SASL
422 Group:          Libraries
423 Requires:       %{name} = %{version}-%{release}
424
425 %description sqlite
426 Cyrus SASL SQLite plugin.
427
428 %description sqlite -l pl.UTF-8
429 Wtyczka SQLite do Cyrus SASL.
430
431 %package -n nagios-plugin-check_saslauthd
432 Summary:        Nagios plugin to check health of saslauthd
433 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
434 Group:          Networking
435 Requires:       nagios-core
436
437 %description -n nagios-plugin-check_saslauthd
438 Nagios plugin to check health of saslauthd.
439
440 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
441 Wtyczka Nagiosa do sprawdzania działania saslauthd.
442
443 %prep
444 %setup -q
445 %patch0 -p1
446 %patch1 -p1
447 %patch2 -p1
448 %patch3 -p1
449 %patch4 -p1
450 %if %{with cryptedpw}
451 %patch5 -p1
452 %patch6 -p1
453 %endif
454 %patch7 -p1
455 %patch8 -p1
456 %patch9 -p2
457 %patch10 -p1
458 %patch11 -p1
459 %patch12 -p1
460 %patch13 -p1
461 %patch14 -p1
462
463 cd doc
464 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
465 ls rfc*.txt >> rfc-compliance
466 rm -f rfc*.txt
467 cd ..
468
469 rm -rf autom4te.cache saslauthd/autom4te.cache
470 # acinclude.m4 contains only old libtool.m4
471 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
472
473 %build
474 %{__libtoolize}
475 %{__aclocal} -I cmulocal -I config
476 %{__autoheader}
477 %{__automake}
478 %{__autoconf}
479
480 cd saslauthd
481 %{__libtoolize}
482 %{__aclocal} -I ../cmulocal -I ../config -I config
483 %{__autoheader}
484 %{__automake}
485 %{__autoconf}
486 cd ..
487
488 %configure \
489         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
490         --disable-krb4 \
491         %{!?with_gssapi: --disable-gssapi} \
492         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
493         --enable-login \
494         --enable-sample \
495         --enable-httpform \
496         --enable-sql \
497         %{?with_srp: --enable-srp} \
498         --enable-static \
499         --with-plugindir=%{_libdir}/sasl2 \
500         --with-configdir=%{_sysconfdir} \
501         --with-dblib=berkeley \
502         --with-dbpath=/var/lib/sasl2/sasl.db \
503         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
504         %{?with_ldap: --with-ldap=%{_prefix}} \
505         %{?with_mysql: --with-mysql=%{_prefix}} \
506         %{?with_pgsql: --with-pgsql=%{_prefix}} \
507         %{?with_sqlite: --with-sqlite=%{_prefix}} \
508         %{?with_opie: --with-opie=%{_prefix}} \
509         --with-pam \
510         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
511         --with-saslauthd=/var/lib/sasl2
512 %{__make}
513
514 %{__make} -C saslauthd testsaslauthd
515 %{__make} -C saslauthd saslcache
516 %{__make} -C sample sample-client sample-server
517
518 cd doc
519 RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
520 for i in $RFCLIST; do
521         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
522         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
523 done
524
525 %install
526 rm -rf $RPM_BUILD_ROOT
527 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
528                 $RPM_BUILD_ROOT%{_mandir}/man8
529
530 %{__make} install \
531         sasldir=%{_libdir}/sasl2 \
532         DESTDIR=$RPM_BUILD_ROOT
533
534 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
535 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
536
537 install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
538 install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
539
540 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
541
542 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
543
544 # create empty config
545 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
546 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
547 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
548 install %{SOURCE3} cyrus.pam
549
550 install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
551
552 # sample programs for testing sasl
553 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
554 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
555
556 # package for ghost
557 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
558
559 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
560 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
561
562 %clean
563 rm -rf $RPM_BUILD_ROOT
564
565 %post   -p /sbin/ldconfig
566 %postun -p /sbin/ldconfig
567
568 %post saslauthd
569 /sbin/chkconfig --add saslauthd
570 %service saslauthd restart
571
572 %preun saslauthd
573 if [ "$1" = "0" ]; then
574         %service saslauthd stop
575         /sbin/chkconfig --del saslauthd
576 fi
577
578 %files
579 %defattr(644,root,root,755)
580 %doc AUTHORS COPYING ChangeLog NEWS README
581 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
582 %dir %{_sysconfdir}
583 %dir %{_libdir}/sasl2
584 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
585 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
586 # sample programs to subpackage instead?
587 %attr(755,root,root) %{_bindir}/sasl-sample-client
588 %attr(755,root,root) %{_bindir}/sasl-sample-server
589 %attr(755,root,root) %{_sbindir}/pluginviewer
590 %attr(755,root,root) %{_sbindir}/sasldblistusers2
591 %attr(755,root,root) %{_sbindir}/saslpasswd2
592 %dir /var/lib/sasl2
593 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
594 %{_mandir}/man8/pluginviewer.8*
595 %{_mandir}/man8/sasldblistusers2.8*
596 %{_mandir}/man8/saslpasswd2.8*
597
598 %files devel
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_libdir}/libsasl2.so
601 %attr(755,root,root) %{_libdir}/libsasl.so
602 %{_libdir}/libsasl2.la
603 %{_includedir}/sasl
604 %{_mandir}/man3/sasl*.3*
605
606 %files static
607 %defattr(644,root,root,755)
608 %{_libdir}/libsasl2.a
609
610 %files anonymous
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
613
614 %if %{with gssapi}
615 %files gssapi
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
618 %endif
619
620 %files cram-md5
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
623
624 %files digest-md5
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
627
628 %files login
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
631
632 %files otp
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
635
636 %if %{with opie}
637 %files opie
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
640 %endif
641
642 %files plain
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
645
646 %files sasldb
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
649
650 %if %{with mysql}
651 %files mysql
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
654 %endif
655
656 %if %{with pgsql}
657 %files pgsql
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
660 %endif
661
662 %if %{with sqlite}
663 %files sqlite
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
666 %endif
667
668 %if %{with srp}
669 %files srp
670 %defattr(644,root,root,755)
671 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
672 %endif
673
674 %if %{with x509}
675 %files x509
676 %defattr(644,root,root,755)
677 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
678 %endif
679
680 %if %{with pwcheck}
681 %files pwcheck
682 %defattr(644,root,root,755)
683 %attr(755,root,root) %{_sbindir}/pwcheck
684 %endif
685
686 %files saslauthd
687 %defattr(644,root,root,755)
688 %doc cyrus.pam
689 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
690 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
691 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
692 %attr(755,root,root) %{_sbindir}/saslauthd
693 %attr(755,root,root) %{_sbindir}/testsaslauthd
694 %attr(755,root,root) %{_sbindir}/saslcache
695 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
696 %ghost /var/lib/sasl2/cache.flock
697 %ghost /var/lib/sasl2/cache.mmap
698 %ghost /var/lib/sasl2/mux
699 %ghost /var/lib/sasl2/mux.accept
700 %ghost /var/lib/sasl2/saslauthd.pid
701 %{_mandir}/man8/saslauthd.8*
702
703 %files -n nagios-plugin-check_saslauthd
704 %defattr(644,root,root,755)
705 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
706 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.089768 seconds and 2 git commands to generate.