]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
CVE-2013-4122 cyrus-sasl: NULL pointer dereference (DoS)
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 #
2 # Conditional build:
3 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
4 %bcond_without  ldap            # disable LDAP support for saslauthd
5 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
6 %bcond_without  mysql           # don't build MySQL pluggin
7 %bcond_without  pgsql           # do not build PostgreSQL pluggin
8 %bcond_without  sqlite          # do not enable sqlite 2 plugin
9 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
10 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
11 %bcond_with     opie            # OTP plugin using opie library instead of internal code
12 %bcond_with     srp             # build srp plugin
13 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
14 #
15 %if %{without mysql} && %{without pgsql}
16 %undefine with_cryptedpw
17 %endif
18
19 Summary:        The SASL library API for the Cyrus mail system
20 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
21 Summary(pt_BR.UTF-8):   Implementação da API SASL
22 Summary(ru.UTF-8):      Библиотека Cyrus SASL
23 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
24 Name:           cyrus-sasl
25 Version:        2.1.26
26 Release:        2
27 License:        distributable
28 Group:          Libraries
29 Source0:        ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
30 # Source0-md5:  a7f4e5e559a0e37b3ffc438c9456e425
31 Source1:        saslauthd.init
32 Source2:        saslauthd.sysconfig
33 Source3:        %{name}.pam
34 Source4:        check_saslauthd.cfg
35 Patch0:         %{name}-nolibs.patch
36 Patch1:         %{name}-lt.patch
37 Patch2:         %{name}-split-sql.patch
38 Patch3:         %{name}-opie.patch
39 Patch4:         %{name}-gcc4.patch
40 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
41 Patch5:         %{name}-cryptedpw.patch
42 Patch6:         %{name}-md5sum-passwords.patch
43 Patch7:         %{name}-db.patch
44 Patch8:         %{name}-keytab.patch
45 Patch9:         %{name}-sizes.patch
46 Patch10:        %{name}-nagios-plugin.patch
47 Patch11:        %{name}-parallel-make.patch
48 Patch12:        %{name}-gssapi-detect.patch
49 Patch13:        %{name}-saslauthd-httpform-urlescape.patch
50 Patch14:        %{name}-ac-libs.patch
51 Patch15:        %{name}-pam.patch
52 Patch16:        %{name}-gssapi_ext.patch
53 Patch17:        0032-revert_1.103_revision_to_unbreak_GSSAPI.patch
54 Patch18:        0033-fix_segfault_in_GSSAPI.patch
55 Patch19:        0034-fix_dovecot_authentication.patch
56 Patch20:        %{name}-auxprop.patch
57 Patch21:        0030-dont_use_la_files_for_opening_plugins.patch
58 Patch22:        %{name}-stddef.patch
59 Patch23:        http://sourceforge.net/projects/miscellaneouspa/files/glibc217/cyrus-sasl-2.1.26-glibc217-crypt.diff
60 URL:            http://asg.web.cmu.edu/sasl/
61 BuildRequires:  autoconf >= 2.54
62 BuildRequires:  automake >= 1:1.7
63 %{?with_authlib:BuildRequires:  courier-authlib-devel}
64 BuildRequires:  db-devel
65 BuildRequires:  ed
66 BuildRequires:  groff
67 %{?with_gssapi:BuildRequires:   heimdal-devel}
68 BuildRequires:  libtool >= 1.4
69 %{?with_mysql:BuildRequires:    mysql-devel}
70 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
71 BuildRequires:  openssl-devel >= 0.9.7d
72 %{?with_opie:BuildRequires:     opie-devel}
73 BuildRequires:  pam-devel
74 %{?with_pgsql:BuildRequires:    postgresql-devel}
75 BuildRequires:  rpmbuild(macros) >= 1.268
76 %{?with_sqlite:BuildRequires:   sqlite-devel}
77 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
78 Requires:       pam >= 0.79.0
79 Requires:       %{name}-libs = %{version}-%{release}
80 Obsoletes:      cyrus-sasl-x509 < %{version}
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %define         _sysconfdir     /etc/sasl
84
85 %define         specflags       -fno-strict-aliasing
86
87 %description
88 This is an implementation of the SASL API, useful for adding
89 authentication, authorization, and security to network protocols. The
90 SASL protocol itself is documented in rfc2222; the API standard is a
91 work in progress.
92
93 Note: remember to install appropriate plugins, or you won't have any
94 authentication mechanisms available.
95
96 %description -l pl.UTF-8
97 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
98 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
99 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
100 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
101 RFC 2222; standaryzacja API jest w toku.
102
103 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
104 doinstalować odpowiednie wtyczki.
105
106 %description -l pt_BR.UTF-8
107 Esta é uma implementação da API SASL, útil para acrescentar
108 autenticação, autorização e seguança (criptografia) para protocolos de
109 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
110 ainda está em desenvolvimento.
111
112 %description -l ru.UTF-8
113 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
114 Authentication and Security Layer, метод для добавления поддержки
115 аутентикации к протоколам, основанным на соединениях.
116
117 %description -l uk.UTF-8
118 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
119 Authentication and Security Layer, метод для додання підтримки
120 аутентикації до протоколів, базованих на з'єднаннях.
121
122 %package libs
123 Summary:        cyrus-sasl library itself
124 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
125 Group:          Libraries
126 Requires(post,postun):  /sbin/ldconfig
127 Conflicts:      cyrus-sasl < 2.1.23-8
128
129 %description libs
130 cyrus-sasl library itself.
131
132 %description libs -l pl.UTF-8
133 Sama biblioteka cyrus-sasl.
134
135 %package devel
136 Summary:        Header files and documentation for cyrus-sasl
137 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
138 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
139 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
140 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
141 Group:          Development/Libraries
142 Requires:       %{name} = %{version}-%{release}
143
144 %description devel
145 This includes the header files and documentation needed to develop
146 applications which use SASL.
147
148 %description devel -l pl.UTF-8
149 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
150
151 %description devel -l pt_BR.UTF-8
152 Este pacote inclui os arquivos de cabeçalho e documentação necessários
153 para desenvolver aplicativos que usem SASL.
154
155 %description devel -l ru.UTF-8
156 Хедеры и библиотеки, необходимые для разработки приложений,
157 использующих Cyrus SASL.
158
159 %description devel -l uk.UTF-8
160 Хедери та бібліотеки, необхідні для розробки програм, що
161 використовують Cyrus SASL.
162
163 %package static
164 Summary:        Static cyrus-sasl libraries
165 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
166 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
167 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
168 Group:          Development/Libraries
169 Requires:       %{name}-devel = %{version}-%{release}
170
171 %description static
172 Static cyrus-sasl libraries.
173
174 %description static -l pl.UTF-8
175 Statyczne biblioteki cyrus-sasl.
176
177 %description static -l ru.UTF-8
178 Статические библиотеки, необходимые для разработки приложений,
179 использующих Cyrus SASL.
180
181 %description static -l uk.UTF-8
182 Статичні бібліотеки, необхідні для розробки програм, що використовують
183 Cyrus SASL.
184
185 %package anonymous
186 Summary:        Anonymous Cyrus SASL plugin
187 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
188 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
189 Group:          Libraries
190 Requires:       %{name} = %{version}-%{release}
191
192 %description anonymous
193 This plugin implements the SASL ANONYMOUS mechanism, used for
194 anonymous authentication.
195
196 %description anonymous -l pl.UTF-8
197 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
198 anonimowego uwierzytelniania.
199
200 %description anonymous -l pt_BR.UTF-8
201 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
202 autenticação anônima.
203
204 %package cram-md5
205 Summary:        Cram-MD5 Cyrus SASL plugin
206 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
207 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
208 Group:          Libraries
209 Requires:       %{name} = %{version}-%{release}
210
211 %description cram-md5
212 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
213 mandatory-to-implement authentication mechanism for a number of
214 protocols; it uses MD5 with a challenge/response system to
215 authenticate the user.
216
217 %description cram-md5 -l pl.UTF-8
218 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
219 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
220 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
221 systemem challenge/response.
222
223 %description cram-md5 -l pt_BR.UTF-8
224 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
225 mecanismo de autenticação obrigatório de ser implementado para vários
226 protocolos: ele usa MD5 com um sistema de desafio/resposta para
227 autenticar o usuário.
228
229 %package digest-md5
230 Summary:        Digest-MD5 Cyrus SASL plugin
231 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
232 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
233 Group:          Libraries
234 Requires:       %{name} = %{version}-%{release}
235
236 %description digest-md5
237 This plugin implements the latest draft of the SASL DIGEST-MD5
238 mechanism. Although not yet finalized, this is likely to become the
239 new mandatory-to-implement authentication system in all new protocols.
240 It's based on the digest md5 authentication system designed for HTTP.
241
242 %description digest-md5 -l pl.UTF-8
243 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
244 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
245 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
246 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
247 Digest-MD5 zaprojektowanym dla HTTP.
248
249 %description digest-md5 -l pt_BR.UTF-8
250 Este plugin implementa a última versão da especificação do mecanismo
251 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
252 provavelmente será o novo sistema de autenticação obrigatório para
253 protocolos novos. Ele é baseado na autenticação md5 digest
254 desenvolvida para HTTP.
255
256 %package gssapi
257 Summary:        GSSAPI Cyrus SASL plugin
258 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
259 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
260 Group:          Libraries
261 Requires:       %{name} = %{version}-%{release}
262
263 %description gssapi
264 This plugin implements the SASL GSSAPI mechanism, used for
265 GSSAPI/Kerberos5 authentication.
266
267 %description gssapi -l pl.UTF-8
268 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
269 uwierzytelniania z użyciem GSSAPI/Kerberos5.
270
271 %description gssapi -l pt_BR.UTF-8
272 Este plugin implementa o mecanismo SASL GSSAPI, usado para
273 autenticação Kerberos/GSSAPI.
274
275 %package login
276 Summary:        Unsupported Login Cyrus SASL plugin
277 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
278 Group:          Libraries
279 Requires:       %{name} = %{version}-%{release}
280
281 %description login
282 Unsupported LOGIN Cyrus SASL plugin.
283
284 %description login -l pl.UTF-8
285 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
286 SASL.
287
288 %package mysql
289 Summary:        Cyrus SASL MySQL plugin
290 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
291 Group:          Libraries
292 Requires:       %{name} = %{version}-%{release}
293
294 %description mysql
295 Cyrus SASL MySQL plugin.
296
297 %description mysql -l pl.UTF-8
298 Wtyczka MySQL do Cyrus SASL.
299
300 %package otp
301 Summary:        OTP Cyrus SASL plugin
302 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
303 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
304 Group:          Libraries
305 Requires:       %{name} = %{version}-%{release}
306 Obsoletes:      cyrus-sasl-opie < %{version}
307
308 %description otp
309 This plugin implements the SASL OTP (One Time Password) mechanism.
310
311 %description otp -l pl.UTF-8
312 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
313 SASL.
314
315 %package pgsql
316 Summary:        Cyrus SASL PostgreSQL plugin
317 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
318 Group:          Libraries
319 Requires:       %{name} = %{version}-%{release}
320
321 %description pgsql
322 Cyrus SASL PostgreSQL plugin.
323
324 %description pgsql -l pl.UTF-8
325 Wtyczka PostgreSQL do Cyrus SASL.
326
327 %package plain
328 Summary:        Plain Cyrus SASL plugin
329 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
330 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
331 Group:          Libraries
332 Requires:       %{name} = %{version}-%{release}
333
334 %description plain
335 This plugin implements the SASL PLAIN mechanism. Although insecure,
336 PLAIN is useful for transitioning to new security mechanisms, as this
337 is the only mechanism which gives the server a copy of the user's
338 password.
339
340 %description plain -l pl.UTF-8
341 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
342 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
343 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
344 który udostępnia serwerowi kopię hasła użytkownika.
345
346 %description plain -l pt_BR.UTF-8
347 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
348 mecanismo é útil durante transições para novos mecanismos de
349 segurança, pois é o único esquema que fornece uma cópia da senha do
350 usuário para o servidor.
351
352 %package sasldb
353 Summary:        Cyrus SASL sasldb plugin
354 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
355 Group:          Libraries
356 Requires:       %{name} = %{version}-%{release}
357
358 %description sasldb
359 Cyrus SASL sasldb plugin.
360
361 %description sasldb -l pl.UTF-8
362 Wtyczka sasldb do Cyrus SASL.
363
364 %package ldapdb
365 Summary:        Cyrus SASL LDAPDB plugin
366 Summary(pl.UTF-8):      Wtyczka LDAPDB do Cyrus SASL
367 Group:          Libraries
368 Requires:       %{name} = %{version}-%{release}
369
370 %description ldapdb
371 Cyrus SASL ldapdb plugin.
372
373 %description ldapdb -l pl.UTF-8
374 Wtyczka ldapdb do Cyrus SASL.
375
376 %package passdss
377 Summary:        PASSDSS Cyrus SASL plugin
378 Summary(pl.UTF-8):      Wtyczka PASSDSS do Cyrus SASL
379 Summary(pt_BR.UTF-8):   Mecanismo SASL PASSDSS
380 Group:          Libraries
381 Requires:       %{name} = %{version}-%{release}
382
383 %description passdss
384 This plugin implements the PASSDSS 3DES mechanism.
385
386 %description passdss -l pl.UTF-8
387 Wtyczka dodająca obsługę mechanizmu PASSDSS 3DES do Cyrus SASL.
388
389 %description passdss -l pt_BR.UTF-8
390 Este plugin implementa o mecanismo SASL PASSDSS 3DES.
391
392 %package scram
393 Summary:        SCRAM Cyrus SASL plugin
394 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
395 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
396 Group:          Libraries
397 Requires:       %{name} = %{version}-%{release}
398
399 %description scram
400 This plugin implements the SASL SCRAM-MD5 mechanism.
401
402 %description scram -l pl.UTF-8
403 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
404
405 %description scram -l pt_BR.UTF-8
406 Este plugin implementa o mecanismo SASL SCRAM.
407
408 %package sqlite
409 Summary:        Cyrus SQLite 2 PostgreSQL plugin
410 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
411 Group:          Libraries
412 Requires:       %{name} = %{version}-%{release}
413
414 %description sqlite
415 Cyrus SASL SQLite 2 plugin.
416
417 %description sqlite -l pl.UTF-8
418 Wtyczka SQLite 2 do Cyrus SASL.
419
420 %package sqlite3
421 Summary:        Cyrus SQLite 3 PostgreSQL plugin
422 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
423 Group:          Libraries
424 Requires:       %{name} = %{version}-%{release}
425
426 %description sqlite3
427 Cyrus SASL SQLite 3 plugin.
428
429 %description sqlite3 -l pl.UTF-8
430 Wtyczka SQLite 3 do Cyrus SASL.
431
432 %package srp
433 Summary:        SRP Cyrus SASL plugin
434 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
435 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
436 Group:          Libraries
437 Requires:       %{name} = %{version}-%{release}
438
439 %description srp
440 This plugin implements the SASL SRP mechanism, based on the Secure
441 Remote Password protocol. This mechanism performs mutual
442 authentication and can provide a security layer with replay detection,
443 integrity protection and/or condifentiality protection.
444
445 %description srp -l pl.UTF-8
446 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
447 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
448 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
449 powtarzania, zabezpieczeniem integralności i/lub poufności.
450
451 %description srp -l pt_BR.UTF-8
452 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
453 (Secure Remote Password). Este mecanismo oferece autenticação mútua
454 (do cliente e do servidor) e pode prover uma camada de segurança com
455 detecção de ataques de replay, garantia de integridade e/ou
456 confidencialidade.
457
458 %package pwcheck
459 Summary:        Cyrus SASL pwcheck helper
460 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
461 Group:          Libraries
462 Requires:       %{name} = %{version}-%{release}
463
464 %description pwcheck
465 Cyrus SASL pwcheck helper.
466
467 %description pwcheck -l pl.UTF-8
468 Program pomocniczy pwcheck do Cyrus SASL.
469
470 %package saslauthd
471 Summary:        Cyrus SASL authd
472 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
473 Group:          Daemons
474 Requires(post,preun):   /sbin/chkconfig
475 Requires:       %{name} = %{version}-%{release}
476 Requires:       /sbin/chkconfig
477 Requires:       rc-scripts
478
479 %description saslauthd
480 Cyrus SASL authd.
481
482 %description saslauthd -l pl.UTF-8
483 Demon authd do Cyrus SASL.
484
485 %package -n nagios-plugin-check_saslauthd
486 Summary:        Nagios plugin to check health of saslauthd
487 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
488 Group:          Networking
489 Requires:       nagios-core
490
491 %description -n nagios-plugin-check_saslauthd
492 Nagios plugin to check health of saslauthd.
493
494 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
495 Wtyczka Nagiosa do sprawdzania działania saslauthd.
496
497 %prep
498 %setup -q
499 %patch0 -p1
500 %patch1 -p1
501 %patch2 -p1
502 %patch3 -p1
503 %patch4 -p1
504 %if %{with cryptedpw}
505 %patch5 -p1
506 %patch6 -p1
507 %endif
508 %patch7 -p1
509 %patch8 -p1
510 %patch9 -p1
511 %patch10 -p1
512 %patch11 -p1
513 %patch12 -p1
514 %patch13 -p0
515 %patch14 -p1
516 %patch15 -p1
517 %patch16 -p1
518 %patch17 -p1
519 %patch18 -p1
520 %patch19 -p1
521 %patch20 -p1
522 %patch21 -p1
523 %patch22 -p1
524
525 cd doc
526 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
527 ls rfc*.txt >> rfc-compliance
528 rm -f rfc*.txt
529 cd ..
530
531 # old version
532 %{__rm} config/libtool.m4
533
534 # update to our paths
535 sed -i -e '
536         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
537         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
538         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
539         s,/var/state/saslauthd,/var/lib/sasl2,g
540 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
541
542 %build
543 %{__libtoolize}
544 %{__aclocal} -I cmulocal -I config
545 %{__autoheader}
546 %{__autoconf}
547 %{__automake}
548 cd saslauthd
549 %{__aclocal} -I ../cmulocal -I ../config
550 %{__autoheader}
551 %{__autoconf}
552 %{__automake}
553 cd ..
554 %configure \
555         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
556         --disable-krb4 \
557         %{!?with_gssapi: --disable-gssapi} \
558         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
559         --enable-login \
560         --enable-sample \
561         --enable-httpform \
562         --enable-sql \
563         --enable-passdss \
564         %{?with_srp: --enable-srp} \
565         --enable-static \
566         --with-plugindir=%{_libdir}/sasl2 \
567         --with-configdir=%{_sysconfdir} \
568         --with-dblib=berkeley \
569         --with-dbpath=/var/lib/sasl2/sasl.db \
570         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
571         %{?with_ldap: --with-ldap=%{_prefix}} \
572         %{?with_ldap: --enable-ldapdb} \
573         %{?with_mysql: --with-mysql=%{_prefix}} \
574         %{?with_pgsql: --with-pgsql=%{_prefix}} \
575         %{?with_sqlite: --with-sqlite=%{_prefix}} \
576         %{?with_sqlite3: --with-sqlite3=%{_prefix}} \
577         %{?with_opie: --with-opie=%{_prefix}} \
578         --with-pam \
579         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
580         --with-saslauthd=/var/lib/sasl2
581
582 %{__make}
583
584 %{__make} -C saslauthd testsaslauthd
585 %{__make} -C saslauthd saslcache
586 %{__make} -C sample sample-client sample-server
587
588 cd doc
589 RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
590 for i in $RFCLIST; do
591         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
592         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
593 done
594
595 %install
596 rm -rf $RPM_BUILD_ROOT
597 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
598                 $RPM_BUILD_ROOT%{_mandir}/man8
599
600 %{__make} install \
601         sasldir=%{_libdir}/sasl2 \
602         DESTDIR=$RPM_BUILD_ROOT
603
604 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
605
606 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
607 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
608
609 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
610
611 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
612
613 # create empty config
614 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
615 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
616 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
617 cp -a %{SOURCE3} cyrus.pam
618
619 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
620
621 # sample programs for testing sasl
622 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
623 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
624
625 # package for ghost
626 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
627
628 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
629 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
630
631 %clean
632 rm -rf $RPM_BUILD_ROOT
633
634 %post   libs -p /sbin/ldconfig
635 %postun libs -p /sbin/ldconfig
636
637 %post saslauthd
638 /sbin/chkconfig --add saslauthd
639 %service saslauthd restart
640
641 %preun saslauthd
642 if [ "$1" = "0" ]; then
643         %service saslauthd stop
644         /sbin/chkconfig --del saslauthd
645 fi
646
647 %triggerin saslauthd -- pam
648 # restart saslauthd if pam is upgraded
649 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
650 if [ "$2" != 1 ]; then
651         %service -q saslauthd restart
652 fi
653
654 %files
655 %defattr(644,root,root,755)
656 %doc AUTHORS COPYING ChangeLog NEWS README
657 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
658 %dir %{_sysconfdir}
659 %dir %{_libdir}/sasl2
660 # sample programs to subpackage instead?
661 %attr(755,root,root) %{_bindir}/sasl-sample-client
662 %attr(755,root,root) %{_bindir}/sasl-sample-server
663 %attr(755,root,root) %{_sbindir}/pluginviewer
664 %attr(755,root,root) %{_sbindir}/sasldblistusers2
665 %attr(755,root,root) %{_sbindir}/saslpasswd2
666 %dir /var/lib/sasl2
667 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
668 %{_mandir}/man8/pluginviewer.8*
669 %{_mandir}/man8/sasldblistusers2.8*
670 %{_mandir}/man8/saslpasswd2.8*
671
672 %files libs
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
675 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.3
676
677 %files devel
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/libsasl2.so
680 %attr(755,root,root) %{_libdir}/libsasl.so
681 %{_libdir}/libsasl2.la
682 %{_includedir}/sasl
683 %{_pkgconfigdir}/libsasl2.pc
684 %{_mandir}/man3/sasl*.3*
685
686 %files static
687 %defattr(644,root,root,755)
688 %{_libdir}/libsasl2.a
689
690 %files anonymous
691 %defattr(644,root,root,755)
692 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
693
694 %if %{with gssapi}
695 %files gssapi
696 %defattr(644,root,root,755)
697 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
698 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
699 %endif
700
701 %files cram-md5
702 %defattr(644,root,root,755)
703 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
704
705 %files digest-md5
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
708
709 %files login
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
712
713 %if %{with mysql}
714 %files mysql
715 %defattr(644,root,root,755)
716 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
717 %endif
718
719 %files otp
720 %defattr(644,root,root,755)
721 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
722
723 %if %{with pgsql}
724 %files pgsql
725 %defattr(644,root,root,755)
726 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
727 %endif
728
729 %files plain
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
732
733 %files sasldb
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
736
737 %if %{with ldap}
738 %files ldapdb
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/sasl2/libldapdb.so*
741 %endif
742
743 %files passdss
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_libdir}/sasl2/libpassdss.so*
746
747 %files scram
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
750
751 %if %{with sqlite}
752 %files sqlite
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
755 %endif
756
757 %if %{with sqlite3}
758 %files sqlite3
759 %defattr(644,root,root,755)
760 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
761 %endif
762
763 %if %{with srp}
764 %files srp
765 %defattr(644,root,root,755)
766 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
767 %endif
768
769 %if %{with pwcheck}
770 %files pwcheck
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{_sbindir}/pwcheck
773 %endif
774
775 %files saslauthd
776 %defattr(644,root,root,755)
777 %doc cyrus.pam
778 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
779 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
780 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
781 %attr(755,root,root) %{_sbindir}/saslauthd
782 %attr(755,root,root) %{_sbindir}/testsaslauthd
783 %attr(755,root,root) %{_sbindir}/saslcache
784 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
785 %ghost /var/lib/sasl2/cache.flock
786 %ghost /var/lib/sasl2/cache.mmap
787 %ghost /var/lib/sasl2/mux
788 %ghost /var/lib/sasl2/mux.accept
789 %ghost /var/lib/sasl2/saslauthd.pid
790 %{_mandir}/man8/saslauthd.8*
791
792 %files -n nagios-plugin-check_saslauthd
793 %defattr(644,root,root,755)
794 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
795 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.163604 seconds and 3 git commands to generate.