]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- allow building without Nagios support
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 #
2 # Conditional build:
3 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
4 %bcond_without  ldap            # disable LDAP support for saslauthd
5 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
6 %bcond_without  mysql           # don't build MySQL plugin
7 %bcond_without  nagios          # do not enable Nagios plugin
8 %bcond_without  ntlm            # do not build NTLM plugin
9 %bcond_without  pgsql           # do not build PostgreSQL plugin
10 %bcond_without  sqlite          # do not enable sqlite 2 plugin
11 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
12 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
13 %bcond_with     opie            # OTP plugin using opie library instead of internal code
14 %bcond_with     srp             # build srp plugin
15 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.28
28 Release:        2
29 License:        distributable
30 Group:          Libraries
31 #Source0Download: https://github.com/cyrusimap/cyrus-sasl/releases
32 Source0:        https://github.com/cyrusimap/cyrus-sasl/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
33 # Source0-md5:  6f228a692516f5318a64505b46966cfa
34 Source1:        saslauthd.init
35 Source2:        saslauthd.sysconfig
36 Source3:        %{name}.pam
37 Source4:        check_saslauthd.cfg
38 Patch0:         %{name}-nolibs.patch
39 Patch1:         %{name}-lt.patch
40 Patch2:         %{name}-split-sql.patch
41 Patch3:         %{name}-opie.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-db.patch
46 Patch9:         %{name}-sizes.patch
47 Patch10:        %{name}-nagios-plugin.patch
48 Patch12:        %{name}-gssapi-detect.patch
49 Patch14:        %{name}-ac-libs.patch
50 Patch20:        %{name}-auxprop.patch
51 Patch21:        0030-dont_use_la_files_for_opening_plugins.patch
52 URL:            https://www.cyrusimap.org/sasl/
53 BuildRequires:  autoconf >= 2.63
54 BuildRequires:  automake >= 1:1.11
55 %{?with_authlib:BuildRequires:  courier-authlib-devel}
56 BuildRequires:  db-devel
57 BuildRequires:  ed
58 BuildRequires:  groff
59 %{?with_gssapi:BuildRequires:   heimdal-devel}
60 BuildRequires:  libtool >= 1.4
61 %{?with_mysql:BuildRequires:    mysql-devel}
62 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
63 BuildRequires:  openssl-devel >= 0.9.7d
64 %{?with_opie:BuildRequires:     opie-devel}
65 BuildRequires:  pam-devel
66 %{?with_pgsql:BuildRequires:    postgresql-devel}
67 BuildRequires:  rpmbuild(macros) >= 1.268
68 BuildRequires:  sphinx-pdg-3
69 %{?with_sqlite:BuildRequires:   sqlite-devel}
70 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
71 Requires:       pam >= 0.79.0
72 Requires:       %{name}-libs = %{version}-%{release}
73 Obsoletes:      cyrus-sasl-x509 < %{version}
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         _sysconfdir     /etc/sasl
77
78 %define         specflags       -fno-strict-aliasing
79
80 %description
81 This is an implementation of the SASL API, useful for adding
82 authentication, authorization, and security to network protocols. The
83 SASL protocol itself is documented in rfc2222; the API standard is a
84 work in progress.
85
86 Note: remember to install appropriate plugins, or you won't have any
87 authentication mechanisms available.
88
89 %description -l pl.UTF-8
90 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
91 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
92 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
93 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
94 RFC 2222; standaryzacja API jest w toku.
95
96 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
97 doinstalować odpowiednie wtyczki.
98
99 %description -l pt_BR.UTF-8
100 Esta é uma implementação da API SASL, útil para acrescentar
101 autenticação, autorização e seguança (criptografia) para protocolos de
102 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
103 ainda está em desenvolvimento.
104
105 %description -l ru.UTF-8
106 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
107 Authentication and Security Layer, метод для добавления поддержки
108 аутентикации к протоколам, основанным на соединениях.
109
110 %description -l uk.UTF-8
111 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
112 Authentication and Security Layer, метод для додання підтримки
113 аутентикації до протоколів, базованих на з'єднаннях.
114
115 %package libs
116 Summary:        cyrus-sasl library itself
117 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
118 Group:          Libraries
119 Requires(post,postun):  /sbin/ldconfig
120 Conflicts:      cyrus-sasl < 2.1.23-8
121
122 %description libs
123 cyrus-sasl library itself.
124
125 %description libs -l pl.UTF-8
126 Sama biblioteka cyrus-sasl.
127
128 %package devel
129 Summary:        Header files and documentation for cyrus-sasl
130 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
131 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
132 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
133 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
134 Group:          Development/Libraries
135 Requires:       %{name} = %{version}-%{release}
136
137 %description devel
138 This includes the header files and documentation needed to develop
139 applications which use SASL.
140
141 %description devel -l pl.UTF-8
142 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
143
144 %description devel -l pt_BR.UTF-8
145 Este pacote inclui os arquivos de cabeçalho e documentação necessários
146 para desenvolver aplicativos que usem SASL.
147
148 %description devel -l ru.UTF-8
149 Хедеры и библиотеки, необходимые для разработки приложений,
150 использующих Cyrus SASL.
151
152 %description devel -l uk.UTF-8
153 Хедери та бібліотеки, необхідні для розробки програм, що
154 використовують Cyrus SASL.
155
156 %package static
157 Summary:        Static cyrus-sasl libraries
158 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
159 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
160 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
161 Group:          Development/Libraries
162 Requires:       %{name}-devel = %{version}-%{release}
163
164 %description static
165 Static cyrus-sasl libraries.
166
167 %description static -l pl.UTF-8
168 Statyczne biblioteki cyrus-sasl.
169
170 %description static -l ru.UTF-8
171 Статические библиотеки, необходимые для разработки приложений,
172 использующих Cyrus SASL.
173
174 %description static -l uk.UTF-8
175 Статичні бібліотеки, необхідні для розробки програм, що використовують
176 Cyrus SASL.
177
178 %package anonymous
179 Summary:        Anonymous Cyrus SASL plugin
180 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
181 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
182 Group:          Libraries
183 Requires:       %{name} = %{version}-%{release}
184
185 %description anonymous
186 This plugin implements the SASL ANONYMOUS mechanism, used for
187 anonymous authentication.
188
189 %description anonymous -l pl.UTF-8
190 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
191 anonimowego uwierzytelniania.
192
193 %description anonymous -l pt_BR.UTF-8
194 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
195 autenticação anônima.
196
197 %package cram-md5
198 Summary:        Cram-MD5 Cyrus SASL plugin
199 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
200 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
201 Group:          Libraries
202 Requires:       %{name} = %{version}-%{release}
203
204 %description cram-md5
205 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
206 mandatory-to-implement authentication mechanism for a number of
207 protocols; it uses MD5 with a challenge/response system to
208 authenticate the user.
209
210 %description cram-md5 -l pl.UTF-8
211 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
212 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
213 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
214 systemem challenge/response.
215
216 %description cram-md5 -l pt_BR.UTF-8
217 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
218 mecanismo de autenticação obrigatório de ser implementado para vários
219 protocolos: ele usa MD5 com um sistema de desafio/resposta para
220 autenticar o usuário.
221
222 %package digest-md5
223 Summary:        Digest-MD5 Cyrus SASL plugin
224 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
225 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
226 Group:          Libraries
227 Requires:       %{name} = %{version}-%{release}
228
229 %description digest-md5
230 This plugin implements the latest draft of the SASL DIGEST-MD5
231 mechanism. Although not yet finalized, this is likely to become the
232 new mandatory-to-implement authentication system in all new protocols.
233 It's based on the digest md5 authentication system designed for HTTP.
234
235 %description digest-md5 -l pl.UTF-8
236 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
237 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
238 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
239 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
240 Digest-MD5 zaprojektowanym dla HTTP.
241
242 %description digest-md5 -l pt_BR.UTF-8
243 Este plugin implementa a última versão da especificação do mecanismo
244 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
245 provavelmente será o novo sistema de autenticação obrigatório para
246 protocolos novos. Ele é baseado na autenticação md5 digest
247 desenvolvida para HTTP.
248
249 %package gssapi
250 Summary:        GSSAPI Cyrus SASL plugin
251 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
252 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
253 Group:          Libraries
254 Requires:       %{name} = %{version}-%{release}
255
256 %description gssapi
257 This plugin implements the SASL GSSAPI mechanism, used for
258 GSSAPI/Kerberos5 authentication.
259
260 %description gssapi -l pl.UTF-8
261 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
262 uwierzytelniania z użyciem GSSAPI/Kerberos5.
263
264 %description gssapi -l pt_BR.UTF-8
265 Este plugin implementa o mecanismo SASL GSSAPI, usado para
266 autenticação Kerberos/GSSAPI.
267
268 %package login
269 Summary:        Unsupported Login Cyrus SASL plugin
270 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
271 Group:          Libraries
272 Requires:       %{name} = %{version}-%{release}
273
274 %description login
275 Unsupported LOGIN Cyrus SASL plugin.
276
277 %description login -l pl.UTF-8
278 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
279 SASL.
280
281 %package mysql
282 Summary:        Cyrus SASL MySQL plugin
283 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
284 Group:          Libraries
285 Requires:       %{name} = %{version}-%{release}
286
287 %description mysql
288 Cyrus SASL MySQL plugin.
289
290 %description mysql -l pl.UTF-8
291 Wtyczka MySQL do Cyrus SASL.
292
293 %package ntlm
294 Summary:        Cyrus SASL NTLM plugin
295 Summary(pl.UTF-8):      Wtyczka NTLM do Cyrus SASL
296 Group:          Libraries
297 Requires:       %{name} = %{version}-%{release}
298
299 %description ntlm
300 Cyrus SASL NTLM plugin.
301
302 %description ntlm -l pl.UTF-8
303 Wtyczka NTLM do Cyrus SASL.
304
305 %package otp
306 Summary:        OTP Cyrus SASL plugin
307 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
308 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
309 Group:          Libraries
310 Requires:       %{name} = %{version}-%{release}
311 Obsoletes:      cyrus-sasl-opie < %{version}
312
313 %description otp
314 This plugin implements the SASL OTP (One Time Password) mechanism.
315
316 %description otp -l pl.UTF-8
317 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
318 SASL.
319
320 %package pgsql
321 Summary:        Cyrus SASL PostgreSQL plugin
322 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
323 Group:          Libraries
324 Requires:       %{name} = %{version}-%{release}
325
326 %description pgsql
327 Cyrus SASL PostgreSQL plugin.
328
329 %description pgsql -l pl.UTF-8
330 Wtyczka PostgreSQL do Cyrus SASL.
331
332 %package plain
333 Summary:        Plain Cyrus SASL plugin
334 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
335 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
336 Group:          Libraries
337 Requires:       %{name} = %{version}-%{release}
338
339 %description plain
340 This plugin implements the SASL PLAIN mechanism. Although insecure,
341 PLAIN is useful for transitioning to new security mechanisms, as this
342 is the only mechanism which gives the server a copy of the user's
343 password.
344
345 %description plain -l pl.UTF-8
346 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
347 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
348 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
349 który udostępnia serwerowi kopię hasła użytkownika.
350
351 %description plain -l pt_BR.UTF-8
352 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
353 mecanismo é útil durante transições para novos mecanismos de
354 segurança, pois é o único esquema que fornece uma cópia da senha do
355 usuário para o servidor.
356
357 %package sasldb
358 Summary:        Cyrus SASL sasldb plugin
359 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
360 Group:          Libraries
361 Requires:       %{name} = %{version}-%{release}
362
363 %description sasldb
364 Cyrus SASL sasldb plugin.
365
366 %description sasldb -l pl.UTF-8
367 Wtyczka sasldb do Cyrus SASL.
368
369 %package ldapdb
370 Summary:        Cyrus SASL LDAPDB plugin
371 Summary(pl.UTF-8):      Wtyczka LDAPDB do Cyrus SASL
372 Group:          Libraries
373 Requires:       %{name} = %{version}-%{release}
374
375 %description ldapdb
376 Cyrus SASL ldapdb plugin.
377
378 %description ldapdb -l pl.UTF-8
379 Wtyczka ldapdb do Cyrus SASL.
380
381 %package passdss
382 Summary:        PASSDSS Cyrus SASL plugin
383 Summary(pl.UTF-8):      Wtyczka PASSDSS do Cyrus SASL
384 Summary(pt_BR.UTF-8):   Mecanismo SASL PASSDSS
385 Group:          Libraries
386 Requires:       %{name} = %{version}-%{release}
387
388 %description passdss
389 This plugin implements the PASSDSS 3DES mechanism.
390
391 %description passdss -l pl.UTF-8
392 Wtyczka dodająca obsługę mechanizmu PASSDSS 3DES do Cyrus SASL.
393
394 %description passdss -l pt_BR.UTF-8
395 Este plugin implementa o mecanismo SASL PASSDSS 3DES.
396
397 %package scram
398 Summary:        SCRAM Cyrus SASL plugin
399 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
400 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
401 Group:          Libraries
402 Requires:       %{name} = %{version}-%{release}
403
404 %description scram
405 This plugin implements the SASL SCRAM-MD5 mechanism.
406
407 %description scram -l pl.UTF-8
408 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
409
410 %description scram -l pt_BR.UTF-8
411 Este plugin implementa o mecanismo SASL SCRAM.
412
413 %package sqlite
414 Summary:        Cyrus SQLite 2 PostgreSQL plugin
415 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
416 Group:          Libraries
417 Requires:       %{name} = %{version}-%{release}
418
419 %description sqlite
420 Cyrus SASL SQLite 2 plugin.
421
422 %description sqlite -l pl.UTF-8
423 Wtyczka SQLite 2 do Cyrus SASL.
424
425 %package sqlite3
426 Summary:        Cyrus SQLite 3 PostgreSQL plugin
427 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
428 Group:          Libraries
429 Requires:       %{name} = %{version}-%{release}
430
431 %description sqlite3
432 Cyrus SASL SQLite 3 plugin.
433
434 %description sqlite3 -l pl.UTF-8
435 Wtyczka SQLite 3 do Cyrus SASL.
436
437 %package srp
438 Summary:        SRP Cyrus SASL plugin
439 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
440 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
441 Group:          Libraries
442 Requires:       %{name} = %{version}-%{release}
443
444 %description srp
445 This plugin implements the SASL SRP mechanism, based on the Secure
446 Remote Password protocol. This mechanism performs mutual
447 authentication and can provide a security layer with replay detection,
448 integrity protection and/or condifentiality protection.
449
450 %description srp -l pl.UTF-8
451 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
452 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
453 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
454 powtarzania, zabezpieczeniem integralności i/lub poufności.
455
456 %description srp -l pt_BR.UTF-8
457 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
458 (Secure Remote Password). Este mecanismo oferece autenticação mútua
459 (do cliente e do servidor) e pode prover uma camada de segurança com
460 detecção de ataques de replay, garantia de integridade e/ou
461 confidencialidade.
462
463 %package pwcheck
464 Summary:        Cyrus SASL pwcheck helper
465 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
466 Group:          Libraries
467 Requires:       %{name} = %{version}-%{release}
468
469 %description pwcheck
470 Cyrus SASL pwcheck helper.
471
472 %description pwcheck -l pl.UTF-8
473 Program pomocniczy pwcheck do Cyrus SASL.
474
475 %package saslauthd
476 Summary:        Cyrus SASL authd
477 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
478 Group:          Daemons
479 Requires(post,preun):   /sbin/chkconfig
480 Requires:       %{name} = %{version}-%{release}
481 Requires:       /sbin/chkconfig
482 Requires:       rc-scripts
483
484 %description saslauthd
485 Cyrus SASL authd.
486
487 %description saslauthd -l pl.UTF-8
488 Demon authd do Cyrus SASL.
489
490 %package -n nagios-plugin-check_saslauthd
491 Summary:        Nagios plugin to check health of saslauthd
492 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
493 Group:          Networking
494 Requires:       nagios-core
495
496 %description -n nagios-plugin-check_saslauthd
497 Nagios plugin to check health of saslauthd.
498
499 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
500 Wtyczka Nagiosa do sprawdzania działania saslauthd.
501
502 %prep
503 %setup -q
504 %patch0 -p1
505 %patch1 -p1
506 %patch2 -p1
507 %patch3 -p1
508 %if %{with cryptedpw}
509 %patch5 -p1
510 %patch6 -p1
511 %endif
512 %patch7 -p1
513 %patch9 -p1
514 %{?with_nagios:%patch10 -p1}
515 %patch12 -p1
516 %patch14 -p1
517 %patch20 -p1
518 %patch21 -p1
519
520 # update to our paths
521 sed -i -e '
522         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
523         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
524         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
525         s,/var/state/saslauthd,/var/lib/sasl2,g
526 ' saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/legacy/sysadmin.html
527
528 %build
529 %{__libtoolize}
530 %{__aclocal} -I m4
531 %{__autoconf}
532 %{__autoheader}
533 %{__automake}
534 %configure \
535         SPHINX_BUILD=/usr/bin/sphinx-build-3 \
536         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
537         %{!?with_gssapi:--disable-gssapi} \
538         %{?with_gssapi:--enable-gssapi --with-gss_impl=heimdal} \
539         --enable-httpform \
540         --disable-krb4 \
541         %{?with_ldap:--enable-ldapdb} \
542         --enable-login \
543         --enable-passdss \
544         --enable-sample \
545         --enable-sql \
546         %{?with_srp:--enable-srp} \
547         --enable-static \
548         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
549         --with-configdir=%{_sysconfdir} \
550         --with-dblib=berkeley \
551         --with-dbpath=/var/lib/sasl2/sasl.db \
552         %{?with_ldap:--with-ldap} \
553         %{?with_mysql:--with-mysql=%{_prefix}} \
554         %{?with_ntlm:--enable-ntlm} \
555         %{?with_opie:--with-opie=%{_prefix}} \
556         --with-pam \
557         %{?with_pgsql:--with-pgsql=%{_prefix}} \
558         --with-plugindir=%{_libdir}/sasl2 \
559         %{?with_pwcheck:--with-pwcheck=/var/lib/sasl2} \
560         --with-saslauthd=/var/lib/sasl2 \
561         %{?with_sqlite:--with-sqlite=%{_prefix}} \
562         %{?with_sqlite3:--with-sqlite3=%{_prefix}}
563
564 %{__make}
565
566 %{__make} -C saslauthd testsaslauthd
567 %{__make} -C saslauthd saslcache
568 %{__make} -C sample sample-client sample-server
569
570 %{__rm} -rf doc/html/{_sources,objects.inv,.buildinfo}
571
572 %install
573 rm -rf $RPM_BUILD_ROOT
574 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
575                 $RPM_BUILD_ROOT%{_mandir}/man8
576
577 %{__make} install \
578         sasldir=%{_libdir}/sasl2 \
579         DESTDIR=$RPM_BUILD_ROOT
580
581 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
582
583 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
584 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
585
586 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
587
588 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
589
590 # create empty config
591 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
592 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
593 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
594 cp -a %{SOURCE3} cyrus.pam
595
596 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
597
598 # sample programs for testing sasl
599 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
600 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
601
602 # package for ghost
603 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
604
605 %if %{with nagios}
606 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
607 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
608 %endif
609
610 %clean
611 rm -rf $RPM_BUILD_ROOT
612
613 %post   libs -p /sbin/ldconfig
614 %postun libs -p /sbin/ldconfig
615
616 %post saslauthd
617 /sbin/chkconfig --add saslauthd
618 %service saslauthd restart
619
620 %preun saslauthd
621 if [ "$1" = "0" ]; then
622         %service saslauthd stop
623         /sbin/chkconfig --del saslauthd
624 fi
625
626 %triggerin saslauthd -- pam
627 # restart saslauthd if pam is upgraded
628 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
629 if [ "$2" != 1 ]; then
630         %service -q saslauthd restart
631 fi
632
633 %files
634 %defattr(644,root,root,755)
635 %doc AUTHORS COPYING ChangeLog README doc/legacy/{TODO,*.html,*.fig} doc/html
636 %dir %{_sysconfdir}
637 %dir %{_libdir}/sasl2
638 # sample programs to subpackage instead?
639 %attr(755,root,root) %{_bindir}/sasl-sample-client
640 %attr(755,root,root) %{_bindir}/sasl-sample-server
641 %attr(755,root,root) %{_sbindir}/pluginviewer
642 %attr(755,root,root) %{_sbindir}/sasldblistusers2
643 %attr(755,root,root) %{_sbindir}/saslpasswd2
644 %dir /var/lib/sasl2
645 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
646 %{_mandir}/man8/pluginviewer.8*
647 %{_mandir}/man8/sasldblistusers2.8*
648 %{_mandir}/man8/saslpasswd2.8*
649
650 %files libs
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
653 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.3
654
655 %files devel
656 %defattr(644,root,root,755)
657 %attr(755,root,root) %{_libdir}/libsasl2.so
658 %attr(755,root,root) %{_libdir}/libsasl.so
659 %{_libdir}/libsasl2.la
660 %{_includedir}/sasl
661 %{_pkgconfigdir}/libsasl2.pc
662 %{_mandir}/man3/sasl*.3*
663
664 %files static
665 %defattr(644,root,root,755)
666 %{_libdir}/libsasl2.a
667
668 %files anonymous
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
671
672 %if %{with gssapi}
673 %files gssapi
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
676 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
677 %endif
678
679 %files cram-md5
680 %defattr(644,root,root,755)
681 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
682
683 %files digest-md5
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
686
687 %files login
688 %defattr(644,root,root,755)
689 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
690
691 %if %{with mysql}
692 %files mysql
693 %defattr(644,root,root,755)
694 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
695 %endif
696
697 %if %{with ntlm}
698 %files ntlm
699 %defattr(644,root,root,755)
700 %attr(755,root,root) %{_libdir}/sasl2/libntlm.so*
701 %endif
702
703 %files otp
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
706
707 %if %{with pgsql}
708 %files pgsql
709 %defattr(644,root,root,755)
710 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
711 %endif
712
713 %files plain
714 %defattr(644,root,root,755)
715 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
716
717 %files sasldb
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
720
721 %if %{with ldap}
722 %files ldapdb
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/sasl2/libldapdb.so*
725 %endif
726
727 %files passdss
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_libdir}/sasl2/libpassdss.so*
730
731 %files scram
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
734
735 %if %{with sqlite}
736 %files sqlite
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
739 %endif
740
741 %if %{with sqlite3}
742 %files sqlite3
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
745 %endif
746
747 %if %{with srp}
748 %files srp
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
751 %endif
752
753 %if %{with pwcheck}
754 %files pwcheck
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_sbindir}/pwcheck
757 %endif
758
759 %files saslauthd
760 %defattr(644,root,root,755)
761 %doc cyrus.pam saslauthd/{COPYING,LDAP_SASLAUTHD}
762 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
763 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
764 %attr(755,root,root) %{_sbindir}/saslauthd
765 %attr(755,root,root) %{_sbindir}/testsaslauthd
766 %attr(755,root,root) %{_sbindir}/saslcache
767 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
768 %ghost /var/lib/sasl2/cache.flock
769 %ghost /var/lib/sasl2/cache.mmap
770 %ghost /var/lib/sasl2/mux
771 %ghost /var/lib/sasl2/mux.accept
772 %ghost /var/lib/sasl2/saslauthd.pid
773 %{_mandir}/man8/saslauthd.8*
774 %{_mandir}/man8/testsaslauthd.8*
775
776 %if %{with nagios}
777 %files -n nagios-plugin-check_saslauthd
778 %defattr(644,root,root,755)
779 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
780 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
781 %endif
This page took 0.172142 seconds and 3 git commands to generate.