]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
87a2595ce21295c59bf38b666608a7e6cfec6a10
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 #
2 # Conditional build:
3 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
4 %bcond_without  ldap            # disable LDAP support for saslauthd
5 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
6 %bcond_without  mysql           # don't build MySQL pluggin
7 %bcond_without  pgsql           # do not build PostgreSQL pluggin
8 %bcond_without  sqlite          # do not enable sqlite 2 plugin
9 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
10 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
11 %bcond_with     opie            # OTP plugin using opie library instead of internal code
12 %bcond_with     srp             # build srp plugin
13 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
14 #
15 %if %{without mysql} && %{without pgsql}
16 %undefine with_cryptedpw
17 %endif
18
19 Summary:        The SASL library API for the Cyrus mail system
20 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
21 Summary(pt_BR.UTF-8):   Implementação da API SASL
22 Summary(ru.UTF-8):      Библиотека Cyrus SASL
23 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
24 Name:           cyrus-sasl
25 Version:        2.1.25
26 Release:        7
27 License:        distributable
28 Group:          Libraries
29 Source0:        ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
30 # Source0-md5:  341cffe829a4d71f2a6503d669d5a946
31 Source1:        saslauthd.init
32 Source2:        saslauthd.sysconfig
33 Source3:        %{name}.pam
34 Source4:        check_saslauthd.cfg
35 Patch0:         %{name}-nolibs.patch
36 Patch1:         %{name}-lt.patch
37 Patch2:         %{name}-split-sql.patch
38 Patch3:         %{name}-opie.patch
39 Patch4:         %{name}-gcc4.patch
40 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
41 Patch5:         %{name}-cryptedpw.patch
42 Patch6:         %{name}-md5sum-passwords.patch
43 Patch7:         %{name}-db.patch
44 Patch8:         %{name}-keytab.patch
45 Patch9:         %{name}-sizes.patch
46 Patch10:        %{name}-nagios-plugin.patch
47 Patch11:        %{name}-parallel-make.patch
48 Patch12:        %{name}-gssapi-detect.patch
49 Patch13:        %{name}-saslauthd-httpform-urlescape.patch
50 Patch14:        %{name}-ac-libs.patch
51 Patch15:        %{name}-pam.patch
52 Patch16:        %{name}-gssapi_ext.patch
53 Patch17:        0032-revert_1.103_revision_to_unbreak_GSSAPI.patch
54 Patch18:        0033-fix_segfault_in_GSSAPI.patch
55 Patch19:        0034-fix_dovecot_authentication.patch
56 Patch20:        %{name}-auxprop.patch
57 Patch21:        %{name}-get_fqhostname.patch
58 Patch22:        0030-dont_use_la_files_for_opening_plugins.patch
59 URL:            http://asg.web.cmu.edu/sasl/
60 BuildRequires:  autoconf >= 2.54
61 BuildRequires:  automake >= 1:1.7
62 %{?with_authlib:BuildRequires:  courier-authlib-devel}
63 BuildRequires:  db-devel
64 BuildRequires:  ed
65 BuildRequires:  groff
66 %{?with_gssapi:BuildRequires:   heimdal-devel}
67 BuildRequires:  libtool >= 1.4
68 %{?with_mysql:BuildRequires:    mysql-devel}
69 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
70 BuildRequires:  openssl-devel >= 0.9.7d
71 %{?with_opie:BuildRequires:     opie-devel}
72 BuildRequires:  pam-devel
73 %{?with_pgsql:BuildRequires:    postgresql-devel}
74 BuildRequires:  rpmbuild(macros) >= 1.268
75 %{?with_sqlite:BuildRequires:   sqlite-devel}
76 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
77 Requires:       pam >= 0.79.0
78 Requires:       %{name}-libs = %{version}-%{release}
79 Obsoletes:      cyrus-sasl-x509 < %{version}
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %define         _sysconfdir     /etc/sasl
83
84 %define         specflags       -fno-strict-aliasing
85
86 %description
87 This is an implementation of the SASL API, useful for adding
88 authentication, authorization, and security to network protocols. The
89 SASL protocol itself is documented in rfc2222; the API standard is a
90 work in progress.
91
92 Note: remember to install appropriate plugins, or you won't have any
93 authentication mechanisms available.
94
95 %description -l pl.UTF-8
96 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
97 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
98 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
99 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
100 RFC 2222; standaryzacja API jest w toku.
101
102 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
103 doinstalować odpowiednie wtyczki.
104
105 %description -l pt_BR.UTF-8
106 Esta é uma implementação da API SASL, útil para acrescentar
107 autenticação, autorização e seguança (criptografia) para protocolos de
108 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
109 ainda está em desenvolvimento.
110
111 %description -l ru.UTF-8
112 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
113 Authentication and Security Layer, метод для добавления поддержки
114 аутентикации к протоколам, основанным на соединениях.
115
116 %description -l uk.UTF-8
117 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
118 Authentication and Security Layer, метод для додання підтримки
119 аутентикації до протоколів, базованих на з'єднаннях.
120
121 %package libs
122 Summary:        cyrus-sasl library itself
123 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
124 Group:          Libraries
125 Requires(post,postun):  /sbin/ldconfig
126 Conflicts:      cyrus-sasl < 2.1.23-8
127
128 %description libs
129 cyrus-sasl library itself.
130
131 %description libs -l pl.UTF-8
132 Sama biblioteka cyrus-sasl.
133
134 %package devel
135 Summary:        Header files and documentation for cyrus-sasl
136 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
137 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
138 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
139 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
140 Group:          Development/Libraries
141 Requires:       %{name} = %{version}-%{release}
142
143 %description devel
144 This includes the header files and documentation needed to develop
145 applications which use SASL.
146
147 %description devel -l pl.UTF-8
148 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
149
150 %description devel -l pt_BR.UTF-8
151 Este pacote inclui os arquivos de cabeçalho e documentação necessários
152 para desenvolver aplicativos que usem SASL.
153
154 %description devel -l ru.UTF-8
155 Хедеры и библиотеки, необходимые для разработки приложений,
156 использующих Cyrus SASL.
157
158 %description devel -l uk.UTF-8
159 Хедери та бібліотеки, необхідні для розробки програм, що
160 використовують Cyrus SASL.
161
162 %package static
163 Summary:        Static cyrus-sasl libraries
164 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
165 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
166 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
167 Group:          Development/Libraries
168 Requires:       %{name}-devel = %{version}-%{release}
169
170 %description static
171 Static cyrus-sasl libraries.
172
173 %description static -l pl.UTF-8
174 Statyczne biblioteki cyrus-sasl.
175
176 %description static -l ru.UTF-8
177 Статические библиотеки, необходимые для разработки приложений,
178 использующих Cyrus SASL.
179
180 %description static -l uk.UTF-8
181 Статичні бібліотеки, необхідні для розробки програм, що використовують
182 Cyrus SASL.
183
184 %package anonymous
185 Summary:        Anonymous Cyrus SASL plugin
186 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
187 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
188 Group:          Libraries
189 Requires:       %{name} = %{version}-%{release}
190
191 %description anonymous
192 This plugin implements the SASL ANONYMOUS mechanism, used for
193 anonymous authentication.
194
195 %description anonymous -l pl.UTF-8
196 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
197 anonimowego uwierzytelniania.
198
199 %description anonymous -l pt_BR.UTF-8
200 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
201 autenticação anônima.
202
203 %package cram-md5
204 Summary:        Cram-MD5 Cyrus SASL plugin
205 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
206 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
207 Group:          Libraries
208 Requires:       %{name} = %{version}-%{release}
209
210 %description cram-md5
211 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
212 mandatory-to-implement authentication mechanism for a number of
213 protocols; it uses MD5 with a challenge/response system to
214 authenticate the user.
215
216 %description cram-md5 -l pl.UTF-8
217 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
218 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
219 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
220 systemem challenge/response.
221
222 %description cram-md5 -l pt_BR.UTF-8
223 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
224 mecanismo de autenticação obrigatório de ser implementado para vários
225 protocolos: ele usa MD5 com um sistema de desafio/resposta para
226 autenticar o usuário.
227
228 %package digest-md5
229 Summary:        Digest-MD5 Cyrus SASL plugin
230 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
231 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
232 Group:          Libraries
233 Requires:       %{name} = %{version}-%{release}
234
235 %description digest-md5
236 This plugin implements the latest draft of the SASL DIGEST-MD5
237 mechanism. Although not yet finalized, this is likely to become the
238 new mandatory-to-implement authentication system in all new protocols.
239 It's based on the digest md5 authentication system designed for HTTP.
240
241 %description digest-md5 -l pl.UTF-8
242 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
243 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
244 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
245 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
246 Digest-MD5 zaprojektowanym dla HTTP.
247
248 %description digest-md5 -l pt_BR.UTF-8
249 Este plugin implementa a última versão da especificação do mecanismo
250 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
251 provavelmente será o novo sistema de autenticação obrigatório para
252 protocolos novos. Ele é baseado na autenticação md5 digest
253 desenvolvida para HTTP.
254
255 %package gssapi
256 Summary:        GSSAPI Cyrus SASL plugin
257 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
258 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
259 Group:          Libraries
260 Requires:       %{name} = %{version}-%{release}
261
262 %description gssapi
263 This plugin implements the SASL GSSAPI mechanism, used for
264 GSSAPI/Kerberos5 authentication.
265
266 %description gssapi -l pl.UTF-8
267 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
268 uwierzytelniania z użyciem GSSAPI/Kerberos5.
269
270 %description gssapi -l pt_BR.UTF-8
271 Este plugin implementa o mecanismo SASL GSSAPI, usado para
272 autenticação Kerberos/GSSAPI.
273
274 %package login
275 Summary:        Unsupported Login Cyrus SASL plugin
276 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
277 Group:          Libraries
278 Requires:       %{name} = %{version}-%{release}
279
280 %description login
281 Unsupported LOGIN Cyrus SASL plugin.
282
283 %description login -l pl.UTF-8
284 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
285 SASL.
286
287 %package mysql
288 Summary:        Cyrus SASL MySQL plugin
289 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
290 Group:          Libraries
291 Requires:       %{name} = %{version}-%{release}
292
293 %description mysql
294 Cyrus SASL MySQL plugin.
295
296 %description mysql -l pl.UTF-8
297 Wtyczka MySQL do Cyrus SASL.
298
299 %package otp
300 Summary:        OTP Cyrus SASL plugin
301 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
302 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
303 Group:          Libraries
304 Requires:       %{name} = %{version}-%{release}
305 Obsoletes:      cyrus-sasl-opie < %{version}
306
307 %description otp
308 This plugin implements the SASL OTP (One Time Password) mechanism.
309
310 %description otp -l pl.UTF-8
311 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
312 SASL.
313
314 %package pgsql
315 Summary:        Cyrus SASL PostgreSQL plugin
316 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
317 Group:          Libraries
318 Requires:       %{name} = %{version}-%{release}
319
320 %description pgsql
321 Cyrus SASL PostgreSQL plugin.
322
323 %description pgsql -l pl.UTF-8
324 Wtyczka PostgreSQL do Cyrus SASL.
325
326 %package plain
327 Summary:        Plain Cyrus SASL plugin
328 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
329 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
330 Group:          Libraries
331 Requires:       %{name} = %{version}-%{release}
332
333 %description plain
334 This plugin implements the SASL PLAIN mechanism. Although insecure,
335 PLAIN is useful for transitioning to new security mechanisms, as this
336 is the only mechanism which gives the server a copy of the user's
337 password.
338
339 %description plain -l pl.UTF-8
340 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
341 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
342 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
343 który udostępnia serwerowi kopię hasła użytkownika.
344
345 %description plain -l pt_BR.UTF-8
346 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
347 mecanismo é útil durante transições para novos mecanismos de
348 segurança, pois é o único esquema que fornece uma cópia da senha do
349 usuário para o servidor.
350
351 %package sasldb
352 Summary:        Cyrus SASL sasldb plugin
353 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
354 Group:          Libraries
355 Requires:       %{name} = %{version}-%{release}
356
357 %description sasldb
358 Cyrus SASL sasldb plugin.
359
360 %description sasldb -l pl.UTF-8
361 Wtyczka sasldb do Cyrus SASL.
362
363 %package ldapdb
364 Summary:        Cyrus SASL LDAPDB plugin
365 Summary(pl.UTF-8):      Wtyczka LDAPDB do Cyrus SASL
366 Group:          Libraries
367 Requires:       %{name} = %{version}-%{release}
368
369 %description ldapdb
370 Cyrus SASL ldapdb plugin.
371
372 %description ldapdb -l pl.UTF-8
373 Wtyczka ldapdb do Cyrus SASL.
374
375 %package passdss
376 Summary:        PASSDSS Cyrus SASL plugin
377 Summary(pl.UTF-8):      Wtyczka PASSDSS do Cyrus SASL
378 Summary(pt_BR.UTF-8):   Mecanismo SASL PASSDSS
379 Group:          Libraries
380 Requires:       %{name} = %{version}-%{release}
381
382 %description passdss
383 This plugin implements the PASSDSS 3DES mechanism.
384
385 %description passdss -l pl.UTF-8
386 Wtyczka dodająca obsługę mechanizmu PASSDSS 3DES do Cyrus SASL.
387
388 %description passdss -l pt_BR.UTF-8
389 Este plugin implementa o mecanismo SASL PASSDSS 3DES.
390
391 %package scram
392 Summary:        SCRAM Cyrus SASL plugin
393 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
394 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
395 Group:          Libraries
396 Requires:       %{name} = %{version}-%{release}
397
398 %description scram
399 This plugin implements the SASL SCRAM-MD5 mechanism.
400
401 %description scram -l pl.UTF-8
402 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
403
404 %description scram -l pt_BR.UTF-8
405 Este plugin implementa o mecanismo SASL SCRAM.
406
407 %package sqlite
408 Summary:        Cyrus SQLite 2 PostgreSQL plugin
409 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
410 Group:          Libraries
411 Requires:       %{name} = %{version}-%{release}
412
413 %description sqlite
414 Cyrus SASL SQLite 2 plugin.
415
416 %description sqlite -l pl.UTF-8
417 Wtyczka SQLite 2 do Cyrus SASL.
418
419 %package sqlite3
420 Summary:        Cyrus SQLite 3 PostgreSQL plugin
421 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
422 Group:          Libraries
423 Requires:       %{name} = %{version}-%{release}
424
425 %description sqlite3
426 Cyrus SASL SQLite 3 plugin.
427
428 %description sqlite3 -l pl.UTF-8
429 Wtyczka SQLite 3 do Cyrus SASL.
430
431 %package srp
432 Summary:        SRP Cyrus SASL plugin
433 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
434 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
435 Group:          Libraries
436 Requires:       %{name} = %{version}-%{release}
437
438 %description srp
439 This plugin implements the SASL SRP mechanism, based on the Secure
440 Remote Password protocol. This mechanism performs mutual
441 authentication and can provide a security layer with replay detection,
442 integrity protection and/or condifentiality protection.
443
444 %description srp -l pl.UTF-8
445 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
446 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
447 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
448 powtarzania, zabezpieczeniem integralności i/lub poufności.
449
450 %description srp -l pt_BR.UTF-8
451 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
452 (Secure Remote Password). Este mecanismo oferece autenticação mútua
453 (do cliente e do servidor) e pode prover uma camada de segurança com
454 detecção de ataques de replay, garantia de integridade e/ou
455 confidencialidade.
456
457 %package pwcheck
458 Summary:        Cyrus SASL pwcheck helper
459 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
460 Group:          Libraries
461 Requires:       %{name} = %{version}-%{release}
462
463 %description pwcheck
464 Cyrus SASL pwcheck helper.
465
466 %description pwcheck -l pl.UTF-8
467 Program pomocniczy pwcheck do Cyrus SASL.
468
469 %package saslauthd
470 Summary:        Cyrus SASL authd
471 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
472 Group:          Daemons
473 Requires(post,preun):   /sbin/chkconfig
474 Requires:       %{name} = %{version}-%{release}
475 Requires:       /sbin/chkconfig
476 Requires:       rc-scripts
477
478 %description saslauthd
479 Cyrus SASL authd.
480
481 %description saslauthd -l pl.UTF-8
482 Demon authd do Cyrus SASL.
483
484 %package -n nagios-plugin-check_saslauthd
485 Summary:        Nagios plugin to check health of saslauthd
486 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
487 Group:          Networking
488 Requires:       nagios-core
489
490 %description -n nagios-plugin-check_saslauthd
491 Nagios plugin to check health of saslauthd.
492
493 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
494 Wtyczka Nagiosa do sprawdzania działania saslauthd.
495
496 %prep
497 %setup -q
498 %patch0 -p1
499 %patch1 -p1
500 %patch2 -p1
501 %patch3 -p1
502 %patch4 -p1
503 %if %{with cryptedpw}
504 %patch5 -p1
505 %patch6 -p1
506 %endif
507 %patch7 -p1
508 %patch8 -p1
509 %patch9 -p1
510 %patch10 -p1
511 %patch11 -p1
512 %patch12 -p1
513 %patch13 -p0
514 %patch14 -p1
515 %patch15 -p1
516 %patch16 -p1
517 %patch17 -p1
518 %patch18 -p1
519 %patch19 -p1
520 %patch20 -p1
521 %patch21 -p1
522 %patch22 -p1
523
524 cd doc
525 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
526 ls rfc*.txt >> rfc-compliance
527 rm -f rfc*.txt
528 cd ..
529
530 # old version
531 %{__rm} config/libtool.m4
532
533 # update to our paths
534 sed -i -e '
535         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
536         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
537         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
538         s,/var/state/saslauthd,/var/lib/sasl2,g
539 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
540
541 %build
542 %{__libtoolize}
543 %{__aclocal} -I cmulocal -I config
544 %{__autoheader}
545 %{__autoconf}
546 %{__automake}
547 cd saslauthd
548 %{__aclocal} -I ../cmulocal -I ../config
549 %{__autoheader}
550 %{__autoconf}
551 %{__automake}
552 cd ..
553 %configure \
554         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
555         --disable-krb4 \
556         %{!?with_gssapi: --disable-gssapi} \
557         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
558         --enable-login \
559         --enable-sample \
560         --enable-httpform \
561         --enable-sql \
562         --enable-passdss \
563         %{?with_srp: --enable-srp} \
564         --enable-static \
565         --with-plugindir=%{_libdir}/sasl2 \
566         --with-configdir=%{_sysconfdir} \
567         --with-dblib=berkeley \
568         --with-dbpath=/var/lib/sasl2/sasl.db \
569         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
570         %{?with_ldap: --with-ldap=%{_prefix}} \
571         %{?with_ldap: --enable-ldapdb} \
572         %{?with_mysql: --with-mysql=%{_prefix}} \
573         %{?with_pgsql: --with-pgsql=%{_prefix}} \
574         %{?with_sqlite: --with-sqlite=%{_prefix}} \
575         %{?with_sqlite3: --with-sqlite3=%{_prefix}} \
576         %{?with_opie: --with-opie=%{_prefix}} \
577         --with-pam \
578         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
579         --with-saslauthd=/var/lib/sasl2
580
581 %{__make}
582
583 %{__make} -C saslauthd testsaslauthd
584 %{__make} -C saslauthd saslcache
585 %{__make} -C sample sample-client sample-server
586
587 cd doc
588 RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
589 for i in $RFCLIST; do
590         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
591         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
592 done
593
594 %install
595 rm -rf $RPM_BUILD_ROOT
596 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
597                 $RPM_BUILD_ROOT%{_mandir}/man8
598
599 %{__make} install \
600         sasldir=%{_libdir}/sasl2 \
601         DESTDIR=$RPM_BUILD_ROOT
602
603 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
604
605 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
606 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
607
608 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
609
610 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
611
612 # create empty config
613 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
614 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
615 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
616 cp -a %{SOURCE3} cyrus.pam
617
618 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
619
620 # sample programs for testing sasl
621 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
622 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
623
624 # package for ghost
625 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
626
627 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
628 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
629
630 %clean
631 rm -rf $RPM_BUILD_ROOT
632
633 %post   libs -p /sbin/ldconfig
634 %postun libs -p /sbin/ldconfig
635
636 %post saslauthd
637 /sbin/chkconfig --add saslauthd
638 %service saslauthd restart
639
640 %preun saslauthd
641 if [ "$1" = "0" ]; then
642         %service saslauthd stop
643         /sbin/chkconfig --del saslauthd
644 fi
645
646 %triggerin saslauthd -- pam
647 # restart saslauthd if pam is upgraded
648 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
649 if [ "$2" != 1 ]; then
650         %service -q saslauthd restart
651 fi
652
653 %files
654 %defattr(644,root,root,755)
655 %doc AUTHORS COPYING ChangeLog NEWS README
656 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
657 %dir %{_sysconfdir}
658 %dir %{_libdir}/sasl2
659 # sample programs to subpackage instead?
660 %attr(755,root,root) %{_bindir}/sasl-sample-client
661 %attr(755,root,root) %{_bindir}/sasl-sample-server
662 %attr(755,root,root) %{_sbindir}/pluginviewer
663 %attr(755,root,root) %{_sbindir}/sasldblistusers2
664 %attr(755,root,root) %{_sbindir}/saslpasswd2
665 %dir /var/lib/sasl2
666 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
667 %{_mandir}/man8/pluginviewer.8*
668 %{_mandir}/man8/sasldblistusers2.8*
669 %{_mandir}/man8/saslpasswd2.8*
670
671 %files libs
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
674 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
675
676 %files devel
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/libsasl2.so
679 %attr(755,root,root) %{_libdir}/libsasl.so
680 %{_libdir}/libsasl2.la
681 %{_includedir}/sasl
682 %{_mandir}/man3/sasl*.3*
683
684 %files static
685 %defattr(644,root,root,755)
686 %{_libdir}/libsasl2.a
687
688 %files anonymous
689 %defattr(644,root,root,755)
690 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
691
692 %if %{with gssapi}
693 %files gssapi
694 %defattr(644,root,root,755)
695 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
696 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
697 %endif
698
699 %files cram-md5
700 %defattr(644,root,root,755)
701 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
702
703 %files digest-md5
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
706
707 %files login
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
710
711 %if %{with mysql}
712 %files mysql
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
715 %endif
716
717 %files otp
718 %defattr(644,root,root,755)
719 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
720
721 %if %{with pgsql}
722 %files pgsql
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
725 %endif
726
727 %files plain
728 %defattr(644,root,root,755)
729 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
730
731 %files sasldb
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
734
735 %if %{with ldap}
736 %files ldapdb
737 %defattr(644,root,root,755)
738 %attr(755,root,root) %{_libdir}/sasl2/libldapdb.so*
739 %endif
740
741 %files passdss
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_libdir}/sasl2/libpassdss.so*
744
745 %files scram
746 %defattr(644,root,root,755)
747 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
748
749 %if %{with sqlite}
750 %files sqlite
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
753 %endif
754
755 %if %{with sqlite3}
756 %files sqlite3
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
759 %endif
760
761 %if %{with srp}
762 %files srp
763 %defattr(644,root,root,755)
764 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
765 %endif
766
767 %if %{with pwcheck}
768 %files pwcheck
769 %defattr(644,root,root,755)
770 %attr(755,root,root) %{_sbindir}/pwcheck
771 %endif
772
773 %files saslauthd
774 %defattr(644,root,root,755)
775 %doc cyrus.pam
776 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
777 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
778 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
779 %attr(755,root,root) %{_sbindir}/saslauthd
780 %attr(755,root,root) %{_sbindir}/testsaslauthd
781 %attr(755,root,root) %{_sbindir}/saslcache
782 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
783 %ghost /var/lib/sasl2/cache.flock
784 %ghost /var/lib/sasl2/cache.mmap
785 %ghost /var/lib/sasl2/mux
786 %ghost /var/lib/sasl2/mux.accept
787 %ghost /var/lib/sasl2/saslauthd.pid
788 %{_mandir}/man8/saslauthd.8*
789
790 %files -n nagios-plugin-check_saslauthd
791 %defattr(644,root,root,755)
792 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
793 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.088522 seconds and 2 git commands to generate.