]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- rel 8; build with openssl 1.1.1
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 #
2 # Conditional build:
3 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
4 %bcond_without  ldap            # disable LDAP support for saslauthd
5 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
6 %bcond_without  mysql           # don't build MySQL plugin
7 %bcond_without  ntlm            # do not build NTLM plugin
8 %bcond_without  pgsql           # do not build PostgreSQL plugin
9 %bcond_without  sqlite          # do not enable sqlite 2 plugin
10 %bcond_without  sqlite3         # do not enable sqlite 3 plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # OTP plugin using opie library instead of internal code
13 %bcond_with     srp             # build srp plugin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 #
16 %if %{without mysql} && %{without pgsql}
17 %undefine with_cryptedpw
18 %endif
19
20 Summary:        The SASL library API for the Cyrus mail system
21 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
22 Summary(pt_BR.UTF-8):   Implementação da API SASL
23 Summary(ru.UTF-8):      Библиотека Cyrus SASL
24 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
25 Name:           cyrus-sasl
26 Version:        2.1.26
27 Release:        8
28 License:        distributable
29 Group:          Libraries
30 Source0:        ftp://ftp.cyrusimap.org/cyrus-sasl/%{name}-%{version}.tar.gz
31 # Source0-md5:  a7f4e5e559a0e37b3ffc438c9456e425
32 Source1:        saslauthd.init
33 Source2:        saslauthd.sysconfig
34 Source3:        %{name}.pam
35 Source4:        check_saslauthd.cfg
36 Patch0:         %{name}-nolibs.patch
37 Patch1:         %{name}-lt.patch
38 Patch2:         %{name}-split-sql.patch
39 Patch3:         %{name}-opie.patch
40 Patch4:         %{name}-gcc4.patch
41 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
42 Patch5:         %{name}-cryptedpw.patch
43 Patch6:         %{name}-md5sum-passwords.patch
44 Patch7:         %{name}-db.patch
45 Patch8:         %{name}-keytab.patch
46 Patch9:         %{name}-sizes.patch
47 Patch10:        %{name}-nagios-plugin.patch
48 Patch11:        %{name}-parallel-make.patch
49 Patch12:        %{name}-gssapi-detect.patch
50 Patch13:        %{name}-saslauthd-httpform-urlescape.patch
51 Patch14:        %{name}-ac-libs.patch
52 Patch15:        %{name}-pam.patch
53 Patch16:        %{name}-gssapi_ext.patch
54 Patch17:        0032-revert_1.103_revision_to_unbreak_GSSAPI.patch
55 Patch18:        0033-fix_segfault_in_GSSAPI.patch
56 Patch19:        0034-fix_dovecot_authentication.patch
57 Patch20:        %{name}-auxprop.patch
58 Patch21:        0030-dont_use_la_files_for_opening_plugins.patch
59 Patch22:        %{name}-stddef.patch
60 Patch23:        http://sourceforge.net/projects/miscellaneouspa/files/glibc217/cyrus-sasl-2.1.26-glibc217-crypt.diff
61 Patch24:        cyrus-sasl-2.1.27-openssl-1.1.0.patch
62 URL:            http://asg.web.cmu.edu/sasl/
63 BuildRequires:  autoconf >= 2.54
64 BuildRequires:  automake >= 1:1.7
65 %{?with_authlib:BuildRequires:  courier-authlib-devel}
66 BuildRequires:  db-devel
67 BuildRequires:  ed
68 BuildRequires:  groff
69 %{?with_gssapi:BuildRequires:   heimdal-devel}
70 BuildRequires:  libtool >= 1.4
71 %{?with_mysql:BuildRequires:    mysql-devel}
72 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
73 BuildRequires:  openssl-devel >= 0.9.7d
74 %{?with_opie:BuildRequires:     opie-devel}
75 BuildRequires:  pam-devel
76 %{?with_pgsql:BuildRequires:    postgresql-devel}
77 BuildRequires:  rpmbuild(macros) >= 1.268
78 %{?with_sqlite:BuildRequires:   sqlite-devel}
79 %{?with_sqlite3:BuildRequires:  sqlite3-devel >= 3}
80 Requires:       pam >= 0.79.0
81 Requires:       %{name}-libs = %{version}-%{release}
82 Obsoletes:      cyrus-sasl-x509 < %{version}
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         _sysconfdir     /etc/sasl
86
87 %define         specflags       -fno-strict-aliasing
88
89 %description
90 This is an implementation of the SASL API, useful for adding
91 authentication, authorization, and security to network protocols. The
92 SASL protocol itself is documented in rfc2222; the API standard is a
93 work in progress.
94
95 Note: remember to install appropriate plugins, or you won't have any
96 authentication mechanisms available.
97
98 %description -l pl.UTF-8
99 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
100 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
101 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
102 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
103 RFC 2222; standaryzacja API jest w toku.
104
105 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
106 doinstalować odpowiednie wtyczki.
107
108 %description -l pt_BR.UTF-8
109 Esta é uma implementação da API SASL, útil para acrescentar
110 autenticação, autorização e seguança (criptografia) para protocolos de
111 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
112 ainda está em desenvolvimento.
113
114 %description -l ru.UTF-8
115 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
116 Authentication and Security Layer, метод для добавления поддержки
117 аутентикации к протоколам, основанным на соединениях.
118
119 %description -l uk.UTF-8
120 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
121 Authentication and Security Layer, метод для додання підтримки
122 аутентикації до протоколів, базованих на з'єднаннях.
123
124 %package libs
125 Summary:        cyrus-sasl library itself
126 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
127 Group:          Libraries
128 Requires(post,postun):  /sbin/ldconfig
129 Conflicts:      cyrus-sasl < 2.1.23-8
130
131 %description libs
132 cyrus-sasl library itself.
133
134 %description libs -l pl.UTF-8
135 Sama biblioteka cyrus-sasl.
136
137 %package devel
138 Summary:        Header files and documentation for cyrus-sasl
139 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
140 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
141 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
142 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
143 Group:          Development/Libraries
144 Requires:       %{name} = %{version}-%{release}
145
146 %description devel
147 This includes the header files and documentation needed to develop
148 applications which use SASL.
149
150 %description devel -l pl.UTF-8
151 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
152
153 %description devel -l pt_BR.UTF-8
154 Este pacote inclui os arquivos de cabeçalho e documentação necessários
155 para desenvolver aplicativos que usem SASL.
156
157 %description devel -l ru.UTF-8
158 Хедеры и библиотеки, необходимые для разработки приложений,
159 использующих Cyrus SASL.
160
161 %description devel -l uk.UTF-8
162 Хедери та бібліотеки, необхідні для розробки програм, що
163 використовують Cyrus SASL.
164
165 %package static
166 Summary:        Static cyrus-sasl libraries
167 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
168 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
169 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
170 Group:          Development/Libraries
171 Requires:       %{name}-devel = %{version}-%{release}
172
173 %description static
174 Static cyrus-sasl libraries.
175
176 %description static -l pl.UTF-8
177 Statyczne biblioteki cyrus-sasl.
178
179 %description static -l ru.UTF-8
180 Статические библиотеки, необходимые для разработки приложений,
181 использующих Cyrus SASL.
182
183 %description static -l uk.UTF-8
184 Статичні бібліотеки, необхідні для розробки програм, що використовують
185 Cyrus SASL.
186
187 %package anonymous
188 Summary:        Anonymous Cyrus SASL plugin
189 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
190 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
191 Group:          Libraries
192 Requires:       %{name} = %{version}-%{release}
193
194 %description anonymous
195 This plugin implements the SASL ANONYMOUS mechanism, used for
196 anonymous authentication.
197
198 %description anonymous -l pl.UTF-8
199 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
200 anonimowego uwierzytelniania.
201
202 %description anonymous -l pt_BR.UTF-8
203 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
204 autenticação anônima.
205
206 %package cram-md5
207 Summary:        Cram-MD5 Cyrus SASL plugin
208 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
209 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
210 Group:          Libraries
211 Requires:       %{name} = %{version}-%{release}
212
213 %description cram-md5
214 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
215 mandatory-to-implement authentication mechanism for a number of
216 protocols; it uses MD5 with a challenge/response system to
217 authenticate the user.
218
219 %description cram-md5 -l pl.UTF-8
220 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
221 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
222 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
223 systemem challenge/response.
224
225 %description cram-md5 -l pt_BR.UTF-8
226 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
227 mecanismo de autenticação obrigatório de ser implementado para vários
228 protocolos: ele usa MD5 com um sistema de desafio/resposta para
229 autenticar o usuário.
230
231 %package digest-md5
232 Summary:        Digest-MD5 Cyrus SASL plugin
233 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
234 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
235 Group:          Libraries
236 Requires:       %{name} = %{version}-%{release}
237
238 %description digest-md5
239 This plugin implements the latest draft of the SASL DIGEST-MD5
240 mechanism. Although not yet finalized, this is likely to become the
241 new mandatory-to-implement authentication system in all new protocols.
242 It's based on the digest md5 authentication system designed for HTTP.
243
244 %description digest-md5 -l pl.UTF-8
245 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
246 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
247 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
248 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
249 Digest-MD5 zaprojektowanym dla HTTP.
250
251 %description digest-md5 -l pt_BR.UTF-8
252 Este plugin implementa a última versão da especificação do mecanismo
253 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
254 provavelmente será o novo sistema de autenticação obrigatório para
255 protocolos novos. Ele é baseado na autenticação md5 digest
256 desenvolvida para HTTP.
257
258 %package gssapi
259 Summary:        GSSAPI Cyrus SASL plugin
260 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
261 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
262 Group:          Libraries
263 Requires:       %{name} = %{version}-%{release}
264
265 %description gssapi
266 This plugin implements the SASL GSSAPI mechanism, used for
267 GSSAPI/Kerberos5 authentication.
268
269 %description gssapi -l pl.UTF-8
270 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
271 uwierzytelniania z użyciem GSSAPI/Kerberos5.
272
273 %description gssapi -l pt_BR.UTF-8
274 Este plugin implementa o mecanismo SASL GSSAPI, usado para
275 autenticação Kerberos/GSSAPI.
276
277 %package login
278 Summary:        Unsupported Login Cyrus SASL plugin
279 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
280 Group:          Libraries
281 Requires:       %{name} = %{version}-%{release}
282
283 %description login
284 Unsupported LOGIN Cyrus SASL plugin.
285
286 %description login -l pl.UTF-8
287 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
288 SASL.
289
290 %package mysql
291 Summary:        Cyrus SASL MySQL plugin
292 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
293 Group:          Libraries
294 Requires:       %{name} = %{version}-%{release}
295
296 %description mysql
297 Cyrus SASL MySQL plugin.
298
299 %description mysql -l pl.UTF-8
300 Wtyczka MySQL do Cyrus SASL.
301
302 %package ntlm
303 Summary:        Cyrus SASL NTLM plugin
304 Summary(pl.UTF-8):      Wtyczka NTLM do Cyrus SASL
305 Group:          Libraries
306 Requires:       %{name} = %{version}-%{release}
307
308 %description ntlm
309 Cyrus SASL NTLM plugin.
310
311 %description ntlm -l pl.UTF-8
312 Wtyczka NTLM do Cyrus SASL.
313
314 %package otp
315 Summary:        OTP Cyrus SASL plugin
316 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
317 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
318 Group:          Libraries
319 Requires:       %{name} = %{version}-%{release}
320 Obsoletes:      cyrus-sasl-opie < %{version}
321
322 %description otp
323 This plugin implements the SASL OTP (One Time Password) mechanism.
324
325 %description otp -l pl.UTF-8
326 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
327 SASL.
328
329 %package pgsql
330 Summary:        Cyrus SASL PostgreSQL plugin
331 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
332 Group:          Libraries
333 Requires:       %{name} = %{version}-%{release}
334
335 %description pgsql
336 Cyrus SASL PostgreSQL plugin.
337
338 %description pgsql -l pl.UTF-8
339 Wtyczka PostgreSQL do Cyrus SASL.
340
341 %package plain
342 Summary:        Plain Cyrus SASL plugin
343 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
344 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
345 Group:          Libraries
346 Requires:       %{name} = %{version}-%{release}
347
348 %description plain
349 This plugin implements the SASL PLAIN mechanism. Although insecure,
350 PLAIN is useful for transitioning to new security mechanisms, as this
351 is the only mechanism which gives the server a copy of the user's
352 password.
353
354 %description plain -l pl.UTF-8
355 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
356 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
357 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
358 który udostępnia serwerowi kopię hasła użytkownika.
359
360 %description plain -l pt_BR.UTF-8
361 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
362 mecanismo é útil durante transições para novos mecanismos de
363 segurança, pois é o único esquema que fornece uma cópia da senha do
364 usuário para o servidor.
365
366 %package sasldb
367 Summary:        Cyrus SASL sasldb plugin
368 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
369 Group:          Libraries
370 Requires:       %{name} = %{version}-%{release}
371
372 %description sasldb
373 Cyrus SASL sasldb plugin.
374
375 %description sasldb -l pl.UTF-8
376 Wtyczka sasldb do Cyrus SASL.
377
378 %package ldapdb
379 Summary:        Cyrus SASL LDAPDB plugin
380 Summary(pl.UTF-8):      Wtyczka LDAPDB do Cyrus SASL
381 Group:          Libraries
382 Requires:       %{name} = %{version}-%{release}
383
384 %description ldapdb
385 Cyrus SASL ldapdb plugin.
386
387 %description ldapdb -l pl.UTF-8
388 Wtyczka ldapdb do Cyrus SASL.
389
390 %package passdss
391 Summary:        PASSDSS Cyrus SASL plugin
392 Summary(pl.UTF-8):      Wtyczka PASSDSS do Cyrus SASL
393 Summary(pt_BR.UTF-8):   Mecanismo SASL PASSDSS
394 Group:          Libraries
395 Requires:       %{name} = %{version}-%{release}
396
397 %description passdss
398 This plugin implements the PASSDSS 3DES mechanism.
399
400 %description passdss -l pl.UTF-8
401 Wtyczka dodająca obsługę mechanizmu PASSDSS 3DES do Cyrus SASL.
402
403 %description passdss -l pt_BR.UTF-8
404 Este plugin implementa o mecanismo SASL PASSDSS 3DES.
405
406 %package scram
407 Summary:        SCRAM Cyrus SASL plugin
408 Summary(pl.UTF-8):      Wtyczka SCRAM do Cyrus SASL
409 Summary(pt_BR.UTF-8):   Mecanismo SASL SCRAM
410 Group:          Libraries
411 Requires:       %{name} = %{version}-%{release}
412
413 %description scram
414 This plugin implements the SASL SCRAM-MD5 mechanism.
415
416 %description scram -l pl.UTF-8
417 Wtyczka dodająca obsługę mechanizmu SCRAM do Cyrus SASL.
418
419 %description scram -l pt_BR.UTF-8
420 Este plugin implementa o mecanismo SASL SCRAM.
421
422 %package sqlite
423 Summary:        Cyrus SQLite 2 PostgreSQL plugin
424 Summary(pl.UTF-8):      Wtyczka SQLite 2 do Cyrus SASL
425 Group:          Libraries
426 Requires:       %{name} = %{version}-%{release}
427
428 %description sqlite
429 Cyrus SASL SQLite 2 plugin.
430
431 %description sqlite -l pl.UTF-8
432 Wtyczka SQLite 2 do Cyrus SASL.
433
434 %package sqlite3
435 Summary:        Cyrus SQLite 3 PostgreSQL plugin
436 Summary(pl.UTF-8):      Wtyczka SQLite 3 do Cyrus SASL
437 Group:          Libraries
438 Requires:       %{name} = %{version}-%{release}
439
440 %description sqlite3
441 Cyrus SASL SQLite 3 plugin.
442
443 %description sqlite3 -l pl.UTF-8
444 Wtyczka SQLite 3 do Cyrus SASL.
445
446 %package srp
447 Summary:        SRP Cyrus SASL plugin
448 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
449 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
450 Group:          Libraries
451 Requires:       %{name} = %{version}-%{release}
452
453 %description srp
454 This plugin implements the SASL SRP mechanism, based on the Secure
455 Remote Password protocol. This mechanism performs mutual
456 authentication and can provide a security layer with replay detection,
457 integrity protection and/or condifentiality protection.
458
459 %description srp -l pl.UTF-8
460 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
461 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
462 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
463 powtarzania, zabezpieczeniem integralności i/lub poufności.
464
465 %description srp -l pt_BR.UTF-8
466 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
467 (Secure Remote Password). Este mecanismo oferece autenticação mútua
468 (do cliente e do servidor) e pode prover uma camada de segurança com
469 detecção de ataques de replay, garantia de integridade e/ou
470 confidencialidade.
471
472 %package pwcheck
473 Summary:        Cyrus SASL pwcheck helper
474 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
475 Group:          Libraries
476 Requires:       %{name} = %{version}-%{release}
477
478 %description pwcheck
479 Cyrus SASL pwcheck helper.
480
481 %description pwcheck -l pl.UTF-8
482 Program pomocniczy pwcheck do Cyrus SASL.
483
484 %package saslauthd
485 Summary:        Cyrus SASL authd
486 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
487 Group:          Daemons
488 Requires(post,preun):   /sbin/chkconfig
489 Requires:       %{name} = %{version}-%{release}
490 Requires:       /sbin/chkconfig
491 Requires:       rc-scripts
492
493 %description saslauthd
494 Cyrus SASL authd.
495
496 %description saslauthd -l pl.UTF-8
497 Demon authd do Cyrus SASL.
498
499 %package -n nagios-plugin-check_saslauthd
500 Summary:        Nagios plugin to check health of saslauthd
501 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
502 Group:          Networking
503 Requires:       nagios-core
504
505 %description -n nagios-plugin-check_saslauthd
506 Nagios plugin to check health of saslauthd.
507
508 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
509 Wtyczka Nagiosa do sprawdzania działania saslauthd.
510
511 %prep
512 %setup -q
513 %patch0 -p1
514 %patch1 -p1
515 %patch2 -p1
516 %patch3 -p1
517 %patch4 -p1
518 %if %{with cryptedpw}
519 %patch5 -p1
520 %patch6 -p1
521 %endif
522 %patch7 -p1
523 %patch8 -p1
524 %patch9 -p1
525 %patch10 -p1
526 %patch11 -p1
527 %patch12 -p1
528 %patch13 -p0
529 %patch14 -p1
530 %patch15 -p1
531 %patch16 -p1
532 %patch17 -p1
533 %patch18 -p1
534 %patch19 -p1
535 %patch20 -p1
536 %patch21 -p1
537 %patch22 -p1
538 %patch23 -p1
539 %patch24 -p1
540
541 cd doc
542 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
543 ls rfc*.txt >> rfc-compliance
544 rm -f rfc*.txt
545 cd ..
546
547 # old version
548 %{__rm} config/libtool.m4
549
550 # update to our paths
551 sed -i -e '
552         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
553         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
554         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
555         s,/var/state/saslauthd,/var/lib/sasl2,g
556 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
557
558 %build
559 %{__libtoolize}
560 %{__aclocal} -I cmulocal -I config
561 %{__autoheader}
562 %{__autoconf}
563 %{__automake}
564 cd saslauthd
565 %{__aclocal} -I ../cmulocal -I ../config
566 %{__autoheader}
567 %{__autoconf}
568 %{__automake}
569 cd ..
570 %configure \
571         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
572         --disable-krb4 \
573         %{!?with_gssapi:--disable-gssapi} \
574         %{?with_gssapi:--enable-gssapi --with-gss_impl=heimdal} \
575         --enable-login \
576         --enable-sample \
577         --enable-httpform \
578         --enable-sql \
579         --enable-passdss \
580         %{?with_srp:--enable-srp} \
581         --enable-static \
582         --with-plugindir=%{_libdir}/sasl2 \
583         --with-configdir=%{_sysconfdir} \
584         --with-dblib=berkeley \
585         --with-dbpath=/var/lib/sasl2/sasl.db \
586         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
587         %{?with_ldap:--with-ldap=%{_prefix}} \
588         %{?with_ldap:--enable-ldapdb} \
589         %{?with_mysql:--with-mysql=%{_prefix}} \
590         %{?with_ntlm:--enable-ntlm} \
591         %{?with_pgsql:--with-pgsql=%{_prefix}} \
592         %{?with_sqlite:--with-sqlite=%{_prefix}} \
593         %{?with_sqlite3:--with-sqlite3=%{_prefix}} \
594         %{?with_opie:--with-opie=%{_prefix}} \
595         --with-pam \
596         %{?with_pwcheck:--with-pwcheck=/var/lib/sasl2} \
597         --with-saslauthd=/var/lib/sasl2
598
599 %{__make}
600
601 %{__make} -C saslauthd testsaslauthd
602 %{__make} -C saslauthd saslcache
603 %{__make} -C sample sample-client sample-server
604
605 cd doc
606 RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
607 for i in $RFCLIST; do
608         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
609         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
610 done
611
612 %install
613 rm -rf $RPM_BUILD_ROOT
614 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
615                 $RPM_BUILD_ROOT%{_mandir}/man8
616
617 %{__make} install \
618         sasldir=%{_libdir}/sasl2 \
619         DESTDIR=$RPM_BUILD_ROOT
620
621 %{__rm} $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
622
623 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
624 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
625
626 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
627
628 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
629
630 # create empty config
631 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
632 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
633 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
634 cp -a %{SOURCE3} cyrus.pam
635
636 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
637
638 # sample programs for testing sasl
639 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
640 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
641
642 # package for ghost
643 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
644
645 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
646 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
647
648 %clean
649 rm -rf $RPM_BUILD_ROOT
650
651 %post   libs -p /sbin/ldconfig
652 %postun libs -p /sbin/ldconfig
653
654 %post saslauthd
655 /sbin/chkconfig --add saslauthd
656 %service saslauthd restart
657
658 %preun saslauthd
659 if [ "$1" = "0" ]; then
660         %service saslauthd stop
661         /sbin/chkconfig --del saslauthd
662 fi
663
664 %triggerin saslauthd -- pam
665 # restart saslauthd if pam is upgraded
666 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
667 if [ "$2" != 1 ]; then
668         %service -q saslauthd restart
669 fi
670
671 %files
672 %defattr(644,root,root,755)
673 %doc AUTHORS COPYING ChangeLog NEWS README
674 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
675 %dir %{_sysconfdir}
676 %dir %{_libdir}/sasl2
677 # sample programs to subpackage instead?
678 %attr(755,root,root) %{_bindir}/sasl-sample-client
679 %attr(755,root,root) %{_bindir}/sasl-sample-server
680 %attr(755,root,root) %{_sbindir}/pluginviewer
681 %attr(755,root,root) %{_sbindir}/sasldblistusers2
682 %attr(755,root,root) %{_sbindir}/saslpasswd2
683 %dir /var/lib/sasl2
684 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
685 %{_mandir}/man8/pluginviewer.8*
686 %{_mandir}/man8/sasldblistusers2.8*
687 %{_mandir}/man8/saslpasswd2.8*
688
689 %files libs
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
692 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.3
693
694 %files devel
695 %defattr(644,root,root,755)
696 %attr(755,root,root) %{_libdir}/libsasl2.so
697 %attr(755,root,root) %{_libdir}/libsasl.so
698 %{_libdir}/libsasl2.la
699 %{_includedir}/sasl
700 %{_pkgconfigdir}/libsasl2.pc
701 %{_mandir}/man3/sasl*.3*
702
703 %files static
704 %defattr(644,root,root,755)
705 %{_libdir}/libsasl2.a
706
707 %files anonymous
708 %defattr(644,root,root,755)
709 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
710
711 %if %{with gssapi}
712 %files gssapi
713 %defattr(644,root,root,755)
714 %attr(755,root,root) %{_libdir}/sasl2/libgs2.so*
715 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
716 %endif
717
718 %files cram-md5
719 %defattr(644,root,root,755)
720 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
721
722 %files digest-md5
723 %defattr(644,root,root,755)
724 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
725
726 %files login
727 %defattr(644,root,root,755)
728 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
729
730 %if %{with mysql}
731 %files mysql
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
734 %endif
735
736 %if %{with ntlm}
737 %files ntlm
738 %defattr(644,root,root,755)
739 %attr(755,root,root) %{_libdir}/sasl2/libntlm.so*
740 %endif
741
742 %files otp
743 %defattr(644,root,root,755)
744 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
745
746 %if %{with pgsql}
747 %files pgsql
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
750 %endif
751
752 %files plain
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
755
756 %files sasldb
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
759
760 %if %{with ldap}
761 %files ldapdb
762 %defattr(644,root,root,755)
763 %attr(755,root,root) %{_libdir}/sasl2/libldapdb.so*
764 %endif
765
766 %files passdss
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{_libdir}/sasl2/libpassdss.so*
769
770 %files scram
771 %defattr(644,root,root,755)
772 %attr(755,root,root) %{_libdir}/sasl2/libscram.so*
773
774 %if %{with sqlite}
775 %files sqlite
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
778 %endif
779
780 %if %{with sqlite3}
781 %files sqlite3
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/sasl2/libsqlite3.so*
784 %endif
785
786 %if %{with srp}
787 %files srp
788 %defattr(644,root,root,755)
789 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
790 %endif
791
792 %if %{with pwcheck}
793 %files pwcheck
794 %defattr(644,root,root,755)
795 %attr(755,root,root) %{_sbindir}/pwcheck
796 %endif
797
798 %files saslauthd
799 %defattr(644,root,root,755)
800 %doc cyrus.pam
801 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
802 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
803 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
804 %attr(755,root,root) %{_sbindir}/saslauthd
805 %attr(755,root,root) %{_sbindir}/testsaslauthd
806 %attr(755,root,root) %{_sbindir}/saslcache
807 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
808 %ghost /var/lib/sasl2/cache.flock
809 %ghost /var/lib/sasl2/cache.mmap
810 %ghost /var/lib/sasl2/mux
811 %ghost /var/lib/sasl2/mux.accept
812 %ghost /var/lib/sasl2/saslauthd.pid
813 %{_mandir}/man8/saslauthd.8*
814
815 %files -n nagios-plugin-check_saslauthd
816 %defattr(644,root,root,755)
817 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
818 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.209275 seconds and 3 git commands to generate.