]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- add -saslauthd-httpform-urlescape.patch from AC-branch
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # enable opie plugin
13 %bcond_with     srp             # build srp pluggin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 %bcond_with     x509            # build x509 plugin (no sources in package???)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.23
28 Release:        7
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
32 # Source0-md5:  2eb0e48106f0e9cd8001e654f267ecbc
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-db.patch
46 Patch8:         %{name}-automake_1_10.patch
47 Patch9:         %{name}-digest-commas.patch
48 Patch10:        %{name}-keytab.patch
49 Patch11:        %{name}-sizes.patch
50 Patch12:        %{name}-nagios-plugin.patch
51 Patch13:        %{name}-parallel-make.patch
52 Patch14:        %{name}-gssapi-detect.patch
53 Patch15:                %{name}-saslauthd-httpform-urlescape.patch
54 URL:            http://asg.web.cmu.edu/sasl/
55 BuildRequires:  autoconf >= 2.54
56 BuildRequires:  automake >= 1:1.7
57 %{?with_authlib:BuildRequires:  courier-authlib-devel}
58 BuildRequires:  db-devel
59 BuildRequires:  ed
60 BuildRequires:  groff
61 %{?with_gssapi:BuildRequires:   heimdal-devel}
62 BuildRequires:  libtool >= 1.4
63 %{?with_mysql:BuildRequires:    mysql-devel}
64 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
65 BuildRequires:  openssl-devel >= 0.9.7d
66 %{?with_opie:BuildRequires:     opie-devel}
67 BuildRequires:  pam-devel
68 %{?with_pgsql:BuildRequires:    postgresql-devel}
69 BuildRequires:  rpmbuild(macros) >= 1.268
70 %{?with_sqlite:BuildRequires:   sqlite-devel}
71 Requires:       pam >= 0.79.0
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _sysconfdir     /etc/sasl
75
76 %define         specflags       -fno-strict-aliasing
77
78 %description
79 This is an implementation of the SASL API, useful for adding
80 authentication, authorization, and security to network protocols. The
81 SASL protocol itself is documented in rfc2222; the API standard is a
82 work in progress.
83
84 Note: remember to install appropriate plugins, or you won't have any
85 authentication mechanisms available.
86
87 %description -l pl.UTF-8
88 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
89 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
90 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
91 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
92 RFC 2222; standaryzacja API jest w toku.
93
94 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
95 doinstalować odpowiednie wtyczki.
96
97 %description -l pt_BR.UTF-8
98 Esta é uma implementação da API SASL, útil para acrescentar
99 autenticação, autorização e seguança (criptografia) para protocolos de
100 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
101 ainda está em desenvolvimento.
102
103 %description -l ru.UTF-8
104 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
105 Authentication and Security Layer, метод для добавления поддержки
106 аутентикации к протоколам, основанным на соединениях.
107
108 %description -l uk.UTF-8
109 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
110 Authentication and Security Layer, метод для додання підтримки
111 аутентикації до протоколів, базованих на з'єднаннях.
112
113 %package devel
114 Summary:        Header files and documentation for cyrus-sasl
115 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
116 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
117 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
118 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
119 Group:          Development/Libraries
120 Requires:       %{name} = %{version}-%{release}
121
122 %description devel
123 This includes the header files and documentation needed to develop
124 applications which use SASL.
125
126 %description devel -l pl.UTF-8
127 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
128
129 %description devel -l pt_BR.UTF-8
130 Este pacote inclui os arquivos de cabeçalho e documentação necessários
131 para desenvolver aplicativos que usem SASL.
132
133 %description devel -l ru.UTF-8
134 Хедеры и библиотеки, необходимые для разработки приложений,
135 использующих Cyrus SASL.
136
137 %description devel -l uk.UTF-8
138 Хедери та бібліотеки, необхідні для розробки програм, що
139 використовують Cyrus SASL.
140
141 %package static
142 Summary:        Static cyrus-sasl libraries
143 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
144 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
145 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
146 Group:          Development/Libraries
147 Requires:       %{name}-devel = %{version}-%{release}
148
149 %description static
150 Static cyrus-sasl libraries.
151
152 %description static -l pl.UTF-8
153 Statyczne biblioteki cyrus-sasl.
154
155 %description static -l ru.UTF-8
156 Статические библиотеки, необходимые для разработки приложений,
157 использующих Cyrus SASL.
158
159 %description static -l uk.UTF-8
160 Статичні бібліотеки, необхідні для розробки програм, що використовують
161 Cyrus SASL.
162
163 %package cram-md5
164 Summary:        Cram-MD5 Cyrus SASL plugin
165 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
166 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
167 Group:          Libraries
168 Requires:       %{name} = %{version}-%{release}
169
170 %description cram-md5
171 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
172 mandatory-to-implement authentication mechanism for a number of
173 protocols; it uses MD5 with a challenge/response system to
174 authenticate the user.
175
176 %description cram-md5 -l pl.UTF-8
177 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
178 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
179 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
180 systemem challenge/response.
181
182 %description cram-md5 -l pt_BR.UTF-8
183 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
184 mecanismo de autenticação obrigatório de ser implementado para vários
185 protocolos: ele usa MD5 com um sistema de desafio/resposta para
186 autenticar o usuário.
187
188 %package digest-md5
189 Summary:        Digest-MD5 Cyrus SASL plugin
190 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
191 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
192 Group:          Libraries
193 Requires:       %{name} = %{version}-%{release}
194
195 %description digest-md5
196 This plugin implements the latest draft of the SASL DIGEST-MD5
197 mechanism. Although not yet finalized, this is likely to become the
198 new mandatory-to-implement authentication system in all new protocols.
199 It's based on the digest md5 authentication system designed for HTTP.
200
201 %description digest-md5 -l pl.UTF-8
202 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
203 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
204 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
205 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
206 Digest-MD5 zaprojektowanym dla HTTP.
207
208 %description digest-md5 -l pt_BR.UTF-8
209 Este plugin implementa a última versão da especificação do mecanismo
210 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
211 provavelmente será o novo sistema de autenticação obrigatório para
212 protocolos novos. Ele é baseado na autenticação md5 digest
213 desenvolvida para HTTP.
214
215 %package plain
216 Summary:        Plain Cyrus SASL plugin
217 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
218 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
219 Group:          Libraries
220 Requires:       %{name} = %{version}-%{release}
221
222 %description plain
223 This plugin implements the SASL PLAIN mechanism. Although insecure,
224 PLAIN is useful for transitioning to new security mechanisms, as this
225 is the only mechanism which gives the server a copy of the user's
226 password.
227
228 %description plain -l pl.UTF-8
229 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
230 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
231 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
232 który udostępnia serwerowi kopię hasła użytkownika.
233
234 %description plain -l pt_BR.UTF-8
235 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
236 mecanismo é útil durante transições para novos mecanismos de
237 segurança, pois é o único esquema que fornece uma cópia da senha do
238 usuário para o servidor.
239
240 %package anonymous
241 Summary:        Anonymous Cyrus SASL plugin
242 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
243 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
244 Group:          Libraries
245 Requires:       %{name} = %{version}-%{release}
246
247 %description anonymous
248 This plugin implements the SASL ANONYMOUS mechanism, used for
249 anonymous authentication.
250
251 %description anonymous -l pl.UTF-8
252 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
253 anonimowego uwierzytelniania.
254
255 %description anonymous -l pt_BR.UTF-8
256 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
257 autenticação anônima.
258
259 %package gssapi
260 Summary:        GSSAPI Cyrus SASL plugin
261 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
262 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
263 Group:          Libraries
264 Requires:       %{name} = %{version}-%{release}
265
266 %description gssapi
267 This plugin implements the SASL GSSAPI mechanism, used for
268 GSSAPI/Kerberos5 authentication.
269
270 %description gssapi -l pl.UTF-8
271 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
272 uwierzytelniania z użyciem GSSAPI/Kerberos5.
273
274 %description gssapi -l pt_BR.UTF-8
275 Este plugin implementa o mecanismo SASL GSSAPI, usado para
276 autenticação Kerberos/GSSAPI.
277
278 %package login
279 Summary:        Unsupported Login Cyrus SASL plugin
280 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
281 Group:          Libraries
282 Requires:       %{name} = %{version}-%{release}
283
284 %description login
285 Unsupported LOGIN Cyrus SASL plugin.
286
287 %description login -l pl.UTF-8
288 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
289 SASL.
290
291 %package srp
292 Summary:        SRP Cyrus SASL plugin
293 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
294 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
295 Group:          Libraries
296 Requires:       %{name} = %{version}-%{release}
297
298 %description srp
299 This plugin implements the SASL SRP mechanism, based on the Secure
300 Remote Password protocol. This mechanism performs mutual
301 authentication and can provide a security layer with replay detection,
302 integrity protection and/or condifentiality protection.
303
304 %description srp -l pl.UTF-8
305 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
306 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
307 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
308 powtarzania, zabezpieczeniem integralności i/lub poufności.
309
310 %description srp -l pt_BR.UTF-8
311 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
312 (Secure Remote Password). Este mecanismo oferece autenticação mútua
313 (do cliente e do servidor) e pode prover uma camada de segurança com
314 detecção de ataques de replay, garantia de integridade e/ou
315 confidencialidade.
316
317 %package otp
318 Summary:        OTP Cyrus SASL plugin
319 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
320 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
321 Group:          Libraries
322 Requires:       %{name} = %{version}-%{release}
323
324 %description otp
325 This plugin implements the SASL OTP (One Time Password) mechanism.
326
327 %description otp -l pl.UTF-8
328 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
329 SASL.
330
331 %package opie
332 Summary:        OPIE Cyrus SASL plugin
333 Summary(pl.UTF-8):      Wtyczka OPIE do Cyrus SASL
334 Summary(pt_BR.UTF-8):   Mecanismo SASL OPIE
335 Group:          Libraries
336 Requires:       %{name} = %{version}-%{release}
337
338 %description opie
339 This plugin implements the SASL OPIE (One Time Password) mechanism.
340
341 %description opie -l pl.UTF-8
342 Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
343 SASL.
344
345 %package x509
346 Summary:        x509 Cyrus SASL plugin
347 Summary(pl.UTF-8):      Wtyczka x509 do Cyrus SASL
348 Group:          Libraries
349 Requires:       %{name} = %{version}-%{release}
350
351 %description x509
352 x509 Cyrus SASL plugin.
353
354 %description x509 -l pl.UTF-8
355 Wtyczka x509 do Cyrus SASL.
356
357 %package saslauthd
358 Summary:        Cyrus SASL authd
359 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
360 Group:          Daemons
361 Requires(post,preun):   /sbin/chkconfig
362 Requires:       %{name} = %{version}-%{release}
363 Requires:       /sbin/chkconfig
364 Requires:       rc-scripts
365
366 %description saslauthd
367 Cyrus SASL authd.
368
369 %description saslauthd -l pl.UTF-8
370 Demon authd do Cyrus SASL.
371
372 %package pwcheck
373 Summary:        Cyrus SASL pwcheck helper
374 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
375 Group:          Libraries
376 Requires:       %{name} = %{version}-%{release}
377
378 %description pwcheck
379 Cyrus SASL pwcheck helper.
380
381 %description pwcheck -l pl.UTF-8
382 Program pomocniczy pwcheck do Cyrus SASL.
383
384 %package sasldb
385 Summary:        Cyrus SASL sasldb plugin
386 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
387 Group:          Libraries
388 Requires:       %{name} = %{version}-%{release}
389
390 %description sasldb
391 Cyrus SASL sasldb plugin.
392
393 %description sasldb -l pl.UTF-8
394 Wtyczka sasldb do Cyrus SASL.
395
396 %package mysql
397 Summary:        Cyrus SASL MySQL plugin
398 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
399 Group:          Libraries
400 Requires:       %{name} = %{version}-%{release}
401
402 %description mysql
403 Cyrus SASL MySQL plugin.
404
405 %description mysql -l pl.UTF-8
406 Wtyczka MySQL do Cyrus SASL.
407
408 %package pgsql
409 Summary:        Cyrus SASL PostgreSQL plugin
410 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
411 Group:          Libraries
412 Requires:       %{name} = %{version}-%{release}
413
414 %description pgsql
415 Cyrus SASL PostgreSQL plugin.
416
417 %description pgsql -l pl.UTF-8
418 Wtyczka PostgreSQL do Cyrus SASL.
419
420 %package sqlite
421 Summary:        Cyrus SQLite PostgreSQL plugin
422 Summary(pl.UTF-8):      Wtyczka SQLite do Cyrus SASL
423 Group:          Libraries
424 Requires:       %{name} = %{version}-%{release}
425
426 %description sqlite
427 Cyrus SASL SQLite plugin.
428
429 %description sqlite -l pl.UTF-8
430 Wtyczka SQLite do Cyrus SASL.
431
432 %package -n nagios-plugin-check_saslauthd
433 Summary:        Nagios plugin to check health of saslauthd
434 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
435 Group:          Networking
436 Requires:       nagios-core
437
438 %description -n nagios-plugin-check_saslauthd
439 Nagios plugin to check health of saslauthd.
440
441 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
442 Wtyczka Nagiosa do sprawdzania działania saslauthd.
443
444 %prep
445 %setup -q
446 %patch0 -p1
447 %patch1 -p1
448 %patch2 -p1
449 %patch3 -p1
450 %patch4 -p1
451 %if %{with cryptedpw}
452 %patch5 -p1
453 %patch6 -p1
454 %endif
455 %patch7 -p1
456 %patch8 -p1
457 %patch9 -p2
458 %patch10 -p1
459 %patch11 -p1
460 %patch12 -p1
461 %patch13 -p1
462 %patch14 -p1
463 %patch15 -p0
464
465 cd doc
466 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
467 ls rfc*.txt >> rfc-compliance
468 rm -f rfc*.txt
469 cd ..
470
471 rm -rf autom4te.cache saslauthd/autom4te.cache
472 # acinclude.m4 contains only old libtool.m4
473 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
474
475 %build
476 %{__libtoolize}
477 %{__aclocal} -I cmulocal -I config
478 %{__autoheader}
479 %{__automake}
480 %{__autoconf}
481
482 cd saslauthd
483 %{__libtoolize}
484 %{__aclocal} -I ../cmulocal -I ../config -I config
485 %{__autoheader}
486 %{__automake}
487 %{__autoconf}
488 cd ..
489
490 %configure \
491         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
492         --disable-krb4 \
493         %{!?with_gssapi: --disable-gssapi} \
494         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
495         --enable-login \
496         --enable-sample \
497         --enable-httpform \
498         --enable-sql \
499         %{?with_srp: --enable-srp} \
500         --enable-static \
501         --with-plugindir=%{_libdir}/sasl2 \
502         --with-configdir=%{_sysconfdir} \
503         --with-dblib=berkeley \
504         --with-dbpath=/var/lib/sasl2/sasl.db \
505         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
506         %{?with_ldap: --with-ldap=%{_prefix}} \
507         %{?with_mysql: --with-mysql=%{_prefix}} \
508         %{?with_pgsql: --with-pgsql=%{_prefix}} \
509         %{?with_sqlite: --with-sqlite=%{_prefix}} \
510         %{?with_opie: --with-opie=%{_prefix}} \
511         --with-pam \
512         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
513         --with-saslauthd=/var/lib/sasl2
514 %{__make}
515
516 %{__make} -C saslauthd testsaslauthd
517 %{__make} -C saslauthd saslcache
518 %{__make} -C sample sample-client sample-server
519
520 cd doc
521 RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
522 for i in $RFCLIST; do
523         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
524         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
525 done
526
527 %install
528 rm -rf $RPM_BUILD_ROOT
529 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
530                 $RPM_BUILD_ROOT%{_mandir}/man8
531
532 %{__make} install \
533         sasldir=%{_libdir}/sasl2 \
534         DESTDIR=$RPM_BUILD_ROOT
535
536 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
537 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
538
539 install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
540 install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
541
542 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
543
544 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
545
546 # create empty config
547 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
548 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
549 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
550 install %{SOURCE3} cyrus.pam
551
552 install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
553
554 # sample programs for testing sasl
555 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
556 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
557
558 # package for ghost
559 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
560
561 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
562 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
563
564 %clean
565 rm -rf $RPM_BUILD_ROOT
566
567 %post   -p /sbin/ldconfig
568 %postun -p /sbin/ldconfig
569
570 %post saslauthd
571 /sbin/chkconfig --add saslauthd
572 %service saslauthd restart
573
574 %preun saslauthd
575 if [ "$1" = "0" ]; then
576         %service saslauthd stop
577         /sbin/chkconfig --del saslauthd
578 fi
579
580 %files
581 %defattr(644,root,root,755)
582 %doc AUTHORS COPYING ChangeLog NEWS README
583 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
584 %dir %{_sysconfdir}
585 %dir %{_libdir}/sasl2
586 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
587 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
588 # sample programs to subpackage instead?
589 %attr(755,root,root) %{_bindir}/sasl-sample-client
590 %attr(755,root,root) %{_bindir}/sasl-sample-server
591 %attr(755,root,root) %{_sbindir}/pluginviewer
592 %attr(755,root,root) %{_sbindir}/sasldblistusers2
593 %attr(755,root,root) %{_sbindir}/saslpasswd2
594 %dir /var/lib/sasl2
595 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
596 %{_mandir}/man8/pluginviewer.8*
597 %{_mandir}/man8/sasldblistusers2.8*
598 %{_mandir}/man8/saslpasswd2.8*
599
600 %files devel
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{_libdir}/libsasl2.so
603 %attr(755,root,root) %{_libdir}/libsasl.so
604 %{_libdir}/libsasl2.la
605 %{_includedir}/sasl
606 %{_mandir}/man3/sasl*.3*
607
608 %files static
609 %defattr(644,root,root,755)
610 %{_libdir}/libsasl2.a
611
612 %files anonymous
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
615
616 %if %{with gssapi}
617 %files gssapi
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
620 %endif
621
622 %files cram-md5
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
625
626 %files digest-md5
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
629
630 %files login
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
633
634 %files otp
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
637
638 %if %{with opie}
639 %files opie
640 %defattr(644,root,root,755)
641 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
642 %endif
643
644 %files plain
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
647
648 %files sasldb
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
651
652 %if %{with mysql}
653 %files mysql
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
656 %endif
657
658 %if %{with pgsql}
659 %files pgsql
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
662 %endif
663
664 %if %{with sqlite}
665 %files sqlite
666 %defattr(644,root,root,755)
667 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
668 %endif
669
670 %if %{with srp}
671 %files srp
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
674 %endif
675
676 %if %{with x509}
677 %files x509
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
680 %endif
681
682 %if %{with pwcheck}
683 %files pwcheck
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_sbindir}/pwcheck
686 %endif
687
688 %files saslauthd
689 %defattr(644,root,root,755)
690 %doc cyrus.pam
691 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
692 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
693 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
694 %attr(755,root,root) %{_sbindir}/saslauthd
695 %attr(755,root,root) %{_sbindir}/testsaslauthd
696 %attr(755,root,root) %{_sbindir}/saslcache
697 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
698 %ghost /var/lib/sasl2/cache.flock
699 %ghost /var/lib/sasl2/cache.mmap
700 %ghost /var/lib/sasl2/mux
701 %ghost /var/lib/sasl2/mux.accept
702 %ghost /var/lib/sasl2/saslauthd.pid
703 %{_mandir}/man8/saslauthd.8*
704
705 %files -n nagios-plugin-check_saslauthd
706 %defattr(644,root,root,755)
707 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
708 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.096965 seconds and 3 git commands to generate.