]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- updated openldap BR/R to 2.4.6
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # enable opie plugin
13 %bcond_with     srp             # build srp pluggin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 %bcond_with     x509            # build x509 plugin (no sources in package???)
16 #
17 %if !%{with mysql} && !%{with pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.22
28 Release:        11
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
32 # Source0-md5:  45dde9d19193ae9dd388eb68b2027bc9
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Patch0:         %{name}-nolibs.patch
37 Patch1:         %{name}-lt.patch
38 Patch2:         %{name}-split-sql.patch
39 Patch3:         %{name}-opie.patch
40 Patch4:         %{name}-gcc4.patch
41 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
42 Patch5:         %{name}-cryptedpw.patch
43 Patch6:         %{name}-md5sum-passwords.patch
44 Patch7:         %{name}-db.patch
45 Patch8:         %{name}-automake_1_10.patch
46 Patch9:         %{name}-digest-commas.patch
47 Patch10:        %{name}-keytab.patch
48 Patch11:        %{name}-sizes.patch
49 URL:            http://asg.web.cmu.edu/sasl/
50 BuildRequires:  autoconf >= 2.54
51 BuildRequires:  automake
52 %{?with_authlib:BuildRequires:  courier-authlib-devel}
53 BuildRequires:  db-devel
54 BuildRequires:  ed
55 BuildRequires:  groff
56 %{?with_gssapi:BuildRequires:   krb5-devel}
57 BuildRequires:  libtool >= 1.4
58 %{?with_mysql:BuildRequires:    mysql-devel}
59 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
60 BuildRequires:  openssl-devel >= 0.9.7d
61 %{?with_opie:BuildRequires:     opie-devel}
62 BuildRequires:  pam-devel
63 %{?with_pgsql:BuildRequires:    postgresql-devel}
64 BuildRequires:  rpmbuild(macros) >= 1.268
65 %{?with_sqlite:BuildRequires:   sqlite-devel}
66 Requires:       pam >= 0.79.0
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         _sysconfdir     /etc/sasl
70
71 %define         specflags       -fno-strict-aliasing
72
73 %description
74 This is an implementation of the SASL API, useful for adding
75 authentication, authorization, and security to network protocols. The
76 SASL protocol itself is documented in rfc2222; the API standard is a
77 work in progress.
78
79 Note: remember to install appropriate plugins, or you won't have any
80 authentication mechanisms available.
81
82 %description -l pl.UTF-8
83 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
84 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
85 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
86 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
87 RFC 2222; standaryzacja API jest w toku.
88
89 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
90 doinstalować odpowiednie wtyczki.
91
92 %description -l pt_BR.UTF-8
93 Esta é uma implementação da API SASL, útil para acrescentar
94 autenticação, autorização e seguança (criptografia) para protocolos de
95 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
96 ainda está em desenvolvimento.
97
98 %description -l ru.UTF-8
99 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
100 Authentication and Security Layer, метод для добавления поддержки
101 аутентикации к протоколам, основанным на соединениях.
102
103 %description -l uk.UTF-8
104 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
105 Authentication and Security Layer, метод для додання підтримки
106 аутентикації до протоколів, базованих на з'єднаннях.
107
108 %package devel
109 Summary:        Header files and documentation for cyrus-sasl
110 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
111 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
112 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
113 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
114 Group:          Development/Libraries
115 Requires:       %{name} = %{version}-%{release}
116
117 %description devel
118 This includes the header files and documentation needed to develop
119 applications which use SASL.
120
121 %description devel -l pl.UTF-8
122 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
123
124 %description devel -l pt_BR.UTF-8
125 Este pacote inclui os arquivos de cabeçalho e documentação necessários
126 para desenvolver aplicativos que usem SASL.
127
128 %description devel -l ru.UTF-8
129 Хедеры и библиотеки, необходимые для разработки приложений,
130 использующих Cyrus SASL.
131
132 %description devel -l uk.UTF-8
133 Хедери та бібліотеки, необхідні для розробки програм, що
134 використовують Cyrus SASL.
135
136 %package static
137 Summary:        Static cyrus-sasl libraries
138 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
139 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
140 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
141 Group:          Development/Libraries
142 Requires:       %{name}-devel = %{version}-%{release}
143
144 %description static
145 Static cyrus-sasl libraries.
146
147 %description static -l pl.UTF-8
148 Statyczne biblioteki cyrus-sasl.
149
150 %description static -l ru.UTF-8
151 Статические библиотеки, необходимые для разработки приложений,
152 использующих Cyrus SASL.
153
154 %description static -l uk.UTF-8
155 Статичні бібліотеки, необхідні для розробки програм, що використовують
156 Cyrus SASL.
157
158 %package cram-md5
159 Summary:        Cram-MD5 Cyrus SASL plugin
160 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
161 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
162 Group:          Libraries
163 Requires:       %{name} = %{version}-%{release}
164
165 %description cram-md5
166 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
167 mandatory-to-implement authentication mechanism for a number of
168 protocols; it uses MD5 with a challenge/response system to
169 authenticate the user.
170
171 %description cram-md5 -l pl.UTF-8
172 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
173 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
174 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
175 systemem challenge/response.
176
177 %description cram-md5 -l pt_BR.UTF-8
178 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
179 mecanismo de autenticação obrigatório de ser implementado para vários
180 protocolos: ele usa MD5 com um sistema de desafio/resposta para
181 autenticar o usuário.
182
183 %package digest-md5
184 Summary:        Digest-MD5 Cyrus SASL plugin
185 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
186 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
187 Group:          Libraries
188 Requires:       %{name} = %{version}-%{release}
189
190 %description digest-md5
191 This plugin implements the latest draft of the SASL DIGEST-MD5
192 mechanism. Although not yet finalized, this is likely to become the
193 new mandatory-to-implement authentication system in all new protocols.
194 It's based on the digest md5 authentication system designed for HTTP.
195
196 %description digest-md5 -l pl.UTF-8
197 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
198 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
199 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
200 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
201 Digest-MD5 zaprojektowanym dla HTTP.
202
203 %description digest-md5 -l pt_BR.UTF-8
204 Este plugin implementa a última versão da especificação do mecanismo
205 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
206 provavelmente será o novo sistema de autenticação obrigatório para
207 protocolos novos. Ele é baseado na autenticação md5 digest
208 desenvolvida para HTTP.
209
210 %package plain
211 Summary:        Plain Cyrus SASL plugin
212 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
213 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
214 Group:          Libraries
215 Requires:       %{name} = %{version}-%{release}
216
217 %description plain
218 This plugin implements the SASL PLAIN mechanism. Although insecure,
219 PLAIN is useful for transitioning to new security mechanisms, as this
220 is the only mechanism which gives the server a copy of the user's
221 password.
222
223 %description plain -l pl.UTF-8
224 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
225 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
226 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
227 który udostępnia serwerowi kopię hasła użytkownika.
228
229 %description plain -l pt_BR.UTF-8
230 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
231 mecanismo é útil durante transições para novos mecanismos de
232 segurança, pois é o único esquema que fornece uma cópia da senha do
233 usuário para o servidor.
234
235 %package anonymous
236 Summary:        Anonymous Cyrus SASL plugin
237 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
238 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
239 Group:          Libraries
240 Requires:       %{name} = %{version}-%{release}
241
242 %description anonymous
243 This plugin implements the SASL ANONYMOUS mechanism, used for
244 anonymous authentication.
245
246 %description anonymous -l pl.UTF-8
247 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
248 anonimowego uwierzytelniania.
249
250 %description anonymous -l pt_BR.UTF-8
251 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
252 autenticação anônima.
253
254 %package gssapi
255 Summary:        GSSAPI Cyrus SASL plugin
256 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
257 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
258 Group:          Libraries
259 Requires:       %{name} = %{version}-%{release}
260
261 %description gssapi
262 This plugin implements the SASL GSSAPI mechanism, used for
263 GSSAPI/Kerberos5 authentication.
264
265 %description gssapi -l pl.UTF-8
266 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
267 uwierzytelniania z użyciem GSSAPI/Kerberos5.
268
269 %description gssapi -l pt_BR.UTF-8
270 Este plugin implementa o mecanismo SASL GSSAPI, usado para
271 autenticação Kerberos/GSSAPI.
272
273 %package login
274 Summary:        Unsupported Login Cyrus SASL plugin
275 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
276 Group:          Libraries
277 Requires:       %{name} = %{version}-%{release}
278
279 %description login
280 Unsupported LOGIN Cyrus SASL plugin.
281
282 %description login -l pl.UTF-8
283 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
284 SASL.
285
286 %package srp
287 Summary:        SRP Cyrus SASL plugin
288 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
289 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
290 Group:          Libraries
291 Requires:       %{name} = %{version}-%{release}
292
293 %description srp
294 This plugin implements the SASL SRP mechanism, based on the Secure
295 Remote Password protocol. This mechanism performs mutual
296 authentication and can provide a security layer with replay detection,
297 integrity protection and/or condifentiality protection.
298
299 %description srp -l pl.UTF-8
300 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
301 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
302 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
303 powtarzania, zabezpieczeniem integralności i/lub poufności.
304
305 %description srp -l pt_BR.UTF-8
306 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
307 (Secure Remote Password). Este mecanismo oferece autenticação mútua
308 (do cliente e do servidor) e pode prover uma camada de segurança com
309 detecção de ataques de replay, garantia de integridade e/ou
310 confidencialidade.
311
312 %package otp
313 Summary:        OTP Cyrus SASL plugin
314 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
315 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
316 Group:          Libraries
317 Requires:       %{name} = %{version}-%{release}
318
319 %description otp
320 This plugin implements the SASL OTP (One Time Password) mechanism.
321
322 %description otp -l pl.UTF-8
323 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
324 SASL.
325
326 %package opie
327 Summary:        OPIE Cyrus SASL plugin
328 Summary(pl.UTF-8):      Wtyczka OPIE do Cyrus SASL
329 Summary(pt_BR.UTF-8):   Mecanismo SASL OPIE
330 Group:          Libraries
331 Requires:       %{name} = %{version}-%{release}
332
333 %description opie
334 This plugin implements the SASL OPIE (One Time Password) mechanism.
335
336 %description opie -l pl.UTF-8
337 Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
338 SASL.
339
340 %package x509
341 Summary:        x509 Cyrus SASL plugin
342 Summary(pl.UTF-8):      Wtyczka x509 do Cyrus SASL
343 Group:          Libraries
344 Requires:       %{name} = %{version}-%{release}
345
346 %description x509
347 x509 Cyrus SASL plugin.
348
349 %description x509 -l pl.UTF-8
350 Wtyczka x509 do Cyrus SASL.
351
352 %package saslauthd
353 Summary:        Cyrus SASL authd
354 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
355 Group:          Daemons
356 Requires(post,preun):   /sbin/chkconfig
357 Requires:       %{name} = %{version}-%{release}
358 Requires:       /sbin/chkconfig
359 Requires:       rc-scripts
360
361 %description saslauthd
362 Cyrus SASL authd.
363
364 %description saslauthd -l pl.UTF-8
365 Demon authd do Cyrus SASL.
366
367 %package pwcheck
368 Summary:        Cyrus SASL pwcheck helper
369 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
370 Group:          Libraries
371 Requires:       %{name} = %{version}-%{release}
372
373 %description pwcheck
374 Cyrus SASL pwcheck helper.
375
376 %description pwcheck -l pl.UTF-8
377 Program pomocniczy pwcheck do Cyrus SASL.
378
379 %package sasldb
380 Summary:        Cyrus SASL sasldb plugin
381 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
382 Group:          Libraries
383 Requires:       %{name} = %{version}-%{release}
384
385 %description sasldb
386 Cyrus SASL sasldb plugin.
387
388 %description sasldb -l pl.UTF-8
389 Wtyczka sasldb do Cyrus SASL.
390
391 %package mysql
392 Summary:        Cyrus SASL MySQL plugin
393 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
394 Group:          Libraries
395 Requires:       %{name} = %{version}-%{release}
396
397 %description mysql
398 Cyrus SASL MySQL plugin.
399
400 %description mysql -l pl.UTF-8
401 Wtyczka MySQL do Cyrus SASL.
402
403 %package pgsql
404 Summary:        Cyrus SASL PostgreSQL plugin
405 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
406 Group:          Libraries
407 Requires:       %{name} = %{version}-%{release}
408
409 %description pgsql
410 Cyrus SASL PostgreSQL plugin.
411
412 %description pgsql -l pl.UTF-8
413 Wtyczka PostgreSQL do Cyrus SASL.
414
415 %package sqlite
416 Summary:        Cyrus SQLite PostgreSQL plugin
417 Summary(pl.UTF-8):      Wtyczka SQLite do Cyrus SASL
418 Group:          Libraries
419 Requires:       %{name} = %{version}-%{release}
420
421 %description sqlite
422 Cyrus SASL SQLite plugin.
423
424 %description sqlite -l pl.UTF-8
425 Wtyczka SQLite do Cyrus SASL.
426
427 %prep
428 %setup -q
429 %patch0 -p1
430 %patch1 -p1
431 %patch2 -p1
432 %patch3 -p1
433 %patch4 -p1
434 %if %{with cryptedpw}
435 %patch5 -p1
436 %patch6 -p1
437 %endif
438 %patch7 -p1
439 %patch8 -p1
440 %patch9 -p2
441 %patch10 -p1
442 %patch11 -p1
443
444 cd doc
445 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
446 ls rfc*.txt >> rfc-compliance
447 rm -f rfc*.txt
448 cd ..
449
450 rm -rf autom4te.cache saslauthd/autom4te.cache
451 # acinclude.m4 contains only old libtool.m4
452 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
453
454 %build
455 %{__libtoolize}
456 %{__aclocal} -I cmulocal -I config
457 %{__autoheader}
458 %{__automake}
459 %{__autoconf}
460
461 cd saslauthd
462 %{__libtoolize}
463 %{__aclocal} -I ../cmulocal -I ../config -I config
464 %{__autoheader}
465 %{__automake}
466 %{__autoconf}
467 cd ..
468
469 %configure \
470         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
471         --disable-krb4 \
472         %{!?with_gssapi: --disable-gssapi} \
473         %{?with_gssapi: --enable-gssapi --with-gss_impl=mit} \
474         --enable-login \
475         --enable-sample \
476         --enable-sql \
477         %{?with_srp: --enable-srp} \
478         --enable-static \
479         --with-plugindir=%{_libdir}/sasl2 \
480         --with-configdir=%{_sysconfdir} \
481         --with-dblib=berkeley \
482         --with-dbpath=/var/lib/sasl2/sasl.db \
483         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
484         %{?with_ldap: --with-ldap=%{_prefix}} \
485         %{?with_mysql: --with-mysql=%{_prefix}} \
486         %{?with_pgsql: --with-pgsql=%{_prefix}} \
487         %{?with_sqlite: --with-sqlite=%{_prefix}} \
488         %{?with_opie: --with-opie=%{_prefix}} \
489         --with-pam \
490         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
491         --with-saslauthd=/var/lib/sasl2
492 %{__make}
493
494 %{__make} -C saslauthd testsaslauthd
495 %{__make} -C saslauthd saslcache
496
497 cd doc
498 RFCLIST=`grep 'rfc.\+\.txt' rfc-compliance`
499 for i in $RFCLIST; do
500         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
501         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
502 done
503
504 %install
505 rm -rf $RPM_BUILD_ROOT
506 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
507                 $RPM_BUILD_ROOT%{_mandir}/man8
508
509 %{__make} install \
510         sasldir=%{_libdir}/sasl2 \
511         DESTDIR=$RPM_BUILD_ROOT
512
513 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
514 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
515
516 install utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
517 install saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
518
519 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
520
521 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
522
523 # create empty config
524 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
525 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
526 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
527 install %{SOURCE3} ./cyrus.pam
528
529 install saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
530
531 # sample programs for testing sasl
532 libtool --mode=install cp sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
533 libtool --mode=install cp sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
534
535 %clean
536 rm -rf $RPM_BUILD_ROOT
537
538 %post   -p /sbin/ldconfig
539 %postun -p /sbin/ldconfig
540
541 %post saslauthd
542 /sbin/chkconfig --add saslauthd
543 %service saslauthd restart
544
545 %preun saslauthd
546 if [ "$1" = "0" ]; then
547         %service saslauthd stop
548         /sbin/chkconfig --del saslauthd
549 fi
550
551 %files
552 %defattr(644,root,root,755)
553 %doc AUTHORS COPYING ChangeLog NEWS README
554 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
555 %dir %{_sysconfdir}
556 %dir %{_libdir}/sasl2
557 %dir /var/lib/sasl2
558 %attr(755,root,root) %{_libdir}/lib*.so.*.*
559 # sample programs to subpackage instead?
560 %attr(755,root,root) %{_bindir}/sasl-sample-client
561 %attr(755,root,root) %{_bindir}/sasl-sample-server
562 %attr(755,root,root) %{_sbindir}/pluginviewer
563 %attr(755,root,root) %{_sbindir}/sasldblistusers2
564 %attr(755,root,root) %{_sbindir}/saslpasswd2
565
566 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
567 %{_mandir}/man8/pluginviewer.8*
568 %{_mandir}/man8/sasldblistusers2.8*
569 %{_mandir}/man8/saslpasswd2.8*
570
571 %files devel
572 %defattr(644,root,root,755)
573 %{_includedir}/sasl
574 %attr(755,root,root) %{_libdir}/lib*.so
575 %{_libdir}/lib*.la
576 %{_mandir}/man3/*
577
578 %files static
579 %defattr(644,root,root,755)
580 %{_libdir}/lib*.a
581
582 %files anonymous
583 %defattr(644,root,root,755)
584 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
585
586 %if %{with gssapi}
587 %files gssapi
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
590 %endif
591
592 %files cram-md5
593 %defattr(644,root,root,755)
594 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
595
596 %files digest-md5
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
599
600 %files login
601 %defattr(644,root,root,755)
602 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
603
604 %files otp
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
607
608 %if %{with opie}
609 %files opie
610 %defattr(644,root,root,755)
611 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
612 %endif
613
614 %files plain
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
617
618 %files sasldb
619 %defattr(644,root,root,755)
620 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
621
622 %if %{with mysql}
623 %files mysql
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
626 %endif
627
628 %if %{with pgsql}
629 %files pgsql
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
632 %endif
633
634 %if %{with sqlite}
635 %files sqlite
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
638 %endif
639
640 %if %{with srp}
641 %files srp
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
644 %endif
645
646 %if %{with x509}
647 %files x509
648 %defattr(644,root,root,755)
649 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
650 %endif
651
652 %if %{with pwcheck}
653 %files pwcheck
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_sbindir}/pwcheck
656 %endif
657
658 %files saslauthd
659 %defattr(644,root,root,755)
660 %doc cyrus.pam
661 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
662 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
663 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
664 %attr(755,root,root) %{_sbindir}/saslauthd
665 %attr(755,root,root) %{_sbindir}/testsaslauthd
666 %attr(755,root,root) %{_sbindir}/saslcache
667 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
668 %{_mandir}/man8/saslauthd.8*
This page took 0.072414 seconds and 3 git commands to generate.