]> git.pld-linux.org Git - packages/cyrus-sasl.git/blob - cyrus-sasl.spec
- typo in comment
[packages/cyrus-sasl.git] / cyrus-sasl.spec
1 # TODO:
2 # - add ldap plugin from openldap sources
3 #
4 # Conditional build:
5 %bcond_without  cryptedpw       # if you keep crypted passwords in your *sql
6 %bcond_without  ldap            # disable LDAP support for saslauthd
7 %bcond_without  gssapi          # do not enable GSSAPI support for saslauthd and build gssapi plugin
8 %bcond_without  mysql           # don't build MySQL pluggin
9 %bcond_without  pgsql           # do not build PostgreSQL pluggin
10 %bcond_without  sqlite          # do not enable sqlite plugin
11 %bcond_with     authlib         # enable courier-authlib (i wasn't able to test it)
12 %bcond_with     opie            # enable opie plugin
13 %bcond_with     srp             # build srp pluggin
14 %bcond_with     pwcheck         # build pwcheck helper (deprecated)
15 %bcond_with     x509            # build x509 plugin (no sources in package???)
16 #
17 %if %{without mysql} && %{without pgsql}
18 %undefine with_cryptedpw
19 %endif
20
21 Summary:        The SASL library API for the Cyrus mail system
22 Summary(pl.UTF-8):      Biblioteka Cyrus SASL
23 Summary(pt_BR.UTF-8):   Implementação da API SASL
24 Summary(ru.UTF-8):      Библиотека Cyrus SASL
25 Summary(uk.UTF-8):      Бібліотека Cyrus SASL
26 Name:           cyrus-sasl
27 Version:        2.1.23
28 Release:        10
29 License:        distributable
30 Group:          Libraries
31 Source0:        ftp://ftp.andrew.cmu.edu/pub/cyrus/%{name}-%{version}.tar.gz
32 # Source0-md5:  2eb0e48106f0e9cd8001e654f267ecbc
33 Source1:        saslauthd.init
34 Source2:        saslauthd.sysconfig
35 Source3:        %{name}.pam
36 Source4:        check_saslauthd.cfg
37 Patch0:         %{name}-nolibs.patch
38 Patch1:         %{name}-lt.patch
39 Patch2:         %{name}-split-sql.patch
40 Patch3:         %{name}-opie.patch
41 Patch4:         %{name}-gcc4.patch
42 # Adapted from http://frost.ath.cx/software/cyrus-sasl-patches/dist/2.1.19/cyrus-sasl-2.1.19-checkpw.c+sql.c.patch
43 Patch5:         %{name}-cryptedpw.patch
44 Patch6:         %{name}-md5sum-passwords.patch
45 Patch7:         %{name}-db.patch
46 Patch8:         %{name}-automake_1_10.patch
47 Patch9:         %{name}-digest-commas.patch
48 Patch10:        %{name}-keytab.patch
49 Patch11:        %{name}-sizes.patch
50 Patch12:        %{name}-nagios-plugin.patch
51 Patch13:        %{name}-parallel-make.patch
52 Patch14:        %{name}-gssapi-detect.patch
53 Patch15:                %{name}-saslauthd-httpform-urlescape.patch
54 URL:            http://asg.web.cmu.edu/sasl/
55 BuildRequires:  autoconf >= 2.54
56 BuildRequires:  automake >= 1:1.7
57 %{?with_authlib:BuildRequires:  courier-authlib-devel}
58 BuildRequires:  db-devel
59 BuildRequires:  ed
60 BuildRequires:  groff
61 %{?with_gssapi:BuildRequires:   heimdal-devel}
62 BuildRequires:  libtool >= 1.4
63 %{?with_mysql:BuildRequires:    mysql-devel}
64 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
65 BuildRequires:  openssl-devel >= 0.9.7d
66 %{?with_opie:BuildRequires:     opie-devel}
67 BuildRequires:  pam-devel
68 %{?with_pgsql:BuildRequires:    postgresql-devel}
69 BuildRequires:  rpmbuild(macros) >= 1.268
70 %{?with_sqlite:BuildRequires:   sqlite-devel}
71 Requires:       pam >= 0.79.0
72 Requires:       %{name}-libs = %{version}-%{release}
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _sysconfdir     /etc/sasl
76
77 %define         specflags       -fno-strict-aliasing
78
79 %description
80 This is an implementation of the SASL API, useful for adding
81 authentication, authorization, and security to network protocols. The
82 SASL protocol itself is documented in rfc2222; the API standard is a
83 work in progress.
84
85 Note: remember to install appropriate plugins, or you won't have any
86 authentication mechanisms available.
87
88 %description -l pl.UTF-8
89 Pakiet cyrus-sasl zawiera implementację biblioteki API SASL dla
90 systemu poczty elektronicznej Cyrusa. Biblioteka ta jest przydatna
91 także do dodawania uwierzytelniania, autoryzacji oraz zwiększania
92 bezpieczeństwa protokołów sieciowych. Sam protokół SASL jest opisany w
93 RFC 2222; standaryzacja API jest w toku.
94
95 Uwaga: aby były dostępne jakiekolwiek mechanizmy autoryzacji, należy
96 doinstalować odpowiednie wtyczki.
97
98 %description -l pt_BR.UTF-8
99 Esta é uma implementação da API SASL, útil para acrescentar
100 autenticação, autorização e seguança (criptografia) para protocolos de
101 rede. O protocolo SASL está documentado na RFC 2222. A API "padrão"
102 ainda está em desenvolvimento.
103
104 %description -l ru.UTF-8
105 Пакет cyrus-sasl содержит реализацию Cyrus SASL. SASL - это Simple
106 Authentication and Security Layer, метод для добавления поддержки
107 аутентикации к протоколам, основанным на соединениях.
108
109 %description -l uk.UTF-8
110 Пакет cyrus-sasl містить реалізацію Cyrus SASL. SASL - це Simple
111 Authentication and Security Layer, метод для додання підтримки
112 аутентикації до протоколів, базованих на з'єднаннях.
113
114 %package libs
115 Summary:        cyrus-sasl library itself
116 Summary(pl.UTF-8):      Sama biblioteka cyrus-sasl
117 Group:          Libraries
118 Requires(post,postun):  /sbin/ldconfig
119 Conflicts:      cyrus-sasl < 2.1.23-8
120
121 %description libs
122 cyrus-sasl library itself.
123
124 %description libs -l pl.UTF-8
125 Sama biblioteka cyrus-sasl.
126
127 %package devel
128 Summary:        Header files and documentation for cyrus-sasl
129 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja dla cyrus-sasl
130 Summary(pt_BR.UTF-8):   Exemplos e arquivos para desenvolvimento com SASL
131 Summary(ru.UTF-8):      Файлы для программирования с библиотекой Cyrus SASL
132 Summary(uk.UTF-8):      Файли для програмування з бібліотекою Cyrus SASL
133 Group:          Development/Libraries
134 Requires:       %{name} = %{version}-%{release}
135
136 %description devel
137 This includes the header files and documentation needed to develop
138 applications which use SASL.
139
140 %description devel -l pl.UTF-8
141 Pliki nagłówkowe i dokumentacja dla cyrus-sasl.
142
143 %description devel -l pt_BR.UTF-8
144 Este pacote inclui os arquivos de cabeçalho e documentação necessários
145 para desenvolver aplicativos que usem SASL.
146
147 %description devel -l ru.UTF-8
148 Хедеры и библиотеки, необходимые для разработки приложений,
149 использующих Cyrus SASL.
150
151 %description devel -l uk.UTF-8
152 Хедери та бібліотеки, необхідні для розробки програм, що
153 використовують Cyrus SASL.
154
155 %package static
156 Summary:        Static cyrus-sasl libraries
157 Summary(pl.UTF-8):      Statyczne biblioteki cyrus-sasl
158 Summary(ru.UTF-8):      Статические библиотеки Cyrus SASL
159 Summary(uk.UTF-8):      Статичні бібліотеки Cyrus SASL
160 Group:          Development/Libraries
161 Requires:       %{name}-devel = %{version}-%{release}
162
163 %description static
164 Static cyrus-sasl libraries.
165
166 %description static -l pl.UTF-8
167 Statyczne biblioteki cyrus-sasl.
168
169 %description static -l ru.UTF-8
170 Статические библиотеки, необходимые для разработки приложений,
171 использующих Cyrus SASL.
172
173 %description static -l uk.UTF-8
174 Статичні бібліотеки, необхідні для розробки програм, що використовують
175 Cyrus SASL.
176
177 %package cram-md5
178 Summary:        Cram-MD5 Cyrus SASL plugin
179 Summary(pl.UTF-8):      Wtyczka Cram-MD5 do Cyrus SASL
180 Summary(pt_BR.UTF-8):   Mecanismo SASL CRAM-MD5
181 Group:          Libraries
182 Requires:       %{name} = %{version}-%{release}
183
184 %description cram-md5
185 This plugin implements the SASL CRAM-MD5 mechanism. CRAM-MD5 is the
186 mandatory-to-implement authentication mechanism for a number of
187 protocols; it uses MD5 with a challenge/response system to
188 authenticate the user.
189
190 %description cram-md5 -l pl.UTF-8
191 Wtyczka dodająca obsługę mechanizmu CRAM-MD5 do Cyrus SASL. CRAM-MD5
192 jest obowiązkowym do zaimplementowania mechanizmem uwierzytelniania
193 dla wielu protokołów; do uwierzytelnienia użytkownika używa MD5 wraz z
194 systemem challenge/response.
195
196 %description cram-md5 -l pt_BR.UTF-8
197 Este plugin implementa o mecanismo SASL CRAM-MD5. CRAM-MD5 é o
198 mecanismo de autenticação obrigatório de ser implementado para vários
199 protocolos: ele usa MD5 com um sistema de desafio/resposta para
200 autenticar o usuário.
201
202 %package digest-md5
203 Summary:        Digest-MD5 Cyrus SASL plugin
204 Summary(pl.UTF-8):      Wtyczka Digest-MD5 do Cyrus SASL
205 Summary(pt_BR.UTF-8):   Mecanismo SASL DIGEST-MD5
206 Group:          Libraries
207 Requires:       %{name} = %{version}-%{release}
208
209 %description digest-md5
210 This plugin implements the latest draft of the SASL DIGEST-MD5
211 mechanism. Although not yet finalized, this is likely to become the
212 new mandatory-to-implement authentication system in all new protocols.
213 It's based on the digest md5 authentication system designed for HTTP.
214
215 %description digest-md5 -l pl.UTF-8
216 Wtyczka dodająca najnowszą wersję mechanizmu DIGEST-MD5 do Cyrus SASL.
217 Pomimo tego, że nie jest jeszcze ukończony, najprawdopodobniej stanie
218 się obowiązkowym do zaimplementowania systemem uwierzytelniania we
219 wszystkich nowych protokołach. Bazuje na systemie uwierzytelniania
220 Digest-MD5 zaprojektowanym dla HTTP.
221
222 %description digest-md5 -l pt_BR.UTF-8
223 Este plugin implementa a última versão da especificação do mecanismo
224 SASL DIGEST-MD5. Embora ainda não esteja finalizado, DIGEST-MD5
225 provavelmente será o novo sistema de autenticação obrigatório para
226 protocolos novos. Ele é baseado na autenticação md5 digest
227 desenvolvida para HTTP.
228
229 %package plain
230 Summary:        Plain Cyrus SASL plugin
231 Summary(pl.UTF-8):      Wtyczka plain do Cyrus SASL
232 Summary(pt_BR.UTF-8):   Mecanismo SASL PLAIN
233 Group:          Libraries
234 Requires:       %{name} = %{version}-%{release}
235
236 %description plain
237 This plugin implements the SASL PLAIN mechanism. Although insecure,
238 PLAIN is useful for transitioning to new security mechanisms, as this
239 is the only mechanism which gives the server a copy of the user's
240 password.
241
242 %description plain -l pl.UTF-8
243 Wtyczka dodająca obsługę mechanizmu PLAIN do Cyrus SASL. Pomimo tego,
244 że nie jest bezpieczny, PLAIN jest przydatny przy przechodzeniu na
245 nowe mechanizmu bezpieczeństwa, jako że jest to jedyny mechanizm,
246 który udostępnia serwerowi kopię hasła użytkownika.
247
248 %description plain -l pt_BR.UTF-8
249 Este plugin implementa o mecanismo SASL PLAIN. Embora inseguro, este
250 mecanismo é útil durante transições para novos mecanismos de
251 segurança, pois é o único esquema que fornece uma cópia da senha do
252 usuário para o servidor.
253
254 %package anonymous
255 Summary:        Anonymous Cyrus SASL plugin
256 Summary(pl.UTF-8):      Wtyczka anonymous do Cyrus SASL
257 Summary(pt_BR.UTF-8):   Mecanismo SASL ANONYMOUS
258 Group:          Libraries
259 Requires:       %{name} = %{version}-%{release}
260
261 %description anonymous
262 This plugin implements the SASL ANONYMOUS mechanism, used for
263 anonymous authentication.
264
265 %description anonymous -l pl.UTF-8
266 Wtyczka dodająca obsługę mechanizmu ANONYMOUS do Cyrus SASL. Służy do
267 anonimowego uwierzytelniania.
268
269 %description anonymous -l pt_BR.UTF-8
270 Este plugin implementa o mecanismo SASL ANONYMOUS, usado para
271 autenticação anônima.
272
273 %package gssapi
274 Summary:        GSSAPI Cyrus SASL plugin
275 Summary(pl.UTF-8):      Wtyczka GSSAPI do Cyrus SASL
276 Summary(pt_BR.UTF-8):   Mecanismo SASL GSSAPI
277 Group:          Libraries
278 Requires:       %{name} = %{version}-%{release}
279
280 %description gssapi
281 This plugin implements the SASL GSSAPI mechanism, used for
282 GSSAPI/Kerberos5 authentication.
283
284 %description gssapi -l pl.UTF-8
285 Wtyczka dodająca obsługę mechanizmu SASL GSSAPI, używanego do
286 uwierzytelniania z użyciem GSSAPI/Kerberos5.
287
288 %description gssapi -l pt_BR.UTF-8
289 Este plugin implementa o mecanismo SASL GSSAPI, usado para
290 autenticação Kerberos/GSSAPI.
291
292 %package login
293 Summary:        Unsupported Login Cyrus SASL plugin
294 Summary(pl.UTF-8):      Nie wspierana wtyczka Login do Cyrus SASL
295 Group:          Libraries
296 Requires:       %{name} = %{version}-%{release}
297
298 %description login
299 Unsupported LOGIN Cyrus SASL plugin.
300
301 %description login -l pl.UTF-8
302 Wtyczka dodająca obsługę nie wspieranego mechanizmu LOGIN do Cyrus
303 SASL.
304
305 %package srp
306 Summary:        SRP Cyrus SASL plugin
307 Summary(pl.UTF-8):      Wtyczka SRP do Cyrus SASL
308 Summary(pt_BR.UTF-8):   Mecanismo SASL SRP
309 Group:          Libraries
310 Requires:       %{name} = %{version}-%{release}
311
312 %description srp
313 This plugin implements the SASL SRP mechanism, based on the Secure
314 Remote Password protocol. This mechanism performs mutual
315 authentication and can provide a security layer with replay detection,
316 integrity protection and/or condifentiality protection.
317
318 %description srp -l pl.UTF-8
319 Wtyczka dodająca obsługę mechanizmu SRP do Cyrus SASL. Bazuje na
320 protokole Secure Remote Password. Ten mechanizm dokonuje wzajemnego
321 uwierzytelnienia i może dodawać warstwę bezpieczeństwa z wykrywaniem
322 powtarzania, zabezpieczeniem integralności i/lub poufności.
323
324 %description srp -l pt_BR.UTF-8
325 Este plugin implementa o mecanismo SASL SRP, baseado no protocolo SRP
326 (Secure Remote Password). Este mecanismo oferece autenticação mútua
327 (do cliente e do servidor) e pode prover uma camada de segurança com
328 detecção de ataques de replay, garantia de integridade e/ou
329 confidencialidade.
330
331 %package otp
332 Summary:        OTP Cyrus SASL plugin
333 Summary(pl.UTF-8):      Wtyczka OTP do Cyrus SASL
334 Summary(pt_BR.UTF-8):   Mecanismo SASL OTP
335 Group:          Libraries
336 Requires:       %{name} = %{version}-%{release}
337
338 %description otp
339 This plugin implements the SASL OTP (One Time Password) mechanism.
340
341 %description otp -l pl.UTF-8
342 Wtyczka dodająca obsługę mechanizmu OTP (hasła jednorazowe) do Cyrus
343 SASL.
344
345 %package opie
346 Summary:        OPIE Cyrus SASL plugin
347 Summary(pl.UTF-8):      Wtyczka OPIE do Cyrus SASL
348 Summary(pt_BR.UTF-8):   Mecanismo SASL OPIE
349 Group:          Libraries
350 Requires:       %{name} = %{version}-%{release}
351
352 %description opie
353 This plugin implements the SASL OPIE (One Time Password) mechanism.
354
355 %description opie -l pl.UTF-8
356 Wtyczka dodająca obsługę mechanizmu OPIE (hasła jednorazowe) do Cyrus
357 SASL.
358
359 %package x509
360 Summary:        x509 Cyrus SASL plugin
361 Summary(pl.UTF-8):      Wtyczka x509 do Cyrus SASL
362 Group:          Libraries
363 Requires:       %{name} = %{version}-%{release}
364
365 %description x509
366 x509 Cyrus SASL plugin.
367
368 %description x509 -l pl.UTF-8
369 Wtyczka x509 do Cyrus SASL.
370
371 %package saslauthd
372 Summary:        Cyrus SASL authd
373 Summary(pl.UTF-8):      Demon authd do Cyrus SASL
374 Group:          Daemons
375 Requires(post,preun):   /sbin/chkconfig
376 Requires:       %{name} = %{version}-%{release}
377 Requires:       /sbin/chkconfig
378 Requires:       rc-scripts
379
380 %description saslauthd
381 Cyrus SASL authd.
382
383 %description saslauthd -l pl.UTF-8
384 Demon authd do Cyrus SASL.
385
386 %package pwcheck
387 Summary:        Cyrus SASL pwcheck helper
388 Summary(pl.UTF-8):      Program pomocniczy pwcheck do Cyrus SASL
389 Group:          Libraries
390 Requires:       %{name} = %{version}-%{release}
391
392 %description pwcheck
393 Cyrus SASL pwcheck helper.
394
395 %description pwcheck -l pl.UTF-8
396 Program pomocniczy pwcheck do Cyrus SASL.
397
398 %package sasldb
399 Summary:        Cyrus SASL sasldb plugin
400 Summary(pl.UTF-8):      Wtyczka sasldb do Cyrus SASL
401 Group:          Libraries
402 Requires:       %{name} = %{version}-%{release}
403
404 %description sasldb
405 Cyrus SASL sasldb plugin.
406
407 %description sasldb -l pl.UTF-8
408 Wtyczka sasldb do Cyrus SASL.
409
410 %package mysql
411 Summary:        Cyrus SASL MySQL plugin
412 Summary(pl.UTF-8):      Wtyczka MySQL do Cyrus SASL
413 Group:          Libraries
414 Requires:       %{name} = %{version}-%{release}
415
416 %description mysql
417 Cyrus SASL MySQL plugin.
418
419 %description mysql -l pl.UTF-8
420 Wtyczka MySQL do Cyrus SASL.
421
422 %package pgsql
423 Summary:        Cyrus SASL PostgreSQL plugin
424 Summary(pl.UTF-8):      Wtyczka PostgreSQL do Cyrus SASL
425 Group:          Libraries
426 Requires:       %{name} = %{version}-%{release}
427
428 %description pgsql
429 Cyrus SASL PostgreSQL plugin.
430
431 %description pgsql -l pl.UTF-8
432 Wtyczka PostgreSQL do Cyrus SASL.
433
434 %package sqlite
435 Summary:        Cyrus SQLite PostgreSQL plugin
436 Summary(pl.UTF-8):      Wtyczka SQLite do Cyrus SASL
437 Group:          Libraries
438 Requires:       %{name} = %{version}-%{release}
439
440 %description sqlite
441 Cyrus SASL SQLite plugin.
442
443 %description sqlite -l pl.UTF-8
444 Wtyczka SQLite do Cyrus SASL.
445
446 %package -n nagios-plugin-check_saslauthd
447 Summary:        Nagios plugin to check health of saslauthd
448 Summary(pl.UTF-8):      Wtyczka Nagiosa do sprawdzania działania saslauthd
449 Group:          Networking
450 Requires:       nagios-core
451
452 %description -n nagios-plugin-check_saslauthd
453 Nagios plugin to check health of saslauthd.
454
455 %description -n nagios-plugin-check_saslauthd -l pl.UTF-8
456 Wtyczka Nagiosa do sprawdzania działania saslauthd.
457
458 %prep
459 %setup -q
460 %patch0 -p1
461 %patch1 -p1
462 %patch2 -p1
463 %patch3 -p1
464 %patch4 -p1
465 %if %{with cryptedpw}
466 %patch5 -p1
467 %patch6 -p1
468 %endif
469 %patch7 -p1
470 %patch8 -p1
471 %patch9 -p2
472 %patch10 -p1
473 %patch11 -p1
474 %patch12 -p1
475 %patch13 -p1
476 %patch14 -p1
477 %patch15 -p0
478
479 cd doc
480 echo "cyrus-sasl complies with the following RFCs:" > rfc-compliance
481 ls rfc*.txt >> rfc-compliance
482 rm -f rfc*.txt
483 cd ..
484
485 rm -rf autom4te.cache saslauthd/autom4te.cache
486 # acinclude.m4 contains only old libtool.m4
487 rm -f acinclude.m4 libtool config/libtool.m4 saslauthd/acinclude.m4
488
489 # update to our paths
490 sed -i -e '
491         s,/usr/local/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
492         s,/etc/saslauthd.conf,%{_sysconfdir}/saslauthd.conf,g
493         s,/var/run/saslauthd/mux,/var/lib/sasl2/mux,g
494         s,/var/state/saslauthd,/var/lib/sasl2,g
495 ' saslauthd/saslauthd.8 saslauthd/saslauthd.mdoc saslauthd/LDAP_SASLAUTHD doc/sysadmin.html
496
497 %build
498 %{__libtoolize}
499 %{__aclocal} -I cmulocal -I config
500 %{__autoheader}
501 %{__automake}
502 %{__autoconf}
503
504 cd saslauthd
505 %{__libtoolize}
506 %{__aclocal} -I ../cmulocal -I ../config -I config
507 %{__autoheader}
508 %{__automake}
509 %{__autoconf}
510 cd ..
511
512 %configure \
513         %{?with_cryptedpw: LDFLAGS=-lcrypt} \
514         --disable-krb4 \
515         %{!?with_gssapi: --disable-gssapi} \
516         %{?with_gssapi: --enable-gssapi --with-gss_impl=heimdal} \
517         --enable-login \
518         --enable-sample \
519         --enable-httpform \
520         --enable-sql \
521         %{?with_srp: --enable-srp} \
522         --enable-static \
523         --with-plugindir=%{_libdir}/sasl2 \
524         --with-configdir=%{_sysconfdir} \
525         --with-dblib=berkeley \
526         --with-dbpath=/var/lib/sasl2/sasl.db \
527         %{?with_authlib:--with-authdaemond=/var/spool/authdaemon/socket} \
528         %{?with_ldap: --with-ldap=%{_prefix}} \
529         %{?with_mysql: --with-mysql=%{_prefix}} \
530         %{?with_pgsql: --with-pgsql=%{_prefix}} \
531         %{?with_sqlite: --with-sqlite=%{_prefix}} \
532         %{?with_opie: --with-opie=%{_prefix}} \
533         --with-pam \
534         %{?with_pwcheck: --with-pwcheck=/var/lib/sasl2} \
535         --with-saslauthd=/var/lib/sasl2
536 %{__make}
537
538 %{__make} -C saslauthd testsaslauthd
539 %{__make} -C saslauthd saslcache
540 %{__make} -C sample sample-client sample-server
541
542 cd doc
543 RFCLIST=$(grep 'rfc.\+\.txt' rfc-compliance)
544 for i in $RFCLIST; do
545         RFCDIR=../RFC/text/`echo $i | sed -e 's:^rfc::' -e 's:..\.txt$::' `00
546         echo -e ',s:'$i':'$RFCDIR/$i'\n,w\nq' | ed index.html
547 done
548
549 %install
550 rm -rf $RPM_BUILD_ROOT
551 install -d $RPM_BUILD_ROOT{%{_bindir},/var/lib/sasl2,%{_sysconfdir},/etc/{rc.d/init.d,sysconfig}} \
552                 $RPM_BUILD_ROOT%{_mandir}/man8
553
554 %{__make} install \
555         sasldir=%{_libdir}/sasl2 \
556         DESTDIR=$RPM_BUILD_ROOT
557
558 rm -rf $RPM_BUILD_ROOT%{_mandir}/cat*
559 rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.{la,a}
560
561 cp -a utils/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
562 cp -a saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
563
564 ln -sf libsasl2.so $RPM_BUILD_ROOT%{_libdir}/libsasl.so
565
566 touch $RPM_BUILD_ROOT/var/lib/sasl2/sasl.db
567
568 # create empty config
569 touch $RPM_BUILD_ROOT%{_sysconfdir}/saslauthd.conf
570 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
571 cp -a %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
572 cp -a %{SOURCE3} cyrus.pam
573
574 install -p saslauthd/{testsaslauthd,saslcache} $RPM_BUILD_ROOT%{_sbindir}
575
576 # sample programs for testing sasl
577 libtool --mode=install cp sample/sample-client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
578 libtool --mode=install cp sample/sample-server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
579
580 # package for ghost
581 touch $RPM_BUILD_ROOT/var/lib/sasl2/{cache.flock,cache.mmap,mux,mux.accept,saslauthd.pid}
582
583 install -d $RPM_BUILD_ROOT/etc/nagios/plugins
584 %{__sed} -e 's,@plugindir@,%{_libdir}/nagios/plugins,' %{SOURCE4} > $RPM_BUILD_ROOT/etc/nagios/plugins/check_saslauthd.cfg
585
586 %clean
587 rm -rf $RPM_BUILD_ROOT
588
589 %post   libs -p /sbin/ldconfig
590 %postun libs -p /sbin/ldconfig
591
592 %post saslauthd
593 /sbin/chkconfig --add saslauthd
594 %service saslauthd restart
595
596 %preun saslauthd
597 if [ "$1" = "0" ]; then
598         %service saslauthd stop
599         /sbin/chkconfig --del saslauthd
600 fi
601
602 %triggerin saslauthd -- pam
603 # restart saslauthd if pam is upgraded
604 # (saslauth is linked with old libpam but tries to open modules linked with new libpam)
605 if [ "$2" != 1 ]; then
606         %service -q saslauthd restart
607 fi
608
609 %files
610 %defattr(644,root,root,755)
611 %doc AUTHORS COPYING ChangeLog NEWS README
612 %doc doc/{ONEWS,TODO,*.txt,*.html,*.fig,rfc-compliance}
613 %dir %{_sysconfdir}
614 %dir %{_libdir}/sasl2
615 # sample programs to subpackage instead?
616 %attr(755,root,root) %{_bindir}/sasl-sample-client
617 %attr(755,root,root) %{_bindir}/sasl-sample-server
618 %attr(755,root,root) %{_sbindir}/pluginviewer
619 %attr(755,root,root) %{_sbindir}/sasldblistusers2
620 %attr(755,root,root) %{_sbindir}/saslpasswd2
621 %dir /var/lib/sasl2
622 %attr(640,root,mail) %ghost %config(noreplace) %verify(not md5 mtime size) /var/lib/sasl2/sasl.db
623 %{_mandir}/man8/pluginviewer.8*
624 %{_mandir}/man8/sasldblistusers2.8*
625 %{_mandir}/man8/saslpasswd2.8*
626
627 %files libs
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_libdir}/libsasl2.so.*.*.*
630 %attr(755,root,root) %ghost %{_libdir}/libsasl2.so.2
631
632 %files devel
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_libdir}/libsasl2.so
635 %attr(755,root,root) %{_libdir}/libsasl.so
636 %{_libdir}/libsasl2.la
637 %{_includedir}/sasl
638 %{_mandir}/man3/sasl*.3*
639
640 %files static
641 %defattr(644,root,root,755)
642 %{_libdir}/libsasl2.a
643
644 %files anonymous
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_libdir}/sasl2/libanonymous.so*
647
648 %if %{with gssapi}
649 %files gssapi
650 %defattr(644,root,root,755)
651 %attr(755,root,root) %{_libdir}/sasl2/libgssapiv2.so*
652 %endif
653
654 %files cram-md5
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_libdir}/sasl2/libcrammd5.so*
657
658 %files digest-md5
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_libdir}/sasl2/libdigestmd5.so*
661
662 %files login
663 %defattr(644,root,root,755)
664 %attr(755,root,root) %{_libdir}/sasl2/liblogin.so*
665
666 %files otp
667 %defattr(644,root,root,755)
668 %attr(755,root,root) %{_libdir}/sasl2/libotp.so*
669
670 %if %{with opie}
671 %files opie
672 %defattr(644,root,root,755)
673 %attr(755,root,root) %{_libdir}/sasl2/libopie.so*
674 %endif
675
676 %files plain
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/sasl2/libplain.so*
679
680 %files sasldb
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_libdir}/sasl2/libsasldb.so*
683
684 %if %{with mysql}
685 %files mysql
686 %defattr(644,root,root,755)
687 %attr(755,root,root) %{_libdir}/sasl2/libmysql.so*
688 %endif
689
690 %if %{with pgsql}
691 %files pgsql
692 %defattr(644,root,root,755)
693 %attr(755,root,root) %{_libdir}/sasl2/libpgsql.so*
694 %endif
695
696 %if %{with sqlite}
697 %files sqlite
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_libdir}/sasl2/libsqlite.so*
700 %endif
701
702 %if %{with srp}
703 %files srp
704 %defattr(644,root,root,755)
705 %attr(755,root,root) %{_libdir}/sasl2/libsrp.so*
706 %endif
707
708 %if %{with x509}
709 %files x509
710 %defattr(644,root,root,755)
711 %attr(755,root,root) %{_libdir}/sasl2/libx509.so*
712 %endif
713
714 %if %{with pwcheck}
715 %files pwcheck
716 %defattr(644,root,root,755)
717 %attr(755,root,root) %{_sbindir}/pwcheck
718 %endif
719
720 %files saslauthd
721 %defattr(644,root,root,755)
722 %doc cyrus.pam
723 %doc saslauthd/{AUTHORS,LDAP_SASLAUTHD}
724 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/saslauthd.conf
725 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/saslauthd
726 %attr(755,root,root) %{_sbindir}/saslauthd
727 %attr(755,root,root) %{_sbindir}/testsaslauthd
728 %attr(755,root,root) %{_sbindir}/saslcache
729 %attr(754,root,root) /etc/rc.d/init.d/saslauthd
730 %ghost /var/lib/sasl2/cache.flock
731 %ghost /var/lib/sasl2/cache.mmap
732 %ghost /var/lib/sasl2/mux
733 %ghost /var/lib/sasl2/mux.accept
734 %ghost /var/lib/sasl2/saslauthd.pid
735 %{_mandir}/man8/saslauthd.8*
736
737 %files -n nagios-plugin-check_saslauthd
738 %defattr(644,root,root,755)
739 %config(noreplace) %verify(not md5 mtime size) /etc/nagios/plugins/check_saslauthd.cfg
740 %attr(755,root,root) %{_libdir}/nagios/plugins/check_saslauthd
This page took 0.169474 seconds and 3 git commands to generate.