]> git.pld-linux.org Git - packages/cyclone.git/blob - cyclone.spec
0713e5268598328c17e5a7055a49b296ca826d43
[packages/cyclone.git] / cyclone.spec
1 Summary:        The Cyclone compiler
2 Summary(pl):    Kompilator jêzyka Cyclone
3 Name:           cyclone
4 Version:        0.2
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        http://www.cs.cornell.edu/projects/%{name}/%{name}-%{version}.tar.gz
9 Source1:        http://www.cs.cornell.edu/projects/%{name}-%{version}-docs.tar.gz
10 Patch0:         %{name}-DESTDIR.patch
11 Patch1:         %{name}-options.patch
12 URL:            http://www.cs.cornell.edu/projects/cyclone/
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 Cyclone is a language for C programmers who want to write secure, robust
17 programs. It's a dialect of C designed to be safe: free of crashes,
18 buffer overflows, format string attacks, and so on.
19
20 %description -l pl
21 Cyclone jest jêzykiem dla programistów C, którzy chc± pisaæ bezpieczne i
22 szybkie programy. Jest on dialektem C zaprojektowanym by byæ bezpiecznym:
23 wolnym od SEGV, przepe³nieñ buforów, format string attacks, itd.
24
25 %prep
26 %setup -q -n %{name} -a1
27 %patch0 -p1
28 %patch1 -p1
29
30 %build
31 ./configure \
32         -sh /bin/sh \
33         -bindir %{_bindir} \
34         -libdir %{_libdir}/%{name} \
35         -incdir %{_includedir}/%{name} 
36
37 %{__make}
38 %{__make} cyclone_src
39 %{__make} update
40 # hack, there is no doc/ in source distribution
41 mkdir doc
42 echo 'clean:' > doc/Makefile
43 %{__make} clean_nogc
44 # here we got C sources generated from patched cyclone,
45 # we can build for real.
46 %{__make} CFLAGS="%{rpmcflags}" CYC_FLAGS="%{rpmcflags}"
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 make install DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc online-manual/*
59 %attr(755, root, root) %{_bindir}/*
60 %{_libdir}/%{name}
61 %{_includedir}/%{name}
This page took 0.051248 seconds and 2 git commands to generate.