]> git.pld-linux.org Git - packages/cvsspam.git/commitdiff
- drop the shortrepo prepend, breaks my setup and don't understand why it is needed
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 4 Mar 2009 21:16:07 +0000 (21:16 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cvsspam-svn-noshortrepo.patch -> 1.1
    cvsspam.spec -> 1.40

cvsspam-svn-noshortrepo.patch [new file with mode: 0644]
cvsspam.spec

diff --git a/cvsspam-svn-noshortrepo.patch b/cvsspam-svn-noshortrepo.patch
new file mode 100644 (file)
index 0000000..3f847a2
--- /dev/null
@@ -0,0 +1,85 @@
+--- cvsspam/svn_post_commit_hook.rb~   2009-03-04 22:22:15.000000000 +0200
++++ cvsspam/svn_post_commit_hook.rb    2009-03-04 23:07:24.382496937 +0200
+@@ -88,8 +88,6 @@
+   unless FileTest.directory?($repository)
+     usage("no such directory: #{$repository.inspect}")
+   end
+-  $repository =~ /([^\/]+$)/ 
+-  $shortrepo = $1
+ end
+ # runs the given svnlook subcommand
+@@ -173,7 +171,7 @@
+   prev_rev= $revision-1
+   next_rev= $revision
+   out.puts "#V #{prev_rev},#{next_rev}"
+-  out.puts "#M #{$shortrepo}/#{path}"
++  out.puts "#M #{path}"
+   out.puts "#U diff x x"
+   out.puts "#U Binary files x and y differ"
+ end
+@@ -187,7 +185,7 @@
+   next_rev = m[1].to_i
+   diff2 = lines.current
+   out.puts "#V #{prev_rev},#{next_rev}"
+-  out.puts "#M #{$shortrepo}/#{path}"
++  out.puts "#M #{path}"
+   out.puts "#U #{diff1}"
+   out.puts "#U #{diff2}"
+   while lines.next_line && lines.current =~ /^[-\+ @\\]/
+@@ -208,7 +206,7 @@
+ def process_added_binary_diff(out, lines, path)
+   next_rev= $revision
+   out.puts "#V NONE,#{next_rev}"
+-  out.puts "#A #{$shortrepo}/#{path}"
++  out.puts "#A #{path}"
+   out.puts "#U diff x x"
+   out.puts "#U Binary file x added"
+ end
+@@ -221,7 +219,7 @@
+   next_rev = m[1].to_i
+   diff2 = lines.current
+   out.puts "#V NONE,#{next_rev}"
+-  out.puts "#A #{$shortrepo}/#{path}"
++  out.puts "#A #{path}"
+   out.puts "#U #{diff1}"
+   out.puts "#U #{diff2}"
+   while lines.next_line && lines.current =~ /^[-\+ @\\]/
+@@ -238,7 +236,7 @@
+   next_rev = m[1].to_i
+   diff2 = lines.current
+   out.puts "#V #{prev_rev},NONE"
+-  out.puts "#R #{$shortrepo}/#{path}"
++  out.puts "#R #{path}"
+   out.puts "#U #{diff1}"
+   out.puts "#U #{diff2}"
+   while lines.next_line && lines.current =~ /^[-\+ @\\]/
+@@ -287,7 +285,7 @@
+   lines.assert_next(/^_+$/)
+   return unless lines.next_line
+   out.puts "#V #{prev_rev},#{next_rev}"
+-  out.puts "#P #{$shortrepo}/#{path}"
++  out.puts "#P #{path}"
+ # The first three get consumed and not highlighted
+   out.puts "#U "
+   out.puts "#U Property changes:"
+@@ -316,8 +314,8 @@
+ def handle_copy(out, lines, path, from_ref, from_file)
+   prev_rev= $revision-1
+   next_rev= $revision
+-  out.puts "#V #{$shortrepo}/#{from_file}:#{prev_rev},#{next_rev}"
+-  out.puts "#C #{$shortrepo}/#{path}"
++  out.puts "#V #{from_file}:#{prev_rev},#{next_rev}"
++  out.puts "#C #{path}"
+   if lines.next_line && lines.current =~ /^=+$/
+     m = lines.assert_next(/^---.*\(rev (\d+)\)$/)
+     prev_rev = m[1].to_i
+@@ -332,7 +330,7 @@
+     end
+   else
+     out.puts "#U "
+-    out.puts "#U Copied from #{$shortrepo}/#{from_file}:#{from_ref}"
++    out.puts "#U Copied from #{from_file}:#{from_ref}"
+     out.puts "#U "
+   end
+ end
index 34609a07cb382d1fba3696d5fd5848ad23b2492f..d51a189a250825045b69b3ee1549da6a6bb0698c 100644 (file)
@@ -2,7 +2,7 @@ Summary:        CVSspam emails you diffs when someone commits a change to your CVS repo
 Summary(pl.UTF-8):     CVSspam - wysyłanie różnic po wykonaniu zmiany w repozytorium CVS
 Name:          cvsspam
 Version:       0.2.12
-Release:       11.1
+Release:       11.3
 License:       GPL
 Group:         Applications/System
 Source0:       http://www.badgers-in-foil.co.uk/projects/cvsspam/releases/%{name}-%{version}.tar.gz
@@ -14,6 +14,7 @@ Patch1:               %{name}-textdiff.patch
 Patch2:                %{name}-rfc2045.patch
 Patch3:                %{name}-trac.patch
 Patch4:                %{name}-svnspam.patch
+Patch5:                %{name}-svn-noshortrepo.patch
 URL:           http://www.badgers-in-foil.co.uk/projects/cvsspam/
 BuildRequires: rpmbuild(macros) >= 1.277
 Requires:      cvs-client
@@ -46,6 +47,7 @@ możliwe, generowane są odnośniki do frontendów WWW do CVS i systemów
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.07494 seconds and 4 git commands to generate.