]> git.pld-linux.org Git - packages/cvsnt.git/commitdiff
- first use system crypt() which works; then try own broken one; TODO: consider dropp... auto/th/cvsnt-2_5_04_3055-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sun, 15 Jun 2008 01:14:01 +0000 (01:14 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cvsnt-crypt.patch -> 1.1

cvsnt-crypt.patch [new file with mode: 0644]

diff --git a/cvsnt-crypt.patch b/cvsnt-crypt.patch
new file mode 100644 (file)
index 0000000..ad51b34
--- /dev/null
@@ -0,0 +1,32 @@
+--- cvsapi/lib/md5crypt.c.org  2008-06-15 02:55:11.067778449 +0200
++++ cvsapi/lib/md5crypt.c      2008-06-15 02:57:43.657094377 +0200
+@@ -19,6 +19,7 @@
+ #include "api_system.h"
+ #include <string.h>
++#include <unistd.h>
+ #include "md5.h"
+ #include "md5crypt.h"
+@@ -157,7 +158,10 @@
+ {
+       const char *test_pw;
+-      if(is_md5_salt(crypt_pw))
++      test_pw = crypt(text, crypt_pw);
++      if (strcmp(test_pw, crypt_pw) == 0)
++              return 0;
++      else if(is_md5_salt(crypt_pw))
+               test_pw = md5_crypt(text,crypt_pw+strlen(magic));
+       else
+               test_pw = ufc_crypt(text,crypt_pw);
+--- cvsapi/Makefile.am~        2008-04-23 09:35:15.000000000 +0200
++++ cvsapi/Makefile.am 2008-06-15 03:00:51.707076565 +0200
+@@ -96,6 +96,6 @@
+       unix/SSPIHandler.cpp 
+ libcvsapi_la_LDFLAGS = -release $(VERSION) -L$(DESTDIR)/$(libdir)
+-libcvsapi_la_LIBADD = $(LIBXML_LIBS) $(pcre_lib) $(mdns_client_lib) $(LIBLTDL) 
++libcvsapi_la_LIBADD = $(LIBXML_LIBS) $(pcre_lib) $(mdns_client_lib) $(LIBLTDL) -lcrypt
+ lib_LTLIBRARIES = libcvsapi.la
This page took 0.152135 seconds and 4 git commands to generate.