]> git.pld-linux.org Git - packages/cvsnt.git/commitdiff
- fix C++ brekage
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 20 Mar 2018 00:10:33 +0000 (01:10 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 20 Mar 2018 00:10:33 +0000 (01:10 +0100)
- updated deps

cvsnt.spec
cxx.patch [new file with mode: 0644]

index a9ca5ba467abb717ef3da2bb9a89ee7adbe77313..4ee0a977fc0b757b1bb2ec2e726a85331ed0e267 100644 (file)
@@ -38,11 +38,12 @@ Patch3:             %{name}-nospam.patch
 Patch4:                %{name}-fixes.patch
 Patch5:                %{name}-gcc4.patch
 Patch6:                format-security.patch
+Patch7:                cxx.patch
 URL:           http://www.cvsnt.org/
 BuildRequires: autoconf >= 2.58
 BuildRequires: automake >= 1:1.7.9
 BuildRequires: docbook-style-xsl
-BuildRequires: howl-devel
+BuildRequires: avahi-compat-howl-devel
 %{?with_kerberos:BuildRequires:        heimdal-devel}
 BuildRequires: libltdl-devel
 BuildRequires: libntlm-devel >= 0.3.6
@@ -211,6 +212,7 @@ CVSNT version of RCS tools.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 rm -r protocols/ntlm
 
diff --git a/cxx.patch b/cxx.patch
new file mode 100644 (file)
index 0000000..975bebb
--- /dev/null
+++ b/cxx.patch
@@ -0,0 +1,30 @@
+--- cvsnt-2.5.05.3744/cvsapi/mdns.cpp.orig     2006-07-12 15:38:09.000000000 +0200
++++ cvsnt-2.5.05.3744/cvsapi/mdns.cpp  2018-03-18 22:44:15.595819988 +0100
+@@ -35,7 +35,7 @@
+       cvs::string tmp = type;
+       tmp+=SHARED_LIBRARY_EXTENSION;
+       if(!la.Load(tmp.c_str(),dir))
+-              return false;
++              return NULL;
+       pNewMdnsHelper = (CMdnsHelperBase*(*)())la.GetProc("CreateHelper");
+       if(!pNewMdnsHelper)
+               return NULL;
+--- cvsnt-2.5.05.3744/cvsapi/SqlConnection.cpp~        2006-07-14 15:35:28.000000000 +0200
++++ cvsnt-2.5.05.3744/cvsapi/SqlConnection.cpp 2018-03-18 22:44:52.440169383 +0100
+@@ -35,7 +35,7 @@
+       CServerIo::trace(3,"Connecting to %s",db);
+       if(!la.Load(name.c_str(),dir))
+-              return false;
++              return NULL;
+       pNewSqlConnection = (CSqlConnection*(*)())la.GetProc("CreateConnection");
+       if(!pNewSqlConnection)
+--- cvsnt-2.5.05.3744/diff/unicodeapi.cpp~     2018-03-20 01:02:30.000000000 +0100
++++ cvsnt-2.5.05.3744/diff/unicodeapi.cpp      2018-03-20 01:02:48.344855888 +0100
+@@ -1,5 +1,4 @@
+ #include <config.h>
+-#include <system.h>
+ #include <string.h>
+ #ifdef HAVE_MALLOC_H
+ #include <malloc.h>
This page took 0.054031 seconds and 4 git commands to generate.