]> git.pld-linux.org Git - packages/cvsnt.git/blob - cvsnt.spec
- properly detect patched pcre (with a patch avoiding symbol clash)
[packages/cvsnt.git] / cvsnt.spec
1 #
2 # Conditional build:
3 %bcond_without  kerberos                # build without krb5 support
4 #
5 # TODO:
6 # - stay with STABLE 2.5.04 line as soon as it becomes stable
7 # - check server mode and default config
8 # - unpackaged:
9 #   /usr/lib/libcvsapi.la
10 #   /usr/lib/libcvsapi.so
11 #   /usr/lib/libcvstools.la
12 #   /usr/lib/libcvstools.so
13 #   /usr/lib/libmdnsclient.la
14 #   /usr/lib/libmdnsclient.so
15 Summary:        Concurrent Versioning System
16 Summary(pl.UTF-8):      Concurrent Versioning System
17 Name:           cvsnt
18 Version:        2.5.04.2980
19 Release:        0.1
20 License:        GPL v2+/LGPL v2+
21 Group:          Development/Version Control
22 # http://www.cvsnt.org/wiki/Download
23 Source0:        http://www.cvsnt.org/archive/%{name}-%{version}.tar.gz
24 # Source0-md5:  2f82c5b76cd450edcde714eed52b6377
25 Source1:        %{name}.inetd
26 Source2:        %{name}-cvslockd.init
27 Source3:        %{name}.pam
28 Patch0:         %{name}-system-ltdl.patch
29 Patch1:         %{name}-system-pcre.patch
30 Patch2:         %{name}-system-zlib.patch
31 Patch3:         %{name}-system-ntlm.patch
32 URL:            http://www.cvsnt.org/
33 BuildRequires:  autoconf >= 2.58
34 BuildRequires:  automake >= 1:1.7.9
35 BuildRequires:  docbook-style-xsl
36 BuildRequires:  expat-devel
37 BuildRequires:  howl-devel
38 %{?with_kerberos:BuildRequires: krb5-devel}
39 BuildRequires:  libltdl-devel
40 BuildRequires:  libntlm-devel >= 0.3.6
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libxml2-devel
43 BuildRequires:  mysql-devel
44 BuildRequires:  openssl-devel
45 BuildRequires:  pam-devel
46 BuildRequires:  pcre-devel
47 BuildRequires:  postgresql-devel
48 BuildRequires:  rpmbuild(macros) >= 1.268
49 BuildRequires:  sqlite3-devel
50 BuildRequires:  unixODBC-devel
51 BuildRequires:  xmlto
52 BuildRequires:  zlib-devel
53 Provides:       cvs-client = %{version}
54 Obsoletes:      cvs-client
55 Obsoletes:      cvs-nserver-client
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %define         _cvs_root       /var/lib/cvs
59
60 %description
61 CVS means Concurrent Version System; it is a version control system
62 which can record the history of your files (usually, but not always,
63 source code). CVS only stores the differences between versions,
64 instead of every version of every file you've ever created. CVS also
65 keeps a log of who and when made some changes and why they occurred,
66 among other aspects.
67
68 CVSNT Server features include:
69 - Access control for securing projects and branches.
70 - Detailed audit and metrics recorded in an SQL database.
71 - Authentication with Active Directory.
72 - Tracking everything about the change - including whether it was
73   merged from somewhere, belongs to a problem report or was part of a
74   change set.
75 - A control panel to manage email notification of changes, defect
76   tracking integration, and more.
77 - Integrated repository synchronisation (for fail-over servers).
78 - Change set support (group changes by defect number).
79 - Supports UNICODE UTF-8/UCS-2 files and multi-lingual filenames.
80 - When operating in UTF-8 (Unicode) mode it can automatically
81   translate filename encoding for any client.
82 - Plug-ins for email notification.
83 - Helps make merging branches easier with its "Mergepoint" feature.
84 - Native servers available for Mac OS X, Windows, Linux, Solaris,
85   HPUX.
86 - Supports reserved and unreserved versioning methodologies.
87 - CVSAPI for integration into 3rd party products.
88 - Script, COM and 3GL interface for triggers and integration into 3rd
89   party tools (such as defect tracking)
90
91 %package pserver
92 Summary:        rc-inetd config files to run CVS pserver
93 Summary(pl.UTF-8):      Pliki konfiguracyjne rc-inetd do postawienia pservera CVS
94 Group:          Development/Version Control
95 Requires(post): fileutils
96 Requires(postun):       /usr/sbin/groupdel
97 Requires(postun):       /usr/sbin/userdel
98 Requires(pre):  /bin/id
99 Requires(pre):  /usr/bin/getgid
100 Requires(pre):  /usr/sbin/groupadd
101 Requires(pre):  /usr/sbin/useradd
102 Requires:       %{name} = %{version}-%{release}
103 Requires:       rc-inetd
104 Provides:       group(cvs)
105 Provides:       user(cvs)
106 Obsoletes:      cvs-nserver-common
107 Obsoletes:      cvs-nserver-nserver
108 Obsoletes:      cvs-nserver-pserver
109
110 %description pserver
111 Config files for rc-inetd that are necessary to run CVS in pserver
112 mode.
113
114 %package database-mysql
115 Summary:        MySQL Database support for CVSNT
116 Group:          Development/Version Control
117 Requires:       %{name} = %{version}-%{release}
118
119 %description database-mysql
120 MySQL Database support for CVSNT.
121
122 %package database-odbc
123 Summary:        ODBC support for CVSNT
124 Group:          Development/Version Control
125 Requires:       %{name} = %{version}-%{release}
126
127 %description database-odbc
128 ODBC support for CVSNT.
129
130 %package database-postgres
131 Summary:        PostgreSQL Database support for CVSNT
132 Group:          Development/Version Control
133 Requires:       %{name} = %{version}-%{release}
134
135 %description database-postgres
136 PostgreSQL Database support for CVSNT.
137
138 %package database-sqlite
139 Summary:        SQLite Database support for CVSNT
140 Group:          Development/Version Control
141 Requires:       %{name} = %{version}-%{release}
142
143 %description database-sqlite
144 SQLite Database support for CVSNT.
145
146 %package protocol-gserver
147 Summary:        gserver (Kerberos GSS) protocol support for CVSNT
148 Group:          Development/Version Control
149 Requires:       %{name} = %{version}-%{release}
150
151 %description protocol-gserver
152 gserver (Kerberos GSS) support for CVSNT.
153
154 %package protocol-sserver
155 Summary:        sserver (SSL) procotol support for for CVSNT
156 Group:          Development/Version Control
157 Requires:       %{name} = %{version}-%{release}
158
159 %description protocol-sserver
160 sserver (SSL) protocol support for CVSNT.
161
162 %package protocol-sync
163 Summary:        sync procotol support for for CVSNT
164 Group:          Development/Version Control
165 Requires:       %{name} = %{version}-%{release}
166
167 %description protocol-sync
168 sync protocol support for CVSNT.
169
170 %package rcs
171 Summary:        CVSNT version of RCS tools
172 Group:          Development/Version Control
173 Requires:       %{name} = %{version}-%{release}
174
175 %description rcs
176 CVSNT version of RCS tools.
177
178 %prep
179 %setup -q
180 %patch0 -p1
181 %patch1 -p1
182 %patch2 -p1
183 %patch3 -p1
184
185 rm -rf pcre libltdl zlib protocols/ntlm
186
187 %build
188 %{__libtoolize}
189 %{__aclocal}
190 %{__autoconf}
191 %{__automake}
192 %configure \
193         --enable-mdns \
194         --enable-sqlite \
195         --enable-mysql \
196         --enable-odbc \
197         --enable-postgres \
198         --enable-pam \
199         --enable-server \
200         --enable-lockserver \
201         --enable-pserver \
202         --enable-ext \
203         --enable-rsh \
204         --%{?with_kerberos:en}%{!?with_kerberos:dis}able-gserver \
205         --enable-sserver \
206         --enable-sspi \
207         --enable-enum \
208         --enable-rcs
209
210 %{__make}
211
212 cd doc
213 sed "s/__VERSION__/%{version}/" < cvs.dbk > cvs2.dbk
214 sed "s/__VERSION__/%{version}/" < cvsclient.dbk > cvsclient2.dbk
215 xmlto --skip-validation -o html_cvs html cvs2.dbk
216 xmlto --skip-validation -o html_cvsclient html cvsclient2.dbk
217
218 %install
219 rm -rf $RPM_BUILD_ROOT
220 install -d $RPM_BUILD_ROOT{/etc/{pam.d,rc.d/init.d,sysconfig/rc-inetd},%{_cvs_root}}
221
222 %{__make} install -j1 \
223         DESTDIR=$RPM_BUILD_ROOT
224
225 install %{SOURCE1} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/%{name}
226 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/cvslockd
227 install %{SOURCE3} $RPM_BUILD_ROOT/etc/pam.d/cvsnt
228
229 mv $RPM_BUILD_ROOT%{_sysconfdir}/cvsnt/PServer{.example,}
230 mv $RPM_BUILD_ROOT%{_sysconfdir}/cvsnt/Plugins{.example,}
231
232 %clean
233 rm -rf $RPM_BUILD_ROOT
234
235 %post
236 /sbin/ldconfig
237 /sbin/chkconfig --add cvslockd
238 %service cvslockd restart
239
240 %preun
241 if [ "$1" = "0" ]; then
242         %service cvslockd stop
243         /sbin/chkconfig --del cvslockd
244 fi
245
246 %postun -p /sbin/ldconfig
247
248 %pre pserver
249 %groupadd -f -g 52 cvs
250 %useradd -g cvs -d %{_cvs_root} -u 52 -s /bin/false cvs
251
252 %post pserver
253 if [ "$1" = "1" ]; then
254         # Initialise repository
255         %{_bindir}/cvs -d :local:%{_cvs_root} init
256         chown -R cvs:cvs %{_cvs_root}/CVSROOT
257 fi
258 %service -q rc-inetd reload
259
260 %postun pserver
261 if [ "$1" = "0" ]; then
262         %userremove cvs
263         %groupremove cvs
264         %service -q rc-inetd reload
265 fi
266
267 %files
268 %defattr(644,root,root,755)
269 %doc doc/html_cvsclient
270 %doc AUTHORS FAQ README
271 %doc triggers/examples/*.txt
272 %dir %{_sysconfdir}/cvsnt
273 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/cvsnt
274 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvsnt/*
275 %attr(754,root,root) /etc/rc.d/init.d/cvslockd
276 %attr(755,root,root) %{_bindir}/cvs
277 %attr(755,root,root) %{_bindir}/cvslockd
278 %attr(755,root,root) %{_bindir}/cvsnt
279 %attr(755,root,root) %{_bindir}/cvsscript
280 %dir %{_libdir}/cvsnt
281 %dir %{_libdir}/cvsnt/database
282 %dir %{_libdir}/cvsnt/mdns
283 %attr(755,root,root) %{_libdir}/cvsnt/mdns/*.so
284 %{_libdir}/cvsnt/mdns/*.la
285 %dir %{_libdir}/cvsnt/protocols
286 %attr(755,root,root) %{_libdir}/cvsnt/protocols/enum.so
287 %attr(755,root,root) %{_libdir}/cvsnt/protocols/ext.so
288 %attr(755,root,root) %{_libdir}/cvsnt/protocols/pserver.so
289 %attr(755,root,root) %{_libdir}/cvsnt/protocols/server.so
290 %attr(755,root,root) %{_libdir}/cvsnt/protocols/sspi.so
291 %{_libdir}/cvsnt/protocols/enum.la
292 %{_libdir}/cvsnt/protocols/ext.la
293 %{_libdir}/cvsnt/protocols/pserver.la
294 %{_libdir}/cvsnt/protocols/server.la
295 %{_libdir}/cvsnt/protocols/sspi.la
296 %dir %{_libdir}/cvsnt/triggers
297 %attr(755,root,root) %{_libdir}/cvsnt/triggers/*.so
298 %{_libdir}/cvsnt/triggers/*.la
299 %dir %{_libdir}/cvsnt/xdiff
300 %attr(755,root,root) %{_libdir}/cvsnt/xdiff/*.so
301 %{_libdir}/cvsnt/xdiff/*.la
302 %attr(755,root,root) %{_libdir}/lib*-*.so*
303 %{_mandir}/man[15]/*
304
305 %files pserver
306 %defattr(644,root,root,755)
307 %doc doc/html_cvs
308 %attr(770,root,cvs) %dir %{_cvs_root}
309 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/cvsnt
310
311 %files database-mysql
312 %defattr(644,root,root,755)
313 %doc triggers/sql/*_mysql.sql
314 %attr(755,root,root) %{_libdir}/cvsnt/database/mysql.so
315 %{_libdir}/cvsnt/database/mysql.la
316
317 %files database-odbc
318 %defattr(644,root,root,755)
319 %doc triggers/sql/*_oracle.sql
320 %doc triggers/sql/*_mssql.sql
321 %attr(755,root,root) %{_libdir}/cvsnt/database/odbc.so
322 %{_libdir}/cvsnt/database/odbc.la
323
324 %files database-postgres
325 %defattr(644,root,root,755)
326 %doc triggers/sql/*_postgres.sql
327 %attr(755,root,root) %{_libdir}/cvsnt/database/postgres.so
328 %{_libdir}/cvsnt/database/postgres.la
329
330 %files database-sqlite
331 %defattr(644,root,root,755)
332 %doc triggers/sql/*_sqlite.sql
333 %attr(755,root,root) %{_libdir}/cvsnt/database/sqlite.so
334 %{_libdir}/cvsnt/database/sqlite.la
335
336 %if %{with kerberos}
337 %files protocol-gserver
338 %defattr(644,root,root,755)
339 %attr(755,root,root) %{_libdir}/cvsnt/protocols/gserver.so
340 %{_libdir}/cvsnt/protocols/gserver.la
341 %endif
342
343 %files protocol-sserver
344 %defattr(644,root,root,755)
345 %attr(755,root,root) %{_libdir}/cvsnt/protocols/sserver.so
346 %{_libdir}/cvsnt/protocols/sserver.la
347
348 %files protocol-sync
349 %defattr(644,root,root,755)
350 %attr(755,root,root) %{_libdir}/cvsnt/protocols/sync.so
351 %{_libdir}/cvsnt/protocols/sync.la
352
353 %files rcs
354 %defattr(644,root,root,755)
355 %attr(755,root,root) %{_bindir}/co
356 %attr(755,root,root) %{_bindir}/rcsdiff
357 %attr(755,root,root) %{_bindir}/rlog
This page took 0.182719 seconds and 3 git commands to generate.