]> git.pld-linux.org Git - packages/curl.git/commitdiff
fix bcond disabling
authorJacek Konieczny <jajcus@jajcus.net>
Wed, 3 Jun 2015 17:28:27 +0000 (19:28 +0200)
committerJacek Konieczny <jajcus@jajcus.net>
Wed, 3 Jun 2015 17:29:32 +0000 (19:29 +0200)
Use __with_without and __enable_disable macros to make sure features
are enabled and disabled as requested.

curl.spec

index 0475db37511181bb7fa7cba92856aee62be450b5..df4e656169b622e7e94ef4c840cff1eef7d02183 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -45,7 +45,7 @@ BuildRequires:        nettle-devel
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.453
+BuildRequires: rpmbuild(macros) >= 1.527
 %if %{with ssl}
 %if %{with gnutls}
 BuildRequires: gnutls-devel
@@ -219,13 +219,15 @@ Bibliotecas estáticas para desenvolvimento com o curl.
        --with-ssl=%{_prefix} \
 %endif
 %endif
-       %{?with_kerberos5:--with-gssapi=%{_prefix}} \
-       %{?with_metalink:--with-libmetalink} \
-       %{?with_rtmp:--with-librtmp} \
-       %{?with_http2:--with-nghttp2} \
-       %{?with_ares:--enable-ares} \
+       %{__with_without kerberos5 gssapi %{_prefix}} \
+       %{__with_without metalink libmetalink} \
+       %{__with_without rtmp librtmp} \
+       %{__with_without http2 nghttp2} \
+       %{__enable_disable ares} \
+       %{__with_without ssh ssh2} \
        --enable-ipv6 \
-       %{!?with_ldap:--disable-ldap}%{?with_ldap:--enable-ldaps}
+       %{__enable_disable ldap} \
+       %{__enable_disable ldap ldaps}
 
 %{__make}
 
This page took 0.432924 seconds and 4 git commands to generate.