]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- updated to 7.35.0 (fixes CVE-2014-0015)
[packages/curl.git] / curl.spec
index 060a4710c3db19db5127aeea55c3210d94ec267a..f4961d594b786871023d6fbe50fb0b01b11be6ed 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -4,9 +4,11 @@
 %bcond_without ssl             # without SSL support
 %bcond_without kerberos5       # without Heimdal Kerberos 5 support
 %bcond_without ldap            # without LDAP support
+%bcond_with    http2           # without HTTP/2.0 support (nghttp2 based)
+%bcond_without metalink        # without metalink support
 %if "%{pld_release}" != "ac"
 %bcond_without ares            # with c-ares (asynchronous DNS operations) library
-%bcond_without gnutls          # use GnuTLS instead of OpenSSL
+%bcond_with    gnutls          # use GnuTLS instead of OpenSSL
 %bcond_without rtmp            # without Real Time Media Protocol
 %else
 %bcond_with    ares            # with c-ares (asynchronous DNS operations) library
@@ -21,23 +23,24 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.26.0
+Version:       7.35.0
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
 Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
-# Source0-md5: 2ba226ced5d6ef539df970ac77627623
-Patch1:                %{name}-ac.patch
-Patch2:                %{name}-pc.patch
-Patch3:                %{name}-krb5flags.patch
-Patch4:                lib%{name}.fb-changes.diff
-Patch5:                gnutls3.patch
+# Source0-md5: ad7d63864414c61246450dc5e2248c7b
+Patch0:                %{name}-ac.patch
+Patch1:                %{name}-krb5flags.patch
+# make the curl tool link SSL libraries also used by src/tool_metalink.c
+Patch2:                metalink.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
 %{?with_ares:BuildRequires:    c-ares-devel >= 1.7.0}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
+%{?with_http2:BuildRequires:   nghttp2-devel}
 BuildRequires: libidn-devel >= 0.4.1
+%{?with_metalink:BuildRequires:        libmetalink-devel}
 %{?with_rtmp:BuildRequires:    librtmp-devel}
 %{?with_ssh:BuildRequires:     libssh2-devel >= 1.2.8}
 BuildRequires: libtool
@@ -50,14 +53,13 @@ BuildRequires:      rpmbuild(macros) >= 1.453
 %if %{with gnutls}
 BuildRequires: gnutls-devel
 %else
-BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: openssl-devel >= 1.0.1
 %endif
 %endif
 BuildRequires: tar >= 1:1.22
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      libidn >= 0.4.1
-%{?with_ssh:Requires:  libssh2 >= 1.2.8}
 Obsoletes:     libcurl2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -115,6 +117,10 @@ Summary:   curl library
 Summary(pl.UTF-8):     Biblioteka curl
 Group:         Libraries
 %{?with_ares:Requires: c-ares >= 1.7.0}
+%{?with_ssh:Requires:  libssh2 >= 1.2.8}
+%if %{with ssl} && %{without gnutls}
+Requires:      openssl >= 1.0.1
+%endif
 Suggests:      ca-certificates
 Conflicts:     ca-certificates < 20080809-4
 
@@ -193,11 +199,8 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 
 %prep
 %setup -q
+%patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
 
 %{__rm} -v m4/lt*.m4 m4/libtool.m4
 
@@ -218,17 +221,17 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %endif
 %endif
        %{?with_kerberos5:--with-gssapi=%{_prefix}} \
+       %{?with_metalink:--with-libmetalink} \
        %{?with_rtmp:--with-librtmp} \
+       %{?with_http2:--with-nghttp2} \
        %{?with_ares:--enable-ares} \
-       %{?with_ldap:--enable-ldaps} \
-       %{!?with_ldap:--disable-ldap} \
-       --enable-ipv6
+       --enable-ipv6 \
+       %{!?with_ldap:--disable-ldap}%{?with_ldap:--enable-ldaps}
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -261,6 +264,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libcurl.la
 %{_includedir}/curl
 %{_pkgconfigdir}/libcurl.pc
+%{_aclocaldir}/libcurl.m4
 %{_mandir}/man1/curl-config.1*
 %{_mandir}/man3/curl_*.3*
 %{_mandir}/man3/libcurl*.3*
This page took 0.04509 seconds and 4 git commands to generate.