]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- updated to 7.64.0 (solves CVE-2018-16890, CVE-2019-3822, CVE-2019-3823)
[packages/curl.git] / curl.spec
index ab71327e01558b9c15ef73e8393613879a93e340..f0e451db0a6f2ec05c6ed69241eaedc81ae33340 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -22,12 +22,12 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.46.0
+Version:       7.64.0
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
-Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
-# Source0-md5: f845c513830d38c1b7ac39a98c1c2b11
+Source0:       https://curl.haxx.se/download/%{name}-%{version}.tar.xz
+# Source0-md5: d14fe778e9f00399445d9525117e25a3
 Patch0:                %{name}-ac.patch
 Patch1:                %{name}-krb5flags.patch
 URL:           http://curl.haxx.se/
@@ -35,14 +35,15 @@ BuildRequires:      autoconf >= 2.57
 BuildRequires: automake
 %{?with_ares:BuildRequires:    c-ares-devel >= 1.7.0}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
-BuildRequires: libidn-devel >= 0.4.1
+BuildRequires: libbrotli-devel >= 1.0.0
+BuildRequires: libidn2-devel
 %{?with_metalink:BuildRequires:        libmetalink-devel >= 0.1.0}
 BuildRequires: libpsl-devel
 %{?with_rtmp:BuildRequires:    librtmp-devel}
 %{?with_ssh:BuildRequires:     libssh2-devel >= 1.2.8}
 BuildRequires: libtool
 BuildRequires: nettle-devel
-%{?with_http2:BuildRequires:   nghttp2-devel >= 1.0}
+%{?with_http2:BuildRequires:   nghttp2-devel >= 1.9.0}
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
@@ -57,7 +58,6 @@ BuildRequires:        openssl-devel >= 1.0.1
 BuildRequires: tar >= 1:1.22
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      libidn >= 0.4.1
 Obsoletes:     libcurl2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -116,7 +116,7 @@ Summary(pl.UTF-8):  Biblioteka curl
 Group:         Libraries
 %{?with_ares:Requires: c-ares >= 1.7.0}
 %{?with_ssh:Requires:  libssh2 >= 1.2.8}
-%{?with_http2:Requires:        nghttp2 >= 1.0}
+%{?with_http2:Requires:        nghttp2-libs >= 1.9.0}
 %if %{with ssl} && %{without gnutls}
 Requires:      openssl >= 1.0.1
 %endif
@@ -139,11 +139,12 @@ Group:            Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 %{?with_ares:Requires: c-ares-devel}
 %{?with_kerberos5:Requires:    heimdal-devel}
-Requires:      libidn-devel >= 0.4.1
+Requires:      libbrotli-devel >= 1.0.0
+Requires:      libidn2-devel
 Requires:      libpsl-devel
 %{?with_rtmp:Requires: librtmp-devel}
 %{?with_ssh:Requires:  libssh2-devel >= 1.2.8}
-%{?with_http2:Requires:        nghttp2-devel >= 1.0}
+%{?with_http2:Requires:        nghttp2-devel >= 1.9.0}
 %{?with_ldap:Requires: openldap-devel}
 %if %{with ssl}
 %if %{with gnutls}
@@ -238,6 +239,8 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
 %else
        --with-ssl=%{_prefix} \
 %endif
+%else
+       --without-ssl --without-gnutls \
 %endif
        %{__with_without kerberos5 gssapi %{_prefix}} \
        %{__with_without metalink libmetalink} \
@@ -252,6 +255,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{__make} -C scripts install \
+       DESTDIR=$RPM_BUILD_ROOT
+
 # no longer in upstream but a lot of apps tries to include it so we create fake one
 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
@@ -264,7 +270,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
+%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY.md,KNOWN_BUGS,MANUAL,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting}
 %attr(755,root,root) %{_bindir}/curl
 %{_mandir}/man1/curl.1*
 
@@ -275,7 +281,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
+%doc docs/{CONTRIBUTE.md,INTERNALS.md,LICENSE-MIXING.md,RESOURCES}
 %attr(755,root,root) %{_bindir}/curl-config
 %attr(755,root,root) %{_libdir}/libcurl.so
 %{_libdir}/libcurl.la
This page took 0.032541 seconds and 4 git commands to generate.