]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- up to 7.21.4, fixes connecting to hosts with AAAA but no ipv6 routes (like connecti...
[packages/curl.git] / curl.spec
index f23f3142759ea8f3bd2fa55b8da637bc6c7d291a..db1a2a55639d491639311e9bec81e339cd9dc08c 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,11 +1,12 @@
 #
 # Conditional build:
-%bcond_with    ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
+%bcond_without ares            # with c-ares (asynchronous DNS operations) library
 %bcond_without ssh             # without SSH support
 %bcond_without ssl             # without SSL support
 %bcond_without gnutls          # use GnuTLS instead of OpenSSL
-%bcond_without kerberos5       # without MIT Kerberos 5 support
-#
+%bcond_without kerberos5       # without Heimdal Kerberos 5 support
+%bcond_without rtmp            # without Real Time Media Protocol
+
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
 Summary(es.UTF-8):     Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
 Summary(pl.UTF-8):     Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
@@ -13,25 +14,28 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.19.5
+Version:       7.21.4
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
 Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
-# Source0-md5: e4612af6cc471879ae0f4727457eb6fc
+# Source0-md5: 074fa396afe3dbf10163c05756a5a85d
 Patch0:                %{name}-no_strip.patch
 Patch1:                %{name}-ac.patch
 Patch2:                %{name}-pc.patch
 Patch3:                %{name}-krb5flags.patch
+Patch4:                libcurl.fb-changes.diff
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
-%{?with_ares:BuildRequires:    c-ares-devel}
-%{?with_kerberos5:BuildRequires:       krb5-devel}
+%{?with_ares:BuildRequires:    c-ares-devel >= 1.7.0}
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: libidn-devel >= 0.4.1
+%{?with_rtmp:BuildRequires:    librtmp-devel}
 %{?with_ssh:BuildRequires:     libssh2-devel >= 0.16}
 BuildRequires: libtool
 BuildRequires: openldap-devel
+BuildRequires: pkgconfig
 %if %{with ssl}
 %if %{with gnutls}
 BuildRequires: gnutls-devel
@@ -39,6 +43,7 @@ BuildRequires:        gnutls-devel
 BuildRequires: openssl-devel >= 0.9.7d
 %endif
 %endif
+BuildRequires: tar >= 1:1.22
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      libidn >= 0.4.1
@@ -102,6 +107,7 @@ Summary(pl.UTF-8):  Biblioteka curl
 Group:         Libraries
 Suggests:      ca-certificates
 Conflicts:     ca-certificates < 20080809-4
+%{?with_ares:Requires: c-ares >= 1.7.0}
 
 %description libs
 curl library.
@@ -118,9 +124,11 @@ Summary(uk.UTF-8): Файли для розробки з використанн
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 %{?with_ares:Requires: c-ares-devel}
-%{?with_kerberos5:Requires:    krb5-devel}
+%{?with_kerberos5:Requires:    heimdal-devel}
 Requires:      libidn-devel >= 0.4.1
+%{?with_rtmp:Requires: librtmp-devel}
 %{?with_ssh:Requires:  libssh2-devel >= 0.16}
+Requires:      openldap-devel
 %if %{with ssl}
 %if %{with gnutls}
 Requires:      gnutls-devel
@@ -180,6 +188,7 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__libtoolize}
@@ -192,15 +201,16 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %if %{with ssl}
        --with-ca-bundle=/etc/certs/ca-certificates.crt \
 %if %{with gnutls}
-       --with-gnutls=%{_prefix} --without-ssl \
+       --with-gnutls --without-ssl \
 %else
        --with-ssl=%{_prefix} \
 %endif
 %endif
        %{?with_kerberos5:--with-gssapi=%{_prefix}} \
-       %{?with_ares:--enable-ares=%{_prefix}} \
+       %{?with_rtmp:--with-librtmp} \
+       %{?with_ares:--enable-ares} \
        --enable-ldaps \
-       --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
+       --enable-ipv6
 
 %{__make}
 
This page took 0.081541 seconds and 4 git commands to generate.