]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- up to 7.21.4, fixes connecting to hosts with AAAA but no ipv6 routes (like connecti...
[packages/curl.git] / curl.spec
index 4d1d195464cb1750872b7fe32d2f2eaeca390868..db1a2a55639d491639311e9bec81e339cd9dc08c 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,13 +1,12 @@
-# TODO
-# - VMware needs curl with ares
 #
 # Conditional build:
-%bcond_without ares            # with c-ares (asynchronous DNS operations) library (c-ares may not work properly with ipv6)
+%bcond_without ares            # with c-ares (asynchronous DNS operations) library
 %bcond_without ssh             # without SSH support
 %bcond_without ssl             # without SSL support
 %bcond_without gnutls          # use GnuTLS instead of OpenSSL
 %bcond_without kerberos5       # without Heimdal Kerberos 5 support
-#
+%bcond_without rtmp            # without Real Time Media Protocol
+
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
 Summary(es.UTF-8):     Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
 Summary(pl.UTF-8):     Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
@@ -15,12 +14,12 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.20.1
-Release:       2
+Version:       7.21.4
+Release:       1
 License:       MIT-like
 Group:         Applications/Networking
 Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
-# Source0-md5: e259b58aab40dd4e7b72f52e96a498e4
+# Source0-md5: 074fa396afe3dbf10163c05756a5a85d
 Patch0:                %{name}-no_strip.patch
 Patch1:                %{name}-ac.patch
 Patch2:                %{name}-pc.patch
@@ -29,12 +28,14 @@ Patch4:             libcurl.fb-changes.diff
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
-%{?with_ares:BuildRequires:    c-ares-devel}
+%{?with_ares:BuildRequires:    c-ares-devel >= 1.7.0}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: libidn-devel >= 0.4.1
+%{?with_rtmp:BuildRequires:    librtmp-devel}
 %{?with_ssh:BuildRequires:     libssh2-devel >= 0.16}
 BuildRequires: libtool
 BuildRequires: openldap-devel
+BuildRequires: pkgconfig
 %if %{with ssl}
 %if %{with gnutls}
 BuildRequires: gnutls-devel
@@ -106,6 +107,7 @@ Summary(pl.UTF-8):  Biblioteka curl
 Group:         Libraries
 Suggests:      ca-certificates
 Conflicts:     ca-certificates < 20080809-4
+%{?with_ares:Requires: c-ares >= 1.7.0}
 
 %description libs
 curl library.
@@ -124,7 +126,9 @@ Requires:   %{name}-libs = %{version}-%{release}
 %{?with_ares:Requires: c-ares-devel}
 %{?with_kerberos5:Requires:    heimdal-devel}
 Requires:      libidn-devel >= 0.4.1
+%{?with_rtmp:Requires: librtmp-devel}
 %{?with_ssh:Requires:  libssh2-devel >= 0.16}
+Requires:      openldap-devel
 %if %{with ssl}
 %if %{with gnutls}
 Requires:      gnutls-devel
@@ -184,7 +188,7 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p0
+%patch4 -p1
 
 %build
 %{__libtoolize}
@@ -197,13 +201,14 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %if %{with ssl}
        --with-ca-bundle=/etc/certs/ca-certificates.crt \
 %if %{with gnutls}
-       --with-gnutls=%{_prefix} --without-ssl \
+       --with-gnutls --without-ssl \
 %else
        --with-ssl=%{_prefix} \
 %endif
 %endif
        %{?with_kerberos5:--with-gssapi=%{_prefix}} \
-       %{?with_ares:--enable-ares=%{_prefix}} \
+       %{?with_rtmp:--with-librtmp} \
+       %{?with_ares:--enable-ares} \
        --enable-ldaps \
        --enable-ipv6
 
This page took 1.030033 seconds and 4 git commands to generate.