]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- added config patch (fixes curl-config --version)
[packages/curl.git] / curl.spec
index 19df54c6fa35e7ca8f33854e7f5cf1f109787e9d..902b5a7bf613679dbbbe3705d3d2d094e4de0aef 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,10 +1,13 @@
 #
 # Conditional build:
-%bcond_with    ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
+%bcond_without ares            # with c-ares (asynchronous DNS operations) library
 %bcond_without ssh             # without SSH support
 %bcond_without ssl             # without SSL support
-%bcond_without kerberos5       # without MIT Kerberos 5 support
-#
+%bcond_without gnutls          # use GnuTLS instead of OpenSSL
+%bcond_without kerberos5       # without Heimdal Kerberos 5 support
+%bcond_without rtmp            # without Real Time Media Protocol
+%bcond_without ldap            # without LDAP support
+
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
 Summary(es.UTF-8):     Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
 Summary(pl.UTF-8):     Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
@@ -12,25 +15,37 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.17.1
+Version:       7.21.5
 Release:       2
 License:       MIT-like
 Group:         Applications/Networking
-Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 1fa635d1dfde8337c98c82749d75c1de
+Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
+# Source0-md5: decd5586c2bd0496ca562dc8a7244e24
 Patch0:                %{name}-no_strip.patch
 Patch1:                %{name}-ac.patch
 Patch2:                %{name}-pc.patch
+Patch3:                %{name}-krb5flags.patch
+Patch4:                libcurl.fb-changes.diff
+Patch5:                %{name}-config.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
-%{?with_ares:BuildRequires:    c-ares-devel}
-%{?with_kerberos5:BuildRequires:       krb5-devel}
+%{?with_ares:BuildRequires:    c-ares-devel >= 1.7.0}
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: libidn-devel >= 0.4.1
+%{?with_rtmp:BuildRequires:    librtmp-devel}
 %{?with_ssh:BuildRequires:     libssh2-devel >= 0.16}
 BuildRequires: libtool
-BuildRequires: openldap-devel
-%{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
+%{?with_ldap:BuildRequires:    openldap-devel}
+BuildRequires: pkgconfig
+%if %{with ssl}
+%if %{with gnutls}
+BuildRequires: gnutls-devel
+%else
+BuildRequires: openssl-devel >= 0.9.7d
+%endif
+%endif
+BuildRequires: tar >= 1:1.22
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      libidn >= 0.4.1
@@ -92,6 +107,9 @@ curl п╕дтриму╓ багато корисних можливостей,
 Summary:       curl library
 Summary(pl.UTF-8):     Biblioteka curl
 Group:         Libraries
+Suggests:      ca-certificates
+Conflicts:     ca-certificates < 20080809-4
+%{?with_ares:Requires: c-ares >= 1.7.0}
 
 %description libs
 curl library.
@@ -108,10 +126,18 @@ Summary(uk.UTF-8):        Файли для розробки з використанн
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 %{?with_ares:Requires: c-ares-devel}
-%{?with_kerberos5:Requires:    krb5-devel}
+%{?with_kerberos5:Requires:    heimdal-devel}
 Requires:      libidn-devel >= 0.4.1
+%{?with_rtmp:Requires: librtmp-devel}
 %{?with_ssh:Requires:  libssh2-devel >= 0.16}
-%{?with_ssl:Requires:  openssl-devel >= 0.9.7c}
+%{?with_ldap:Requires: openldap-devel}
+%if %{with ssl}
+%if %{with gnutls}
+Requires:      gnutls-devel
+%else
+Requires:      openssl-devel >= 0.9.7c
+%endif
+%endif
 Requires:      zlib-devel
 Obsoletes:     libcurl2-devel
 
@@ -163,20 +189,32 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
        ac_cv_header_gss_h=no \
-       %{?with_ssl:--with-ssl=%{_prefix}} \
-       %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
+%if %{with ssl}
+       --with-ca-bundle=/etc/certs/ca-certificates.crt \
+%if %{with gnutls}
+       --with-gnutls --without-ssl \
+%else
+       --with-ssl=%{_prefix} \
+%endif
+%endif
        %{?with_kerberos5:--with-gssapi=%{_prefix}} \
-       %{?with_ares:--enable-ares=%{_prefix}} \
-       --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
+       %{?with_rtmp:--with-librtmp} \
+       %{?with_ares:--enable-ares} \
+       %{?with_ldap:--enable-ldaps} \
+       %{!?with_ldap:--disable-ldap} \
+       --enable-ipv6
 
 %{__make}
 
@@ -201,6 +239,7 @@ rm -rf $RPM_BUILD_ROOT
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
 
 %files devel
 %defattr(644,root,root,755)
@@ -211,7 +250,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/curl
 %{_pkgconfigdir}/libcurl.pc
 %{_mandir}/man1/curl-config.1*
-%{_mandir}/man3/*curl*.3*
+%{_mandir}/man3/curl_*.3*
+%{_mandir}/man3/libcurl*.3*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.054595 seconds and 4 git commands to generate.