]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- added config patch (fixes curl-config --version)
[packages/curl.git] / curl.spec
index 11614715d19b1374e20838114ede80c00702c1d5..902b5a7bf613679dbbbe3705d3d2d094e4de0aef 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,38 +1,55 @@
 #
 # Conditional build:
-%bcond_with    ares    # with c-ares (asynchronous DNS operations) library (disables IPv6)
-%bcond_without ssh     # without SSH support
-%bcond_without ssl     # without SSL support
-%bcond_without heimdal # without HEIMDAL support
-#
+%bcond_without ares            # with c-ares (asynchronous DNS operations) library
+%bcond_without ssh             # without SSH support
+%bcond_without ssl             # without SSL support
+%bcond_without gnutls          # use GnuTLS instead of OpenSSL
+%bcond_without kerberos5       # without Heimdal Kerberos 5 support
+%bcond_without rtmp            # without Real Time Media Protocol
+%bcond_without ldap            # without LDAP support
+
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
-Summary(es):   Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
-Summary(pl):   Narzêdzie do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
-Summary(pt_BR):        Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
-Summary(ru):   õÔÉÌÉÔÁ ÄÌÑ ÐÏÌÕÞÅÎÉÑ ÆÁÊÌÏ× Ó ÓÅÒ×ÅÒÏ× FTP, HTTP É ÄÒÕÇÉÈ
-Summary(uk):   õÔÉ̦ÔÁ ÄÌÑ ÏÔÒÉÍÁÎÎÑ ÆÁÊ̦נڠÓÅÒ×ÅҦנFTP, HTTP ÔÁ ¦ÎÛÉÈ
+Summary(es.UTF-8):     Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
+Summary(pl.UTF-8):     Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
+Summary(pt_BR.UTF-8):  Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
+Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
+Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.16.1
-Release:       1
+Version:       7.21.5
+Release:       2
 License:       MIT-like
 Group:         Applications/Networking
-Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
-# Source0-md5: acdab0b0467c55e10ed02d2afed80575
+Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
+# Source0-md5: decd5586c2bd0496ca562dc8a7244e24
 Patch0:                %{name}-no_strip.patch
 Patch1:                %{name}-ac.patch
-Patch2:                %{name}-heimdal.patch
+Patch2:                %{name}-pc.patch
+Patch3:                %{name}-krb5flags.patch
+Patch4:                libcurl.fb-changes.diff
+Patch5:                %{name}-config.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
-%{?with_ares:BuildRequires:    c-ares-devel}
-%{?with_heimdal:BuildRequires: heimdal-devel >= 0.7}
+%{?with_ares:BuildRequires:    c-ares-devel >= 1.7.0}
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: libidn-devel >= 0.4.1
-%{?with_ssh:BuildRequires:     libssh2-devel}
+%{?with_rtmp:BuildRequires:    librtmp-devel}
+%{?with_ssh:BuildRequires:     libssh2-devel >= 0.16}
 BuildRequires: libtool
-%{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
+%{?with_ldap:BuildRequires:    openldap-devel}
+BuildRequires: pkgconfig
+%if %{with ssl}
+%if %{with gnutls}
+BuildRequires: gnutls-devel
+%else
+BuildRequires: openssl-devel >= 0.9.7d
+%endif
+%endif
+BuildRequires: tar >= 1:1.22
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      libidn >= 0.4.1
+%{?with_ssh:Requires:  libssh2 >= 0.16}
 Requires:      openssl-tools >= 0.9.7d
 Obsoletes:     libcurl2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -51,127 +68,153 @@ to work without user interaction or any kind of interactivity. cURL
 offers many useful capabilities, like proxy support, user
 authentication, FTP upload, HTTP post, and file transfer resume.
 
-%description -l pl
-cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
-HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
-HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
+%description -l pl.UTF-8
+cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
+HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
+HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
-u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
-siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
-pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
-%{?with_ssl:Ten pakiet obs³uguje tak¿e SSL.}
+użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
+się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
+pliki z/na serwer używając jednego z dostępnych protokołów.
+%{?with_ssl:Ten pakiet obsługuje także SSL.}
 
-%description -l pt_BR
-Curl é um cliente para baixar/enviar arquivos de/para servidores
-usando um dos protocolos suportados. É projetado para funcionar sem a
-interação do usuário.
+%description -l pt_BR.UTF-8
+Curl é um cliente para baixar/enviar arquivos de/para servidores
+usando um dos protocolos suportados. É projetado para funcionar sem a
+interação do usuário.
 
-Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
-continuar transferências interrompidas, e mais...
+Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
+continuar transferências interrompidas, e mais...
 
-%description -l ru
-curl - ÜÔÏ ËÌÉÅÎÔ Ó ÍÎÏÖÅÓÔ×ÏÍ ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ÐÒÏÔÏËÏÌÏ× ÄÌÑ ÐÏÌÕÞÅÎÉÑ
-ÆÁÊÌÏ× Ó ÓÅÒ×ÅÒÏ×, ÓÐÒÏÅËÔÉÒÏ×ÁÎÎÙÊ ÄÌÑ ÒÁÂÏÔÙ ËÁË × ÎÅÉÎÔÅÒÁËÔÉ×ÎÏÍ
-ÒÅÖÉÍÅ, ÔÁË É Ó ×ÏÚÍÏÖÎÏÓÔØÀ ÄÉÁÌÏÇÁ Ó ÐÏÌØÚÏ×ÁÔÅÌÅÍ.
+%description -l ru.UTF-8
+curl - это клиент с множеством поддерживаемых протоколов для получения
+файлов с серверов, спроектированный для работы как в неинтерактивном
+режиме, так и с возможностью диалога с пользователем.
 
-curl ÐÏÄÄÅÒÖÉ×ÁÅÔ ÍÎÏÇÏ ÐÏÌÅÚÎÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ, ÓÒÅÄÉ ËÏÔÏÒÙÈ ÐÏÄÄÅÒÖËÁ
ÒÏËÓÉ, Á×ÔÏÒÉÚÁÃÉÑ ÐÏÌØÚÏ×ÁÔÅÌÑ, ÚÁËÁÞÉ×ÁÎÉÅ ÐÏ FTP, ÐÏÄÄÅÒÖËÁ HTTP
-POST, ×ÏÓÓÔÁÎÏ×ÌÅÎÉÅ ÐÒÅÒ×ÁÎÎÏÊ ÐÅÒÅÓÙÌËÉ É ÍÎÏÇÏÅ ÄÒÕÇÏÅ.
+curl Ð¿Ð¾Ð´Ð´ÐµÑ\80живаеÑ\82 Ð¼Ð½Ð¾Ð³Ð¾ Ð¿Ð¾Ð»ÐµÐ·Ð½Ñ\8bÑ\85 Ð²Ð¾Ð·Ð¼Ð¾Ð¶Ð½Ð¾Ñ\81Ñ\82ей, Ñ\81Ñ\80еди ÐºÐ¾Ñ\82оÑ\80Ñ\8bÑ\85 Ð¿Ð¾Ð´Ð´ÐµÑ\80жка
¿Ñ\80окÑ\81и, Ð°Ð²Ñ\82оÑ\80изаÑ\86иÑ\8f Ð¿Ð¾Ð»Ñ\8cзоваÑ\82елÑ\8f, Ð·Ð°ÐºÐ°Ñ\87ивание Ð¿Ð¾ FTP, Ð¿Ð¾Ð´Ð´ÐµÑ\80жка HTTP
+POST, восстановление прерванной пересылки и многое другое.
 
-curl - ÃÅ Ë̦¤ÎÔ Ú ÂÁÇÁÔØÍÁ Ð¦ÄÔÒÉÍÕ×ÁÎÉÍÉ ÐÒÏÔÏËÏÌÁÍÉ ÄÌÑ ÏÔÒÉÍÁÎÎÑ
-ÆÁÊ̦נڠÓÅÒ×ÅÒ¦×, ÓÐÒÏÅËÔÏ×ÁÎÉÊ ÄÌÑ ÒÏÂÏÔÉ ÑË × ÎŦÎÔÅÒÁËÔÉ×ÎÏÍÕ
-ÒÅÖÉͦ, ÔÁË ¦ Ú ÍÏÖÌÉצÓÔÀ Ä¦ÁÌÏÇÕ Ú ËÏÒÉÓÔÕ×ÁÞÅÍ.
+curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
+файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
+режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
 
-curl Ð¦ÄÔÒÉÍÕ¤ ÂÁÇÁÔÏ ËÏÒÉÓÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ, ÓÅÒÅÄ ÑËÉȠЦÄÔÒÉÍËÁ
ÒÏËÓ¦, Á×ÔÏÒÉÚÁæѠËÏÒÉÓÔÕ×ÁÞÁ, ×¦Ä×ÁÎÔÁÖÅÎÎÑ ÐÏ FTP, HTTP POST,
-צÄÎÏ×ÌÅÎÎÑ ÐÅÒÅÒ×ÁÎϧ ÐÅÒÅÓÉÌËÉ ÔÁ ÂÁÇÁÔÏ ¦ÎÛÏÇÏ.
+curl Ð¿â\95\95дÑ\82Ñ\80имÑ\83â\95\93 Ð±Ð°Ð³Ð°Ñ\82о ÐºÐ¾Ñ\80иÑ\81ниÑ\85 Ð¼Ð¾Ð¶Ð»Ð¸Ð²Ð¾Ñ\81Ñ\82ей, Ñ\81еÑ\80ед Ñ\8fкиÑ\85 Ð¿â\95\95дÑ\82Ñ\80имка
¿Ñ\80окÑ\81â\95\95, Ð°Ð²Ñ\82оÑ\80изаÑ\86â\95\95Ñ\8f ÐºÐ¾Ñ\80иÑ\81Ñ\82Ñ\83ваÑ\87а, Ð²â\95\95дванÑ\82аженнÑ\8f Ð¿Ð¾ FTP, HTTP POST,
+в╕дновлення перервано╖ пересилки та багато ╕ншого.
 
 %package libs
 Summary:       curl library
-Summary(pl):   Biblioteka curl
+Summary(pl.UTF-8):     Biblioteka curl
 Group:         Libraries
+Suggests:      ca-certificates
+Conflicts:     ca-certificates < 20080809-4
+%{?with_ares:Requires: c-ares >= 1.7.0}
 
 %description libs
 curl library.
 
-%description libs -l pl
+%description libs -l pl.UTF-8
 Biblioteka curl.
 
 %package devel
 Summary:       Header files and development documentation for curl library
-Summary(pl):   Pliki nag³ówkowe i dokumentacja do biblioteki curl
-Summary(pt_BR):        Arquivos de cabeçalho e bibliotecas de desenvolvimento
-Summary(ru):   æÁÊÌÙ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl
-Summary(uk):   æÁÊÌÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl
+Summary(pl.UTF-8):     Pliki nagłówkowe i dokumentacja do biblioteki curl
+Summary(pt_BR.UTF-8):  Arquivos de cabeçalho e bibliotecas de desenvolvimento
+Summary(ru.UTF-8):     Файлы для разработки с использованием библиотеки curl
+Summary(uk.UTF-8):     Файли для розробки з використанням бібліотеки curl
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
-%{?with_heimdal:Requires:      heimdal-devel}
+%{?with_ares:Requires: c-ares-devel}
+%{?with_kerberos5:Requires:    heimdal-devel}
 Requires:      libidn-devel >= 0.4.1
-%{?with_ssl:Requires:  openssl-devel >= 0.9.7c}
+%{?with_rtmp:Requires: librtmp-devel}
+%{?with_ssh:Requires:  libssh2-devel >= 0.16}
+%{?with_ldap:Requires: openldap-devel}
+%if %{with ssl}
+%if %{with gnutls}
+Requires:      gnutls-devel
+%else
+Requires:      openssl-devel >= 0.9.7c
+%endif
+%endif
 Requires:      zlib-devel
 Obsoletes:     libcurl2-devel
 
 %description devel
 Header files and development documentation for curl library.
 
-%description devel -l pl
-Pliki nag³ówkowe i dokumentacja do biblioteki curl.
+%description devel -l pl.UTF-8
+Pliki nagłówkowe i dokumentacja do biblioteki curl.
 
-%description devel -l pt_BR
-Arquivos de cabeçalho e bibliotecas de desenvolvimento.
+%description devel -l pt_BR.UTF-8
+Arquivos de cabeçalho e bibliotecas de desenvolvimento.
 
-%description devel -l ru
-üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ Ó
-ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl.
+%description devel -l ru.UTF-8
+Этот пакет содержит файлы, необходимые для разработки программ с
+использованием библиотеки curl.
 
-%description devel -l uk
-ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ Ú
-×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl.
+%description devel -l uk.UTF-8
+Цей пакет містить файли, необхідні для розробки програм з
+використанням бібліотеки curl.
 
 %package static
 Summary:       Static version of curl library
-Summary(pl):   Statyczna wersja biblioteki curl
-Summary(pt_BR):        Bibliotecas estáticas para desenvolvimento com o curl
-Summary(ru):   óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl
-Summary(uk):   óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl
+Summary(pl.UTF-8):     Statyczna wersja biblioteki curl
+Summary(pt_BR.UTF-8):  Bibliotecas estáticas para desenvolvimento com o curl
+Summary(ru.UTF-8):     Статические библиотеки для разработки с использованием библиотеки curl
+Summary(uk.UTF-8):     Статичні бібліотеки для розробки з використанням бібліотеки curl
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static version of curl library.
 
-%description static -l pl
+%description static -l pl.UTF-8
 Statyczna wersja biblioteki curl.
 
-%description static -l pt_BR
-Bibliotecas estáticas para desenvolvimento com o curl.
+%description static -l pt_BR.UTF-8
+Bibliotecas estáticas para desenvolvimento com o curl.
 
-%description static -l ru
-üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÔÁÔÉÞÅÓËÕÀ ÂÉÂÌÉÏÔÅËÕ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ Ó
-ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl.
+%description static -l ru.UTF-8
+Этот пакет содержит статическую библиотеку для разработки программ с
+использованием библиотеки curl.
 
-%description static -l uk
-ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÔÁÔÉÞÎՠ¦Â̦ÏÔÅËÕ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ Ú
-×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl.
+%description static -l uk.UTF-8
+Цей пакет містить статичну бібліотеку для розробки програм з
+використанням бібліотеки curl.
 
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%{?with_heimdal:%patch2 -p0}
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 %build
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
 %configure \
-       %{?with_ssl:--with-ssl=%{_prefix}} \
-       %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
-       %{?with_heimdal:--with-gssapi=%{_prefix}} \
-       %{?with_ares:--enable-ares=%{_prefix}} \
-       --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
+       ac_cv_header_gss_h=no \
+%if %{with ssl}
+       --with-ca-bundle=/etc/certs/ca-certificates.crt \
+%if %{with gnutls}
+       --with-gnutls --without-ssl \
+%else
+       --with-ssl=%{_prefix} \
+%endif
+%endif
+       %{?with_kerberos5:--with-gssapi=%{_prefix}} \
+       %{?with_rtmp:--with-librtmp} \
+       %{?with_ares:--enable-ares} \
+       %{?with_ldap:--enable-ldaps} \
+       %{!?with_ldap:--disable-ldap} \
+       --enable-ipv6
 
 %{__make}
 
@@ -196,6 +239,7 @@ rm -rf $RPM_BUILD_ROOT
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
 
 %files devel
 %defattr(644,root,root,755)
@@ -206,7 +250,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/curl
 %{_pkgconfigdir}/libcurl.pc
 %{_mandir}/man1/curl-config.1*
-%{_mandir}/man3/*curl*.3*
+%{_mandir}/man3/curl_*.3*
+%{_mandir}/man3/libcurl*.3*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.153566 seconds and 4 git commands to generate.