]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- updated to 7.28.0
[packages/curl.git] / curl.spec
index 7c4ef0940752b3bc1e6d0e035ed1a386eb038892..86a62244e9bfe71c3740de43f70f019481ccbe1b 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,12 +1,19 @@
 #
 # Conditional build:
-%bcond_without ares            # with c-ares (asynchronous DNS operations) library
 %bcond_without ssh             # without SSH support
 %bcond_without ssl             # without SSL support
-%bcond_without gnutls          # use GnuTLS instead of OpenSSL
 %bcond_without kerberos5       # without Heimdal Kerberos 5 support
+%bcond_without ldap            # without LDAP support
+%if "%{pld_release}" != "ac"
+%bcond_without ares            # with c-ares (asynchronous DNS operations) library
+%bcond_without gnutls          # use GnuTLS instead of OpenSSL
 %bcond_without rtmp            # without Real Time Media Protocol
-#
+%else
+%bcond_with    ares            # with c-ares (asynchronous DNS operations) library
+%bcond_with    gnutls          # use GnuTLS instead of OpenSSL
+%bcond_with    rtmp            # without Real Time Media Protocol
+%endif
+
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
 Summary(es.UTF-8):     Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
 Summary(pl.UTF-8):     Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
@@ -14,27 +21,29 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.21.1
-Release:       2
+Version:       7.28.0
+Release:       1
 License:       MIT-like
 Group:         Applications/Networking
 Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
-# Source0-md5: 3ba24de2381c9b183aaac48f029fcb0b
-Patch0:                %{name}-no_strip.patch
+# Source0-md5: f8a9f99d9db71d8ce1d2c4ccea3c3850
 Patch1:                %{name}-ac.patch
 Patch2:                %{name}-pc.patch
 Patch3:                %{name}-krb5flags.patch
-Patch4:                libcurl.fb-changes.diff
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
-%{?with_ares:BuildRequires:    c-ares-devel}
+%{?with_ares:BuildRequires:    c-ares-devel >= 1.7.0}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
 BuildRequires: libidn-devel >= 0.4.1
 %{?with_rtmp:BuildRequires:    librtmp-devel}
-%{?with_ssh:BuildRequires:     libssh2-devel >= 0.16}
+%{?with_ssh:BuildRequires:     libssh2-devel >= 1.2.8}
 BuildRequires: libtool
-BuildRequires: openldap-devel
+BuildRequires: nettle-devel
+%{?with_ldap:BuildRequires:    openldap-devel}
+BuildRequires: pkgconfig
+BuildRequires: rpm >= 4.4.9-56
+BuildRequires: rpmbuild(macros) >= 1.453
 %if %{with ssl}
 %if %{with gnutls}
 BuildRequires: gnutls-devel
@@ -46,8 +55,7 @@ BuildRequires:        tar >= 1:1.22
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      libidn >= 0.4.1
-%{?with_ssh:Requires:  libssh2 >= 0.16}
-Requires:      openssl-tools >= 0.9.7d
+%{?with_ssh:Requires:  libssh2 >= 1.2.8}
 Obsoletes:     libcurl2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -104,6 +112,7 @@ curl п╕дтриму╓ багато корисних можливостей,
 Summary:       curl library
 Summary(pl.UTF-8):     Biblioteka curl
 Group:         Libraries
+%{?with_ares:Requires: c-ares >= 1.7.0}
 Suggests:      ca-certificates
 Conflicts:     ca-certificates < 20080809-4
 
@@ -125,8 +134,8 @@ Requires:   %{name}-libs = %{version}-%{release}
 %{?with_kerberos5:Requires:    heimdal-devel}
 Requires:      libidn-devel >= 0.4.1
 %{?with_rtmp:Requires: librtmp-devel}
-%{?with_ssh:Requires:  libssh2-devel >= 0.16}
-Requires:      openldap-devel
+%{?with_ssh:Requires:  libssh2-devel >= 1.2.8}
+%{?with_ldap:Requires: openldap-devel}
 %if %{with ssl}
 %if %{with gnutls}
 Requires:      gnutls-devel
@@ -182,11 +191,11 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 
 %prep
 %setup -q
-%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p0
+
+%{__rm} -v m4/lt*.m4 m4/libtool.m4
 
 %build
 %{__libtoolize}
@@ -207,7 +216,8 @@ Bibliotecas estáticas para desenvolvimento com o curl.
        %{?with_kerberos5:--with-gssapi=%{_prefix}} \
        %{?with_rtmp:--with-librtmp} \
        %{?with_ares:--enable-ares} \
-       --enable-ldaps \
+       %{?with_ldap:--enable-ldaps} \
+       %{!?with_ldap:--disable-ldap} \
        --enable-ipv6
 
 %{__make}
@@ -218,6 +228,10 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+# no longer in upstream but a lot of apps tries to include it so we create fake one
+[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
+echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
This page took 0.110123 seconds and 4 git commands to generate.