]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- up to 7.57.0; fixes CVE-2017-8816, CVE-2017-8817, CVE-2017-8818
[packages/curl.git] / curl.spec
index 16e88b720374c306729674b9097255b351b749ca..6857b9eea966f0e69e1f60dcd1505e411b893f08 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,17 +1,18 @@
 #
 # Conditional build:
-%bcond_without ssh             # without SSH support
-%bcond_without ssl             # without SSL support
-%bcond_without kerberos5       # without Heimdal Kerberos 5 support
-%bcond_without ldap            # without LDAP support
+%bcond_without ssh             # SSH support
+%bcond_without ssl             # SSL support
+%bcond_with    gnutls          # GnuTLS instead of OpenSSL
+%bcond_without kerberos5       # Heimdal Kerberos 5 support
+%bcond_without ldap            # LDAP support
+%bcond_without http2           # HTTP/2.0 support (nghttp2 based)
+%bcond_without metalink        # metalink support
 %if "%{pld_release}" != "ac"
-%bcond_without ares            # with c-ares (asynchronous DNS operations) library
-%bcond_with    gnutls          # use GnuTLS instead of OpenSSL
-%bcond_without rtmp            # without Real Time Media Protocol
+%bcond_without ares            # c-ares (asynchronous DNS operations) library support
+%bcond_without rtmp            # Real Time Media Protocol support
 %else
-%bcond_with    ares            # with c-ares (asynchronous DNS operations) library
-%bcond_with    gnutls          # use GnuTLS instead of OpenSSL
-%bcond_with    rtmp            # without Real Time Media Protocol
+%bcond_with    ares            # c-ares (asynchronous DNS operations) library support
+%bcond_with    rtmp            # Real Time Media Protocol support
 %endif
 
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
@@ -21,12 +22,12 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.31.0
+Version:       7.57.0
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
-Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
-# Source0-md5: 996c1a5004d96cb4baa3f4e1985058b8
+Source0:       https://curl.haxx.se/download/%{name}-%{version}.tar.xz
+# Source0-md5: 93157c8f6593691bc00ae238a4c53863
 Patch0:                %{name}-ac.patch
 Patch1:                %{name}-krb5flags.patch
 URL:           http://curl.haxx.se/
@@ -34,27 +35,29 @@ BuildRequires:      autoconf >= 2.57
 BuildRequires: automake
 %{?with_ares:BuildRequires:    c-ares-devel >= 1.7.0}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
-BuildRequires: libidn-devel >= 0.4.1
+BuildRequires: libbrotli-devel >= 1.0.0
+BuildRequires: libidn2-devel
+%{?with_metalink:BuildRequires:        libmetalink-devel >= 0.1.0}
+BuildRequires: libpsl-devel
 %{?with_rtmp:BuildRequires:    librtmp-devel}
 %{?with_ssh:BuildRequires:     libssh2-devel >= 1.2.8}
 BuildRequires: libtool
 BuildRequires: nettle-devel
+%{?with_http2:BuildRequires:   nghttp2-devel >= 1.9.0}
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.453
+BuildRequires: rpmbuild(macros) >= 1.527
 %if %{with ssl}
 %if %{with gnutls}
 BuildRequires: gnutls-devel
 %else
-BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: openssl-devel >= 1.0.1
 %endif
 %endif
 BuildRequires: tar >= 1:1.22
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      libidn >= 0.4.1
-%{?with_ssh:Requires:  libssh2 >= 1.2.8}
 Obsoletes:     libcurl2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -112,8 +115,14 @@ Summary:   curl library
 Summary(pl.UTF-8):     Biblioteka curl
 Group:         Libraries
 %{?with_ares:Requires: c-ares >= 1.7.0}
+%{?with_ssh:Requires:  libssh2 >= 1.2.8}
+%{?with_http2:Requires:        nghttp2-libs >= 1.9.0}
+%if %{with ssl} && %{without gnutls}
+Requires:      openssl >= 1.0.1
+%endif
 Suggests:      ca-certificates
 Conflicts:     ca-certificates < 20080809-4
+Conflicts:     mysql-libs < 5.6.30-76.3.3
 
 %description libs
 curl library.
@@ -131,9 +140,11 @@ Group:             Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 %{?with_ares:Requires: c-ares-devel}
 %{?with_kerberos5:Requires:    heimdal-devel}
-Requires:      libidn-devel >= 0.4.1
+Requires:      libidn2-devel
+Requires:      libpsl-devel
 %{?with_rtmp:Requires: librtmp-devel}
 %{?with_ssh:Requires:  libssh2-devel >= 1.2.8}
+%{?with_http2:Requires:        nghttp2-devel >= 1.9.0}
 %{?with_ldap:Requires: openldap-devel}
 %if %{with ssl}
 %if %{with gnutls}
@@ -188,12 +199,25 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 Цей пакет містить статичну бібліотеку для розробки програм з
 використанням бібліотеки curl.
 
+%package -n zsh-completion-curl
+Summary:       ZSH completion for curl command
+Summary(pl.UTF-8):     Dopełnianianie parametrów w ZSH dla polecenia curl
+Group:         Applications/Shells
+Requires:      %{name} = %{version}-%{release}
+Requires:      zsh
+
+%description -n zsh-completion-curl
+ZSH completion for curl command.
+
+%description -n zsh-completion-curl -l pl.UTF-8
+Dopełnianianie parametrów w ZSH dla polecenia curl.
+
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 
-%{__rm} -v m4/lt*.m4 m4/libtool.m4
+%{__rm} m4/lt*.m4 m4/libtool.m4
 
 %build
 %{__libtoolize}
@@ -203,6 +227,11 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %{__automake}
 %configure \
        ac_cv_header_gss_h=no \
+       %{__enable_disable ares} \
+       --enable-ipv6 \
+       %{__enable_disable ldap} \
+       %{__enable_disable ldap ldaps} \
+       --disable-silent-rules \
 %if %{with ssl}
        --with-ca-bundle=/etc/certs/ca-certificates.crt \
 %if %{with gnutls}
@@ -211,21 +240,22 @@ Bibliotecas estáticas para desenvolvimento com o curl.
        --with-ssl=%{_prefix} \
 %endif
 %endif
-       %{?with_kerberos5:--with-gssapi=%{_prefix}} \
-       %{?with_rtmp:--with-librtmp} \
-       %{?with_ares:--enable-ares} \
-       %{?with_ldap:--enable-ldaps} \
-       %{!?with_ldap:--disable-ldap} \
-       --enable-ipv6
+       %{__with_without kerberos5 gssapi %{_prefix}} \
+       %{__with_without metalink libmetalink} \
+       %{__with_without rtmp librtmp} \
+       %{__with_without http2 nghttp2} \
+       %{__with_without ssh libssh2}
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{__make} -C scripts install \
+       DESTDIR=$RPM_BUILD_ROOT
+
 # no longer in upstream but a lot of apps tries to include it so we create fake one
 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
@@ -238,7 +268,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
+%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY.md,KNOWN_BUGS,MANUAL,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting}
 %attr(755,root,root) %{_bindir}/curl
 %{_mandir}/man1/curl.1*
 
@@ -249,16 +279,24 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
+%doc docs/{CONTRIBUTE.md,INTERNALS.md,LICENSE-MIXING.md,RESOURCES}
 %attr(755,root,root) %{_bindir}/curl-config
 %attr(755,root,root) %{_libdir}/libcurl.so
 %{_libdir}/libcurl.la
 %{_includedir}/curl
 %{_pkgconfigdir}/libcurl.pc
+%{_aclocaldir}/libcurl.m4
 %{_mandir}/man1/curl-config.1*
 %{_mandir}/man3/curl_*.3*
 %{_mandir}/man3/libcurl*.3*
+%{_mandir}/man3/CURLINFO_*.3*
+%{_mandir}/man3/CURLOPT_*.3*
+%{_mandir}/man3/CURLMOPT_*.3*
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libcurl.a
+
+%files -n zsh-completion-curl
+%defattr(644,root,root,755)
+%{_datadir}/zsh/site-functions/_curl
This page took 0.050741 seconds and 4 git commands to generate.