]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
without ssh2 fix
[packages/curl.git] / curl.spec
index 4aa562046d5aadab26c199021ce8ce7347d1e696..24074df10201c69451118a34df05600787dfa3de 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,18 +1,18 @@
 #
 # Conditional build:
-%bcond_without ssh             # without SSH support
-%bcond_without ssl             # without SSL support
-%bcond_without kerberos5       # without Heimdal Kerberos 5 support
-%bcond_without ldap            # without LDAP support
-%bcond_without metalink        # without metalink support
+%bcond_without ssh             # SSH support
+%bcond_without ssl             # SSL support
+%bcond_with    gnutls          # GnuTLS instead of OpenSSL
+%bcond_without kerberos5       # Heimdal Kerberos 5 support
+%bcond_without ldap            # LDAP support
+%bcond_without http2           # HTTP/2.0 support (nghttp2 based)
+%bcond_without metalink        # metalink support
 %if "%{pld_release}" != "ac"
-%bcond_without ares            # with c-ares (asynchronous DNS operations) library
-%bcond_with    gnutls          # use GnuTLS instead of OpenSSL
-%bcond_without rtmp            # without Real Time Media Protocol
+%bcond_without ares            # c-ares (asynchronous DNS operations) library support
+%bcond_without rtmp            # Real Time Media Protocol support
 %else
-%bcond_with    ares            # with c-ares (asynchronous DNS operations) library
-%bcond_with    gnutls          # use GnuTLS instead of OpenSSL
-%bcond_with    rtmp            # without Real Time Media Protocol
+%bcond_with    ares            # c-ares (asynchronous DNS operations) library support
+%bcond_with    rtmp            # Real Time Media Protocol support
 %endif
 
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
@@ -22,16 +22,14 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.33.0
+Version:       7.42.1
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
 Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
-# Source0-md5: eb463192f37c260163e006d6c4d3f114
+# Source0-md5: f1e460020a99da039b153e4bf0cd8600
 Patch0:                %{name}-ac.patch
 Patch1:                %{name}-krb5flags.patch
-# make the curl tool link SSL libraries also used by src/tool_metalink.c
-Patch2:                metalink.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
@@ -43,22 +41,22 @@ BuildRequires:      libidn-devel >= 0.4.1
 %{?with_ssh:BuildRequires:     libssh2-devel >= 1.2.8}
 BuildRequires: libtool
 BuildRequires: nettle-devel
+%{?with_http2:BuildRequires:   nghttp2-devel >= 0.6}
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.453
+BuildRequires: rpmbuild(macros) >= 1.527
 %if %{with ssl}
 %if %{with gnutls}
 BuildRequires: gnutls-devel
 %else
-BuildRequires: openssl-devel >= 0.9.7d
+BuildRequires: openssl-devel >= 1.0.1
 %endif
 %endif
 BuildRequires: tar >= 1:1.22
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      libidn >= 0.4.1
-%{?with_ssh:Requires:  libssh2 >= 1.2.8}
 Obsoletes:     libcurl2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -116,6 +114,11 @@ Summary:   curl library
 Summary(pl.UTF-8):     Biblioteka curl
 Group:         Libraries
 %{?with_ares:Requires: c-ares >= 1.7.0}
+%{?with_ssh:Requires:  libssh2 >= 1.2.8}
+%{?with_http2:Requires:        nghttp2 >= 0.6}
+%if %{with ssl} && %{without gnutls}
+Requires:      openssl >= 1.0.1
+%endif
 Suggests:      ca-certificates
 Conflicts:     ca-certificates < 20080809-4
 
@@ -138,6 +141,7 @@ Requires:   %{name}-libs = %{version}-%{release}
 Requires:      libidn-devel >= 0.4.1
 %{?with_rtmp:Requires: librtmp-devel}
 %{?with_ssh:Requires:  libssh2-devel >= 1.2.8}
+%{?with_http2:Requires:        nghttp2-devel >= 0.6}
 %{?with_ldap:Requires: openldap-devel}
 %if %{with ssl}
 %if %{with gnutls}
@@ -197,7 +201,7 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %patch0 -p1
 %patch1 -p1
 
-%{__rm} -v m4/lt*.m4 m4/libtool.m4
+%{__rm} m4/lt*.m4 m4/libtool.m4
 
 %build
 %{__libtoolize}
@@ -215,12 +219,15 @@ Bibliotecas estáticas para desenvolvimento com o curl.
        --with-ssl=%{_prefix} \
 %endif
 %endif
-       %{?with_kerberos5:--with-gssapi=%{_prefix}} \
-       %{?with_rtmp:--with-librtmp} \
-       %{?with_metalink:--with-libmetalink} \
-       %{?with_ares:--enable-ares} \
-       %{!?with_ldap:--disable-ldap}%{?with_ldap:--enable-ldaps} \
-       --enable-ipv6
+       %{__with_without kerberos5 gssapi %{_prefix}} \
+       %{__with_without metalink libmetalink} \
+       %{__with_without rtmp librtmp} \
+       %{__with_without http2 nghttp2} \
+       %{__enable_disable ares} \
+       %{__with_without ssh libssh2} \
+       --enable-ipv6 \
+       %{__enable_disable ldap} \
+       %{__enable_disable ldap ldaps}
 
 %{__make}
 
@@ -258,9 +265,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libcurl.la
 %{_includedir}/curl
 %{_pkgconfigdir}/libcurl.pc
+%{_aclocaldir}/libcurl.m4
 %{_mandir}/man1/curl-config.1*
 %{_mandir}/man3/curl_*.3*
 %{_mandir}/man3/libcurl*.3*
+%{_mandir}/man3/CURLOPT_*.3*
+%{_mandir}/man3/CURLMOPT_*.3*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.063175 seconds and 4 git commands to generate.