]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
- revert openldap version bump
[packages/curl.git] / curl.spec
index a7413416ac8a39fbab724d4da83c4617fed58d63..19df54c6fa35e7ca8f33854e7f5cf1f109787e9d 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,38 +1,40 @@
 #
 # Conditional build:
-%bcond_with    ares    # with c-ares (asynchronous DNS operations) library (disables IPv6)
-%bcond_without ssh     # without SSH support
-%bcond_without ssl     # without SSL support
-%bcond_without heimdal # without HEIMDAL support
+%bcond_with    ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
+%bcond_without ssh             # without SSH support
+%bcond_without ssl             # without SSL support
+%bcond_without kerberos5       # without MIT Kerberos 5 support
 #
 Summary:       A utility for getting files from remote servers (FTP, HTTP, and others)
-Summary(es.UTF-8):   Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
-Summary(pl.UTF-8):   Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
-Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
-Summary(ru.UTF-8):   Утилита для получения файлов с серверов FTP, HTTP и других
-Summary(uk.UTF-8):   Утиліта для отримання файлів з серверів FTP, HTTP та інших
+Summary(es.UTF-8):     Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
+Summary(pl.UTF-8):     Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
+Summary(pt_BR.UTF-8):  Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
+Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
+Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.16.1
-Release:       1
+Version:       7.17.1
+Release:       2
 License:       MIT-like
 Group:         Applications/Networking
 Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
-# Source0-md5: acdab0b0467c55e10ed02d2afed80575
+# Source0-md5: 1fa635d1dfde8337c98c82749d75c1de
 Patch0:                %{name}-no_strip.patch
 Patch1:                %{name}-ac.patch
-Patch2:                %{name}-heimdal.patch
+Patch2:                %{name}-pc.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
 %{?with_ares:BuildRequires:    c-ares-devel}
-%{?with_heimdal:BuildRequires: heimdal-devel >= 0.7}
+%{?with_kerberos5:BuildRequires:       krb5-devel}
 BuildRequires: libidn-devel >= 0.4.1
-%{?with_ssh:BuildRequires:     libssh2-devel}
+%{?with_ssh:BuildRequires:     libssh2-devel >= 0.16}
 BuildRequires: libtool
+BuildRequires: openldap-devel
 %{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7d}
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      libidn >= 0.4.1
+%{?with_ssh:Requires:  libssh2 >= 0.16}
 Requires:      openssl-tools >= 0.9.7d
 Obsoletes:     libcurl2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -88,7 +90,7 @@ curl п╕дтриму╓ багато корисних можливостей,
 
 %package libs
 Summary:       curl library
-Summary(pl.UTF-8):   Biblioteka curl
+Summary(pl.UTF-8):     Biblioteka curl
 Group:         Libraries
 
 %description libs
@@ -99,15 +101,16 @@ Biblioteka curl.
 
 %package devel
 Summary:       Header files and development documentation for curl library
-Summary(pl.UTF-8):   Pliki nagłówkowe i dokumentacja do biblioteki curl
-Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
-Summary(ru.UTF-8):   Файлы для разработки с использованием библиотеки curl
-Summary(uk.UTF-8):   Файли для розробки з використанням бібліотеки curl
+Summary(pl.UTF-8):     Pliki nagłówkowe i dokumentacja do biblioteki curl
+Summary(pt_BR.UTF-8):  Arquivos de cabeçalho e bibliotecas de desenvolvimento
+Summary(ru.UTF-8):     Файлы для разработки с использованием библиотеки curl
+Summary(uk.UTF-8):     Файли для розробки з використанням бібліотеки curl
 Group:         Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 %{?with_ares:Requires: c-ares-devel}
-%{?with_heimdal:Requires:      heimdal-devel}
+%{?with_kerberos5:Requires:    krb5-devel}
 Requires:      libidn-devel >= 0.4.1
+%{?with_ssh:Requires:  libssh2-devel >= 0.16}
 %{?with_ssl:Requires:  openssl-devel >= 0.9.7c}
 Requires:      zlib-devel
 Obsoletes:     libcurl2-devel
@@ -131,10 +134,10 @@ Arquivos de cabeçalho e bibliotecas de desenvolvimento.
 
 %package static
 Summary:       Static version of curl library
-Summary(pl.UTF-8):   Statyczna wersja biblioteki curl
-Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
-Summary(ru.UTF-8):   Статические библиотеки для разработки с использованием библиотеки curl
-Summary(uk.UTF-8):   Статичні бібліотеки для розробки з використанням бібліотеки curl
+Summary(pl.UTF-8):     Statyczna wersja biblioteki curl
+Summary(pt_BR.UTF-8):  Bibliotecas estáticas para desenvolvimento com o curl
+Summary(ru.UTF-8):     Статические библиотеки для разработки с использованием библиотеки curl
+Summary(uk.UTF-8):     Статичні бібліотеки для розробки з використанням бібліотеки curl
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{version}-%{release}
 
@@ -159,7 +162,7 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%{?with_heimdal:%patch2 -p0}
+%patch2 -p1
 
 %build
 %{__libtoolize}
@@ -168,9 +171,10 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %{__autoheader}
 %{__automake}
 %configure \
+       ac_cv_header_gss_h=no \
        %{?with_ssl:--with-ssl=%{_prefix}} \
        %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
-       %{?with_heimdal:--with-gssapi=%{_prefix}} \
+       %{?with_kerberos5:--with-gssapi=%{_prefix}} \
        %{?with_ares:--enable-ares=%{_prefix}} \
        --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
 
This page took 0.042244 seconds and 4 git commands to generate.