]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
up to 8.7.1 (fixes CVE-2024-2004 CVE-2024-2379 CVE-2024-2398 CVE-2024-2466)
[packages/curl.git] / curl.spec
index 482c27fa58475f5d6733beaccd4382def0fc24ca..ab7d9f58f30138d20d35477bbc3bf8ed908e5218 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,6 +1,7 @@
 # TODO: ngtpc2/nghttp3 or quiche or msh3 for HTTP3?
 #
 # Conditional build:
+%bcond_without static_libs     # static library
 %bcond_without ssh             # SSH support
 %bcond_without ssl             # SSL support
 %bcond_with    gnutls          # GnuTLS instead of OpenSSL
@@ -24,16 +25,15 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.84.0
+Version:       8.7.1
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
-Source0:       https://curl.haxx.se/download/%{name}-%{version}.tar.xz
-# Source0-md5: 6ce66afa416bb11b8f39cc9e059afd5b
+Source0:       https://curl.se/download/%{name}-%{version}.tar.xz
+# Source0-md5: f4f37253c5f1ad9ee85fa6215fdfeb42
 Patch0:                %{name}-ac.patch
 Patch1:                %{name}-krb5flags.patch
-Patch2:                sched.patch
-URL:           http://curl.haxx.se/
+URL:           https://curl.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
 %{?with_ares:BuildRequires:    c-ares-devel >= 1.17.0}
@@ -43,10 +43,10 @@ BuildRequires:      libbrotli-devel >= 1.0.0
 BuildRequires: libidn2-devel
 BuildRequires: libpsl-devel
 %{?with_rtmp:BuildRequires:    librtmp-devel}
-%{?with_ssh:BuildRequires:     libssh2-devel >= 1.2.8}
+%{?with_ssh:BuildRequires:     libssh2-devel >= 1.11.0}
 BuildRequires: libtool
 BuildRequires: nettle-devel
-%{?with_http2:BuildRequires:   nghttp2-devel >= 1.12.0}
+%{?with_http2:BuildRequires:   nghttp2-devel >= 1.15.0}
 %{?with_http3:BuildRequires:   nghttp3-devel}
 # with gnutls or openssl crypto, conforming to chosen curl crypto library
 %{?with_http3:BuildRequires:   ngtcp2-devel}
@@ -125,8 +125,8 @@ Summary(pl.UTF-8):  Biblioteka curl
 Group:         Libraries
 %{?with_ares:Requires: c-ares >= 1.17.0}
 %{?with_gnutls:Requires:       gnutls-libs >= 3.1.10}
-%{?with_ssh:Requires:  libssh2 >= 1.2.8}
-%{?with_http2:Requires:        nghttp2-libs >= 1.12.0}
+%{?with_ssh:Requires:  libssh2%{?_isa} >= 1.11.0}
+%{?with_http2:Requires:        nghttp2-libs >= 1.15.0}
 %if %{with ssl} && %{without gnutls}
 Requires:      libbrotli >= 1.0.0
 Requires:      openssl >= 1.0.1
@@ -147,7 +147,7 @@ Summary(pt_BR.UTF-8):       Arquivos de cabeçalho e bibliotecas de desenvolvimento
 Summary(ru.UTF-8):     Файлы для разработки с использованием библиотеки curl
 Summary(uk.UTF-8):     Файли для розробки з використанням бібліотеки curl
 Group:         Development/Libraries
-Requires:      %{name}-libs = %{version}-%{release}
+Requires:      %{name}-libs%{?_isa} = %{version}-%{release}
 %{?with_ares:Requires: c-ares-devel}
 %{?with_gsasl:Requires:        gsasl-devel}
 %{?with_kerberos5:Requires:    heimdal-devel}
@@ -155,8 +155,8 @@ Requires:   libbrotli-devel >= 1.0.0
 Requires:      libidn2-devel
 Requires:      libpsl-devel
 %{?with_rtmp:Requires: librtmp-devel}
-%{?with_ssh:Requires:  libssh2-devel >= 1.2.8}
-%{?with_http2:Requires:        nghttp2-devel >= 1.12.0}
+%{?with_ssh:Requires:  libssh2-devel%{?_isa} >= 1.11.0}
+%{?with_http2:Requires:        nghttp2-devel >= 1.15.0}
 %{?with_ldap:Requires: openldap-devel}
 %if %{with ssl}
 %if %{with gnutls}
@@ -244,7 +244,6 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %{__rm} m4/lt*.m4 m4/libtool.m4
 
@@ -256,6 +255,7 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
 %{__automake}
 %configure \
        ac_cv_header_gss_h=no \
+       %{__enable_disable static_libs static} \
        %{__enable_disable ares} \
        %{__with_without gsasl libgsasl} \
        --enable-headers-api \
@@ -263,6 +263,7 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
        %{__enable_disable ldap} \
        %{__enable_disable ldap ldaps} \
        --disable-silent-rules \
+       --enable-websockets \
 %if %{with ssl}
        --with-ca-bundle=/etc/certs/ca-certificates.crt \
 %if %{with gnutls}
@@ -274,6 +275,7 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
        --without-ssl \
 %endif
        --with-fish-functions-dir=%{fish_compdir} \
+       --with-zsh-functions-dir=%{zsh_compdir} \
        %{__with_without kerberos5 gssapi %{_prefix}} \
        %{__with_without rtmp librtmp} \
        %{__with_without http2 nghttp2} \
@@ -332,9 +334,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/CURLMOPT_*.3*
 %{_mandir}/man3/CURLSHOPT_*.3*
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libcurl.a
+%endif
 
 %files -n fish-completion-%{name}
 %defattr(644,root,root,755)
@@ -342,4 +346,4 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n zsh-completion-curl
 %defattr(644,root,root,755)
-%{_datadir}/zsh/site-functions/_curl
+%{zsh_compdir}/_curl
This page took 0.196274 seconds and 4 git commands to generate.