]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
d7cc63a5483a01e406379bc35779f7192cff4550
[packages/curl.git] / curl.spec
1 # TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
2 #
3 # Conditional build:
4 %bcond_without  ssh             # SSH support
5 %bcond_without  ssl             # SSL support
6 %bcond_with     gnutls          # GnuTLS instead of OpenSSL
7 %bcond_without  kerberos5       # Heimdal Kerberos 5 support
8 %bcond_without  ldap            # LDAP support
9 %bcond_without  http2           # HTTP/2.0 support (nghttp2 based)
10 %bcond_without  metalink        # metalink support
11 %if "%{pld_release}" != "ac"
12 %bcond_without  ares            # c-ares (asynchronous DNS operations) library support
13 %bcond_without  rtmp            # Real Time Media Protocol support
14 %else
15 %bcond_with     ares            # c-ares (asynchronous DNS operations) library support
16 %bcond_with     rtmp            # Real Time Media Protocol support
17 %endif
18
19 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
20 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
21 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
22 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
23 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
24 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
25 Name:           curl
26 Version:        7.67.0
27 Release:        1
28 License:        MIT-like
29 Group:          Applications/Networking
30 Source0:        https://curl.haxx.se/download/%{name}-%{version}.tar.xz
31 # Source0-md5:  d55351b88dec558dd3a24dabb2c2d899
32 Patch0:         %{name}-ac.patch
33 Patch1:         %{name}-krb5flags.patch
34 URL:            http://curl.haxx.se/
35 BuildRequires:  autoconf >= 2.57
36 BuildRequires:  automake
37 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
38 %{?with_kerberos5:BuildRequires:        heimdal-devel}
39 BuildRequires:  libbrotli-devel >= 1.0.0
40 BuildRequires:  libidn2-devel
41 %{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
42 BuildRequires:  libpsl-devel
43 %{?with_rtmp:BuildRequires:     librtmp-devel}
44 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
45 BuildRequires:  libtool
46 BuildRequires:  nettle-devel
47 %{?with_http2:BuildRequires:    nghttp2-devel >= 1.9.0}
48 %{?with_ldap:BuildRequires:     openldap-devel}
49 BuildRequires:  pkgconfig
50 BuildRequires:  rpm >= 4.4.9-56
51 BuildRequires:  rpmbuild(macros) >= 1.527
52 %if %{with ssl}
53 %if %{with gnutls}
54 BuildRequires:  gnutls-devel
55 %else
56 BuildRequires:  openssl-devel >= 1.0.1
57 %endif
58 %endif
59 BuildRequires:  tar >= 1:1.22
60 BuildRequires:  zlib-devel
61 Requires:       %{name}-libs = %{version}-%{release}
62 Obsoletes:      libcurl2
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 cURL is a tool for getting files with URL syntax, supporting FTP,
67 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
68 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
69 cookies, user+password authentication and a busload of other useful
70 tricks. The main use for curl is when you want to get or send files
71 automatically to or from a site using one of the supported protocols.
72
73 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
74 Dict servers, using any of the supported protocols. cURL is designed
75 to work without user interaction or any kind of interactivity. cURL
76 offers many useful capabilities, like proxy support, user
77 authentication, FTP upload, HTTP post, and file transfer resume.
78
79 %description -l pl.UTF-8
80 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
81 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
82 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
83 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
84 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
85 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
86 pliki z/na serwer używając jednego z dostępnych protokołów.
87 %{?with_ssl:Ten pakiet obsługuje także SSL.}
88
89 %description -l pt_BR.UTF-8
90 Curl é um cliente para baixar/enviar arquivos de/para servidores
91 usando um dos protocolos suportados. É projetado para funcionar sem a
92 interação do usuário.
93
94 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
95 continuar transferências interrompidas, e mais...
96
97 %description -l ru.UTF-8
98 curl - это клиент с множеством поддерживаемых протоколов для получения
99 файлов с серверов, спроектированный для работы как в неинтерактивном
100 режиме, так и с возможностью диалога с пользователем.
101
102 curl поддерживает много полезных возможностей, среди которых поддержка
103 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
104 POST, восстановление прерванной пересылки и многое другое.
105
106 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
107 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
108 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
109
110 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
111 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
112 в╕дновлення перервано╖ пересилки та багато ╕ншого.
113
114 %package libs
115 Summary:        curl library
116 Summary(pl.UTF-8):      Biblioteka curl
117 Group:          Libraries
118 %{?with_ares:Requires:  c-ares >= 1.7.0}
119 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
120 %{?with_http2:Requires: nghttp2-libs >= 1.9.0}
121 %if %{with ssl} && %{without gnutls}
122 Requires:       openssl >= 1.0.1
123 %endif
124 Suggests:       ca-certificates
125 Conflicts:      ca-certificates < 20080809-4
126
127 %description libs
128 curl library.
129
130 %description libs -l pl.UTF-8
131 Biblioteka curl.
132
133 %package devel
134 Summary:        Header files and development documentation for curl library
135 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
136 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
137 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
138 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
139 Group:          Development/Libraries
140 Requires:       %{name}-libs = %{version}-%{release}
141 %{?with_ares:Requires:  c-ares-devel}
142 %{?with_kerberos5:Requires:     heimdal-devel}
143 Requires:       libbrotli-devel >= 1.0.0
144 Requires:       libidn2-devel
145 Requires:       libpsl-devel
146 %{?with_rtmp:Requires:  librtmp-devel}
147 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
148 %{?with_http2:Requires: nghttp2-devel >= 1.9.0}
149 %{?with_ldap:Requires:  openldap-devel}
150 %if %{with ssl}
151 %if %{with gnutls}
152 Requires:       gnutls-devel
153 %else
154 Requires:       openssl-devel >= 0.9.7c
155 %endif
156 %endif
157 Requires:       zlib-devel
158 Obsoletes:      libcurl2-devel
159
160 %description devel
161 Header files and development documentation for curl library.
162
163 %description devel -l pl.UTF-8
164 Pliki nagłówkowe i dokumentacja do biblioteki curl.
165
166 %description devel -l pt_BR.UTF-8
167 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
168
169 %description devel -l ru.UTF-8
170 Этот пакет содержит файлы, необходимые для разработки программ с
171 использованием библиотеки curl.
172
173 %description devel -l uk.UTF-8
174 Цей пакет містить файли, необхідні для розробки програм з
175 використанням бібліотеки curl.
176
177 %package static
178 Summary:        Static version of curl library
179 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
180 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
181 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
182 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
183 Group:          Development/Libraries
184 Requires:       %{name}-devel = %{version}-%{release}
185
186 %description static
187 Static version of curl library.
188
189 %description static -l pl.UTF-8
190 Statyczna wersja biblioteki curl.
191
192 %description static -l pt_BR.UTF-8
193 Bibliotecas estáticas para desenvolvimento com o curl.
194
195 %description static -l ru.UTF-8
196 Этот пакет содержит статическую библиотеку для разработки программ с
197 использованием библиотеки curl.
198
199 %description static -l uk.UTF-8
200 Цей пакет містить статичну бібліотеку для розробки програм з
201 використанням бібліотеки curl.
202
203 %package -n fish-completion-%{name}
204 Summary:        Fish completion for curl command
205 Summary(pl.UTF-8):      Dopełnianie parametrów w fish dla polecenia curl
206 Group:          Applications/Shells
207 Requires:       %{name} = %{version}-%{release}
208 Requires:       fish
209
210 %description -n fish-completion-%{name}
211 Fish completion for curl command.
212
213 %description -n fish-completion-%{name} -l pl.UTF-8
214 Dopełnianie parametrów w fish dla polecenia curl.
215
216 %package -n zsh-completion-curl
217 Summary:        ZSH completion for curl command
218 Summary(pl.UTF-8):      Dopełnianianie parametrów w ZSH dla polecenia curl
219 Group:          Applications/Shells
220 Requires:       %{name} = %{version}-%{release}
221 Requires:       zsh
222
223 %description -n zsh-completion-curl
224 ZSH completion for curl command.
225
226 %description -n zsh-completion-curl -l pl.UTF-8
227 Dopełnianianie parametrów w ZSH dla polecenia curl.
228
229 %prep
230 %setup -q
231 %patch0 -p1
232 %patch1 -p1
233
234 %{__rm} m4/lt*.m4 m4/libtool.m4
235
236 %build
237 %{__libtoolize}
238 %{__aclocal} -I m4
239 %{__autoconf}
240 %{__autoheader}
241 %{__automake}
242 %configure \
243         ac_cv_header_gss_h=no \
244         %{__enable_disable ares} \
245         --enable-ipv6 \
246         %{__enable_disable ldap} \
247         %{__enable_disable ldap ldaps} \
248         --disable-silent-rules \
249 %if %{with ssl}
250         --with-ca-bundle=/etc/certs/ca-certificates.crt \
251 %if %{with gnutls}
252         --with-gnutls --without-ssl \
253 %else
254         --with-ssl=%{_prefix} \
255 %endif
256 %else
257         --without-ssl --without-gnutls \
258 %endif
259         --with-fish-functions-dir=%{fish_compdir} \
260         %{__with_without kerberos5 gssapi %{_prefix}} \
261         %{__with_without metalink libmetalink} \
262         %{__with_without rtmp librtmp} \
263         %{__with_without http2 nghttp2} \
264         %{__with_without ssh libssh2}
265
266 %{__make}
267
268 %install
269 rm -rf $RPM_BUILD_ROOT
270 %{__make} install \
271         DESTDIR=$RPM_BUILD_ROOT
272
273 %{__make} -C scripts install \
274         DESTDIR=$RPM_BUILD_ROOT
275
276 # no longer in upstream but a lot of apps tries to include it so we create fake one
277 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
278 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
279
280 %clean
281 rm -rf $RPM_BUILD_ROOT
282
283 %post   libs -p /sbin/ldconfig
284 %postun libs -p /sbin/ldconfig
285
286 %files
287 %defattr(644,root,root,755)
288 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting}
289 %attr(755,root,root) %{_bindir}/curl
290 %{_mandir}/man1/curl.1*
291
292 %files libs
293 %defattr(644,root,root,755)
294 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
295 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
296
297 %files devel
298 %defattr(644,root,root,755)
299 %doc docs/{CONTRIBUTE.md,INTERNALS.md,LICENSE-MIXING.md,RESOURCES}
300 %attr(755,root,root) %{_bindir}/curl-config
301 %attr(755,root,root) %{_libdir}/libcurl.so
302 %{_libdir}/libcurl.la
303 %{_includedir}/curl
304 %{_pkgconfigdir}/libcurl.pc
305 %{_aclocaldir}/libcurl.m4
306 %{_mandir}/man1/curl-config.1*
307 %{_mandir}/man3/curl_*.3*
308 %{_mandir}/man3/libcurl*.3*
309 %{_mandir}/man3/CURLINFO_*.3*
310 %{_mandir}/man3/CURLOPT_*.3*
311 %{_mandir}/man3/CURLMOPT_*.3*
312
313 %files static
314 %defattr(644,root,root,755)
315 %{_libdir}/libcurl.a
316
317 %files -n fish-completion-%{name}
318 %defattr(644,root,root,755)
319 %{fish_compdir}/%{name}.fish
320
321 %files -n zsh-completion-curl
322 %defattr(644,root,root,755)
323 %{_datadir}/zsh/site-functions/_curl
This page took 0.052795 seconds and 2 git commands to generate.