]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
d56589f7592030a21cff6b591f9b0a04ce2ba7d2
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssh             # SSH support
4 %bcond_without  ssl             # SSL support
5 %bcond_with     gnutls          # GnuTLS instead of OpenSSL
6 %bcond_without  kerberos5       # Heimdal Kerberos 5 support
7 %bcond_without  ldap            # LDAP support
8 %bcond_with     http2           # HTTP/2.0 support (nghttp2 based)
9 %bcond_without  metalink        # metalink support
10 %if "%{pld_release}" != "ac"
11 %bcond_without  ares            # c-ares (asynchronous DNS operations) library support
12 %bcond_without  rtmp            # Real Time Media Protocol support
13 %else
14 %bcond_with     ares            # c-ares (asynchronous DNS operations) library support
15 %bcond_with     rtmp            # Real Time Media Protocol support
16 %endif
17
18 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
19 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
20 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
21 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
22 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
23 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
24 Name:           curl
25 Version:        7.38.0
26 Release:        1
27 License:        MIT-like
28 Group:          Applications/Networking
29 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
30 # Source0-md5:  fdafc30cbf0acd2fe6bc31b956b856a5
31 Patch0:         %{name}-ac.patch
32 Patch1:         %{name}-krb5flags.patch
33 URL:            http://curl.haxx.se/
34 BuildRequires:  autoconf >= 2.57
35 BuildRequires:  automake
36 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
37 %{?with_kerberos5:BuildRequires:        heimdal-devel}
38 BuildRequires:  libidn-devel >= 0.4.1
39 %{?with_metalink:BuildRequires: libmetalink-devel}
40 %{?with_rtmp:BuildRequires:     librtmp-devel}
41 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
42 BuildRequires:  libtool
43 BuildRequires:  nettle-devel
44 %{?with_http2:BuildRequires:    nghttp2-devel >= 0.4}
45 %{?with_ldap:BuildRequires:     openldap-devel}
46 BuildRequires:  pkgconfig
47 BuildRequires:  rpm >= 4.4.9-56
48 BuildRequires:  rpmbuild(macros) >= 1.453
49 %if %{with ssl}
50 %if %{with gnutls}
51 BuildRequires:  gnutls-devel
52 %else
53 BuildRequires:  openssl-devel >= 1.0.1
54 %endif
55 %endif
56 BuildRequires:  tar >= 1:1.22
57 BuildRequires:  zlib-devel
58 Requires:       %{name}-libs = %{version}-%{release}
59 Requires:       libidn >= 0.4.1
60 Obsoletes:      libcurl2
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 cURL is a tool for getting files with URL syntax, supporting FTP,
65 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
66 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
67 cookies, user+password authentication and a busload of other useful
68 tricks. The main use for curl is when you want to get or send files
69 automatically to or from a site using one of the supported protocols.
70
71 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
72 Dict servers, using any of the supported protocols. cURL is designed
73 to work without user interaction or any kind of interactivity. cURL
74 offers many useful capabilities, like proxy support, user
75 authentication, FTP upload, HTTP post, and file transfer resume.
76
77 %description -l pl.UTF-8
78 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
79 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
80 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
81 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
82 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
83 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
84 pliki z/na serwer używając jednego z dostępnych protokołów.
85 %{?with_ssl:Ten pakiet obsługuje także SSL.}
86
87 %description -l pt_BR.UTF-8
88 Curl é um cliente para baixar/enviar arquivos de/para servidores
89 usando um dos protocolos suportados. É projetado para funcionar sem a
90 interação do usuário.
91
92 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
93 continuar transferências interrompidas, e mais...
94
95 %description -l ru.UTF-8
96 curl - это клиент с множеством поддерживаемых протоколов для получения
97 файлов с серверов, спроектированный для работы как в неинтерактивном
98 режиме, так и с возможностью диалога с пользователем.
99
100 curl поддерживает много полезных возможностей, среди которых поддержка
101 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
102 POST, восстановление прерванной пересылки и многое другое.
103
104 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
105 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
106 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
107
108 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
109 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
110 в╕дновлення перервано╖ пересилки та багато ╕ншого.
111
112 %package libs
113 Summary:        curl library
114 Summary(pl.UTF-8):      Biblioteka curl
115 Group:          Libraries
116 %{?with_ares:Requires:  c-ares >= 1.7.0}
117 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
118 %{?with_http2:Requires: nghttp2 >= 0.4}
119 %if %{with ssl} && %{without gnutls}
120 Requires:       openssl >= 1.0.1
121 %endif
122 Suggests:       ca-certificates
123 Conflicts:      ca-certificates < 20080809-4
124
125 %description libs
126 curl library.
127
128 %description libs -l pl.UTF-8
129 Biblioteka curl.
130
131 %package devel
132 Summary:        Header files and development documentation for curl library
133 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
134 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
135 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
136 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
137 Group:          Development/Libraries
138 Requires:       %{name}-libs = %{version}-%{release}
139 %{?with_ares:Requires:  c-ares-devel}
140 %{?with_kerberos5:Requires:     heimdal-devel}
141 Requires:       libidn-devel >= 0.4.1
142 %{?with_rtmp:Requires:  librtmp-devel}
143 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
144 %{?with_http2:Requires: nghttp2-devel >= 0.4}
145 %{?with_ldap:Requires:  openldap-devel}
146 %if %{with ssl}
147 %if %{with gnutls}
148 Requires:       gnutls-devel
149 %else
150 Requires:       openssl-devel >= 0.9.7c
151 %endif
152 %endif
153 Requires:       zlib-devel
154 Obsoletes:      libcurl2-devel
155
156 %description devel
157 Header files and development documentation for curl library.
158
159 %description devel -l pl.UTF-8
160 Pliki nagłówkowe i dokumentacja do biblioteki curl.
161
162 %description devel -l pt_BR.UTF-8
163 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
164
165 %description devel -l ru.UTF-8
166 Этот пакет содержит файлы, необходимые для разработки программ с
167 использованием библиотеки curl.
168
169 %description devel -l uk.UTF-8
170 Цей пакет містить файли, необхідні для розробки програм з
171 використанням бібліотеки curl.
172
173 %package static
174 Summary:        Static version of curl library
175 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
176 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
177 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
178 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
179 Group:          Development/Libraries
180 Requires:       %{name}-devel = %{version}-%{release}
181
182 %description static
183 Static version of curl library.
184
185 %description static -l pl.UTF-8
186 Statyczna wersja biblioteki curl.
187
188 %description static -l pt_BR.UTF-8
189 Bibliotecas estáticas para desenvolvimento com o curl.
190
191 %description static -l ru.UTF-8
192 Этот пакет содержит статическую библиотеку для разработки программ с
193 использованием библиотеки curl.
194
195 %description static -l uk.UTF-8
196 Цей пакет містить статичну бібліотеку для розробки програм з
197 використанням бібліотеки curl.
198
199 %prep
200 %setup -q
201 %patch0 -p1
202 %patch1 -p1
203
204 %{__rm} m4/lt*.m4 m4/libtool.m4
205
206 %build
207 %{__libtoolize}
208 %{__aclocal} -I m4
209 %{__autoconf}
210 %{__autoheader}
211 %{__automake}
212 %configure \
213         ac_cv_header_gss_h=no \
214 %if %{with ssl}
215         --with-ca-bundle=/etc/certs/ca-certificates.crt \
216 %if %{with gnutls}
217         --with-gnutls --without-ssl \
218 %else
219         --with-ssl=%{_prefix} \
220 %endif
221 %endif
222         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
223         %{?with_metalink:--with-libmetalink} \
224         %{?with_rtmp:--with-librtmp} \
225         %{?with_http2:--with-nghttp2} \
226         %{?with_ares:--enable-ares} \
227         --enable-ipv6 \
228         %{!?with_ldap:--disable-ldap}%{?with_ldap:--enable-ldaps}
229
230 %{__make}
231
232 %install
233 rm -rf $RPM_BUILD_ROOT
234 %{__make} install \
235         DESTDIR=$RPM_BUILD_ROOT
236
237 # no longer in upstream but a lot of apps tries to include it so we create fake one
238 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
239 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
240
241 %clean
242 rm -rf $RPM_BUILD_ROOT
243
244 %post   libs -p /sbin/ldconfig
245 %postun libs -p /sbin/ldconfig
246
247 %files
248 %defattr(644,root,root,755)
249 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
250 %attr(755,root,root) %{_bindir}/curl
251 %{_mandir}/man1/curl.1*
252
253 %files libs
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
256 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
257
258 %files devel
259 %defattr(644,root,root,755)
260 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
261 %attr(755,root,root) %{_bindir}/curl-config
262 %attr(755,root,root) %{_libdir}/libcurl.so
263 %{_libdir}/libcurl.la
264 %{_includedir}/curl
265 %{_pkgconfigdir}/libcurl.pc
266 %{_aclocaldir}/libcurl.m4
267 %{_mandir}/man1/curl-config.1*
268 %{_mandir}/man3/curl_*.3*
269 %{_mandir}/man3/libcurl*.3*
270 %{_mandir}/man3/CURLOPT_*.3*
271
272 %files static
273 %defattr(644,root,root,755)
274 %{_libdir}/libcurl.a
This page took 0.045403 seconds and 2 git commands to generate.