]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
cacc10b310d826c5f4068d269b105b916d588b91
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ares            # with c-ares (asynchronous DNS operations) library
4 %bcond_without  ssh             # without SSH support
5 %bcond_without  ssl             # without SSL support
6 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
7 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
8 %bcond_without  rtmp            # without Real Time Media Protocol
9 %bcond_without  ldap            # without LDAP support
10
11 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
12 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
13 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
14 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
15 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
16 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
17 Name:           curl
18 Version:        7.21.7
19 Release:        4
20 License:        MIT-like
21 Group:          Applications/Networking
22 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
23 # Source0-md5:  5dbcbabe8fd577763106c4f655e31b66
24 Patch0:         %{name}-no_strip.patch
25 Patch1:         %{name}-ac.patch
26 Patch2:         %{name}-pc.patch
27 Patch3:         %{name}-krb5flags.patch
28 Patch4:         libcurl.fb-changes.diff
29 URL:            http://curl.haxx.se/
30 BuildRequires:  autoconf >= 2.57
31 BuildRequires:  automake
32 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
33 %{?with_kerberos5:BuildRequires:        heimdal-devel}
34 BuildRequires:  libidn-devel >= 0.4.1
35 %{?with_rtmp:BuildRequires:     librtmp-devel}
36 %{?with_ssh:BuildRequires:      libssh2-devel >= 0.16}
37 BuildRequires:  libtool
38 %{?with_ldap:BuildRequires:     openldap-devel}
39 BuildRequires:  pkgconfig
40 %if %{with ssl}
41 %if %{with gnutls}
42 BuildRequires:  gnutls-devel
43 %else
44 BuildRequires:  openssl-devel >= 0.9.7d
45 %endif
46 %endif
47 BuildRequires:  tar >= 1:1.22
48 BuildRequires:  zlib-devel
49 Requires:       %{name}-libs = %{version}-%{release}
50 Requires:       libidn >= 0.4.1
51 %{?with_ssh:Requires:   libssh2 >= 0.16}
52 Requires:       openssl-tools >= 0.9.7d
53 Obsoletes:      libcurl2
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 cURL is a tool for getting files with URL syntax, supporting FTP,
58 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
59 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
60 cookies, user+password authentication and a busload of other useful
61 tricks. The main use for curl is when you want to get or send files
62 automatically to or from a site using one of the supported protocols.
63
64 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
65 Dict servers, using any of the supported protocols. cURL is designed
66 to work without user interaction or any kind of interactivity. cURL
67 offers many useful capabilities, like proxy support, user
68 authentication, FTP upload, HTTP post, and file transfer resume.
69
70 %description -l pl.UTF-8
71 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
72 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
73 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
74 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
75 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
76 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
77 pliki z/na serwer używając jednego z dostępnych protokołów.
78 %{?with_ssl:Ten pakiet obsługuje także SSL.}
79
80 %description -l pt_BR.UTF-8
81 Curl é um cliente para baixar/enviar arquivos de/para servidores
82 usando um dos protocolos suportados. É projetado para funcionar sem a
83 interação do usuário.
84
85 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
86 continuar transferências interrompidas, e mais...
87
88 %description -l ru.UTF-8
89 curl - это клиент с множеством поддерживаемых протоколов для получения
90 файлов с серверов, спроектированный для работы как в неинтерактивном
91 режиме, так и с возможностью диалога с пользователем.
92
93 curl поддерживает много полезных возможностей, среди которых поддержка
94 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
95 POST, восстановление прерванной пересылки и многое другое.
96
97 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
98 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
99 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
100
101 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
102 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
103 в╕дновлення перервано╖ пересилки та багато ╕ншого.
104
105 %package libs
106 Summary:        curl library
107 Summary(pl.UTF-8):      Biblioteka curl
108 Group:          Libraries
109 Suggests:       ca-certificates
110 Conflicts:      ca-certificates < 20080809-4
111 %{?with_ares:Requires:  c-ares >= 1.7.0}
112
113 %description libs
114 curl library.
115
116 %description libs -l pl.UTF-8
117 Biblioteka curl.
118
119 %package devel
120 Summary:        Header files and development documentation for curl library
121 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
122 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
123 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
124 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
125 Group:          Development/Libraries
126 Requires:       %{name}-libs = %{version}-%{release}
127 %{?with_ares:Requires:  c-ares-devel}
128 %{?with_kerberos5:Requires:     heimdal-devel}
129 Requires:       libidn-devel >= 0.4.1
130 %{?with_rtmp:Requires:  librtmp-devel}
131 %{?with_ssh:Requires:   libssh2-devel >= 0.16}
132 %{?with_ldap:Requires:  openldap-devel}
133 %if %{with ssl}
134 %if %{with gnutls}
135 Requires:       gnutls-devel
136 %else
137 Requires:       openssl-devel >= 0.9.7c
138 %endif
139 %endif
140 Requires:       zlib-devel
141 Obsoletes:      libcurl2-devel
142
143 %description devel
144 Header files and development documentation for curl library.
145
146 %description devel -l pl.UTF-8
147 Pliki nagłówkowe i dokumentacja do biblioteki curl.
148
149 %description devel -l pt_BR.UTF-8
150 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
151
152 %description devel -l ru.UTF-8
153 Этот пакет содержит файлы, необходимые для разработки программ с
154 использованием библиотеки curl.
155
156 %description devel -l uk.UTF-8
157 Цей пакет містить файли, необхідні для розробки програм з
158 використанням бібліотеки curl.
159
160 %package static
161 Summary:        Static version of curl library
162 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
163 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
164 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
165 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
166 Group:          Development/Libraries
167 Requires:       %{name}-devel = %{version}-%{release}
168
169 %description static
170 Static version of curl library.
171
172 %description static -l pl.UTF-8
173 Statyczna wersja biblioteki curl.
174
175 %description static -l pt_BR.UTF-8
176 Bibliotecas estáticas para desenvolvimento com o curl.
177
178 %description static -l ru.UTF-8
179 Этот пакет содержит статическую библиотеку для разработки программ с
180 использованием библиотеки curl.
181
182 %description static -l uk.UTF-8
183 Цей пакет містить статичну бібліотеку для розробки програм з
184 використанням бібліотеки curl.
185
186 %prep
187 %setup -q
188 %patch0 -p1
189 %patch1 -p1
190 %patch2 -p1
191 %patch3 -p1
192 %patch4 -p1
193
194 %build
195 %{__libtoolize}
196 %{__aclocal} -I m4
197 %{__autoconf}
198 %{__autoheader}
199 %{__automake}
200 %configure \
201         ac_cv_header_gss_h=no \
202 %if %{with ssl}
203         --with-ca-bundle=/etc/certs/ca-certificates.crt \
204 %if %{with gnutls}
205         --with-gnutls --without-ssl \
206 %else
207         --with-ssl=%{_prefix} \
208 %endif
209 %endif
210         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
211         %{?with_rtmp:--with-librtmp} \
212         %{?with_ares:--enable-ares} \
213         %{?with_ldap:--enable-ldaps} \
214         %{!?with_ldap:--disable-ldap} \
215         --enable-ipv6
216
217 %{__make}
218
219 %install
220 rm -rf $RPM_BUILD_ROOT
221
222 %{__make} install \
223         DESTDIR=$RPM_BUILD_ROOT
224
225 # no longer in upstream but a lot of apps tries to include it so we create fake one
226 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
227 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
228
229 %clean
230 rm -rf $RPM_BUILD_ROOT
231
232 %post   libs -p /sbin/ldconfig
233 %postun libs -p /sbin/ldconfig
234
235 %files
236 %defattr(644,root,root,755)
237 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
238 %attr(755,root,root) %{_bindir}/curl
239 %{_mandir}/man1/curl.1*
240
241 %files libs
242 %defattr(644,root,root,755)
243 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
244 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
245
246 %files devel
247 %defattr(644,root,root,755)
248 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
249 %attr(755,root,root) %{_bindir}/curl-config
250 %attr(755,root,root) %{_libdir}/libcurl.so
251 %{_libdir}/libcurl.la
252 %{_includedir}/curl
253 %{_pkgconfigdir}/libcurl.pc
254 %{_mandir}/man1/curl-config.1*
255 %{_mandir}/man3/curl_*.3*
256 %{_mandir}/man3/libcurl*.3*
257
258 %files static
259 %defattr(644,root,root,755)
260 %{_libdir}/libcurl.a
This page took 2.798541 seconds and 2 git commands to generate.