]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
bc8aae59611f1f5d4b3285942727ea3b6a616d79
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssh             # without SSH support
4 %bcond_without  ssl             # without SSL support
5 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
6 %bcond_without  ldap            # without LDAP support
7 %if "%{pld_release}" != "ac"
8 %bcond_without  ares            # with c-ares (asynchronous DNS operations) library
9 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
10 %bcond_without  rtmp            # without Real Time Media Protocol
11 %else
12 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library
13 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
14 %bcond_with     rtmp            # without Real Time Media Protocol
15 %endif
16
17 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
18 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
19 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
20 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
21 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
22 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
23 Name:           curl
24 Version:        7.27.0
25 Release:        2
26 License:        MIT-like
27 Group:          Applications/Networking
28 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
29 # Source0-md5:  1b669875527ba4b943a0cdb5b255a02c
30 Patch1:         %{name}-ac.patch
31 Patch2:         %{name}-pc.patch
32 Patch3:         %{name}-krb5flags.patch
33 Patch4:         lib%{name}.fb-changes.diff
34 Patch5:         gnutls3.patch
35 Patch6:         %{name}-gtls.patch
36 Patch7:         %{name}-config.patch
37 URL:            http://curl.haxx.se/
38 BuildRequires:  autoconf >= 2.57
39 BuildRequires:  automake
40 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
41 %{?with_kerberos5:BuildRequires:        heimdal-devel}
42 BuildRequires:  libidn-devel >= 0.4.1
43 %{?with_rtmp:BuildRequires:     librtmp-devel}
44 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
45 BuildRequires:  libtool
46 BuildRequires:  nettle-devel
47 %{?with_ldap:BuildRequires:     openldap-devel}
48 BuildRequires:  pkgconfig
49 BuildRequires:  rpm >= 4.4.9-56
50 BuildRequires:  rpmbuild(macros) >= 1.453
51 %if %{with ssl}
52 %if %{with gnutls}
53 BuildRequires:  gnutls-devel
54 %else
55 BuildRequires:  openssl-devel >= 0.9.7d
56 %endif
57 %endif
58 BuildRequires:  tar >= 1:1.22
59 BuildRequires:  zlib-devel
60 Requires:       %{name}-libs = %{version}-%{release}
61 Requires:       libidn >= 0.4.1
62 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
63 Obsoletes:      libcurl2
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 cURL is a tool for getting files with URL syntax, supporting FTP,
68 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
69 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
70 cookies, user+password authentication and a busload of other useful
71 tricks. The main use for curl is when you want to get or send files
72 automatically to or from a site using one of the supported protocols.
73
74 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
75 Dict servers, using any of the supported protocols. cURL is designed
76 to work without user interaction or any kind of interactivity. cURL
77 offers many useful capabilities, like proxy support, user
78 authentication, FTP upload, HTTP post, and file transfer resume.
79
80 %description -l pl.UTF-8
81 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
82 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
83 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
84 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
85 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
86 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
87 pliki z/na serwer używając jednego z dostępnych protokołów.
88 %{?with_ssl:Ten pakiet obsługuje także SSL.}
89
90 %description -l pt_BR.UTF-8
91 Curl é um cliente para baixar/enviar arquivos de/para servidores
92 usando um dos protocolos suportados. É projetado para funcionar sem a
93 interação do usuário.
94
95 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
96 continuar transferências interrompidas, e mais...
97
98 %description -l ru.UTF-8
99 curl - это клиент с множеством поддерживаемых протоколов для получения
100 файлов с серверов, спроектированный для работы как в неинтерактивном
101 режиме, так и с возможностью диалога с пользователем.
102
103 curl поддерживает много полезных возможностей, среди которых поддержка
104 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
105 POST, восстановление прерванной пересылки и многое другое.
106
107 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
108 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
109 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
110
111 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
112 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
113 в╕дновлення перервано╖ пересилки та багато ╕ншого.
114
115 %package libs
116 Summary:        curl library
117 Summary(pl.UTF-8):      Biblioteka curl
118 Group:          Libraries
119 %{?with_ares:Requires:  c-ares >= 1.7.0}
120 Suggests:       ca-certificates
121 Conflicts:      ca-certificates < 20080809-4
122
123 %description libs
124 curl library.
125
126 %description libs -l pl.UTF-8
127 Biblioteka curl.
128
129 %package devel
130 Summary:        Header files and development documentation for curl library
131 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
132 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
133 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
134 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
135 Group:          Development/Libraries
136 Requires:       %{name}-libs = %{version}-%{release}
137 %{?with_ares:Requires:  c-ares-devel}
138 %{?with_kerberos5:Requires:     heimdal-devel}
139 Requires:       libidn-devel >= 0.4.1
140 %{?with_rtmp:Requires:  librtmp-devel}
141 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
142 %{?with_ldap:Requires:  openldap-devel}
143 %if %{with ssl}
144 %if %{with gnutls}
145 Requires:       gnutls-devel
146 %else
147 Requires:       openssl-devel >= 0.9.7c
148 %endif
149 %endif
150 Requires:       zlib-devel
151 Obsoletes:      libcurl2-devel
152
153 %description devel
154 Header files and development documentation for curl library.
155
156 %description devel -l pl.UTF-8
157 Pliki nagłówkowe i dokumentacja do biblioteki curl.
158
159 %description devel -l pt_BR.UTF-8
160 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
161
162 %description devel -l ru.UTF-8
163 Этот пакет содержит файлы, необходимые для разработки программ с
164 использованием библиотеки curl.
165
166 %description devel -l uk.UTF-8
167 Цей пакет містить файли, необхідні для розробки програм з
168 використанням бібліотеки curl.
169
170 %package static
171 Summary:        Static version of curl library
172 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
173 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
174 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
175 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
176 Group:          Development/Libraries
177 Requires:       %{name}-devel = %{version}-%{release}
178
179 %description static
180 Static version of curl library.
181
182 %description static -l pl.UTF-8
183 Statyczna wersja biblioteki curl.
184
185 %description static -l pt_BR.UTF-8
186 Bibliotecas estáticas para desenvolvimento com o curl.
187
188 %description static -l ru.UTF-8
189 Этот пакет содержит статическую библиотеку для разработки программ с
190 использованием библиотеки curl.
191
192 %description static -l uk.UTF-8
193 Цей пакет містить статичну бібліотеку для розробки програм з
194 використанням бібліотеки curl.
195
196 %prep
197 %setup -q
198 %patch1 -p1
199 %patch2 -p1
200 %patch3 -p1
201 %patch4 -p1
202 %patch5 -p1
203 %patch6 -p1
204 %patch7 -p1
205
206 %{__rm} -v m4/lt*.m4 m4/libtool.m4
207
208 %build
209 %{__libtoolize}
210 %{__aclocal} -I m4
211 %{__autoconf}
212 %{__autoheader}
213 %{__automake}
214 %configure \
215         ac_cv_header_gss_h=no \
216 %if %{with ssl}
217         --with-ca-bundle=/etc/certs/ca-certificates.crt \
218 %if %{with gnutls}
219         --with-gnutls --without-ssl \
220 %else
221         --with-ssl=%{_prefix} \
222 %endif
223 %endif
224         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
225         %{?with_rtmp:--with-librtmp} \
226         %{?with_ares:--enable-ares} \
227         %{?with_ldap:--enable-ldaps} \
228         %{!?with_ldap:--disable-ldap} \
229         --enable-ipv6
230
231 %{__make}
232
233 %install
234 rm -rf $RPM_BUILD_ROOT
235
236 %{__make} install \
237         DESTDIR=$RPM_BUILD_ROOT
238
239 # no longer in upstream but a lot of apps tries to include it so we create fake one
240 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
241 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
242
243 %clean
244 rm -rf $RPM_BUILD_ROOT
245
246 %post   libs -p /sbin/ldconfig
247 %postun libs -p /sbin/ldconfig
248
249 %files
250 %defattr(644,root,root,755)
251 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
252 %attr(755,root,root) %{_bindir}/curl
253 %{_mandir}/man1/curl.1*
254
255 %files libs
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
258 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
259
260 %files devel
261 %defattr(644,root,root,755)
262 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
263 %attr(755,root,root) %{_bindir}/curl-config
264 %attr(755,root,root) %{_libdir}/libcurl.so
265 %{_libdir}/libcurl.la
266 %{_includedir}/curl
267 %{_pkgconfigdir}/libcurl.pc
268 %{_mandir}/man1/curl-config.1*
269 %{_mandir}/man3/curl_*.3*
270 %{_mandir}/man3/libcurl*.3*
271
272 %files static
273 %defattr(644,root,root,755)
274 %{_libdir}/libcurl.a
This page took 0.046849 seconds and 3 git commands to generate.