]> git.pld-linux.org Git - packages/curl.git/blame - curl.spec
up to 7.76.0 (fixes CVE-2021-22876 CVE-2021-22890)
[packages/curl.git] / curl.spec
CommitLineData
8a9e937b 1# TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
195ea5a8
JB
2#
3# Conditional build:
358ad66a
JB
4%bcond_without ssh # SSH support
5%bcond_without ssl # SSL support
6%bcond_with gnutls # GnuTLS instead of OpenSSL
eef5da07 7%bcond_without gsasl # SCRAM support with gsasl
358ad66a
JB
8%bcond_without kerberos5 # Heimdal Kerberos 5 support
9%bcond_without ldap # LDAP support
8424568c 10%bcond_without http2 # HTTP/2.0 support (nghttp2 based)
358ad66a 11%bcond_without metalink # metalink support
de17b215 12%if "%{pld_release}" != "ac"
358ad66a
JB
13%bcond_without ares # c-ares (asynchronous DNS operations) library support
14%bcond_without rtmp # Real Time Media Protocol support
de17b215 15%else
358ad66a
JB
16%bcond_with ares # c-ares (asynchronous DNS operations) library support
17%bcond_with rtmp # Real Time Media Protocol support
de17b215
ER
18%endif
19
f7f276d9 20Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
ce380d80
ER
21Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
22Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
23Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
24Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
25Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
5767e1a7 26Name: curl
eef5da07 27Version: 7.76.0
91672efb 28Release: 1
c091c0ac 29License: MIT-like
5767e1a7 30Group: Applications/Networking
d8be0059 31Source0: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
eef5da07 32# Source0-md5: 41178ceea57c863f883b6fe2c3ac276f
d0cec3a8
JB
33Patch0: %{name}-ac.patch
34Patch1: %{name}-krb5flags.patch
4557544f 35URL: http://curl.haxx.se/
c091c0ac 36BuildRequires: autoconf >= 2.57
66cf63f1 37BuildRequires: automake
7c7ffb45 38%{?with_ares:BuildRequires: c-ares-devel >= 1.7.0}
eef5da07 39%{?with_gsasl:BuildRequires: gsasl-devel}
f73c4120 40%{?with_kerberos5:BuildRequires: heimdal-devel}
8a129a6b 41BuildRequires: libbrotli-devel >= 1.0.0
04f3f89d 42BuildRequires: libidn2-devel
e80259d2
JB
43%{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
44BuildRequires: libpsl-devel
9defadab 45%{?with_rtmp:BuildRequires: librtmp-devel}
b83a223e 46%{?with_ssh:BuildRequires: libssh2-devel >= 1.2.8}
c091c0ac 47BuildRequires: libtool
0f90f9c0 48BuildRequires: nettle-devel
e37f03dc 49%{?with_http2:BuildRequires: nghttp2-devel >= 1.12.0}
588be88f 50%{?with_ldap:BuildRequires: openldap-devel}
c260acfc 51BuildRequires: pkgconfig
de17b215 52BuildRequires: rpm >= 4.4.9-56
838a6eda 53BuildRequires: rpmbuild(macros) >= 1.527
5559a124
AM
54%if %{with ssl}
55%if %{with gnutls}
e37f03dc 56BuildRequires: gnutls-devel >= 3.1.10
5559a124 57%else
549c5328 58BuildRequires: openssl-devel >= 1.0.1
5559a124
AM
59%endif
60%endif
d04a5e91 61BuildRequires: tar >= 1:1.22
eef5da07 62BuildRequires: xz
6903f0dc 63BuildRequires: zlib-devel
0ee795f8 64BuildRequires: zstd-devel
3fb47407 65Requires: %{name}-libs = %{version}-%{release}
cfa95fc0 66Obsoletes: libcurl2
8aa4e5ec 67BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81714278 68
69%description
655b91ad 70cURL is a tool for getting files with URL syntax, supporting FTP,
71HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
72POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
73cookies, user+password authentication and a busload of other useful
74tricks. The main use for curl is when you want to get or send files
75automatically to or from a site using one of the supported protocols.
76
77cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
78Dict servers, using any of the supported protocols. cURL is designed
79to work without user interaction or any kind of interactivity. cURL
80offers many useful capabilities, like proxy support, user
e566d906 81authentication, FTP upload, HTTP post, and file transfer resume.
81714278 82
d63bcf1b
JR
83%description -l pl.UTF-8
84cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
85HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
86HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
655b91ad 87oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
d63bcf1b
JR
88użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
89się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
90pliki z/na serwer używając jednego z dostępnych protokołów.
91%{?with_ssl:Ten pakiet obsługuje także SSL.}
1310544e 92
d63bcf1b
JR
93%description -l pt_BR.UTF-8
94Curl é um cliente para baixar/enviar arquivos de/para servidores
95usando um dos protocolos suportados. É projetado para funcionar sem a
96interação do usuário.
1310544e 97
d63bcf1b
JR
98Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
99continuar transferências interrompidas, e mais...
1310544e 100
d63bcf1b
JR
101%description -l ru.UTF-8
102curl - это клиент с множеством поддерживаемых протоколов для получения
103файлов с серверов, спроектированный для работы как в неинтерактивном
104режиме, так и с возможностью диалога с пользователем.
f05b825f 105
d63bcf1b
JR
106curl поддерживает много полезных возможностей, среди которых поддержка
107прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
108POST, восстановление прерванной пересылки и многое другое.
f05b825f 109
d63bcf1b
JR
110curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
111файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
112режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
f05b825f 113
d63bcf1b
JR
114curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
115прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
116в╕дновлення перервано╖ пересилки та багато ╕ншого.
f05b825f 117
814b6f7d
JB
118%package libs
119Summary: curl library
ce380d80 120Summary(pl.UTF-8): Biblioteka curl
814b6f7d 121Group: Libraries
de17b215 122%{?with_ares:Requires: c-ares >= 1.7.0}
e37f03dc 123%{?with_gnutls:Requires: gnutls-libs >= 3.1.10}
549c5328 124%{?with_ssh:Requires: libssh2 >= 1.2.8}
e37f03dc 125%{?with_http2:Requires: nghttp2-libs >= 1.12.0}
fddc44fa 126%if %{with ssl} && %{without gnutls}
00b2a6eb 127Requires: libbrotli >= 1.0.0
549c5328 128Requires: openssl >= 1.0.1
fddc44fa 129%endif
dfeb0d8d
PG
130Suggests: ca-certificates
131Conflicts: ca-certificates < 20080809-4
814b6f7d
JB
132
133%description libs
134curl library.
135
d63bcf1b 136%description libs -l pl.UTF-8
814b6f7d
JB
137Biblioteka curl.
138
1f54b511 139%package devel
140Summary: Header files and development documentation for curl library
ce380d80
ER
141Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
142Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
143Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
144Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
1f54b511 145Group: Development/Libraries
3fb47407 146Requires: %{name}-libs = %{version}-%{release}
bd2c841c 147%{?with_ares:Requires: c-ares-devel}
eef5da07 148%{?with_gsasl:Requires: gsasl-devel}
f73c4120 149%{?with_kerberos5:Requires: heimdal-devel}
72fe5a16 150Requires: libbrotli-devel >= 1.0.0
04f3f89d 151Requires: libidn2-devel
e80259d2 152Requires: libpsl-devel
70778617 153%{?with_rtmp:Requires: librtmp-devel}
b83a223e 154%{?with_ssh:Requires: libssh2-devel >= 1.2.8}
e37f03dc 155%{?with_http2:Requires: nghttp2-devel >= 1.12.0}
588be88f 156%{?with_ldap:Requires: openldap-devel}
5559a124
AM
157%if %{with ssl}
158%if %{with gnutls}
e37f03dc 159Requires: gnutls-devel >= 3.1.10
5559a124
AM
160%else
161Requires: openssl-devel >= 0.9.7c
162%endif
163%endif
5e1699d5 164Requires: zlib-devel
0ee795f8 165Requires: zstd-devel
cfa95fc0 166Obsoletes: libcurl2-devel
1f54b511 167
168%description devel
169Header files and development documentation for curl library.
170
d63bcf1b
JR
171%description devel -l pl.UTF-8
172Pliki nagłówkowe i dokumentacja do biblioteki curl.
cec38cdf 173
d63bcf1b
JR
174%description devel -l pt_BR.UTF-8
175Arquivos de cabeçalho e bibliotecas de desenvolvimento.
1310544e 176
d63bcf1b
JR
177%description devel -l ru.UTF-8
178Этот пакет содержит файлы, необходимые для разработки программ с
179использованием библиотеки curl.
f05b825f 180
d63bcf1b
JR
181%description devel -l uk.UTF-8
182Цей пакет містить файли, необхідні для розробки програм з
183використанням бібліотеки curl.
f05b825f 184
1f54b511 185%package static
186Summary: Static version of curl library
ce380d80
ER
187Summary(pl.UTF-8): Statyczna wersja biblioteki curl
188Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
189Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
190Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
1f54b511 191Group: Development/Libraries
6e6a5186 192Requires: %{name}-devel = %{version}-%{release}
1f54b511 193
194%description static
d06d2fe1 195Static version of curl library.
1f54b511 196
d63bcf1b 197%description static -l pl.UTF-8
cec38cdf 198Statyczna wersja biblioteki curl.
b73e2a73 199
d63bcf1b
JR
200%description static -l pt_BR.UTF-8
201Bibliotecas estáticas para desenvolvimento com o curl.
1310544e 202
d63bcf1b
JR
203%description static -l ru.UTF-8
204Этот пакет содержит статическую библиотеку для разработки программ с
205использованием библиотеки curl.
f05b825f 206
d63bcf1b
JR
207%description static -l uk.UTF-8
208Цей пакет містить статичну бібліотеку для розробки програм з
209використанням бібліотеки curl.
f05b825f 210
8a62d0ef
AG
211%package -n fish-completion-%{name}
212Summary: Fish completion for curl command
213Summary(pl.UTF-8): Dopełnianie parametrów w fish dla polecenia curl
214Group: Applications/Shells
215Requires: %{name} = %{version}-%{release}
216Requires: fish
217
218%description -n fish-completion-%{name}
219Fish completion for curl command.
220
221%description -n fish-completion-%{name} -l pl.UTF-8
222Dopełnianie parametrów w fish dla polecenia curl.
223
e80259d2
JB
224%package -n zsh-completion-curl
225Summary: ZSH completion for curl command
226Summary(pl.UTF-8): Dopełnianianie parametrów w ZSH dla polecenia curl
227Group: Applications/Shells
228Requires: %{name} = %{version}-%{release}
229Requires: zsh
230
231%description -n zsh-completion-curl
232ZSH completion for curl command.
233
234%description -n zsh-completion-curl -l pl.UTF-8
235Dopełnianianie parametrów w ZSH dla polecenia curl.
236
81714278 237%prep
13caa23a 238%setup -q
d0cec3a8 239%patch0 -p1
d4dc980e 240%patch1 -p1
81714278 241
358ad66a 242%{__rm} m4/lt*.m4 m4/libtool.m4
36cd7270 243
81714278 244%build
c091c0ac 245%{__libtoolize}
03613829 246%{__aclocal} -I m4
d4dc980e
AM
247%{__autoconf}
248%{__autoheader}
c091c0ac 249%{__automake}
e566d906 250%configure \
ef822e11 251 ac_cv_header_gss_h=no \
e80259d2 252 %{__enable_disable ares} \
eef5da07 253 %{__enable_disable gsasl} \
e80259d2
JB
254 --enable-ipv6 \
255 %{__enable_disable ldap} \
256 %{__enable_disable ldap ldaps} \
257 --disable-silent-rules \
5559a124 258%if %{with ssl}
03613829 259 --with-ca-bundle=/etc/certs/ca-certificates.crt \
5559a124 260%if %{with gnutls}
28c87603 261 --with-gnutls --without-ssl \
5559a124
AM
262%else
263 --with-ssl=%{_prefix} \
264%endif
0eee87e5
AM
265%else
266 --without-ssl --without-gnutls \
5559a124 267%endif
8a62d0ef 268 --with-fish-functions-dir=%{fish_compdir} \
838a6eda
JK
269 %{__with_without kerberos5 gssapi %{_prefix}} \
270 %{__with_without metalink libmetalink} \
271 %{__with_without rtmp librtmp} \
272 %{__with_without http2 nghttp2} \
e80259d2 273 %{__with_without ssh libssh2}
a436679a 274
c2167492 275%{__make}
81714278 276
277%install
5767e1a7 278rm -rf $RPM_BUILD_ROOT
08c6da60 279
56f17d66
AM
280%{__make} install \
281 DESTDIR=$RPM_BUILD_ROOT
282
4f6d4393
JB
283%{__make} -C scripts install \
284 DESTDIR=$RPM_BUILD_ROOT
285
08c6da60
JB
286# obsoleted by pkg-config
287%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcurl.la
288
34ca770a 289# no longer in upstream but a lot of apps tries to include it so we create fake one
925b36ff
AM
290[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
291echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
34ca770a 292
81714278 293%clean
294rm -rf $RPM_BUILD_ROOT
81714278 295
3fb47407
ER
296%post libs -p /sbin/ldconfig
297%postun libs -p /sbin/ldconfig
1f54b511 298
81714278 299%files
5767e1a7 300%defattr(644,root,root,755)
4c2e4e93 301%doc CHANGES COPYING README docs/{BUGS.md,FAQ,FEATURES.md,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting.md}
c091c0ac 302%attr(755,root,root) %{_bindir}/curl
c091c0ac 303%{_mandir}/man1/curl.1*
1f54b511 304
814b6f7d
JB
305%files libs
306%defattr(644,root,root,755)
307%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
b3964ccb 308%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
814b6f7d 309
1f54b511 310%files devel
311%defattr(644,root,root,755)
c6b65fdb 312%doc docs/{CONTRIBUTE.md,INTERNALS.md}
c091c0ac
JB
313%attr(755,root,root) %{_bindir}/curl-config
314%attr(755,root,root) %{_libdir}/libcurl.so
c091c0ac 315%{_includedir}/curl
8ad78925 316%{_pkgconfigdir}/libcurl.pc
1399f3ff 317%{_aclocaldir}/libcurl.m4
c091c0ac 318%{_mandir}/man1/curl-config.1*
b3964ccb
JB
319%{_mandir}/man3/curl_*.3*
320%{_mandir}/man3/libcurl*.3*
0efd10e8 321%{_mandir}/man3/CURLINFO_*.3*
67744768 322%{_mandir}/man3/CURLOPT_*.3*
eb7a78c8 323%{_mandir}/man3/CURLMOPT_*.3*
1f54b511 324
325%files static
326%defattr(644,root,root,755)
c091c0ac 327%{_libdir}/libcurl.a
e80259d2 328
8a62d0ef
AG
329%files -n fish-completion-%{name}
330%defattr(644,root,root,755)
331%{fish_compdir}/%{name}.fish
332
e80259d2
JB
333%files -n zsh-completion-curl
334%defattr(644,root,root,755)
335%{_datadir}/zsh/site-functions/_curl
This page took 2.912938 seconds and 4 git commands to generate.