]> git.pld-linux.org Git - packages/curl.git/blame - curl.spec
up to 7.79.0 (fixes CVE-2021-22945 CVE-2021-22946 CVE-2021-22947)
[packages/curl.git] / curl.spec
CommitLineData
8a9e937b 1# TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
195ea5a8
JB
2#
3# Conditional build:
358ad66a
JB
4%bcond_without ssh # SSH support
5%bcond_without ssl # SSL support
6%bcond_with gnutls # GnuTLS instead of OpenSSL
eef5da07 7%bcond_without gsasl # SCRAM support with gsasl
358ad66a
JB
8%bcond_without kerberos5 # Heimdal Kerberos 5 support
9%bcond_without ldap # LDAP support
8424568c 10%bcond_without http2 # HTTP/2.0 support (nghttp2 based)
de17b215 11%if "%{pld_release}" != "ac"
358ad66a
JB
12%bcond_without ares # c-ares (asynchronous DNS operations) library support
13%bcond_without rtmp # Real Time Media Protocol support
de17b215 14%else
358ad66a
JB
15%bcond_with ares # c-ares (asynchronous DNS operations) library support
16%bcond_with rtmp # Real Time Media Protocol support
de17b215
ER
17%endif
18
f7f276d9 19Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
ce380d80
ER
20Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
21Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
22Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
23Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
24Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
5767e1a7 25Name: curl
a04e3aea 26Version: 7.79.0
91672efb 27Release: 1
c091c0ac 28License: MIT-like
5767e1a7 29Group: Applications/Networking
d8be0059 30Source0: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
a04e3aea 31# Source0-md5: 24408ce0068de0ae7871039451ad6f97
d0cec3a8
JB
32Patch0: %{name}-ac.patch
33Patch1: %{name}-krb5flags.patch
4557544f 34URL: http://curl.haxx.se/
c091c0ac 35BuildRequires: autoconf >= 2.57
66cf63f1 36BuildRequires: automake
7c7ffb45 37%{?with_ares:BuildRequires: c-ares-devel >= 1.7.0}
eef5da07 38%{?with_gsasl:BuildRequires: gsasl-devel}
f73c4120 39%{?with_kerberos5:BuildRequires: heimdal-devel}
8a129a6b 40BuildRequires: libbrotli-devel >= 1.0.0
04f3f89d 41BuildRequires: libidn2-devel
e80259d2 42BuildRequires: libpsl-devel
9defadab 43%{?with_rtmp:BuildRequires: librtmp-devel}
b83a223e 44%{?with_ssh:BuildRequires: libssh2-devel >= 1.2.8}
c091c0ac 45BuildRequires: libtool
0f90f9c0 46BuildRequires: nettle-devel
e37f03dc 47%{?with_http2:BuildRequires: nghttp2-devel >= 1.12.0}
588be88f 48%{?with_ldap:BuildRequires: openldap-devel}
c260acfc 49BuildRequires: pkgconfig
de17b215 50BuildRequires: rpm >= 4.4.9-56
4416762d 51BuildRequires: rpm-build >= 4.6
838a6eda 52BuildRequires: rpmbuild(macros) >= 1.527
5559a124
AM
53%if %{with ssl}
54%if %{with gnutls}
e37f03dc 55BuildRequires: gnutls-devel >= 3.1.10
5559a124 56%else
549c5328 57BuildRequires: openssl-devel >= 1.0.1
5559a124
AM
58%endif
59%endif
d04a5e91 60BuildRequires: tar >= 1:1.22
eef5da07 61BuildRequires: xz
6903f0dc 62BuildRequires: zlib-devel
0ee795f8 63BuildRequires: zstd-devel
3fb47407 64Requires: %{name}-libs = %{version}-%{release}
cfa95fc0 65Obsoletes: libcurl2
8aa4e5ec 66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81714278 67
68%description
655b91ad 69cURL is a tool for getting files with URL syntax, supporting FTP,
70HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
71POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
72cookies, user+password authentication and a busload of other useful
73tricks. The main use for curl is when you want to get or send files
74automatically to or from a site using one of the supported protocols.
75
76cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
77Dict servers, using any of the supported protocols. cURL is designed
78to work without user interaction or any kind of interactivity. cURL
79offers many useful capabilities, like proxy support, user
e566d906 80authentication, FTP upload, HTTP post, and file transfer resume.
81714278 81
d63bcf1b
JR
82%description -l pl.UTF-8
83cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
84HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
85HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
655b91ad 86oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
d63bcf1b
JR
87użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
88się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
89pliki z/na serwer używając jednego z dostępnych protokołów.
90%{?with_ssl:Ten pakiet obsługuje także SSL.}
1310544e 91
d63bcf1b
JR
92%description -l pt_BR.UTF-8
93Curl é um cliente para baixar/enviar arquivos de/para servidores
94usando um dos protocolos suportados. É projetado para funcionar sem a
95interação do usuário.
1310544e 96
d63bcf1b
JR
97Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
98continuar transferências interrompidas, e mais...
1310544e 99
d63bcf1b
JR
100%description -l ru.UTF-8
101curl - это клиент с множеством поддерживаемых протоколов для получения
102файлов с серверов, спроектированный для работы как в неинтерактивном
103режиме, так и с возможностью диалога с пользователем.
f05b825f 104
d63bcf1b
JR
105curl поддерживает много полезных возможностей, среди которых поддержка
106прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
107POST, восстановление прерванной пересылки и многое другое.
f05b825f 108
d63bcf1b
JR
109curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
110файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
111режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
f05b825f 112
d63bcf1b
JR
113curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
114прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
115в╕дновлення перервано╖ пересилки та багато ╕ншого.
f05b825f 116
814b6f7d
JB
117%package libs
118Summary: curl library
ce380d80 119Summary(pl.UTF-8): Biblioteka curl
814b6f7d 120Group: Libraries
de17b215 121%{?with_ares:Requires: c-ares >= 1.7.0}
e37f03dc 122%{?with_gnutls:Requires: gnutls-libs >= 3.1.10}
549c5328 123%{?with_ssh:Requires: libssh2 >= 1.2.8}
e37f03dc 124%{?with_http2:Requires: nghttp2-libs >= 1.12.0}
fddc44fa 125%if %{with ssl} && %{without gnutls}
00b2a6eb 126Requires: libbrotli >= 1.0.0
549c5328 127Requires: openssl >= 1.0.1
fddc44fa 128%endif
dfeb0d8d
PG
129Suggests: ca-certificates
130Conflicts: ca-certificates < 20080809-4
814b6f7d
JB
131
132%description libs
133curl library.
134
d63bcf1b 135%description libs -l pl.UTF-8
814b6f7d
JB
136Biblioteka curl.
137
1f54b511 138%package devel
139Summary: Header files and development documentation for curl library
ce380d80
ER
140Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
141Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
142Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
143Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
1f54b511 144Group: Development/Libraries
3fb47407 145Requires: %{name}-libs = %{version}-%{release}
bd2c841c 146%{?with_ares:Requires: c-ares-devel}
eef5da07 147%{?with_gsasl:Requires: gsasl-devel}
f73c4120 148%{?with_kerberos5:Requires: heimdal-devel}
72fe5a16 149Requires: libbrotli-devel >= 1.0.0
04f3f89d 150Requires: libidn2-devel
e80259d2 151Requires: libpsl-devel
70778617 152%{?with_rtmp:Requires: librtmp-devel}
b83a223e 153%{?with_ssh:Requires: libssh2-devel >= 1.2.8}
e37f03dc 154%{?with_http2:Requires: nghttp2-devel >= 1.12.0}
588be88f 155%{?with_ldap:Requires: openldap-devel}
5559a124
AM
156%if %{with ssl}
157%if %{with gnutls}
e37f03dc 158Requires: gnutls-devel >= 3.1.10
5559a124
AM
159%else
160Requires: openssl-devel >= 0.9.7c
161%endif
162%endif
5e1699d5 163Requires: zlib-devel
0ee795f8 164Requires: zstd-devel
cfa95fc0 165Obsoletes: libcurl2-devel
1f54b511 166
167%description devel
168Header files and development documentation for curl library.
169
d63bcf1b
JR
170%description devel -l pl.UTF-8
171Pliki nagłówkowe i dokumentacja do biblioteki curl.
cec38cdf 172
d63bcf1b
JR
173%description devel -l pt_BR.UTF-8
174Arquivos de cabeçalho e bibliotecas de desenvolvimento.
1310544e 175
d63bcf1b
JR
176%description devel -l ru.UTF-8
177Этот пакет содержит файлы, необходимые для разработки программ с
178использованием библиотеки curl.
f05b825f 179
d63bcf1b
JR
180%description devel -l uk.UTF-8
181Цей пакет містить файли, необхідні для розробки програм з
182використанням бібліотеки curl.
f05b825f 183
1f54b511 184%package static
185Summary: Static version of curl library
ce380d80
ER
186Summary(pl.UTF-8): Statyczna wersja biblioteki curl
187Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
188Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
189Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
1f54b511 190Group: Development/Libraries
6e6a5186 191Requires: %{name}-devel = %{version}-%{release}
1f54b511 192
193%description static
d06d2fe1 194Static version of curl library.
1f54b511 195
d63bcf1b 196%description static -l pl.UTF-8
cec38cdf 197Statyczna wersja biblioteki curl.
b73e2a73 198
d63bcf1b
JR
199%description static -l pt_BR.UTF-8
200Bibliotecas estáticas para desenvolvimento com o curl.
1310544e 201
d63bcf1b
JR
202%description static -l ru.UTF-8
203Этот пакет содержит статическую библиотеку для разработки программ с
204использованием библиотеки curl.
f05b825f 205
d63bcf1b
JR
206%description static -l uk.UTF-8
207Цей пакет містить статичну бібліотеку для розробки програм з
208використанням бібліотеки curl.
f05b825f 209
8a62d0ef
AG
210%package -n fish-completion-%{name}
211Summary: Fish completion for curl command
212Summary(pl.UTF-8): Dopełnianie parametrów w fish dla polecenia curl
213Group: Applications/Shells
214Requires: %{name} = %{version}-%{release}
215Requires: fish
4416762d 216BuildArch: noarch
8a62d0ef
AG
217
218%description -n fish-completion-%{name}
219Fish completion for curl command.
220
221%description -n fish-completion-%{name} -l pl.UTF-8
222Dopełnianie parametrów w fish dla polecenia curl.
223
e80259d2
JB
224%package -n zsh-completion-curl
225Summary: ZSH completion for curl command
226Summary(pl.UTF-8): Dopełnianianie parametrów w ZSH dla polecenia curl
227Group: Applications/Shells
228Requires: %{name} = %{version}-%{release}
229Requires: zsh
4416762d 230BuildArch: noarch
e80259d2
JB
231
232%description -n zsh-completion-curl
233ZSH completion for curl command.
234
235%description -n zsh-completion-curl -l pl.UTF-8
236Dopełnianianie parametrów w ZSH dla polecenia curl.
237
81714278 238%prep
13caa23a 239%setup -q
d0cec3a8 240%patch0 -p1
d4dc980e 241%patch1 -p1
81714278 242
358ad66a 243%{__rm} m4/lt*.m4 m4/libtool.m4
36cd7270 244
81714278 245%build
c091c0ac 246%{__libtoolize}
03613829 247%{__aclocal} -I m4
d4dc980e
AM
248%{__autoconf}
249%{__autoheader}
c091c0ac 250%{__automake}
e566d906 251%configure \
ef822e11 252 ac_cv_header_gss_h=no \
e80259d2 253 %{__enable_disable ares} \
eef5da07 254 %{__enable_disable gsasl} \
e80259d2
JB
255 --enable-ipv6 \
256 %{__enable_disable ldap} \
257 %{__enable_disable ldap ldaps} \
258 --disable-silent-rules \
5559a124 259%if %{with ssl}
03613829 260 --with-ca-bundle=/etc/certs/ca-certificates.crt \
5559a124 261%if %{with gnutls}
8210eba8 262 --with-gnutls --without-openssl \
5559a124 263%else
8210eba8 264 --with-openssl=%{_prefix} \
5559a124 265%endif
0eee87e5 266%else
8210eba8 267 --without-ssl \
5559a124 268%endif
8a62d0ef 269 --with-fish-functions-dir=%{fish_compdir} \
838a6eda 270 %{__with_without kerberos5 gssapi %{_prefix}} \
838a6eda
JK
271 %{__with_without rtmp librtmp} \
272 %{__with_without http2 nghttp2} \
e80259d2 273 %{__with_without ssh libssh2}
a436679a 274
c2167492 275%{__make}
81714278 276
277%install
5767e1a7 278rm -rf $RPM_BUILD_ROOT
08c6da60 279
56f17d66
AM
280%{__make} install \
281 DESTDIR=$RPM_BUILD_ROOT
282
4f6d4393
JB
283%{__make} -C scripts install \
284 DESTDIR=$RPM_BUILD_ROOT
285
08c6da60
JB
286# obsoleted by pkg-config
287%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcurl.la
288
34ca770a 289# no longer in upstream but a lot of apps tries to include it so we create fake one
925b36ff
AM
290[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
291echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
34ca770a 292
81714278 293%clean
294rm -rf $RPM_BUILD_ROOT
81714278 295
3fb47407
ER
296%post libs -p /sbin/ldconfig
297%postun libs -p /sbin/ldconfig
1f54b511 298
81714278 299%files
5767e1a7 300%defattr(644,root,root,755)
4c2e4e93 301%doc CHANGES COPYING README docs/{BUGS.md,FAQ,FEATURES.md,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting.md}
c091c0ac 302%attr(755,root,root) %{_bindir}/curl
c091c0ac 303%{_mandir}/man1/curl.1*
1f54b511 304
814b6f7d
JB
305%files libs
306%defattr(644,root,root,755)
307%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
b3964ccb 308%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
814b6f7d 309
1f54b511 310%files devel
311%defattr(644,root,root,755)
c6b65fdb 312%doc docs/{CONTRIBUTE.md,INTERNALS.md}
c091c0ac
JB
313%attr(755,root,root) %{_bindir}/curl-config
314%attr(755,root,root) %{_libdir}/libcurl.so
c091c0ac 315%{_includedir}/curl
8ad78925 316%{_pkgconfigdir}/libcurl.pc
1399f3ff 317%{_aclocaldir}/libcurl.m4
c091c0ac 318%{_mandir}/man1/curl-config.1*
b3964ccb
JB
319%{_mandir}/man3/curl_*.3*
320%{_mandir}/man3/libcurl*.3*
0efd10e8 321%{_mandir}/man3/CURLINFO_*.3*
67744768 322%{_mandir}/man3/CURLOPT_*.3*
eb7a78c8 323%{_mandir}/man3/CURLMOPT_*.3*
1f54b511 324
325%files static
326%defattr(644,root,root,755)
c091c0ac 327%{_libdir}/libcurl.a
e80259d2 328
8a62d0ef
AG
329%files -n fish-completion-%{name}
330%defattr(644,root,root,755)
4416762d 331%{fish_compdir}/curl.fish
8a62d0ef 332
e80259d2
JB
333%files -n zsh-completion-curl
334%defattr(644,root,root,755)
335%{_datadir}/zsh/site-functions/_curl
This page took 0.148372 seconds and 4 git commands to generate.