]> git.pld-linux.org Git - packages/curl.git/blame - curl.spec
fix %doc; rel 2
[packages/curl.git] / curl.spec
CommitLineData
8a9e937b 1# TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
195ea5a8
JB
2#
3# Conditional build:
358ad66a
JB
4%bcond_without ssh # SSH support
5%bcond_without ssl # SSL support
6%bcond_with gnutls # GnuTLS instead of OpenSSL
7%bcond_without kerberos5 # Heimdal Kerberos 5 support
8%bcond_without ldap # LDAP support
8424568c 9%bcond_without http2 # HTTP/2.0 support (nghttp2 based)
358ad66a 10%bcond_without metalink # metalink support
de17b215 11%if "%{pld_release}" != "ac"
358ad66a
JB
12%bcond_without ares # c-ares (asynchronous DNS operations) library support
13%bcond_without rtmp # Real Time Media Protocol support
de17b215 14%else
358ad66a
JB
15%bcond_with ares # c-ares (asynchronous DNS operations) library support
16%bcond_with rtmp # Real Time Media Protocol support
de17b215
ER
17%endif
18
f7f276d9 19Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
ce380d80
ER
20Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
21Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
22Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
23Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
24Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
5767e1a7 25Name: curl
d3f393a2 26Version: 7.74.0
4c2e4e93 27Release: 2
c091c0ac 28License: MIT-like
5767e1a7 29Group: Applications/Networking
d8be0059 30Source0: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
d3f393a2 31# Source0-md5: 448156d9cd05009b0097b43de639fd34
d0cec3a8
JB
32Patch0: %{name}-ac.patch
33Patch1: %{name}-krb5flags.patch
4557544f 34URL: http://curl.haxx.se/
c091c0ac 35BuildRequires: autoconf >= 2.57
66cf63f1 36BuildRequires: automake
7c7ffb45 37%{?with_ares:BuildRequires: c-ares-devel >= 1.7.0}
f73c4120 38%{?with_kerberos5:BuildRequires: heimdal-devel}
8a129a6b 39BuildRequires: libbrotli-devel >= 1.0.0
04f3f89d 40BuildRequires: libidn2-devel
e80259d2
JB
41%{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
42BuildRequires: libpsl-devel
9defadab 43%{?with_rtmp:BuildRequires: librtmp-devel}
b83a223e 44%{?with_ssh:BuildRequires: libssh2-devel >= 1.2.8}
c091c0ac 45BuildRequires: libtool
0f90f9c0 46BuildRequires: nettle-devel
e37f03dc 47%{?with_http2:BuildRequires: nghttp2-devel >= 1.12.0}
588be88f 48%{?with_ldap:BuildRequires: openldap-devel}
c260acfc 49BuildRequires: pkgconfig
de17b215 50BuildRequires: rpm >= 4.4.9-56
838a6eda 51BuildRequires: rpmbuild(macros) >= 1.527
5559a124
AM
52%if %{with ssl}
53%if %{with gnutls}
e37f03dc 54BuildRequires: gnutls-devel >= 3.1.10
5559a124 55%else
549c5328 56BuildRequires: openssl-devel >= 1.0.1
5559a124
AM
57%endif
58%endif
d04a5e91 59BuildRequires: tar >= 1:1.22
6903f0dc 60BuildRequires: zlib-devel
0ee795f8 61BuildRequires: zstd-devel
3fb47407 62Requires: %{name}-libs = %{version}-%{release}
cfa95fc0 63Obsoletes: libcurl2
8aa4e5ec 64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81714278 65
66%description
655b91ad 67cURL is a tool for getting files with URL syntax, supporting FTP,
68HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
69POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
70cookies, user+password authentication and a busload of other useful
71tricks. The main use for curl is when you want to get or send files
72automatically to or from a site using one of the supported protocols.
73
74cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
75Dict servers, using any of the supported protocols. cURL is designed
76to work without user interaction or any kind of interactivity. cURL
77offers many useful capabilities, like proxy support, user
e566d906 78authentication, FTP upload, HTTP post, and file transfer resume.
81714278 79
d63bcf1b
JR
80%description -l pl.UTF-8
81cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
82HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
83HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
655b91ad 84oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
d63bcf1b
JR
85użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
86się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
87pliki z/na serwer używając jednego z dostępnych protokołów.
88%{?with_ssl:Ten pakiet obsługuje także SSL.}
1310544e 89
d63bcf1b
JR
90%description -l pt_BR.UTF-8
91Curl é um cliente para baixar/enviar arquivos de/para servidores
92usando um dos protocolos suportados. É projetado para funcionar sem a
93interação do usuário.
1310544e 94
d63bcf1b
JR
95Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
96continuar transferências interrompidas, e mais...
1310544e 97
d63bcf1b
JR
98%description -l ru.UTF-8
99curl - это клиент с множеством поддерживаемых протоколов для получения
100файлов с серверов, спроектированный для работы как в неинтерактивном
101режиме, так и с возможностью диалога с пользователем.
f05b825f 102
d63bcf1b
JR
103curl поддерживает много полезных возможностей, среди которых поддержка
104прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
105POST, восстановление прерванной пересылки и многое другое.
f05b825f 106
d63bcf1b
JR
107curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
108файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
109режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
f05b825f 110
d63bcf1b
JR
111curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
112прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
113в╕дновлення перервано╖ пересилки та багато ╕ншого.
f05b825f 114
814b6f7d
JB
115%package libs
116Summary: curl library
ce380d80 117Summary(pl.UTF-8): Biblioteka curl
814b6f7d 118Group: Libraries
de17b215 119%{?with_ares:Requires: c-ares >= 1.7.0}
e37f03dc 120%{?with_gnutls:Requires: gnutls-libs >= 3.1.10}
549c5328 121%{?with_ssh:Requires: libssh2 >= 1.2.8}
e37f03dc 122%{?with_http2:Requires: nghttp2-libs >= 1.12.0}
fddc44fa 123%if %{with ssl} && %{without gnutls}
00b2a6eb 124Requires: libbrotli >= 1.0.0
549c5328 125Requires: openssl >= 1.0.1
fddc44fa 126%endif
dfeb0d8d
PG
127Suggests: ca-certificates
128Conflicts: ca-certificates < 20080809-4
814b6f7d
JB
129
130%description libs
131curl library.
132
d63bcf1b 133%description libs -l pl.UTF-8
814b6f7d
JB
134Biblioteka curl.
135
1f54b511 136%package devel
137Summary: Header files and development documentation for curl library
ce380d80
ER
138Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
139Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
140Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
141Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
1f54b511 142Group: Development/Libraries
3fb47407 143Requires: %{name}-libs = %{version}-%{release}
bd2c841c 144%{?with_ares:Requires: c-ares-devel}
f73c4120 145%{?with_kerberos5:Requires: heimdal-devel}
72fe5a16 146Requires: libbrotli-devel >= 1.0.0
04f3f89d 147Requires: libidn2-devel
e80259d2 148Requires: libpsl-devel
70778617 149%{?with_rtmp:Requires: librtmp-devel}
b83a223e 150%{?with_ssh:Requires: libssh2-devel >= 1.2.8}
e37f03dc 151%{?with_http2:Requires: nghttp2-devel >= 1.12.0}
588be88f 152%{?with_ldap:Requires: openldap-devel}
5559a124
AM
153%if %{with ssl}
154%if %{with gnutls}
e37f03dc 155Requires: gnutls-devel >= 3.1.10
5559a124
AM
156%else
157Requires: openssl-devel >= 0.9.7c
158%endif
159%endif
5e1699d5 160Requires: zlib-devel
0ee795f8 161Requires: zstd-devel
cfa95fc0 162Obsoletes: libcurl2-devel
1f54b511 163
164%description devel
165Header files and development documentation for curl library.
166
d63bcf1b
JR
167%description devel -l pl.UTF-8
168Pliki nagłówkowe i dokumentacja do biblioteki curl.
cec38cdf 169
d63bcf1b
JR
170%description devel -l pt_BR.UTF-8
171Arquivos de cabeçalho e bibliotecas de desenvolvimento.
1310544e 172
d63bcf1b
JR
173%description devel -l ru.UTF-8
174Этот пакет содержит файлы, необходимые для разработки программ с
175использованием библиотеки curl.
f05b825f 176
d63bcf1b
JR
177%description devel -l uk.UTF-8
178Цей пакет містить файли, необхідні для розробки програм з
179використанням бібліотеки curl.
f05b825f 180
1f54b511 181%package static
182Summary: Static version of curl library
ce380d80
ER
183Summary(pl.UTF-8): Statyczna wersja biblioteki curl
184Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
185Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
186Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
1f54b511 187Group: Development/Libraries
6e6a5186 188Requires: %{name}-devel = %{version}-%{release}
1f54b511 189
190%description static
d06d2fe1 191Static version of curl library.
1f54b511 192
d63bcf1b 193%description static -l pl.UTF-8
cec38cdf 194Statyczna wersja biblioteki curl.
b73e2a73 195
d63bcf1b
JR
196%description static -l pt_BR.UTF-8
197Bibliotecas estáticas para desenvolvimento com o curl.
1310544e 198
d63bcf1b
JR
199%description static -l ru.UTF-8
200Этот пакет содержит статическую библиотеку для разработки программ с
201использованием библиотеки curl.
f05b825f 202
d63bcf1b
JR
203%description static -l uk.UTF-8
204Цей пакет містить статичну бібліотеку для розробки програм з
205використанням бібліотеки curl.
f05b825f 206
8a62d0ef
AG
207%package -n fish-completion-%{name}
208Summary: Fish completion for curl command
209Summary(pl.UTF-8): Dopełnianie parametrów w fish dla polecenia curl
210Group: Applications/Shells
211Requires: %{name} = %{version}-%{release}
212Requires: fish
213
214%description -n fish-completion-%{name}
215Fish completion for curl command.
216
217%description -n fish-completion-%{name} -l pl.UTF-8
218Dopełnianie parametrów w fish dla polecenia curl.
219
e80259d2
JB
220%package -n zsh-completion-curl
221Summary: ZSH completion for curl command
222Summary(pl.UTF-8): Dopełnianianie parametrów w ZSH dla polecenia curl
223Group: Applications/Shells
224Requires: %{name} = %{version}-%{release}
225Requires: zsh
226
227%description -n zsh-completion-curl
228ZSH completion for curl command.
229
230%description -n zsh-completion-curl -l pl.UTF-8
231Dopełnianianie parametrów w ZSH dla polecenia curl.
232
81714278 233%prep
13caa23a 234%setup -q
d0cec3a8 235%patch0 -p1
d4dc980e 236%patch1 -p1
81714278 237
358ad66a 238%{__rm} m4/lt*.m4 m4/libtool.m4
36cd7270 239
81714278 240%build
c091c0ac 241%{__libtoolize}
03613829 242%{__aclocal} -I m4
d4dc980e
AM
243%{__autoconf}
244%{__autoheader}
c091c0ac 245%{__automake}
e566d906 246%configure \
ef822e11 247 ac_cv_header_gss_h=no \
e80259d2
JB
248 %{__enable_disable ares} \
249 --enable-ipv6 \
250 %{__enable_disable ldap} \
251 %{__enable_disable ldap ldaps} \
252 --disable-silent-rules \
5559a124 253%if %{with ssl}
03613829 254 --with-ca-bundle=/etc/certs/ca-certificates.crt \
5559a124 255%if %{with gnutls}
28c87603 256 --with-gnutls --without-ssl \
5559a124
AM
257%else
258 --with-ssl=%{_prefix} \
259%endif
0eee87e5
AM
260%else
261 --without-ssl --without-gnutls \
5559a124 262%endif
8a62d0ef 263 --with-fish-functions-dir=%{fish_compdir} \
838a6eda
JK
264 %{__with_without kerberos5 gssapi %{_prefix}} \
265 %{__with_without metalink libmetalink} \
266 %{__with_without rtmp librtmp} \
267 %{__with_without http2 nghttp2} \
e80259d2 268 %{__with_without ssh libssh2}
a436679a 269
c2167492 270%{__make}
81714278 271
272%install
5767e1a7 273rm -rf $RPM_BUILD_ROOT
08c6da60 274
56f17d66
AM
275%{__make} install \
276 DESTDIR=$RPM_BUILD_ROOT
277
4f6d4393
JB
278%{__make} -C scripts install \
279 DESTDIR=$RPM_BUILD_ROOT
280
08c6da60
JB
281# obsoleted by pkg-config
282%{__rm} $RPM_BUILD_ROOT%{_libdir}/libcurl.la
283
34ca770a 284# no longer in upstream but a lot of apps tries to include it so we create fake one
925b36ff
AM
285[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
286echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
34ca770a 287
81714278 288%clean
289rm -rf $RPM_BUILD_ROOT
81714278 290
3fb47407
ER
291%post libs -p /sbin/ldconfig
292%postun libs -p /sbin/ldconfig
1f54b511 293
81714278 294%files
5767e1a7 295%defattr(644,root,root,755)
4c2e4e93 296%doc CHANGES COPYING README docs/{BUGS.md,FAQ,FEATURES.md,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting.md}
c091c0ac 297%attr(755,root,root) %{_bindir}/curl
c091c0ac 298%{_mandir}/man1/curl.1*
1f54b511 299
814b6f7d
JB
300%files libs
301%defattr(644,root,root,755)
302%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
b3964ccb 303%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
814b6f7d 304
1f54b511 305%files devel
306%defattr(644,root,root,755)
c6b65fdb 307%doc docs/{CONTRIBUTE.md,INTERNALS.md}
c091c0ac
JB
308%attr(755,root,root) %{_bindir}/curl-config
309%attr(755,root,root) %{_libdir}/libcurl.so
c091c0ac 310%{_includedir}/curl
8ad78925 311%{_pkgconfigdir}/libcurl.pc
1399f3ff 312%{_aclocaldir}/libcurl.m4
c091c0ac 313%{_mandir}/man1/curl-config.1*
b3964ccb
JB
314%{_mandir}/man3/curl_*.3*
315%{_mandir}/man3/libcurl*.3*
0efd10e8 316%{_mandir}/man3/CURLINFO_*.3*
67744768 317%{_mandir}/man3/CURLOPT_*.3*
eb7a78c8 318%{_mandir}/man3/CURLMOPT_*.3*
1f54b511 319
320%files static
321%defattr(644,root,root,755)
c091c0ac 322%{_libdir}/libcurl.a
e80259d2 323
8a62d0ef
AG
324%files -n fish-completion-%{name}
325%defattr(644,root,root,755)
326%{fish_compdir}/%{name}.fish
327
e80259d2
JB
328%files -n zsh-completion-curl
329%defattr(644,root,root,755)
330%{_datadir}/zsh/site-functions/_curl
This page took 0.129516 seconds and 4 git commands to generate.