]> git.pld-linux.org Git - packages/curl.git/blame - curl.spec
- up to 7.69.0
[packages/curl.git] / curl.spec
CommitLineData
8a9e937b 1# TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
195ea5a8
JB
2#
3# Conditional build:
358ad66a
JB
4%bcond_without ssh # SSH support
5%bcond_without ssl # SSL support
6%bcond_with gnutls # GnuTLS instead of OpenSSL
7%bcond_without kerberos5 # Heimdal Kerberos 5 support
8%bcond_without ldap # LDAP support
8424568c 9%bcond_without http2 # HTTP/2.0 support (nghttp2 based)
358ad66a 10%bcond_without metalink # metalink support
de17b215 11%if "%{pld_release}" != "ac"
358ad66a
JB
12%bcond_without ares # c-ares (asynchronous DNS operations) library support
13%bcond_without rtmp # Real Time Media Protocol support
de17b215 14%else
358ad66a
JB
15%bcond_with ares # c-ares (asynchronous DNS operations) library support
16%bcond_with rtmp # Real Time Media Protocol support
de17b215
ER
17%endif
18
f7f276d9 19Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
ce380d80
ER
20Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
21Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
22Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
23Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
24Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
5767e1a7 25Name: curl
0ff06b76 26Version: 7.69.0
d1d43e0c 27Release: 1
c091c0ac 28License: MIT-like
5767e1a7 29Group: Applications/Networking
d8be0059 30Source0: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
0ff06b76 31# Source0-md5: aad71c74c5a66eb7eaff6507c22d5615
d0cec3a8
JB
32Patch0: %{name}-ac.patch
33Patch1: %{name}-krb5flags.patch
4557544f 34URL: http://curl.haxx.se/
c091c0ac 35BuildRequires: autoconf >= 2.57
66cf63f1 36BuildRequires: automake
7c7ffb45 37%{?with_ares:BuildRequires: c-ares-devel >= 1.7.0}
f73c4120 38%{?with_kerberos5:BuildRequires: heimdal-devel}
8a129a6b 39BuildRequires: libbrotli-devel >= 1.0.0
04f3f89d 40BuildRequires: libidn2-devel
e80259d2
JB
41%{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
42BuildRequires: libpsl-devel
9defadab 43%{?with_rtmp:BuildRequires: librtmp-devel}
b83a223e 44%{?with_ssh:BuildRequires: libssh2-devel >= 1.2.8}
c091c0ac 45BuildRequires: libtool
0f90f9c0 46BuildRequires: nettle-devel
9204ae0d 47%{?with_http2:BuildRequires: nghttp2-devel >= 1.9.0}
588be88f 48%{?with_ldap:BuildRequires: openldap-devel}
c260acfc 49BuildRequires: pkgconfig
de17b215 50BuildRequires: rpm >= 4.4.9-56
838a6eda 51BuildRequires: rpmbuild(macros) >= 1.527
5559a124
AM
52%if %{with ssl}
53%if %{with gnutls}
54BuildRequires: gnutls-devel
55%else
549c5328 56BuildRequires: openssl-devel >= 1.0.1
5559a124
AM
57%endif
58%endif
d04a5e91 59BuildRequires: tar >= 1:1.22
6903f0dc 60BuildRequires: zlib-devel
3fb47407 61Requires: %{name}-libs = %{version}-%{release}
cfa95fc0 62Obsoletes: libcurl2
8aa4e5ec 63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81714278 64
65%description
655b91ad 66cURL is a tool for getting files with URL syntax, supporting FTP,
67HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
68POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
69cookies, user+password authentication and a busload of other useful
70tricks. The main use for curl is when you want to get or send files
71automatically to or from a site using one of the supported protocols.
72
73cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
74Dict servers, using any of the supported protocols. cURL is designed
75to work without user interaction or any kind of interactivity. cURL
76offers many useful capabilities, like proxy support, user
e566d906 77authentication, FTP upload, HTTP post, and file transfer resume.
81714278 78
d63bcf1b
JR
79%description -l pl.UTF-8
80cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
81HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
82HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
655b91ad 83oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
d63bcf1b
JR
84użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
85się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
86pliki z/na serwer używając jednego z dostępnych protokołów.
87%{?with_ssl:Ten pakiet obsługuje także SSL.}
1310544e 88
d63bcf1b
JR
89%description -l pt_BR.UTF-8
90Curl é um cliente para baixar/enviar arquivos de/para servidores
91usando um dos protocolos suportados. É projetado para funcionar sem a
92interação do usuário.
1310544e 93
d63bcf1b
JR
94Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
95continuar transferências interrompidas, e mais...
1310544e 96
d63bcf1b
JR
97%description -l ru.UTF-8
98curl - это клиент с множеством поддерживаемых протоколов для получения
99файлов с серверов, спроектированный для работы как в неинтерактивном
100режиме, так и с возможностью диалога с пользователем.
f05b825f 101
d63bcf1b
JR
102curl поддерживает много полезных возможностей, среди которых поддержка
103прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
104POST, восстановление прерванной пересылки и многое другое.
f05b825f 105
d63bcf1b
JR
106curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
107файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
108режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
f05b825f 109
d63bcf1b
JR
110curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
111прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
112в╕дновлення перервано╖ пересилки та багато ╕ншого.
f05b825f 113
814b6f7d
JB
114%package libs
115Summary: curl library
ce380d80 116Summary(pl.UTF-8): Biblioteka curl
814b6f7d 117Group: Libraries
de17b215 118%{?with_ares:Requires: c-ares >= 1.7.0}
549c5328 119%{?with_ssh:Requires: libssh2 >= 1.2.8}
f2dad801 120%{?with_http2:Requires: nghttp2-libs >= 1.9.0}
fddc44fa 121%if %{with ssl} && %{without gnutls}
00b2a6eb 122Requires: libbrotli >= 1.0.0
549c5328 123Requires: openssl >= 1.0.1
fddc44fa 124%endif
dfeb0d8d
PG
125Suggests: ca-certificates
126Conflicts: ca-certificates < 20080809-4
814b6f7d
JB
127
128%description libs
129curl library.
130
d63bcf1b 131%description libs -l pl.UTF-8
814b6f7d
JB
132Biblioteka curl.
133
1f54b511 134%package devel
135Summary: Header files and development documentation for curl library
ce380d80
ER
136Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
137Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
138Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
139Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
1f54b511 140Group: Development/Libraries
3fb47407 141Requires: %{name}-libs = %{version}-%{release}
bd2c841c 142%{?with_ares:Requires: c-ares-devel}
f73c4120 143%{?with_kerberos5:Requires: heimdal-devel}
72fe5a16 144Requires: libbrotli-devel >= 1.0.0
04f3f89d 145Requires: libidn2-devel
e80259d2 146Requires: libpsl-devel
70778617 147%{?with_rtmp:Requires: librtmp-devel}
b83a223e 148%{?with_ssh:Requires: libssh2-devel >= 1.2.8}
9204ae0d 149%{?with_http2:Requires: nghttp2-devel >= 1.9.0}
588be88f 150%{?with_ldap:Requires: openldap-devel}
5559a124
AM
151%if %{with ssl}
152%if %{with gnutls}
153Requires: gnutls-devel
154%else
155Requires: openssl-devel >= 0.9.7c
156%endif
157%endif
5e1699d5 158Requires: zlib-devel
cfa95fc0 159Obsoletes: libcurl2-devel
1f54b511 160
161%description devel
162Header files and development documentation for curl library.
163
d63bcf1b
JR
164%description devel -l pl.UTF-8
165Pliki nagłówkowe i dokumentacja do biblioteki curl.
cec38cdf 166
d63bcf1b
JR
167%description devel -l pt_BR.UTF-8
168Arquivos de cabeçalho e bibliotecas de desenvolvimento.
1310544e 169
d63bcf1b
JR
170%description devel -l ru.UTF-8
171Этот пакет содержит файлы, необходимые для разработки программ с
172использованием библиотеки curl.
f05b825f 173
d63bcf1b
JR
174%description devel -l uk.UTF-8
175Цей пакет містить файли, необхідні для розробки програм з
176використанням бібліотеки curl.
f05b825f 177
1f54b511 178%package static
179Summary: Static version of curl library
ce380d80
ER
180Summary(pl.UTF-8): Statyczna wersja biblioteki curl
181Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
182Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
183Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
1f54b511 184Group: Development/Libraries
6e6a5186 185Requires: %{name}-devel = %{version}-%{release}
1f54b511 186
187%description static
d06d2fe1 188Static version of curl library.
1f54b511 189
d63bcf1b 190%description static -l pl.UTF-8
cec38cdf 191Statyczna wersja biblioteki curl.
b73e2a73 192
d63bcf1b
JR
193%description static -l pt_BR.UTF-8
194Bibliotecas estáticas para desenvolvimento com o curl.
1310544e 195
d63bcf1b
JR
196%description static -l ru.UTF-8
197Этот пакет содержит статическую библиотеку для разработки программ с
198использованием библиотеки curl.
f05b825f 199
d63bcf1b
JR
200%description static -l uk.UTF-8
201Цей пакет містить статичну бібліотеку для розробки програм з
202використанням бібліотеки curl.
f05b825f 203
8a62d0ef
AG
204%package -n fish-completion-%{name}
205Summary: Fish completion for curl command
206Summary(pl.UTF-8): Dopełnianie parametrów w fish dla polecenia curl
207Group: Applications/Shells
208Requires: %{name} = %{version}-%{release}
209Requires: fish
210
211%description -n fish-completion-%{name}
212Fish completion for curl command.
213
214%description -n fish-completion-%{name} -l pl.UTF-8
215Dopełnianie parametrów w fish dla polecenia curl.
216
e80259d2
JB
217%package -n zsh-completion-curl
218Summary: ZSH completion for curl command
219Summary(pl.UTF-8): Dopełnianianie parametrów w ZSH dla polecenia curl
220Group: Applications/Shells
221Requires: %{name} = %{version}-%{release}
222Requires: zsh
223
224%description -n zsh-completion-curl
225ZSH completion for curl command.
226
227%description -n zsh-completion-curl -l pl.UTF-8
228Dopełnianianie parametrów w ZSH dla polecenia curl.
229
81714278 230%prep
13caa23a 231%setup -q
d0cec3a8 232%patch0 -p1
d4dc980e 233%patch1 -p1
81714278 234
358ad66a 235%{__rm} m4/lt*.m4 m4/libtool.m4
36cd7270 236
81714278 237%build
c091c0ac 238%{__libtoolize}
03613829 239%{__aclocal} -I m4
d4dc980e
AM
240%{__autoconf}
241%{__autoheader}
c091c0ac 242%{__automake}
e566d906 243%configure \
ef822e11 244 ac_cv_header_gss_h=no \
e80259d2
JB
245 %{__enable_disable ares} \
246 --enable-ipv6 \
247 %{__enable_disable ldap} \
248 %{__enable_disable ldap ldaps} \
249 --disable-silent-rules \
5559a124 250%if %{with ssl}
03613829 251 --with-ca-bundle=/etc/certs/ca-certificates.crt \
5559a124 252%if %{with gnutls}
28c87603 253 --with-gnutls --without-ssl \
5559a124
AM
254%else
255 --with-ssl=%{_prefix} \
256%endif
0eee87e5
AM
257%else
258 --without-ssl --without-gnutls \
5559a124 259%endif
8a62d0ef 260 --with-fish-functions-dir=%{fish_compdir} \
838a6eda
JK
261 %{__with_without kerberos5 gssapi %{_prefix}} \
262 %{__with_without metalink libmetalink} \
263 %{__with_without rtmp librtmp} \
264 %{__with_without http2 nghttp2} \
e80259d2 265 %{__with_without ssh libssh2}
a436679a 266
c2167492 267%{__make}
81714278 268
269%install
5767e1a7 270rm -rf $RPM_BUILD_ROOT
56f17d66
AM
271%{__make} install \
272 DESTDIR=$RPM_BUILD_ROOT
273
4f6d4393
JB
274%{__make} -C scripts install \
275 DESTDIR=$RPM_BUILD_ROOT
276
34ca770a 277# no longer in upstream but a lot of apps tries to include it so we create fake one
925b36ff
AM
278[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
279echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
34ca770a 280
81714278 281%clean
282rm -rf $RPM_BUILD_ROOT
81714278 283
3fb47407
ER
284%post libs -p /sbin/ldconfig
285%postun libs -p /sbin/ldconfig
1f54b511 286
81714278 287%files
5767e1a7 288%defattr(644,root,root,755)
d1d43e0c 289%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting}
c091c0ac 290%attr(755,root,root) %{_bindir}/curl
c091c0ac 291%{_mandir}/man1/curl.1*
1f54b511 292
814b6f7d
JB
293%files libs
294%defattr(644,root,root,755)
295%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
b3964ccb 296%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
814b6f7d 297
1f54b511 298%files devel
299%defattr(644,root,root,755)
f319ccdb 300%doc docs/{CONTRIBUTE.md,INTERNALS.md,LICENSE-MIXING.md,RESOURCES}
c091c0ac
JB
301%attr(755,root,root) %{_bindir}/curl-config
302%attr(755,root,root) %{_libdir}/libcurl.so
303%{_libdir}/libcurl.la
304%{_includedir}/curl
8ad78925 305%{_pkgconfigdir}/libcurl.pc
1399f3ff 306%{_aclocaldir}/libcurl.m4
c091c0ac 307%{_mandir}/man1/curl-config.1*
b3964ccb
JB
308%{_mandir}/man3/curl_*.3*
309%{_mandir}/man3/libcurl*.3*
0efd10e8 310%{_mandir}/man3/CURLINFO_*.3*
67744768 311%{_mandir}/man3/CURLOPT_*.3*
eb7a78c8 312%{_mandir}/man3/CURLMOPT_*.3*
1f54b511 313
314%files static
315%defattr(644,root,root,755)
c091c0ac 316%{_libdir}/libcurl.a
e80259d2 317
8a62d0ef
AG
318%files -n fish-completion-%{name}
319%defattr(644,root,root,755)
320%{fish_compdir}/%{name}.fish
321
e80259d2
JB
322%files -n zsh-completion-curl
323%defattr(644,root,root,755)
324%{_datadir}/zsh/site-functions/_curl
This page took 0.116857 seconds and 4 git commands to generate.