]> git.pld-linux.org Git - packages/cups-filters.git/commitdiff
upstream patch to fix build with poppler 0.69.0; rel 2 auto/th/cups-filters-1.21.3-2
authorJan Palus <atler@pld-linux.org>
Wed, 21 Nov 2018 22:17:27 +0000 (23:17 +0100)
committerJan Palus <atler@pld-linux.org>
Wed, 21 Nov 2018 22:17:27 +0000 (23:17 +0100)
cups-filters-poppler.patch [new file with mode: 0644]
cups-filters.spec

diff --git a/cups-filters-poppler.patch b/cups-filters-poppler.patch
new file mode 100644 (file)
index 0000000..e9516d1
--- /dev/null
@@ -0,0 +1,76 @@
+From 6b0747c1630dd973acd138f927dbded4ea45e360 Mon Sep 17 00:00:00 2001
+From: Olivier Schonken <olivier.schonken@gmail.com>
+Date: Fri, 5 Oct 2018 12:05:31 +0200
+Subject: [PATCH] Poppler removed memCheck and gMemReport functions
+
+Only use gMemReport and memCheck functions if poppler version less
+than 0.69.0
+
+The poppler project removed the memCheck and gMemReport functions in
+commits c362ab1b97f20c5b73b3bad8d52015f679178748 - Remove DEBUG_MEM
+from Object since this uses RAII now and hence cannot leak.
+(The existing tracking also is not thread-safe and hence unreliable.)
+
+and
+
+f89446f6917a869b0f1a80fcc8ce81a7213dade4 - Remove generic heap debugging
+from gmem since external tools and compiler instrumentation achieve the
+same effect.
+
+This commit solves https://github.com/OpenPrinting/cups-filters/issues/62
+
+Signed-off-by: Olivier Schonken <olivier.schonken@gmail.com>
+---
+ filter/pdftoijs.cxx            | 2 ++
+ filter/pdftoopvp/pdftoopvp.cxx | 2 ++
+ filter/pdftoraster.cxx         | 2 ++
+ 3 files changed, 6 insertions(+)
+
+diff --git a/filter/pdftoijs.cxx b/filter/pdftoijs.cxx
+index 22bc33f4..dd6b6fa0 100644
+--- a/filter/pdftoijs.cxx
++++ b/filter/pdftoijs.cxx
+@@ -503,9 +503,11 @@ int main(int argc, char *argv[]) {
+   ppdClose(ppd);
+   free(outputfile);
++#if POPPLER_VERSION_MAJOR == 0 && POPPLER_VERSION_MINOR < 69
+   // Check for memory leaks
+   Object::memCheck(stderr);
+   gMemReport(stderr);
++#endif
+   return exitCode;
+ }
+diff --git a/filter/pdftoopvp/pdftoopvp.cxx b/filter/pdftoopvp/pdftoopvp.cxx
+index 024941ab..bf25983b 100644
+--- a/filter/pdftoopvp/pdftoopvp.cxx
++++ b/filter/pdftoopvp/pdftoopvp.cxx
+@@ -763,9 +763,11 @@ fprintf(stderr,"JobInfo=%s\n",jobInfo);
+  err0:
+   delete globalParams;
++#if POPPLER_VERSION_MAJOR == 0 && POPPLER_VERSION_MINOR < 69
+   // check for memory leaks
+   Object::memCheck(stderr);
+   gMemReport(stderr);
++#endif
+ }
+ /* muntrace(); */
+diff --git a/filter/pdftoraster.cxx b/filter/pdftoraster.cxx
+index 0c63ab8d..4ebf02b0 100644
+--- a/filter/pdftoraster.cxx
++++ b/filter/pdftoraster.cxx
+@@ -2162,9 +2162,11 @@ int main(int argc, char *argv[]) {
+     cmsDeleteTransform(colorTransform);
+   }
++#if POPPLER_VERSION_MAJOR == 0 && POPPLER_VERSION_MINOR < 69
+   // Check for memory leaks
+   Object::memCheck(stderr);
+   gMemReport(stderr);
++#endif
+   return exitCode;
+ }
index 815b39a8492870d33d81f2e7f95d18bccade3c1a..35618898548b1bd151f89b9bf087478819250c18 100644 (file)
@@ -12,7 +12,7 @@ Summary:      OpenPrinting CUPS filters and backends
 Summary(pl.UTF-8):     Filtry i backendy CUPS-a z projektu OpenPrinting
 Name:          cups-filters
 Version:       1.21.3
-Release:       1
+Release:       2
 # For a breakdown of the licensing, see COPYING file
 # GPLv2:   filters: commandto*, imagetoraster, pdftops, rasterto*,
 #                   imagetopdf, pstopdf, texttopdf
@@ -29,6 +29,7 @@ Source0:      http://www.openprinting.org/download/cups-filters/%{name}-%{version}.ta
 Patch0:                %{name}-dbus.patch
 Patch1:                %{name}-php.patch
 Patch2:                %{name}-php7.patch
+Patch3:                %{name}-poppler.patch
 URL:           http://www.linuxfoundation.org/collaborate/workgroups/openprinting/cups-filters
 BuildRequires: autoconf >= 2.65
 BuildRequires: automake >= 1:1.11
@@ -248,6 +249,7 @@ Moduł PHP do ogólnego systemu druku dla Uniksa.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__aclocal}
This page took 0.041945 seconds and 4 git commands to generate.