]> git.pld-linux.org Git - packages/cups-filters.git/blobdiff - cups-filters.spec
- updated to 1.0.54
[packages/cups-filters.git] / cups-filters.spec
index 9b77018598995747976b95b55e2bfac41c15454d..83ba1cb82e82668f2919375ade2be3b88c1ee7f1 100644 (file)
@@ -3,11 +3,14 @@
 %bcond_without static_libs     # static libraries
 %bcond_without perl            # Perl module
 %bcond_without php             # PHP extension
-#
+
+%if 0%{!?php_name:1}
+%define                php_name        php55
+%endif
 Summary:       OpenPrinting CUPS filters and backends
 Summary(pl.UTF-8):     Filtry i backendy CUPS-a z projektu OpenPrinting
 Name:          cups-filters
-Version:       1.0.47
+Version:       1.0.54
 Release:       1
 # For a breakdown of the licensing, see COPYING file
 # GPLv2:   filters: commandto*, imagetoraster, pdftops, rasterto*,
@@ -21,7 +24,7 @@ Release:      1
 License:       GPL v2, GPL v2+, GPL v3, GPL v3+, LGPL v2+, MIT
 Group:         Applications/Printing
 Source0:       http://www.openprinting.org/download/cups-filters/%{name}-%{version}.tar.xz
-# Source0-md5: c1baecc8996c97af1ffe58b5f2046e86
+# Source0-md5: 181ee0e6c27cfbb05e241f0267363678
 Patch0:                %{name}-dbus.patch
 Patch1:                %{name}-php.patch
 URL:           http://www.linuxfoundation.org/collaborate/workgroups/openprinting/cups-filters
@@ -34,6 +37,7 @@ BuildRequires:        dbus-devel
 BuildRequires: fontconfig-devel >= 2.0.0
 BuildRequires: freetype-devel >= 2
 # /usr/bin/gs, for features detection
+%{?with_php:BuildRequires:     %{php_name}-devel}
 BuildRequires: ghostscript
 BuildRequires: ghostscript-ijs-devel
 BuildRequires: glib2-devel >= 1:2.30.2
@@ -44,25 +48,24 @@ BuildRequires:      libstdc++-devel
 BuildRequires: libtiff-devel
 BuildRequires: libtool
 %{?with_perl:BuildRequires:    perl-devel}
-%{?with_php:BuildRequires:     php-devel >= 5}
 BuildRequires: pkgconfig >= 1:0.20
 # just for cpp/poppler-version.h
 BuildRequires: poppler-cpp-devel >= 0.18
 BuildRequires: poppler-devel >= 0.18
 # /usr/bin/pdftops, for features detection
 BuildRequires: poppler-progs >= 0.18
-BuildRequires: rpmbuild(macros) >= 1.671
 BuildRequires: qpdf-devel >= 3.0.2
+BuildRequires: rpmbuild(macros) >= 1.671
 BuildRequires: zlib-devel
 # DejaVuSans.ttf (testing font for test scripts)
 #BuildRequires:        fonts-TTF-DejaVu
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      cups >= 1:1.6.0
 Requires:      fontconfig >= 2.0.0
-Suggests:      fonts-TTF-freefont
 Requires:      ghostscript
 Requires:      poppler-progs >= 0.18
 Requires:      qpdf-libs >= 3.0.2
+Suggests:      fonts-TTF-freefont
 # pstopdf
 Requires:      bc
 Requires:      grep
@@ -149,8 +152,8 @@ Requires:   glib2 >= 1:2.30.2
 Requires:      systemd-units >= 38
 
 %description -n cups-browsed
-A daemon for browsing the Bonjour broadcasts of shared,
-remote CUPS printers.
+A daemon for browsing the Bonjour broadcasts of shared, remote CUPS
+printers.
 
 %description -n cups-browsed -l pl.UTF-8
 Demon do przeglądania broadcastów Bonjour współdzielonych, zdalnych
@@ -205,7 +208,7 @@ Perl module for Common Unix Printing System.
 %description -n perl-cups -l pl.UTF-8
 Moduł Perla do ogólnego systemu druku dla Uniksa.
 
-%package -n php-cups
+%package -n %{php_name}-cups
 Summary:       PHP module for CUPS
 Summary(pl.UTF-8):     Moduł PHP CUPS
 # must be larger than cups.spec before 1.6.0
@@ -214,13 +217,11 @@ License:  GPL v2 + OpenSSL exception
 Group:         Development/Languages/PHP
 Requires:      cups-lib >= 1:1.6.0
 %{?requires_php_extension}
-Requires:      /etc/php/conf.d
-Requires:      php(core) >= 5.0.0
 
-%description -n php-cups
+%description -n %{php_name}-cups
 PHP module for Common Unix Printing System.
 
-%description -n php-cups -l pl.UTF-8
+%description -n %{php_name}-cups -l pl.UTF-8
 Moduł PHP do ogólnego systemu druku dla Uniksa.
 
 # CREATE ANY NEW PACKAGES BEFORE cups-backend-* (EPOCH)
@@ -260,7 +261,6 @@ cd ../..
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{systemdunitdir}
-
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -270,6 +270,8 @@ cat > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/phpcups.ini << 'EOF'
 ; Enable phpcups extension module
 extension=libphpcups.so
 EOF
+# dlopened module
+%{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/libphpcups.la
 %endif
 
 %if %{with perl}
@@ -281,8 +283,6 @@ install -p utils/cups-browsed.service $RPM_BUILD_ROOT%{systemdunitdir}
 
 # obsoleted by pkg-config
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/lib*.la
-# dlopened module
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/php/libphpcups.la
 # packaged as %doc
 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/cups-filters
 # Not sure what is this good for.
@@ -346,6 +346,7 @@ fi
 %attr(755,root,root) %{_cups_serverbin}/filter/pstopdf
 %attr(755,root,root) %{_cups_serverbin}/filter/rastertoescpx
 %attr(755,root,root) %{_cups_serverbin}/filter/rastertopclx
+%attr(755,root,root) %{_cups_serverbin}/filter/rastertopdf
 %attr(755,root,root) %{_cups_serverbin}/filter/textonly
 %attr(755,root,root) %{_cups_serverbin}/filter/texttopdf
 %attr(755,root,root) %{_cups_serverbin}/filter/texttops
@@ -420,9 +421,9 @@ fi
 %endif
 
 %if %{with php}
-%files -n php-cups
+%files -n %{php_name}-cups
 %defattr(644,root,root,755)
 %doc scripting/php/README
-%attr(755,root,root) %{php_extensiondir}/libphpcups.so
 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/phpcups.ini
+%attr(755,root,root) %{php_extensiondir}/libphpcups.so
 %endif
This page took 0.237536 seconds and 4 git commands to generate.