]> git.pld-linux.org Git - packages/ctl.git/commitdiff
- added openexr-update patch (fixes build with OpenEXR 2.3.x) auto/th/ctl-1.5.2-4
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 5 Feb 2022 09:05:01 +0000 (10:05 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 5 Feb 2022 09:05:01 +0000 (10:05 +0100)
- added c++17 patch (fixes build in C++ 17 mode)
- versioned Obsoletes
- use out-of-tree build
- release 4

ctl-c++17.patch [new file with mode: 0644]
ctl-openexr-update.patch [new file with mode: 0644]
ctl.spec

diff --git a/ctl-c++17.patch b/ctl-c++17.patch
new file mode 100644 (file)
index 0000000..7c0aba8
--- /dev/null
@@ -0,0 +1,11 @@
+--- CTL-ctl-1.5.2/lib/dpx/dpx.hh.orig  2014-06-03 03:11:24.000000000 +0200
++++ CTL-ctl-1.5.2/lib/dpx/dpx.hh       2022-02-05 09:54:00.923386506 +0100
+@@ -297,7 +297,7 @@ struct dpx {
+               compliance_e current_compliance;
+               endian_mode_e current_endian_mode;
+-              std::istream::streampos header_start;
++              std::streampos header_start;
+       public:
+               virtual ~dpx();
diff --git a/ctl-openexr-update.patch b/ctl-openexr-update.patch
new file mode 100644 (file)
index 0000000..007c05d
--- /dev/null
@@ -0,0 +1,11 @@
+--- CTL-ctl-1.5.2/lib/IlmCtlSimd/CtlSimdInst.cpp.orig  2014-06-03 03:11:24.000000000 +0200
++++ CTL-ctl-1.5.2/lib/IlmCtlSimd/CtlSimdInst.cpp       2022-02-05 08:36:14.965330834 +0100
+@@ -189,7 +189,7 @@ SimdInst::executePath (SimdBoolMask &mas
+           REPLACE_EXC
+               (e, "\n" <<
+                xcontext.fileName() << ":" <<
+-               inst->lineNumber() << ": " << e);
++               inst->lineNumber() << ": " << e.message());
+           throw e;
+       }
index 673272124ed755dec1d3edcb8920da97ae525a43..f9d71f1c7592a280709ed2ddc7f4dbd427c28252 100644 (file)
--- a/ctl.spec
+++ b/ctl.spec
@@ -2,15 +2,17 @@ Summary:      Color Transform Language libraries
 Summary(pl.UTF-8):     Biblioteki CTL (języka przekształceń kolorów)
 Name:          ctl
 Version:       1.5.2
-Release:       3
+Release:       4
 License:       BSD + IP clause
 Group:         Libraries
-#Source0Download: https://github.com/ampas/CTL/releases
+#Source0Download: https://github.com/ampas/CTL/tags
 Source0:       https://github.com/ampas/CTL/archive/%{name}-%{version}.tar.gz
 # Source0-md5: 4796bf258d0c66d421c864996482f952
 Patch0:                %{name}-libdir.patch
 Patch1:                %{name}-ctlrender.patch
 Patch2:                %{name}-pc.patch
+Patch3:                %{name}-openexr-update.patch
+Patch4:                %{name}-c++17.patch
 URL:           https://www.oscars.org/science-technology/sci-tech-projects/color-transformation-language
 BuildRequires: OpenEXR-devel
 BuildRequires: aces_container-devel
@@ -55,7 +57,7 @@ Group:                Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      ilmbase-devel >= 2.0.0
 Requires:      libstdc++-devel
-Obsoletes:     ctl-static
+Obsoletes:     ctl-static < 1.5
 
 %description devel
 Header files for CTL library.
@@ -84,7 +86,7 @@ Group:                Development/Libraries
 Requires:      OpenEXR-devel
 Requires:      ctl-devel = %{version}-%{release}
 Requires:      openexr_ctl = %{version}-%{release}
-Obsoletes:     openexr_ctl-static
+Obsoletes:     openexr_ctl-static < 1.1
 
 %description -n openexr_ctl-devel
 Header files for IlmInfCtl library.
@@ -146,9 +148,13 @@ ctlrender obsługuje formaty plików OpenEXR, TIFF, DPX oraz ACES.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
 
 %build
-%cmake . \
+install -d build
+cd build
+%cmake .. \
        -DINSTALL_CMAKE_DIR=%{_libdir}/cmake/CTL \
        -DINSTALL_LIB_DIR=%{_libdir}
 %{__make}
@@ -156,7 +162,7 @@ ctlrender obsługuje formaty plików OpenEXR, TIFF, DPX oraz ACES.
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make} install \
+%{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
 # packaged as %doc
This page took 0.066766 seconds and 4 git commands to generate.