]> git.pld-linux.org Git - packages/ctemplate.git/blob - ctemplate.spec
76fe5cf83f09127ef9eb6a35a11685353422f27f
[packages/ctemplate.git] / ctemplate.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Simple and powerful template language for C++
7 Name:           ctemplate
8 Version:        2.2
9 Release:        1
10 License:        BSD
11 Group:          Applications
12 # Google Code no longer provides downloads for projects, upstream
13 # refuses to use Google Drive, they ask users to fetch from svn repository by themselves.
14 Source0:        http://pkgs.fedoraproject.org/repo/pkgs/ctemplate/%{name}-%{version}.tar.gz/1de89d9073f473c1e31862c4581636f3/ctemplate-%{version}.tar.gz
15 # Source0-md5:  1de89d9073f473c1e31862c4581636f3
16 URL:            http://code.google.com/p/google-ctemplate/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 CTemplate is a simple and powerful template language for C++. It
25 emphasizes separating logic from presentation: it is impossible to
26 embed application logic in this template language.
27
28 %package libs
29 Summary:        CTemplate library
30 Summary(pl.UTF-8):      Biblioteka CTemplate
31 Group:          Libraries
32
33 %description libs
34 This package contains CTemplate library.
35
36 %description libs -l pl.UTF-8
37 Ten pakiet zawiera bibliotekę CTemplate.
38
39 %package doc
40 Summary:        CTemplate documentation
41 Summary(pl.UTF-8):      Dokumentacja CTemplate
42 Group:          Development/Libraries
43
44 %description doc
45 CTemplate documentation.
46
47 %description doc -l pl.UTF-8
48 Dokumentacja CTemplate.
49
50 %package devel
51 Summary:        Header files for CTemplate
52 Summary(pl.UTF-8):      Pliki nagłówkowe CTemplate
53 Group:          Development/Libraries
54 Requires:       %{name}-libs = %{version}-%{release}
55
56 %description devel
57 Header files for CTemplate.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe CTemplate.
61
62 %package static
63 Summary:        Static CTemplate library
64 Summary(pl.UTF-8):      Statyczna biblioteka CTemplate
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
67
68 %description static
69 Static CTemplate library.
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka CTemplate.
73
74 %prep
75 %setup -q
76
77 %build
78 %{__libtoolize}
79 %{__aclocal} -I m4
80 %{__autoconf}
81 %{__automake}
82 export PTHREAD_LIBS="-lpthread"
83 %configure \
84         %{!?with_static_libs:--disable-static} \
85         --disable-silent-rules
86 %{__make}
87 %{?with_test:%{__make} check}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   libs -p /sbin/ldconfig
98 %postun libs -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_bindir}/diff_tpl_auto_escape
103 %attr(755,root,root) %{_bindir}/make_tpl_varnames_h
104 %attr(755,root,root) %{_bindir}/template-converter
105
106 %files libs
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libctemplate.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libctemplate.so.2
110 %attr(755,root,root) %{_libdir}/libctemplate_nothreads.so.*.*.*
111 %attr(755,root,root) %ghost %{_libdir}/libctemplate_nothreads.so.2
112
113 %files devel
114 %defattr(644,root,root,755)
115 %{_libdir}/libctemplate.so
116 %{_libdir}/libctemplate_nothreads.so
117 %{_libdir}/libctemplate.la
118 %{_libdir}/libctemplate_nothreads.la
119 %dir %{_includedir}/%{name}
120 %{_includedir}/%{name}/*.h
121 %{_pkgconfigdir}/libctemplate.pc
122 %{_pkgconfigdir}/libctemplate_nothreads.pc
123
124 %if %{with static_libs}
125 %files static
126 %defattr(644,root,root,755)
127 %{_libdir}/libctemplate.a
128 %{_libdir}/libctemplate_nothreads.a
129 %endif
130
131 %files doc
132 %defattr(644,root,root,755)
133 %doc %{_docdir}/*
This page took 0.024579 seconds and 2 git commands to generate.