]> git.pld-linux.org Git - packages/ctags.git/blob - ctags.spec
- added using CVS keywords in %changelog (for automating them).
[packages/ctags.git] / ctags.spec
1 Summary:        Exuberant ctags -- C cross-reference tool
2 Summary(de):    Exuberant ctags - C-Cross-Reference-Tool 
3 Summary(fr):    ctags exubérant
4 Summary(pl):    ctags - generator list odwo³añ
5 Summary(tr):    C dili için çapraz-baþvuru (cross-reference) aracý
6 Name:           ctags
7 Version:        3.2.2
8 Release:        1
9 Copyright:      GPL
10 Group:          Development/Tools
11 Group(pl):      Programowanie/Narzêdzia
12 Source:         ftp://ftp.revnet.com/pub/ctags/%{name}-%{version}.tar.gz
13 patch0:         ctags-glibc.patch
14 URL:            http://darren.hiebert.com/ctags/
15 Buildroot:      /tmp/%{name}-%{version}-root
16
17 %description
18 Ctags generates an index (or tag) file of C language objects found in C
19 source and header files.  The index makes it easy for text editors or other
20 utilities to locate the indexed items.  Ctags can also generate a cross
21 reference file which lists information about the various objects found in a
22 set of C language files in human readable form.  Exuberant Ctags improves on
23 ctags because it can find all types of C language tags, including macro
24 definitions, enumerated values (values inside enum{...}), function and
25 method definitions, enum/struct/union tags, external function prototypes,
26 typedef names and variable declarations.  Exuberant Ctags is far less likely
27 to be fooled by code containing #if preprocessor conditional constructs than
28 ctags.  Exuberant ctags supports output of emacs style TAGS files and can be
29 used to print out a list of selected objects found in source files.
30                                                                                                               
31 Install ctags if you are going to use your system for C programming.                                          
32
33 %description -l de
34 Ein verbessertes ctags, das tags für alle möglichen tag-Typen generiert:
35 Makrodefinitionen, aufgezählte Werte (Werte in enum{...}), Funktions- und
36 Methodendefinitionen, enum/struct/union-tags, externe Funktionsprototypen
37 (wahlweise), typedefs und variable Deklarationen. Es läßt sich weit weniger
38 gut durch Code täuschen, der #if-Präprozessor-Bedingungen enthält, dank
39 eines konditionalen Pfadauswahlalgorithmus, der komplizierte Entscheidungen
40 trifft, und eines Ausweiche-Algorithmus, der ins Spiel kommt, wenn der erste
41 dem Problem nicht gewachsen ist.  Kann auch benutzt werden, um eine Liste
42 ausgewählter Objekte, die in Quelldateien gefunden wurden, auszudrucken.
43
44 %description -l fr
45 un ctags amélioré générant des tags pour tous les types de tags possibles :
46 définitions de macros, valeurs énumérées (valeurs dans enum{...}),
47 définitions de fonctions et de méthodes, enum/struct/union tags, prototypes
48 de fonctions externes (optionnel), typedefs, et déclarations de variables.
49 Peut aussi être utilisé pour afficher une liste des objets choisis trouvés
50 dans les fichiers source.
51
52 %description -l pl
53 Generator tabeli odwo³añ dla: makr, zmiennych, funkcji i procedur, definicji
54 typów, metod (C++) itp. U¿ywany do generacji listy wyspecyfikowanych
55 obiektów znalezionych w plikach ¼ród³owych. Tablica owych odwo³añ mo¿e byæ
56 wykorzystywana przez wiekszosæ standardowych edytorów tekstu (vim, joe,
57 emacs), do przemieszczania siê w ¼ród³ach miêdzy deklaracj± i u¿yciem danego
58 symbolu.
59
60 %description -l tr
61 Olabilecek her türlü etiket çeþitleri - makro tanýmlamalarý, sayýlý
62 (enumerated) deðerler, fonksiyon ve yöntem (method) tanýmlamalarý, tip ve
63 deðiþken tanýmlarý - için etiketler üretir. Kaynak kodlarýnda bulunan,
64 seçilmiþ nesnelerin listesinin çýktýsýný yazýcýdan almak için de
65 kullanýlabilir.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70
71 %build
72 autoconf
73 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
74 ./configure %{_target_platform} \
75         --prefix=%{_prefix}
76 make
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 make prefix=$RPM_BUILD_ROOT%{_prefix} install
82
83 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/etags.1
84 echo ".so ctags.1" > $RPM_BUILD_ROOT%{_mandir}/man1/etags.1
85
86 strip $RPM_BUILD_ROOT%{_bindir}/*
87
88 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
89          FAQ NEWS QUOTES README
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %doc *.gz
97 %attr(755,root,root) %{_bindir}/*
98 %{_mandir}/man1/*
This page took 0.060978 seconds and 3 git commands to generate.