]> git.pld-linux.org Git - packages/ctags.git/blob - ctags.spec
perl -pi -e "s/^automake -a -c -f --foreing/\%\{__automake\}/; \
[packages/ctags.git] / ctags.spec
1 Summary:        Exuberant ctags -- C cross-reference tool
2 Summary(de):    Exuberant ctags - C-Cross-Reference-Tool
3 Summary(es):    Ctags ¡exuberantes! Herramienta de referencia cruzada para C
4 Summary(fr):    ctags exubérant
5 Summary(pl):    ctags - generator list odwo³añ
6 Summary(pt_BR): Ctags exuberantes! Ferramenta de referência cruzada para C
7 Summary(tr):    C dili için çapraz-baþvuru (cross-reference) aracý
8 Name:           ctags
9 Version:        5.2.1
10 Release:        1
11 License:        GPL
12 Group:          Development/Tools
13 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/%{name}/%{name}-%{version}.tar.gz
14 URL:            http://ctags.sourceforge.net/
15 BuildRequires:  autoconf
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Ctags generates an index (or tag) file of C language objects found in
20 C source and header files. The index makes it easy for text editors or
21 other utilities to locate the indexed items. Ctags can also generate a
22 cross reference file which lists information about the various objects
23 found in a set of C language files in human readable form. Exuberant
24 Ctags improves on ctags because it can find all types of C language
25 tags, including macro definitions, enumerated values (values inside
26 enum{...}), function and method definitions, enum/struct/union tags,
27 external function prototypes, typedef names and variable declarations.
28 Exuberant Ctags is far less likely to be fooled by code containing #if
29 preprocessor conditional constructs than ctags. Exuberant ctags
30 supports output of emacs style TAGS files and can be used to print out
31 a list of selected objects found in source files.
32
33 %description -l de
34 #if-Präprozessor-Bedingungen enthält, dank eines konditionalen
35 Ein verbessertes ctags, das tags für alle möglichen tag-Typen
36 generiert: Makrodefinitionen, aufgezählte Werte (Werte in enum{...}),
37 Funktions- und Methodendefinitionen, enum/struct/union-tags, externe
38 Funktionsprototypen (wahlweise), typedefs und variable Deklarationen.
39 Es läßt sich weit weniger gut durch Code täuschen, der
40 Pfadauswahlalgorithmus, der komplizierte Entscheidungen trifft, und
41 eines Ausweiche-Algorithmus, der ins Spiel kommt, wenn der erste dem
42 Problem nicht gewachsen ist. Kann auch benutzt werden, um eine Liste
43 ausgewählter Objekte, die in Quelldateien gefunden wurden,
44 auszudrucken.
45
46 %description -l es
47 Un ctags mejor que crea tags para todos los tipos posibles de tag:
48 definiciones de macro, valores enumerados, definiciones de función y
49 método, tags enum/struct/union, prototipos de función externa
50 (opcional), typedefs y declaraciones variables. Es más difícil de ser
51 engañado en códigos que contenga la directiva condicional #if para el
52 preprocesador, pues utiliza un algoritmo condicional de camino para
53 solucionar decisiones complicadas, y un algoritmo de rescate cuando
54 este falla. También puede ser usado para enseñar una lista de objetos
55 seleccionados que esté en los archivos fuente.
56
57 %description -l fr
58 un ctags amélioré générant des tags pour tous les types de tags
59 possibles : définitions de macros, valeurs énumérées (valeurs dans
60 enum{...}), définitions de fonctions et de méthodes, enum/struct/union
61 tags, prototypes de fonctions externes (optionnel), typedefs, et
62 déclarations de variables. Peut aussi être utilisé pour afficher une
63 liste des objets choisis trouvés dans les fichiers source.
64
65 %description -l pl
66 Generator tabeli odwo³añ dla: makr, zmiennych, funkcji i procedur,
67 definicji typów, metod (C++) itp. U¿ywany do generacji listy
68 wyspecyfikowanych obiektów znalezionych w plikach ¼ród³owych. Tablica
69 owych odwo³añ mo¿e byæ wykorzystywana przez wiekszosæ standardowych
70 edytorów tekstu (vim, joe, emacs), do przemieszczania siê w ¼ród³ach
71 miêdzy deklaracj± i u¿yciem danego symbolu.
72
73 %description -l pt_BR
74 Um ctags melhor que gera tags para todos os tipos possíveis de tag:
75 definições de macro, valores enumerados, definições de função e
76 método, tags enum/struct/union, protótipos de função externa
77 (opcional), typedefs e declarações variáveis. É mais difícil de ser
78 enganado em códigos que contenha a diretiva condicional #if para o
79 pré-processador, pois utiliza um algoritmo condicional de caminho para
80 resolver decisões complicadas, e um algoritmo de resgate quando este
81 falha. Também pode ser usado para mostrar uma lista de objetos
82 selecionados que estejam nos arquivos fonte.
83
84 %description -l tr
85 Olabilecek her türlü etiket çeþitleri - makro tanýmlamalarý, sayýlý
86 (enumerated) deðerler, fonksiyon ve yöntem (method) tanýmlamalarý, tip
87 ve deðiþken tanýmlarý - için etiketler üretir. Kaynak kodlarýnda
88 bulunan, seçilmiþ nesnelerin listesinin çýktýsýný yazýcýdan almak için
89 de kullanýlabilir.
90
91 %prep
92 %setup -q
93
94 %build
95 %{__autoconf}
96 cp -f %{_datadir}/automake/install-sh .
97 cp -f %{_datadir}/automake/config.sub .
98 %configure
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         prefix=$RPM_BUILD_ROOT%{_prefix} \
107         bindir=$RPM_BUILD_ROOT%{_bindir} \
108         mandir=$RPM_BUILD_ROOT%{_mandir}
109
110 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/etags.1
111 echo ".so ctags.1" > $RPM_BUILD_ROOT%{_mandir}/man1/etags.1
112
113 gzip -9nf FAQ NEWS QUOTES README
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %files
119 %defattr(644,root,root,755)
120 %doc *.gz
121 %attr(755,root,root) %{_bindir}/*
122 %{_mandir}/man1/*
This page took 0.05943 seconds and 3 git commands to generate.