]> git.pld-linux.org Git - packages/ctags.git/blob - ctags.spec
3991b2cd753fb53b3dfa2b3941141a65682c2cc0
[packages/ctags.git] / ctags.spec
1 Summary:        Exuberant ctags -- C cross-reference tool
2 Summary(de):    Exuberant ctags - C-Cross-Reference-Tool 
3 Summary(fr):    ctags exubérant
4 Summary(pl):    ctags - generator list odwo³añ
5 Summary(tr):    C dili için çapraz-baþvuru (cross-reference) aracý
6 Name:           ctags
7 Version:        3.2
8 Release:        2
9 Copyright:      GPL
10 Group:          Development/Tools
11 Group(pl):      Programowanie/Narzêdzia
12 Source:         ftp://ftp.revnet.com/pub/ctags/archives/%{name}-%{version}.tar.gz
13 patch0:         ctags-glibc.patch
14 URL:            http://darren.hiebert.com/ctags/
15 Buildroot:      /tmp/%{name}-%{version}-root
16
17 %description
18 Ctags generates an index (or tag) file of C language objects found in C
19 source and header files.  The index makes it easy for text editors or other
20 utilities to locate the indexed items.  Ctags can also generate a cross
21 reference file which lists information about the various objects found in a
22 set of C language files in human readable form.  Exuberant Ctags improves on
23 ctags because it can find all types of C language tags, including macro
24 definitions, enumerated values (values inside enum{...}), function and
25 method definitions, enum/struct/union tags, external function prototypes,
26 typedef names and variable declarations.  Exuberant Ctags is far less likely
27 to be fooled by code containing #if preprocessor conditional constructs than
28 ctags.  Exuberant ctags supports output of emacs style TAGS files and can be
29 used to print out a list of selected objects found in source files.
30                                                                                                               
31 Install ctags if you are going to use your system for C programming.                                          
32
33 %description -l de
34 Ein verbessertes ctags, das tags für alle möglichen tag-Typen generiert:
35 Makrodefinitionen, aufgezählte Werte (Werte in enum{...}), Funktions- und
36 Methodendefinitionen, enum/struct/union-tags, externe Funktionsprototypen
37 (wahlweise), typedefs und variable Deklarationen. Es läßt sich weit weniger
38 gut durch Code täuschen, der #if-Präprozessor-Bedingungen enthält, dank
39 eines konditionalen Pfadauswahlalgorithmus, der komplizierte Entscheidungen
40 trifft, und eines Ausweiche-Algorithmus, der ins Spiel kommt, wenn der erste
41 dem Problem nicht gewachsen ist.  Kann auch benutzt werden, um eine Liste
42 ausgewählter Objekte, die in Quelldateien gefunden wurden, auszudrucken.
43
44 %description -l fr
45 un ctags amélioré générant des tags pour tous les types de tags possibles :
46 définitions de macros, valeurs énumérées (valeurs dans enum{...}),
47 définitions de fonctions et de méthodes, enum/struct/union tags, prototypes
48 de fonctions externes (optionnel), typedefs, et déclarations de variables.
49 Peut aussi être utilisé pour afficher une liste des objets choisis trouvés
50 dans les fichiers source.
51
52 %description -l pl
53 Generator tabeli odwo³añ dla: makr, zmiennych, funkcji i procedur, definicji
54 typów, metod (C++) itp. U¿ywany do generacji listy wyspecyfikowanych
55 obiektów znalezionych w plikach ¼ród³owych. Tablica owych odwo³añ mo¿e byæ
56 wykorzystywana przez wiekszosæ standardowych edytorów tekstu (vim, joe,
57 emacs), do przemieszczania siê w ¼ród³ach miêdzy deklaracj± i u¿yciem danego
58 symbolu.
59
60 %description -l tr
61 Olabilecek her türlü etiket çeþitleri - makro tanýmlamalarý, sayýlý
62 (enumerated) deðerler, fonksiyon ve yöntem (method) tanýmlamalarý, tip ve
63 deðiþken tanýmlarý - için etiketler üretir. Kaynak kodlarýnda bulunan,
64 seçilmiþ nesnelerin listesinin çýktýsýný yazýcýdan almak için de
65 kullanýlabilir.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70
71 %build
72 autoconf
73 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
74 ./configure \
75         --prefix=/usr
76 make
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 make prefix=$RPM_BUILD_ROOT/usr install
82
83 rm -f $RPM_BUILD_ROOT/usr/man/man1/etags.1
84 echo ".so ctags.1" > $RPM_BUILD_ROOT/usr/man/man1/etags.1
85
86 strip $RPM_BUILD_ROOT/usr/bin/*
87
88 gzip -9nf $RPM_BUILD_ROOT/usr/man/man1/* \
89          FAQ NEWS QUOTES README
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %doc *.gz
97 %attr(755,root,root) /usr/bin/*
98 /usr/man/man1/*
99
100 %changelog
101 * Wed Apr 28 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
102   [3.2-2]
103 - added patch for glibc 2.1,
104 - recompiled on new rpm.
105
106 * Mon Apr 12 1999 Micha³ Kuratczyk <kura@pld.org.pl>
107   [3.0.3-3]
108 - added gzipping docimentation
109 - removed man group grom man pages
110 - added stripping binaries
111 - added %defattr(644,root,root,755)
112
113 * Tue Jan 26 1999 Micha³ Kuratczyk <kura@pld.org.pl>
114   [3.0-2]
115 - changed Group to /Development/Tools
116 - added Group(pl)
117
118 * Fri Dec 11 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
119   [3.0-1]
120 - added gzipping man pages,
121 - added using LDFLAGS="-s" to ./configure enviroment.
122 - etags(1) man page is now maked as nroff include to ctags(1) instead
123   making sym link to ctags.1 (this allow compress man pages).
124
125 * Wed Aug 26 1998 Wojciech "Sas" Ciêciwa <cieciwa@zarz.agh.edu.pl>
126   [2.3.1-1]
127 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
128 - added URL,
129 - changed base Source URL to ftp://ftp.revnet.com/pub/ctags/,
130 - added pl translation.
131  
132 * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
133 - translations modified for de, fr, tr
134
135 * Thu Apr 09 1998 Cristian Gafton <gafton@redhat.com>
136 - upgraded to 2.0.3
137
138 * Mon Nov 03 1997 Michael K. Johnson <johnsonm@redhat.com>
139 - removed etags.  Emacs provides its own; and needs to support
140   more than just C.
141
142 * Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
143 - updated from 1.5 to 1.6
144
145 * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
146 - built against glibc
This page took 0.073019 seconds and 2 git commands to generate.